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Getting Started

Welcome to Adobe® InDesign® CC (2019 release), a powerful page-design and production
application that offers precision, control, and seamless integration with other Adobe professional
graphics software. Using InDesign, you can produce professional-quality, full-color documents
and print them using a variety of output devices, including desktop printers, high-resolution
imaging devices, and high-volume color printing presses. You can also design publications for a
broad range of electronic devices, such as tablets, smartphones, and readers, and export InDesign
documents in several formats, including PDF, HTML, and EPUB.
Writers, artists, designers, and publishers can communicate to a broader audience than ever
before through an unprecedented variety of media. InDesign supports this with its seamless
integration with other Creative Cloud (CC) components.

About Classroom in a Book
Adobe InDesign CC Classroom in a Book® (2019 release) is part of the official training series
for Adobe graphics and publishing software developed with the support of Adobe product
experts. The lessons are designed so that you can learn at your own pace. If you’re new to Adobe
InDesign, you’ll master the fundamentals and learn to put the software to work for you. If you’ve
already been using Adobe InDesign, you’ll find that this book teaches many advanced features
and best practices, including tips and techniques for using the latest version of InDesign.
Each lesson provides step-by-step instructions for creating a specific project. You can follow the
book from start to finish or do only the lessons that meet your interests and needs. Each lesson
concludes with several optional tasks that let you further explore the features covered in the
lesson, as well as a set of review questions and answers.

Prerequisites
Before beginning to use Adobe InDesign CC Classroom in a Book (2019 release), you should
have a working knowledge of your computer and its operating system. Make sure that you know
how to use the mouse and standard menus and commands and also how to open, save, and close
files. If you need to review these techniques, see the help resources included with your operating
system.

Note
When instructions differ by platform, Windows commands appear first, followed by the
macOS commands, with the platform noted in parentheses; for example, “Alt-click

(Windows) or Option-click (macOS) the button.”

Installing the software
Before you begin using Adobe InDesign CC Classroom in a Book (2019 release), make sure that
your system is set up correctly and that you’ve installed the proper software and hardware.
The Adobe InDesign CC software is not included with this book; you must purchase the software
separately (visit adobe.com/products/indesign). In addition to Adobe InDesign CC, some lessons
in this book have steps that can be performed with other Adobe applications. You must install
these applications from Adobe Creative Cloud onto your computer. Follow the onscreen
instructions.

Adobe Creative Cloud desktop app
In addition to Adobe InDesign CC, this training requires the Adobe Creative Cloud desktop
application, which provides a central location for managing the dozens of apps and services
included in a Creative Cloud membership. You can use the Creative Cloud desktop application
to sync and share files, manage fonts, access libraries of stock photography and design assets,
and showcase and discover creative work in the design community.
The Creative Cloud desktop application is installed automatically when you download your first
Creative Cloud product. If you have Adobe Application Manager installed, it auto-updates to the
Creative Cloud desktop application.
If the Creative Cloud desktop application is not installed on your computer, you can download it
from the Download Creative Cloud page on the Adobe website
(creative.adobe.com/products/creative-cloud) or the Adobe Creative Cloud desktop apps page
(adobe.com/creativecloud/catalog/desktop.html).

Classroom in a Book fonts
Most of the fonts used in the Classroom in a Book lesson files are installed with Adobe
InDesign. Some fonts are not installed with InDesign but are instead available through Adobe
Fonts, a font-subscription service from Adobe that offers access to a vast library of fonts for use
in desktop applications and on websites.
The Adobe Fonts service is integrated with InDesign’s font selection features and the Creative
Cloud Desktop application. Adobe Fonts is included with your Creative Cloud subscription.
Internet access is required to activate Adobe Fonts.

Online content
Your purchase of this Classroom in a Book includes online materials provided by way of your
Account page on peachpit.com. These include:

Lesson files
To work through the projects in this book, you will need to download the lesson files from
peachpit.com. You can download the files for individual lessons, or it may be possible to
download them all in a single file.

Web Edition
The Web Edition is an online interactive version of the book providing an enhanced learning
experience. Your Web Edition can be accessed from any device with a connection to the Internet,
and it contains:
The complete text of the book
Hours of instructional video keyed to the text
Interactive quizzes
In addition, the Web Edition may be updated when Adobe adds significant feature updates
between major Creative Cloud releases. To accommodate the changes, sections of the online
book may be updated or new sections may be added.

Accessing the lesson files and Web Edition
If you purchased an eBook from peachpit.com or adobepress.com, your Web Edition will
automatically appear under the Digital Purchases tab on your Account page. Click the Launch
link to access the product. Continue reading to learn how to register your product to obtain
access to the lesson files.
If you purchased an eBook from a different vendor or you bought a print book, you must
register your purchase on peachpit.com in order to access the online content:
1.
2.
3.
4.
5.

Go to www.peachpit.com/register.
Sign in or create a new account.
Enter the ISBN: 9780135262153
Answer the questions as proof of purchase.
The Web Edition will appear under the Digital Purchases tab on your Account page. Click
the Launch link to access the product.
The lesson files can be accessed through the Registered Products tab on your Account
page. Click the Access Bonus Content link below the title of your product to proceed to the
download page. Click the lesson file links to download them to your computer.

Saving and restoring the InDesign Defaults file
The InDesign Defaults file stores program preferences and default settings, such as tool settings
and the default unit of measurement. To ensure that the preferences and default settings of your
Adobe InDesign program match those used in this book, move the current InDesign Defaults file
to a different location before you begin working on the lessons. When you have finished the

book, you can return the saved InDesign Defaults file to its original folder, which restores the
preferences and default settings used before you started working on the lessons.

Note
Each time you begin working on a new lesson, some panels may remain open even if you
restore your InDesign Defaults file. If this occurs, you can close the panels manually if
you want.

Moving the current InDesign Defaults file
Moving the InDesign Defaults file to another location prompts InDesign to automatically create
a new one with all preferences and defaults set to their original factory settings.
1. Quit Adobe InDesign.
2. Locate the InDesign Defaults file on Windows or macOS as described below.
3. If you want to restore customized preferences, move the file to another folder on your hard
drive. Otherwise, you can delete the file.
4. Start Adobe InDesign CC.

Note
If you can’t find the InDesign Defaults file, either you haven’t started Adobe InDesign
CC yet or you have already moved the preferences file. The preferences file is created
after you launch the program the first time and is updated thereafter.

Locating the InDesign Defaults file on Windows
The AppData folder is hidden by default on Windows 7, Windows 8, and Windows 10. To
display the AppData folder, click Appearance And Personalization in the Control Panel, and
then click Folder Options (Windows 7 and Windows 8) or File Explorer Options (Windows
10).
Click the View tab in the Folder Options/File Explorer Options dialog box, select Show
Hidden Files, Folders, And Drives, and then click OK.

Note
If hidden files are visible and you still cannot locate the preferences file, use your
operating system’s Find File feature and search for “InDesign Defaults.” The InDesign
Defaults file is located in the folder [startup drive]\Users\
[username]\AppData\Roaming\Adobe\InDesign\Version 14.0\en_US*\InDesign

Defaults.

Locating the InDesign Defaults file on macOS
The InDesign Defaults file is located in the folder [startup
drive]/Users/[username]/Library/Preferences/Adobe InDesign/Version 14.0/en_US*/InDesign
Defaults.
The folder name may be different depending on the language version you have installed.
In macOS 10.9 and later, the Library folder is hidden. To access this folder, choose Go >
Go To Folder from the Finder menu. Type ~/Library in the Go To The Folder box, and
then click OK or Go.

Restoring the saved InDesign Defaults file
If you want to restore your customized InDesign Defaults file that you moved to another
location:
1. Quit Adobe InDesign.
2. Locate your saved InDesign Defaults file, drag it back into its original folder, and replace
the current InDesign Defaults file.

Training resources
Adobe InDesign CC Classroom in a Book (2019 release) is not meant to replace documentation
that comes with the program or to be a comprehensive reference for every feature. Only the
commands and options used in the lessons are explained in this book. For comprehensive
information about program features and tutorials, refer to these resources:

Note
Adobe periodically provides updates to software. You can easily obtain these updates
through Creative Cloud.

Adobe InDesign Learn & Support: helpx.adobe.com/indesign.html is where you can find and
browse Help and Support content on Adobe.com. Adobe InDesign Help and Adobe InDesign
Support Center are accessible from the Help menu in InDesign.
Adobe Forums: forums.adobe.com lets you tap into peer-to-peer discussions, questions, and
answers on Adobe products.
Adobe InDesign CC product home page: adobe.com/products/indesign provides information
about new features and intuitive ways to create professional layouts for print, tablets, and
readers.

Adobe Add-ons: creative.adobe.com/addons is a central resource for finding tools, services,
extensions, code samples, and more to supplement and extend your Adobe products.
Resources for educators: adobe.com/education and edex.adobe.com offer a treasure trove of
information for instructors who teach classes on Adobe software. Find solutions for education at
all levels, including free curricula that use an integrated approach to teaching Adobe software
and can be used to prepare for the Adobe Certified Associate exams.
Adobe Authorized Training Centers: Adobe Authorized Training Centers offer instructor-led
courses and training on Adobe products, employing only Adobe Certified Instructors. A
directory of AATCs is available at training.adobe.com/trainingpartners.

1 Introducing the Workspace

Lesson overview
In this lesson, you’ll learn how to do the following:
Open documents.
Select and use tools.
View information in the Properties panel.
Use the Application bar and Control panel.
Manage document windows.
Work with panels.
Customize the workspace.
Change the magnification of a document.
Navigate through a document.
Use context menus and panel menus.
Change Interface preferences.

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the files for this lesson, or go to the “Getting Started” section at the
beginning of this book and follow the instructions under “Accessing the Lesson Files and Web
Edition.” Store the files on your computer in a convenient location. Your Account page is also
where you’ll find any updates to the lessons or the lesson files. Look on the Lesson & Update
Files tab to access the most current content.

The intuitive Adobe InDesign CC interface makes it easy to create compelling layouts. It is important to understand the InDesign
work area to make the most of its powerful layout and design capabilities. The customizable work area consists of the
Application bar, document window, menus, pasteboard, Tools panel, and other panels (such as the Control panel).

Getting started
In this lesson, you’ll practice using tools and panels, and navigating through a simple layout. The
lesson file represents the final version of the document—you will not make permanent changes
to objects, add graphics, or modify text. You will use this document only to explore the InDesign
work area.
1. To ensure that the preferences and default settings of your InDesign program match those
used in this lesson, move the InDesign Defaults file to a different folder following the
procedure in “Saving and restoring the InDesign Defaults file” on pages 4–5.

Note
If you have not already downloaded the project files for this lesson to your computer
from your Account page, make sure to do so now. See “Getting Started” at the
beginning of the book.

2. Start InDesign.
3. The InDesign Start Screen displays the Learn page, which gives you options for viewing
various tutorials. Explore the Learn page for a few minutes.
4. Click the Open button. (If the Start Screen does not display, choose File > Open from the
InDesign menu bar.)

5. Open the 01_Start.indd file in the Lesson01 folder, located inside the Lessons folder within
the InDesignCIB folder on your hard disk.
6. If an alert informs you that the document contains links to sources that have been modified,
click Update Links.
7. Choose File > Save As, rename the file 01_Intro.indd, and save it in the Lesson01 folder.

Note
The screen captures in this book show the Medium Light interface. Interface
elements such as panels and dialog boxes will be darker on your screen. You will
learn to change this interface preference later in the lesson.

8. To display the document at a higher resolution, choose View > Display Performance >
High Quality Display.
9. Using the scroll bars on the document window, scroll down to see the second page of the
postcard, and then scroll back up to the first page of the postcard.

Looking at the workspace
The InDesign work area encompasses everything you see when you first open or create a
document. By default, InDesign shows tools and panels available in the Essentials workspace.
Menu bar and Application bar, at the top of the screen
Tools panel, docked at the left side of the screen
Commonly used panels, docked at the right side of the screen

Tip
You can customize the InDesign work area to suit your work style. For example, you can
choose to display only the panels you frequently use, minimize and rearrange panel
groups, resize windows, and so on.

The configuration of the work area is referred to as the “workspace.” You can save your custom
workspace setup or choose among special-purpose configurations such as Digital Publishing,
Printing And Proofing, and Typography.

Selecting and using tools
The Tools panel contains tools for creating and modifying page objects, adding and formatting
text and images, and working with color. By default, the Tools panel is docked to the upper-left
corner of the work area. In this exercise, you will select and experiment with several tools.

Using the Selection tool
The Selection tool lets you move and resize objects, and it lets you select objects for formatting,
such as applying color. You will click to select the Selection tool. Later, you will experiment
with other methods of selecting tools.
1. Locate the Tools panel at the far-left side of the screen.

Tip
The building blocks of InDesign pages are objects, which include frames (for
containing text and graphics) and lines.

2. Point at each tool in the Tools panel to see its name.
3. Click the Selection tool ( ), the top tool on the Tools panel.

4. Click near the butterfly’s head to select the graphics frame containing the butterfly
photograph.
5. Drag the frame up and to the right to see how frames move.
The frame’s location is shown in the Properties panel at right. In addition to viewing
information in this panel, you can make adjustments to selected objects.

6. After you release the mouse button, press Ctrl+Z (Windows) or Command+Z (macOS) to
undo the move.
7. With the Selection tool still selected, click other objects on the page, and drag them to new
locations. The page contains another image in a graphics frame, a rectangular text frame,
and an elliptical text frame. Undo each move immediately after you do it.
Using the Type tool

Now you will switch to the Type tool, which lets you enter, edit, and format text. Rather than
clicking to select it, you will use its keyboard shortcut.
1. Point at the Type tool ( ) to display its tool tip. The letter shown in parentheses indicates
a single-letter keyboard shortcut for selecting this tool. In this case, the letter is T.

Note
The single-letter shortcuts do not work when the text insertion bar is in text.

2. Point at various other tools to see their single-letter keyboard shortcuts.
3. Press T on the keyboard to select the Type tool. Click after the word “backyard” and the
period on the lower-right side of the postcard.
4. Type a space and a few characters to get a feel for the Type tool.

5. Press Ctrl+Z (Windows) or Command+Z (macOS) to undo any changes to the postcard
text.

Tip
As you learn InDesign and experiment with designs, remember that you can undo as
many changes as you want.

6. With the Type tool still selected, click in other words and revise the text. Undo each change
immediately after you do so.
Using the Line tool and Hand tool
Now you will switch to the Line tool, which lets you create horizontal, vertical, and diagonal
lines. Once you have experimented with the Line tool, you will select the Hand tool temporarily
by holding its keyboard shortcut: H. When you release the keyboard shortcut, InDesign reverts to
the previously selected tool. This technique is useful for quickly using a tool—for example, you
might use the Hand tool to move to another area of a page and then create a line there.

1. Click the Line tool (

) to select it.

Tip
To constrain the Line tool to creating horizontal, vertical, or 45° lines, press the
Shift key as you draw.

2. Drag to create a line anywhere on the page. Press Ctrl+Z (Windows) or Command+Z
(macOS) to undo the line creation.
3. With the Line tool still selected, press and hold the H key on the keyboard. While you hold
the H key, the Hand tool ( ) is selected.
4. Drag the Hand tool around to view another area of the page. When you release the H key,
the Line tool remains selected.

Using the Rectangle Frame tool and the Ellipse Frame tool
So far, you have selected tools that display on the Tools panel in three ways: (1) clicking them,
(2) pressing a keyboard shortcut, and (3) holding a keyboard shortcut to select the tool
temporarily. Now, you will select a tool that is not visible on the Tools panel. A small triangle in
the lower-right corner of a tool indicates a menu of additional hidden tools.
In this exercise, you will select and use the Rectangle Frame tool, and then you will select and
use the Ellipse Frame tool. You would create these frames to contain imported graphics and text.

1. Choose View > Screen Mode > Normal so you can see the frames that contain graphics and
text.
2. Press F on the keyboard to select the Rectangle Frame tool ( ).

Tip
To easily create a square or circle, press the Shift key while you draw with the
Rectangle Frame tool or with the Ellipse Frame tool.

3. Scroll to the left to view the pasteboard surrounding the document. (See “Reviewing the
document window and pasteboard” later in this lesson.) Click and drag to create a
rectangular graphics frame.

4. Press Ctrl+Z (Windows) or Command+Z (macOS) to undo the frame creation.
5. To see the Ellipse Frame tool, press and hold on the Rectangle Frame tool to display
additional hidden tools.

Tip
You can Alt-click (Windows) or Option-click (macOS) a tool in the Tools panel to
alternate between the tools in a menu.

6. Select the Ellipse Frame tool (

), and notice how it replaces the Rectangle Frame tool.

7. Drag to create an oval graphics frame anywhere on the page.

Tip
Other options in the Properties panel allow you to format any selected object.

8. Notice the object placement information shown in the Transform area of the Properties
panel. Press Ctrl+Z (Windows) or Command+Z (macOS) as many times as necessary to
undo the frame creation.

9. Press and hold the Ellipse Frame tool to display the menu, and choose the Rectangle Frame
tool to display it again. This is the default tool that displays.
10. Review the remaining hidden tools: Press each tool with a triangle and hold down the
mouse button to see its menu of additional tools. The tools with menus for hidden tools
include Type, Pen, Pencil, Rectangle Frame, Rectangle, Free Transform, Color Theme.

Reviewing the Control panel
InDesign provides many more panels than are shown in the default Essentials workspace. In this
exercise, you will switch to the Advanced workspace to view the Control panel, which displays
immediately below the Application bar and offers quick access to full options for editing selected

objects.

Tip
To customize the options showing in the Control panel, click the gear icon (
right side of the panel.

) at the far-

1. Choose View > Screen Mode > Normal so you can see the frames that contain graphics and
text.
2. To ensure that the panels and menu commands match those used in this lesson, choose
Window > Workspace > [Advanced], and then choose Window > Workspace > Reset
Advanced.
3. In the Tools panel, select the Selection tool ( ).
4. Click the butterfly image. The Control panel provides options for controlling the position,
size, and other attributes of the selected object (a graphics frame).

5. In the Control panel, click the X, Y, W, and H up and down arrows to see how you can
reposition the selected text frame and change its dimensions.

Tip
You can also move and resize objects by entering values in these fields and by
dragging objects with the mouse.

6. Press Ctrl+Z (Windows) or Command+Z (macOS) as many times as necessary to undo any
changes.
7. In the Tools panel, select the Type tool ( ).
8. Click in the word “Butterflies.” The Control panel now provides options for controlling
paragraph and character formatting.
9. Double-click to select the word “Butterflies” and click once on the down arrow on the Font
Size field, as shown, to decrease the size of the type.

10. Press Ctrl+Z (Windows) or Command+Z (macOS) to undo the change.
11. Click the pasteboard (the blank area outside the pages) to deselect the text.

Reviewing the Application bar
At the top of the default workspace is the Application bar, which provides quick access to the
most-used layout aids. These include options for changing a document’s zoom level, showing
and hiding guides, and managing multiple document windows. The Application bar also provides
access to Adobe resources such as Adobe Stock art.

Tip
In macOS, you can ungroup these components as follows: (1) To deactivate the
Application frame, choose Window > Application Frame; (2) when the Application frame
is not in use, macOS users can hide the Application bar by choosing Window >
Application Bar; and (3) when you hide the Application bar in macOS, the zoom level
controls display in the lower-left corner of the document window.

To get familiar with the controls in the Application bar, point at each to display its tool tip.

InDesign groups the Application bar, document windows, and panels into a single unit called the
Application frame.

Reviewing the document window and pasteboard
The document window and pasteboard make up your work area and have the following
characteristics:
Controls for displaying different pages in the document are in the lower-left corner of the
document window.
Each page or spread is surrounded by its own pasteboard.
You can use the pasteboard as a work area or a storage area—for example, to place design
elements not yet included in the page layout.

Tip
You can change the size of the pasteboard in Preferences > Guides & Pasteboard.

Now, you will look at the pasteboard and review features on the document window.
1. To see all the pages in the document and the document’s pasteboard, choose 50% from the
Zoom Level menu on the Application bar.

In the 50% view, you will see a circular text frame on the pasteboard to the left of page 1.
2. In the Tools panel, select the Selection tool ( ).

Note
On a smaller monitor, you may not be able to drag the text frame all the way to the
pasteboard. You can still see how the pasteboard can serve as a storage area.

3. Click the text frame containing the words “free community workshop series.” Drag the
frame to the document page.

4. Press Ctrl+Z (Windows) or Command+Z (macOS) to undo the change.
5. Choose View > Fit Page In Window.
6. In the lower-left corner of the document window, click the arrow next to the Page Number
box to display a menu of document pages and master pages.
7. Choose 2 from the menu to display page 2 in the document window.

8. Click the arrow to the left of the Page Number box to turn back to page 1.

9. Choose View > Screen Mode > Preview to hide the frame guides.

Working with multiple document windows
When you open multiple documents, each document displays in its own tab of the main
document window. You can also open multiple windows for a single document so you can see
different parts of the layout at one time. Here, you’ll create a second window so you can see how
changes to the headline affect the entire page. The techniques you use here for arranging
document windows can be used with different views of the same document and for any other
open documents.

Tip
The Application bar provides quick access to options for managing windows. Click the
Arrange Documents button to see all the options.

1. Choose Window > Arrange > New Window For 01_Intro.indd.
A new window, titled 01_Intro.indd:2, opens. The original window is now titled
01_Intro.indd:1.
2. Select the Zoom tool ( ) in the Tools panel.
3. In the second window, 01_Intro.indd:2, click three times on the word “WORKSHOP” to
zoom in on the text.
Notice that the other window stays at its original magnification.
4. Press T on the keyboard to select the Type tool ( ).
5. In the second window, click at the end of the word “WORKSHOP” and add an “S” to make
it plural: WORKSHOPS.
Notice the change in both windows.

6. Press Ctrl+Z (Windows) or Command+Z (macOS) to restore the word “WORKSHOP.”
7. Choose Window > Arrange > New Window For Intro.indd to create additional windows.
Use the Arrange Documents controls on the Application bar to view different displays of
multiple windows.

8. Choose Window > Arrange > Consolidate All Windows. This creates a tab for each
window.

Note
The two windows displaying the document may be in reverse order on your screen.
This does not affect the steps.

9. Click the tabs in the upper-left corner (below the Control panel) to control which document
window to display.

10. Click the Close window button on all the additional tabs, leaving one open. It doesn’t
matter which one remains open.
11. Choose View > Fit Page In Window.

Working with panels
InDesign provides many panels that provide quick access to commonly used tools and features.
By default, various useful panels are docked at the right side of the screen. (Think of a dock as a
collection of panels “glued” together.) The panels that display are different depending on the
selected workspace, and each workspace remembers its panel configuration.

Tip
As you become comfortable with InDesign, experiment with configuring the panels and
workspace to best meet your needs. You will soon find out which panels you use the
most, where you like to keep them, and what size is best for your needs.

You can reorganize panels in various ways. Here, you’ll experiment with opening, collapsing,
and closing the default panels in the Advanced workspace.

Opening and closing panels
To display a hidden panel, choose the panel name from the Window menu (or a submenu of the
Window menu). If the panel name has a check mark, it is already open and in front of any other
panels in its panel group. In this exercise, you will open, use, and close the Info panel, which
provides feedback about anything you select in the document.
1. Choose Window > Info to open the Info panel.
2. In the Tools panel, select the Selection tool ( ).
3. Point at and click various objects on the page to view their details.

Tip
When a panel is floating, you can click its close box ( ) to close it.

4. Choose Window > Info again to close the Info panel.

Expanding and collapsing panels
In this exercise, you will expand and collapse a panel, hide the panel names, and expand all the
panels in the dock.
1. In the default dock to the right of the document window, click the Pages panel icon to
expand the Pages panel.
This technique is handy if you want to open a panel, use it briefly, and then close it.

Tip
The double arrow button expands and collapses panels.

2. When you’ve finished using the Pages panel, click the double arrow ( ) to the right of the
panel names or click the Pages panel icon again to collapse the panel.
3. To reduce the width of the panel dock, drag the left edge of the panel dock to the right until
the names are hidden.

4. To expand all the panels in the dock so you can see all their controls, click the double arrow
( ) in the upper-right corner of the dock.
For the next exercise, you will leave the panels expanded.

Rearranging and customizing panels
In this exercise, you will drag a single panel out of the dock to create a free-floating panel. Then,
you will drag another panel into that panel to create a custom panel group. You will also ungroup
the panels, stack them, and minimize them.
1. Locate the Paragraph Styles panel toward the bottom of the default panels docked at the
right. You will detach this from the dock to create a floating panel.

Note
If necessary, click the double arrow (
expand all of the panels.

) in the upper-right corner of the dock to

2. Click the Paragraph Styles tab in the dock, then drag the panel away from the dock. This
removes the panel from the dock.

Now you will add the Character Styles panel to the floating Paragraph Styles panel to
create a panel group.
3. Locate the Character Styles panel toward the bottom of the panel dock. Drag its tab into the
gray area to the right of the Paragraph Styles panel tab.

Tip
Grouping the Character Styles and Paragraph Styles panels can be helpful for
formatting text. You can put this panel group in a handy location while leaving the
remaining panels collapsed and out of the way.

4. Release the mouse button when the blue line appears along the perimeter of the Paragraph
Styles panel.

5. To ungroup the panels, drag one of the panel tabs out of the panel group.

You can also stack floating panels in a vertical arrangement. You’ll try that now.

Tip
A detached panel is called a floating panel. Click the double arrow on a floating
panel’s title bar to expand or minimize it.

6. Drag the tab of the Character Styles panel to the bottom of the Paragraph Styles panel.
Release the mouse button when a blue line appears.

The panels are now stacked rather than grouped. Stacked panels attach vertically to each
other. You can move the panels as a unit by dragging the topmost title bar. Next, you’ll
experiment with resizing the stacked panels.
7. Drag the lower-right corner of a panel to resize it.

Tip
For floating panels, you can change the width and height by dragging the lower-right
or lower-left corner, change the height by dragging the bottom, and change the
width by dragging the left or right edge of the panel. For docked panels, you can
change the width and height by dragging the lower-left corner, change the width by
dragging the left edge, or change the height by dragging the bottom of the panel.

8. Regroup the panels by dragging the tab of the Character Styles panel up next to the
Paragraph Styles panel tab.

9. Minimize the panel group by double-clicking the gray area to the right of a panel’s tab.
Double-click the area again to expand the panels.

Leave the panels this way to be saved with a workspace in a later exercise.

Moving the Tools panel and Control panel
It’s likely that you will keep the Tools panel and the Control panel open all the time. However,
like all other panels, you can move them to best suit your own work style. Here, you will
experiment with moving these two panels.

Tip
To undock the Tools panel, you can drag either the title bar or the gray dotted bar just
below the title bar.

1. To undock the Tools panel and make it float in the workspace, drag the panel by its dotted
bar to pull it into the pasteboard.
When the Tools panel is floating, it can be a two-column vertical panel, a single-column
vertical panel, or a single-column horizontal row. The Tools panel must be floating (not
docked) to display horizontally.

2. With the Tools panel floating, click the double arrow (

) at the top of the Tools panel.

The Tools panel becomes one horizontal row.

3. Click the double arrow ( ) in the Tools panel to turn it into a two-column vertical panel.
Click the double arrow again to return to the default Tools panel.
4. To dock the Tools panel again, drag the dotted bar (
) at the top of the Tools panel to
the far-left edge of the screen.
5. Release the Tools panel when a blue line appears along the edge of the workspace.
The Control panel can be moved if you don’t like it docked at the top of the document
window.

6. In the Control panel, drag the vertical dotted bar ( ) at the left into the document window.
Release the mouse button to make the panel float.

Tip
You can also dock the Control panel by dragging the dotted bar until a horizontal
blue line appears at the docking position.

7. To dock the panel again, click the Control panel menu button (
choose Dock At Top.

) at the far right and

Customizing the workspace
A workspace is a configuration of panels and menus. (The configuration of document windows
is not saved in workspaces.) InDesign provides a variety of workspaces for special purposes,
such as Digital Publishing, Printing And Proofing, and Typography. You cannot modify the
provided workspaces, but you can save your own. In this exercise, you will save the panel
customizations from the previous exercises. In addition, you will customize the appearance of
the interface.

Tip

To further customize the work-space, you can control which commands appear in the
InDesign menus by choosing Edit > Menus. For example, you might prefer shorter menus
for use on a smaller laptop screen, or you might want to streamline the commands
available to a new user. You can save the menu customization with your saved
workspaces.

1. Choose Window > Workspace > New Workspace.

2. In the New Workspace dialog box, type Styles in the Name box. If necessary, select Panel
Locations and Menu Customization.
3. Click OK. If an alert displays indicating that the workspace already exists, click OK to
replace the existing workspace.
4. Choose Window > Workspace to see that your custom workspace is selected.
5. The name of the selected workspace also displays in a menu at the far right of the Control
panel. Click this menu and select a different workspace.

6. Choose each workspace from the Window > Workspace submenu or the Control panel
Workspace menu to see the different panel and menu configurations.
7. Choose Window > Workspace > Styles again to see your saved workspace.
8. To restore the workspace, choose Window > Workspace > Advanced, and then choose
Window > Workspace > Reset Advanced.

Changing the magnification of a document
Controls in InDesign let you view documents at any zoom level from 5% to 4000%. When a

document is open, the current magnification percentage is displayed in the Zoom Level box in
the Application bar and next to the filename in the document’s tab or title bar.

Tip
Keyboard shortcuts let you quickly change the view to 200%, 400%, and 50%
magnification. In Windows, press Ctrl+2 for 200%, Ctrl+4 for 400%, and Ctrl+5 for
50%. In macOS, press Command+2 for 200%, Command+4 for 400%, and Command+5
for 50%.

Using the view commands
You can easily enlarge or reduce the view of a document by doing any of the following:
Choose View > Zoom In to enlarge the display by one preset increment.
Choose View > Zoom Out to reduce the display by one preset increment.
Choose View > Fit Page In Window to center and display the page in the window.
Choose View > Fit Spread In Window to center and display the targeted spread in the
window.
Choose View > Actual Size to display the document at 100%.
Choose a percentage from the Zoom Level menu in the Application bar to enlarge or reduce
the display by any preset increment.
Type a percentage in the Zoom Level box by clicking in the box, typing the desired viewing
percentage, and then pressing the Enter or Return key.

Press Ctrl+= (Windows) or Command+= (macOS) to increase the magnification by one
preset increment.
Press Ctrl+– (Windows) or Command+– (macOS) to decrease the magnification by one
preset increment.

Using the Zoom tool
In addition to the view commands, you can use the Zoom tool to magnify and reduce the view of

a document. You might zoom in on a text frame to revise text, for example. In this exercise, you
will experiment with the Zoom tool.

Tip
When clicking with the Zoom tool to increase the zoom level, target the item you want to
zoom in to avoid zooming in to random areas of a page.

1. Choose View > Actual Size to view the document at 100%.
2. Select the Zoom tool ( ) in the Tools panel and position it near the butterfly wing on the
left side of page 1. Notice that a plus sign appears in the center of the Zoom tool.
3. Click three times. The view changes to the next preset magnification, centered on the point
where you clicked.

Now you’ll reduce the view.
4. Position the Zoom tool over the butterfly image and hold down the Alt (Windows) or
Option (macOS) key. A minus sign appears in the center of the Zoom tool.

Note
If you have a Mac with a compatible graphics processing unit (GPU) card, your
Zoom tool offers Animated Zoom. See the sidebar on the next page for details.

5. While holding the Alt or Option key, click three times to reduce the view scale.
To magnify a specific area, you can drag the Zoom tool around that area. The percentage

by which the area is magnified depends on the size of the marquee: the smaller the
marquee, the larger the degree of magnification.
6. Scroll as necessary to view the lavender elliptical text frame containing the words “free
community workshop series.”
7. With the Zoom tool still selected, hold down the mouse button to drag a marquee around
the text frame, and then release the mouse button.

8. Choose View > Fit Page In Window.

Note
Your Windows or macOS system preferences may override some InDesign
keyboard shortcuts. If a shortcut is not working, review your system preferences.

9. Because the Zoom tool is used frequently during the design and editing processes, you can
temporarily select it from the keyboard at any time without deselecting the tool you are
using. To do so:
Click the Selection tool (
document window.

) in the Tools panel and position it anywhere in the

Hold down Ctrl+spacebar (Windows) or Command+spacebar (macOS) so that the
Selection tool icon becomes the Zoom tool icon, and then click the butterfly to
magnify the view. Add the Alt (Windows) or Option (macOS) key to reduce the view.
When you release the keys, the pointer returns to the Selection tool.
10. Choose View > Fit Page In Window to center the page again.

Using Animated Zoom
If you have a Mac with a compatible graphics processing unit (GPU) card, InDesign
provides enhanced view features. The Display Performance (View menu) is set to High
Quality by default and you can enable Animated Zoom (InDesign CC > Preferences > GPU
Performance).
Animated Zoom offers smooth, animated displays when using the Zoom tool:

Press and hold: Zoom in to the center.
Press Option and hold: Zoom out from the center.
Press and drag to the right: Zoom in.
Press and drag to the left: Zoom out.
Press Shift while dragging: Access standard marquee zoom.

Navigating through a document
InDesign offers several different ways to navigate through a document, including using the Pages
panel, the Hand tool, the Go To Page dialog box, and controls in the document window. As you
work with InDesign, you will find that you prefer certain methods over others. Once you find a
method you like, remember any shortcuts to make that method easier. For example, if you prefer
to enter a page number in the Go To Page dialog box, memorize its keyboard shortcut.

Tip
To navigate pages, you can also use commands in the Layout menu: First Page, Previous
Page, Next Page, Last Page, Next Spread, and Previous Spread.

Navigating pages
You can navigate document pages using the Pages panel, the page buttons at the bottom of the
document window, the scroll bars, or a variety of other methods. The Pages panel displays an
icon for each page in the document. Double-clicking any page icon or page number in the panel
brings that page or spread into view. In this exercise, you will experiment with turning pages.
1. Click the Pages panel icon to expand the Pages panel, if necessary.
2. Double-click the page 2 icon to display it in the document window.

3. Double-click the page 1 icon to center the first page in the document window.
4. To return to the second page of the document, use the menu in the lower-left corner of the
document window. Click the down arrow, and choose 2.

You will now use the buttons at the bottom of the document window to display a different
page.

Note
When View > Fit Spread In Window is selected, the navigation controls in the
document window are for spreads rather than pages.

5. Click the Previous Page button (left-facing arrow) next to the Page Number box to switch
pages until the first page is displayed.
6. Click the Next Page button (the right-facing arrow) next to the Page Number box until the
second page is displayed.

7. Choose Layout > Go To Page.

Tip
The keyboard shortcut for Layout > Go To Page is Ctrl+J (Windows) or
Command+J (macOS).

8. In the Page box, type 1 or select 1 from the menu. Click OK.

Using the Hand tool
The Hand tool in the Tools panel lets you “push” the pages of a document around until the area
you want to view is visible. In this exercise, you will experiment with the Hand tool.

Tip
When you’re using the Selection tool, you can press the spacebar to temporarily access
the Hand tool. When you’re using the Type tool, press the Alt (Windows) or Option
(macOS) key to use the Hand tool.

1. Choose 400% from the Zoom Level menu on the Application bar.
2. Select the Hand tool ( ).
3. Drag in any direction to move the page around, and then drag upward in the document
window to display page 2.
4. With the Hand tool still selected, click the page and hold the mouse button down to display
a view rectangle.
Drag the rectangle to view a different area of the page or a different page.
Release the mouse button to display the area that the view rectangle encompasses.
When the view rectangle is displayed, press the arrow keys on the keyboard to increase
and decrease the rectangle’s size.

5. Double-click the Hand tool in the Tools panel to fit the page in the document window.

Using context menus
In addition to using the menus at the top of your screen, you can use context menus to display
commands relevant to the active tool or selection. To display context menus, position the pointer
over a selected object or anywhere in the document window and click with the right mouse
button or press Control and hold down the mouse button (macOS).
1. Using the Selection tool ( ), click any object on the page, such as the text frame
containing the postcard’s return address starting with “Urban Oasis Gardens.”

Tip
You can display a context menu when entering or editing text. The Type context
menu lets you insert special characters, check spelling, and perform other textrelated tasks.

2. Right-click the text frame. Note the available options; a partial list is shown here.

3. Select different types of objects on the page and display their context menus to see the
available commands.

Using panel menus
Most panels have additional panel-specific options. Clicking the panel menu button displays a
menu with additional commands and options for the selected panel.
In this exercise, you will change the display of the Swatches panel.
1. Locate the Swatches panel on the dock. (If necessary, choose Window > Color > Swatches
to display it.) Drag the Swatches panel out of the dock at the right to create a free-floating
panel.

Note
If necessary, click the double arrow (
panel.

) in its title bar to expand the Swatches

2. In the upper-right corner of the Swatches panel, click the panel menu button (
the panel menu.

) to display

You can use the Swatches panel menu to create new color swatches, load swatches from
another document, and more.
3. Choose Large Thumbnail from the Swatches panel menu.

Modifying interface preferences
You can customize the InDesign interface by changing the overall color, the way various tools
work, and how the panels are configured through preferences. Some settings in the Preferences
dialog box affect the application (InDesign itself), while others affect only the active document.
If you change the document-specific preferences while no documents are open, the changes
affect all new documents (without affecting existing documents). Here, you will look at Interface
preferences, which affect the application.

Note
The screen captures in this book show the Medium Light interface. You can use any color
theme that you prefer.

1. Choose Edit > Preferences > Interface (Windows) or InDesign CC > Preferences >
Interface (macOS) to customize the appearance of InDesign.
2. In the Appearance area, click the Light box at far right.

3. Experiment with the other options, and then leave the setting at your preference. (Or choose
the default, Medium Dark, again.)

Tip
If your computer has a compatible GPU card, InDesign automatically displays
documents using the GPU and sets the default Display Performance to High Quality.

4. Click through the panels in the Preferences dialog box to see other options for customizing
InDesign. For example, the Display Performance preference lets you specify how images
display in all your InDesign documents (Fast, Typical, or High Quality).
5. When you are finished reviewing Preferences, click OK.

Exploring on your own
Now that you have explored the work area, try some of the following tasks using either the
01_Intro.indd document or your own document.

Tip
For complete and up-to-date information about using InDesign panels, tools, and other
application features, use the Help menu.

Choose Window > Utilities > Tool Hints to display information about the selected tool.
Select various tools to learn more about them.

Choose Window > Editorial > Notes to display the Notes panel group, which includes the
Assignments panel and the Track Changes panel. You can use these panels to collaborate on
documents.
Learn more about existing key commands and how you can change them by exploring the
Keyboard Shortcuts dialog box (Edit > Keyboard Shortcuts).
Review the menu configurations and how you can edit them in the Menu Customization
dialog box (Edit > Menus).
Try organizing your panels to meet your needs, and create your own workspace by choosing
Window > Workspace > New Workspace.

Review questions
1 What are some ways you can change the magnification (zoom level) of a document?
2 How do you select tools in InDesign?
3 What are three ways to display a panel?
4 How do you create a panel group?

Review answers
1 You can choose commands from the View menu to zoom in, zoom out, fit the page to the
window, and more. You can also use the Zoom tool in the Tools panel and click or drag over a
document to enlarge or reduce the view. In addition, you can use keyboard shortcuts to
increase or reduce the magnification. You can also use the Zoom Level box in the Application
bar.
2 You can click to select a tool in the Tools panel. Or, if the Type tool is not selected, you can
press the tool’s keyboard shortcut. For example, you can press V to select the Selection tool
from the keyboard; press and hold the keyboard shortcut to temporarily select the tool. You
select hidden tools by positioning the pointer over a tool in the Tools panel and holding down
the mouse button. When the menu appears, select the tool.
3 To make a panel appear, click its icon, click its tab, or choose its name from the Window
menu. For example, choose Window > Object & Layout > Align. You can also access typespecific panels from the Type menu. For example, choose Type > Glyphs.
4 Drag a panel off the dock to create a free-floating panel. Drag the tab of any other panel into
the tab bar of the new, free-floating panel. A panel group can be moved and resized as one
panel.

2 Getting to Know InDesign

Lesson overview
In this lesson, you’ll learn how to do the following:
View layout aids.
Check on potential production issues with the Preflight panel.
Type and style text.
Import text and thread text frames.
Import a graphic.
Move, rotate, fill, and stroke an object.
Automate formatting with paragraph, character, and object styles.
Preview a document in Presentation mode.

This lesson will take about 60 minutes to complete. Please log in to your account on
peachpit.com to download the files for this lesson, or go to the “Getting Started” section at the
beginning of this book and follow the instructions under “Accessing the Lesson Files and Web
Edition.” Store the files on your computer in a convenient location. Your Account page is also
where you’ll find any updates to the lessons or the lesson files. Look on the Lesson & Update
Files tab to access the most current content.

The building blocks of an Adobe InDesign CC layout are objects, text, and graphics. Layout aids such as guides help with size
and placement, and styles let you format page elements automatically.

Getting started
The document for this lesson is a standard-size postcard designed to be printed and mailed. In
addition, the postcard can be exported as a PDF to use in email marketing. As you will see in this
lesson, the building blocks of an InDesign document are the same, regardless of the output
media. In this lesson, you will add the text, images, and formatting necessary to finish the
postcard.
1. To ensure that the preferences and default settings of your Adobe InDesign program match
those used in this lesson, move the InDesign Defaults file to a different folder following the
procedure in “Saving and restoring the InDesign Defaults file” on pages 4–5.

Note
If you have not already downloaded the project files for this lesson to your computer
from your Account page, make sure to do so now. See “Getting Started” at the
beginning of the book.

2. Start Adobe InDesign.
3. The InDesign Start Screen displays. Click Open at left. (If the Start Screen does not
display, choose File > Open from the InDesign menu bar.)
4. Open the 02_Start.indd file in the Lesson02 folder, located inside the Lessons folder within
the InDesignCIB folder on your hard disk.

Note
For higher contrast in the printed manual, the screen captures in this book show the
Medium Light interface. Interface elements such as panels and dialog boxes will be
darker on your screen.

5. To ensure that the panels and menu commands match those used in this lesson, choose
Window > Workspace > [Advanced], and then choose Window > Workspace > Reset
Advanced.
6. To display the document at a higher resolution, choose View > Display Performance >
High Quality Display (if it’s not already enabled).
7. Choose File > Save As, rename the file 02_Postcard.indd, and save it in the Lesson02
folder.
8. If you want to see what the finished document looks like, open the 02_End.indd file in the
same folder. You can leave this document open to act as a guide as you work.
9. When you’re ready to resume working on the lesson document, display it by clicking its tab
in the upper-left corner of the document window.

Viewing guides
Revising or completing an existing document, as you will do in this lesson, is typical work for
entry-level InDesign users. Currently, the postcard document is displayed in Preview mode,
which displays artwork in a standard window, hiding nonprinting elements such as guides, grids,
frame edges, and hidden characters. To work on this document, you will view guides and hidden
characters (such as spaces and tabs). As you become comfortable working with InDesign, you

will discover which view modes and layout aids work best for you.

Tip
The other view modes are Bleed, for reviewing the predefined bleed area for objects that
extend beyond the page boundaries; Slug, for displaying the area outside the bleed area
that can contain information such as printer instructions or job sign-off information; and
Presentation, which fills the screen and works well for presenting design ideas to clients.

1. Press and hold down the Screen Mode button at the bottom of the Tools panel, and choose
Normal ( ) from the menu.
Any layout aids previously enabled now display. For example, light blue, nonprinting lines
now indicate existing text frames and objects because Frame Edges were displayed (View >
Extras > Show Frame Edges). You will now enable other layout aids.

2. In the Application bar, click the View Options menu (
Guides is checked in the menu.

) and select Guides. Be sure

When guides are displayed, it’s easy to position objects with precision, including
automatically snapping them into place. The guides do not print and do not limit the print
or export area.

Tip
The commands in the Application bar are available in the main InDesign menus as
well. These include View > Grids & Guides > Show Guides and Type > Show
Hidden Characters.

3. From the same View Options menu, choose Hidden Characters. Be sure Hidden Characters
is checked in the menu.
Displaying hidden (nonprinting) characters, such as tabs, spaces, and paragraph returns,
helps you precisely select and style text. In general, it’s a good idea to show hidden
characters whenever you are editing or formatting text.
4. As you work on this document, use the skills you learned in Lesson 1 to move panels,
rearrange panels, scroll, and zoom as necessary.

Preflighting as you work
Anytime you start working on a document for the first time—whether you’re creating a
document from scratch or revising an existing document—you will need to know the intended
output of the document (print and/or display) and keep an eye on output issues. For example, are
all the lines in the document thick enough to print, or will the colors display and print properly?
You will learn more about all of these issues throughout the lessons in this book.
In publishing, the process of evaluating a document for potential output issues is known as
preflighting. The InDesign Live Preflight feature lets you monitor documents as you’re working
to prevent problems from occurring. To customize Live Preflight, you can create or import
production rules (called preflight profiles) against which InDesign checks your documents. The
default profile supplied with InDesign flags issues such as missing fonts (fonts that are not active
on your system) and overset text (text that does not fit in its frame).
1. Choose Window > Output > Preflight to open the Preflight panel.
Using the [Basic] (Working) preflight profile, InDesign finds one error, as indicated by the
red Preflight icon ( ), which displays in the lower-left corner of the Preflight panel and
the document window. According to the Error list in the Preflight panel, the problem is in
the TEXT category.

Tip
Keep an eye on the lower-left corner of the document window to see if any preflight
errors arise. You can double-click the word “error” to open the Preflight panel for
details on any errors.

2. To view the error, click the arrow next to TEXT in the Preflight panel.
3. Click the arrow next to Overset Text, and then click Text Frame.
4. To display details for the error, click the arrow next to Info at the bottom of the Preflight
panel.
5. Double-click Text Frame to locate and select the problem text frame on the page, or click
the page number link to the right in the Page column.
The text frame containing the headline, subhead, and body text is selected. The overset text
is indicated by a red plus sign (+) in the frame’s out port (the small square just above the
lower-right corner of the frame).
6. Using the Selection tool ( ), drag the handle at the bottom of the text frame down so the
frame height is approximately 2.1 in.

Tip
A quick way to expand the overset text frame is to double-click the bottom (center)
handle of the text frame. You can handle overset text by revising the text, reducing
the font size, and using the Auto-Size feature for the text frame (Object > Text
Frame Options > Auto-Size) as well.

7. Click the pasteboard to deselect the text frame.
8. Choose View > Fit Page In Window.
InDesign now reports No Errors in the Preflight panel and in the lower-left corner of the
document window.

9. Close the Preflight panel. Choose File > Save to save your work.

Adding text
With InDesign, most text is contained by a text frame. (Text can be contained in table cells and
flow along paths as well.) You can type text directly into a text frame or import text files from
word-processing programs. When importing text files, you can add the text to existing frames or
create new frames to contain the text. If text doesn’t fit within a single frame, you can “thread,”
or link, multiple text frames.

Typing and styling text
You’re ready to start working on the incomplete postcard. To get started, you’ll edit and style the
text under the headline.
1. Select the Type tool (

) and click immediately after the word “Cafe.”

Tip
Use the Type tool to edit text, format text, and create new text frames.

2. Press Backspace (Windows) or Delete (macOS) four times to delete the word “Cafe.”

3. Type Bistro in the text frame so the restaurant’s descriptor is changed from “Cafe & Bar”
to “Bistro & Bar.”

4. With the insertion point still in the text, click three times to select “Bistro & Bar.”

Note
If necessary, use the Selection tool to drag the bottom of the text frame so that all the
text fits.

5. If necessary, click the Character Formatting Controls icon (
the Font Style menu, select Bold.

) in the Control panel. From

6. Choose File > Save to save your work.

Options for styling and placing text
InDesign provides options for formatting characters and paragraphs and for positioning text
within a frame. Common options are listed here.
Character formats: Font, Font Style, Size, Leading, All Caps
Paragraph formats: Alignment such as Center, Indents, Space Before/After
Text Frame Options: Columns, Inset Spacing, Vertical Justification

The Control panel, Paragraph panel (Type > Paragraph), and Character panel (Type >
Character) provide all the controls you need to style text. To control positioning of the text
within its frame, choose Object > Text Frame Options; many of these options are in the
Control panel as well.

Tip
The Properties panel (Window menu) provides quick access to the most common text
formatting options.

Importing and flowing text
In most publishing workflows, writers and editors use word processors. When the text is almost
final, they send the files to graphic designers. To complete the postcard, you will import a
Microsoft Word file into a text frame at the bottom of the page using the Place command. You
will then link the first text frame to the second frame using a process called “threading.”
1. Using the Selection tool ( ), click a blank area of the pasteboard to make sure no objects
are selected.
2. Choose File > Place. At the bottom of the Place dialog box, make sure that Show Import
Options is not selected.
3. Navigate to the Lesson02 folder, in the Lessons folder, and double-click the Edibles.docx
file.
The pointer changes to a loaded text icon ( ). You’ll add this text to the text frame in the
lower-left quadrant of the postcard. (The text frames are outlined by light blue nonprinting
lines.)

Tip
When the loaded text icon is displayed, you have several choices: You can drag to
create a new text frame, click inside an existing frame, or click to create a new text
frame within the page’s column guides.

4. Position the loaded text icon in the text frame, and then click.

The text in the Word file fills the frame, but it doesn’t all fit. A red plus sign (+) in the out
port of the frame (in the frame’s lower-right corner) indicates overset text. You will thread
the two bottom text frames so the text flows through them.

Note
To see where to place the body copy text, consult the finished lesson document,
02_End.indd.

5. Using the Selection tool, select the text frame that now contains the text.

Tip
All the text in a series of threaded text frames is called a “story.”

6. Click the out port of the selected frame to display the loaded text icon. Click in the text

frame immediately to the right.

Note
Due to variations in font versions, you may see slightly different text in your frames.

At this point, text is still overset. You will resolve this problem by formatting the text with
styles later in this lesson.

7. Choose File > Save.

Working with styles
InDesign provides paragraph styles, character styles, and object styles for quickly and
consistently formatting text and objects and—more important—easily making global changes by
simply editing the style. Styles work as follows:

Tip
A paragraph style can include nested styles that format the beginning of a paragraph and
lines within a paragraph. This automates common paragraph formatting, such as starting
a paragraph with a drop cap followed by all capital letters on the first line.

A paragraph style includes all text formatting attributes—such as font, size, and alignment
—and applies to all the text in a paragraph. You can select a paragraph by simply clicking
in it, highlighting any part it, or highlighting all of it.
A character style includes only character attributes—such as font style (bold or italic) or
color—and applies only to selected text within a paragraph. Character styles are generally
applied to call attention to specific text within a paragraph.
An object style lets you apply formatting—such as fill and stroke color, stroke styles and
corner effects, transparency, drop shadows, feathering, text frame options, and text wrap—
to selected objects.
You will now format the text with paragraph and character styles.

Applying paragraph styles
Because the postcard is almost finished, all the paragraph styles you need are already created.
You will first apply the Body Copy style to all the text in the two threaded text frames, and then
you will apply the Subhead style to the box headings.

Tip
In many publishing environments, including marketing and advertising, the text in a
publication is referred to as “copy,” which is why the writers and editors are called
“copywriters” and “copyeditors.”

1. Using the Type tool ( ), click in one of the text frames containing the newly imported
text.
2. Choose Edit > Select All to select all the text in the threaded frames.
3. Choose Type > Paragraph Styles to display the Paragraph Styles panel.

Note
If a plus sign (+) displays next to the applied style (Body Copy), it indicates that the
text formatting does not precisely match the style’s formatting. To resolve this, click
Clear Overrides ( ) at the bottom of the Paragraph Styles panel. You will learn
more about styles in Lesson 9: “Working with Styles.”

4. In the Paragraph Styles panel, click the Body Copy style to format the entire story with the
Body Copy style.

5. Using the Type tool, click in the first line of text in the story: “Starters & Small Plates.”
As you can see from the hidden character (the paragraph return) at the end of the line, this
line is actually its own paragraph. Therefore, it can be formatted with a paragraph style.
6. Click the Subhead style in the Paragraph Styles panel.
7. Apply the Subhead paragraph style to “Entrées & Desserts” as well.

8. Choose File > Save.

Formatting text for the character style
Highlighting a few key words in a paragraph can draw readers into the text. For the postcard
copy, you will format a few words to make them “pop” and then create a character style based on
those words. You can then quickly apply the character style to other selected words.

Tip
Remember that as you work, you can tear off panels, resize them, and move them to suit
your needs. The configuration of your panels is largely dependent on the amount of
screen space available. Some InDesign users have a second monitor for managing panels.

1. Using the Zoom tool ( ), zoom in on the first text frame in the lower-left quadrant of the
postcard. This frame contains the subhead “Starters & Small Plates.”

2. Using the Type tool ( ), select the words “rose martini” in the first paragraph of body
copy along with the comma after it.
3. If necessary, click the Character Formatting Controls icon ( ) in the Control panel.
4. Display the Type Style menu on the far-left side of the Control panel. Select Italic, leaving
the font as Myriad Pro.
5. In the Control panel, click the arrow next to the Fill menu.
6. Choose the red swatch named Red-Bright to apply the color to the text.

7. Click the pasteboard to deselect the text and view your changes.
8. Choose File > Save.

Creating and applying a character style
Now that you have formatted the text, you are ready to create a character style based on that
formatting.
1. Using the Type tool ( ), select the words “rose martini” and the trailing comma again.
2. If necessary, choose Type > Character Styles to display the Character Styles panel.

Note
Pressing Alt (Windows) or Option (macOS) while you click the Create New Style
button opens the New Character Style dialog box so you can immediately name the
style. This feature works in the Paragraph Styles and Object Styles panels as well.

3. Hold down the Alt (Windows) or Option (macOS) key and click the Create New Style
button, at the bottom of the Character Styles panel.

Note
If the New Character Style dialog box does not open immediately, double-click
Character Style 1 in the Character Styles panel.

A new character style, named Character Style 1, is created in the New Character Style
dialog box. This new style includes the characteristics of the selected text, as indicated in
the Style Settings area of the dialog box.
4. In the Style Name box, type Red Italic.
5. At the bottom of the New Character Style dialog box, select Apply Style To Selection.
6. In the lower-left corner, deselect Add To CC Library (if necessary). Click OK.

7. Using the Type tool, select the words “zucchini blossom fritters or braised dandelion
greens” in the first text frame.
8. Click Red Italic in the Character Styles panel.
Because you applied a character style instead of a paragraph style, the formatting affected
only the selected text, not the entire paragraph.

Tip
Typesetters often apply the same style to any punctuation following text formatted
with a different style. (For example, if a word is italicized, you would italicize a
comma after it.) This may vary based on design preferences or a publisher’s style
guide. The key is to be consistent.

9. Using the Type tool, select the words “orange ginger seared scallops or chive flower
flatbread” and the period after “flatbread.”
10. Click Red Italic in the Character Styles panel.
11. Repeat the process to apply the Red Italic character style to the menu items in the text
frame at right: “lavender honey grilled chicken or fresh basil pesto” and “violet macarons
or candied pansies.”

12. Choose File > Save.

Working with graphics
To add the final design element to the postcard, you’ll import, resize, and position a graphic.
Graphics used in InDesign documents are placed inside frames. Use the Selection tool ( ) to
resize a graphics frame and to position the graphic within the frame. You will learn more about
working with graphics in Lesson 10, “Importing and Modifying Graphics.”

Tip
You can place a graphic into an existing frame or create a new frame as you place the
graphic. You can also drag graphic files from the desktop onto an InDesign page or
pasteboard.

1. Choose View > Fit Page In Window.
You will position the graphic in the upper-right quadrant of the postcard.
2. Make sure that no objects are selected by choosing Edit > Deselect All.
3. Choose File > Place. In the Place dialog box, make sure that Show Import Options is not
selected.
4. Navigate to the Lesson02 folder in the Lessons folder, and double-click the
DiningRoom.jpg file.
The loaded graphics icon ( ) displays a preview of the graphic. If you click the page,
InDesign places the graphic at full size, inside an identically sized graphics frame. In this
case, however, you will scale the graphic as you add it to the page. The resulting graphics
frame will have the same dimensions as the graphic.

Note
To see where to place the graphic, consult the finished lesson document,
02_End.indd.

5. Position the loaded graphics icon at the intersection of the light blue and pink guides in the
upper-right quadrant of the postcard.

Tip
When you create a frame while placing a graphic on the page, the graphic is
automatically scaled to fit within the frame. You can use the scaling controls on the
Control panel to precisely adjust the graphic size. You will learn more about sizing
in Lesson 10, “Importing and Modifying Graphics.”

6. Drag down and to the right until the pointer touches the guide on the right side of the page.
When you release the mouse button, the graphic is added to the page and a graphics frame
is created automatically. The width and height of the graphics frame are determined by the
graphic’s dimensions.

7. Using the Selection tool ( ), select the middle handle at the bottom of the graphics frame
and drag it up. You can crop the image by dragging any of its eight resizing handles.

Use the Selection tool to crop a graphic by reducing the size of its frame.

8. Press Ctrl+Z (Windows) or Command+Z (macOS) to undo the crop.

Tip
To reposition a graphic with more control, press the Shift key while dragging. This
constrains the movement to horizontal, vertical, and 45-degree angles. If you click
and pause briefly before resizing a frame with the Selection tool, or before moving
the graphic within a frame, the cropped part of the graphic is ghosted but visible
outside the frame area.

9. Still using the Selection tool, position the pointer over the graphic to display the content
grabber ( ) in the center of the graphic.
10. Click the content grabber to select the graphic, and then drag up to position the image
within the frame as you please.

11. Press Ctrl+Z (Windows) or Command+Z (macOS) to undo the image move. The eventual
position of the graphic should be where you placed it in step 6.
12. Choose File > Save.

Working with objects
The building blocks of InDesign pages are objects: text frames, graphics frames, lines, and more.
In general, you move and resize objects with the Selection tool. Objects can have a fill color
(background color) and a stroke color (outline or border), which you can customize by
specifying the width and style. You can move objects around freely, snap them to other objects,
and place them with precision according to guides or values you enter. In addition, you can
resize and scale objects and specify how text wraps around them. You will learn more about
objects in Lesson 4, “Working with Objects.” Here, you will experiment with a few objectrelated features.

Moving and rotating an object
A flower graphic created by converting Zapf Dingbats flower characters into outlines (Type >
Create Outlines) is on the pasteboard to the left of the page. You will move this graphic to the
right of the restaurant name, “edible blossoms.” Then, you will rotate the object and adjust its
placement.
1. Choose View > Fit Page In Window to center the page in the document window. If
necessary, scroll left to see the white graphic on the pasteboard.
2. If necessary, use the Selection tool ( ) to click the flower graphic.
3. Drag the graphic to the right of the headline, “edible blossoms.” With the object still

selected, you will fine-tune the placement.

4. To rotate the object, type –10 in the Rotation Angle field. Press Enter (Windows) or Return
(macOS) to apply the change.

Note
When you enter values in the Control panel X and Y fields, the object is
repositioned according to its reference point. You can view and change the reference
point ( ) by clicking a box immediately to the left of the X and Y fields.

5. To specify the object’s placement, type the following values in the Control panel and press
Enter/Return:
X: 1.85 in
Y: .05 in

6. Choose File > Save.

Changing an object’s stroke and fill
When an object is selected, you can change its stroke (outline or border) weight and color. In
addition, you can apply a fill (or background) color.
1. To focus on the objects better, choose Type > Hide Hidden Characters.
2. Choose Edit > Deselect All to make sure nothing is selected.

Note
The flower graphic is a group of objects. The Direct Selection tool lets you select a
single object within a group.

3. Click the Direct Selection ( ) tool on the Tools panel, and then click the white flower in
the graphic to select it.
4. Choose Window > Color > Swatches to open the Swatches panel.
5. Click the Fill box ( ) at the top of the panel to indicate that you want to apply color to the
fill of the object. Click the Green-Dark swatch in the Swatches panel.

6. Press the V key on the keyboard to switch to the Selection tool ( ). Click to select the
black horizontal line at the bottom of the page.
7. Click the Stroke box ( ) at the top of the Swatches panel to ensure that you apply the color
to the stroke (rather than the fill). The Stroke box is the lower right of the two overlapping
boxes.
8. Drag the Green-Medium swatch from the Swatches panel to the line. Release the mouse
button to apply the color.

9. Click the pasteboard to deselect all objects.
10. Choose File > Save.

Working with object styles
As with paragraph and character styles, you can quickly and consistently format objects by
saving attributes as styles. In this exercise, you will apply an existing object style to the two
threaded text frames containing the body copy.
1. Choose View > Fit Page In Window.
2. Choose Window > Styles > Object Styles to display the Object Styles panel.
3. Using the Selection tool ( ), click the text frame at the left containing the “Starters &
Small Plates” subhead.
4. Click the Green Stroke And Drop Shadow style in the Object Styles panel.
5. Click the second text frame, which contains the “Entrées & Desserts” subhead.
6. Click the Green Stroke And Drop Shadow style in the Object Styles panel.

7. Choose File > Save.

Viewing the document in Presentation mode
In Presentation mode, the InDesign interface is hidden entirely, and the document fills the whole
screen. This mode works well for presenting design ideas to clients.
1. Press and hold down the Screen Mode button ( ) at the bottom of the Tools panel, and
select Presentation ( ).
2. After viewing the document, press Esc (Escape) to exit Presentation mode. The document
displays in its previous screen mode, Normal.
3. To view the document without layout aids, choose View > Screen Mode > Preview.
4. Choose View > Actual Size to see the document at its output size.
5. Choose File > Save.
Congratulations! You’ve completed the InDesign tour.

Tip

You cannot edit documents in Presentation mode, but you can make changes in any other
screen mode.

InDesign best practices
While completing the postcard in this lesson, you experimented with the basic building
blocks of a document and the best practices for creating a document. When you create a
document following best practices, the document is easy to format, revise, and replicate
consistently. Some of these techniques are listed here.
Start with preflight. As soon as you receive a document to work on, find out how it
will be used (print and/or display) and use the Live Preflight feature to make sure the
document will output correctly. For example, if the document is missing a font, you
will need to acquire that font before you continue working on the document.
Avoid stacking objects. Format one object rather than using multiple objects. For
example, the two text frames containing the postcard’s body text have a text inset,
stroke weight, stroke color, and drop shadow applied. A new user might be tempted to
create this look by stacking multiple frames. Using multiple objects creates extra work
when moving, aligning, and formatting objects.
Thread text frames. New InDesign users are often tempted to place or paste text into
separate, freestanding text frames. The text in these frames needs to be selected and
formatted individually. If you flow the text through threaded frames, it remains as a
single body of text called a “story.” Among other benefits of working with a story as
opposed to disjointed frames of text, you can select all the text in a story for
formatting, and limit the use of Find/Change and Check Spelling to the text in a story.
When working on a longer document, such as a book, threading text frames is crucial
to controlling the text placement.
Use styles for all formatting. InDesign provides styles for formatting objects,
paragraphs, lines within paragraphs, characters, tables, and table cells. With styles, you
can quickly and consistently format everything in a document. In addition, if you
decide to change a format, you can update the style to make a global change. For
example, in the postcard, if you wanted to change the font used in the body copy, all
you would need to do is edit the Character Formats of the Body Text paragraph style.
Styles can easily be updated to reflect new formatting, and styles can be shared among
documents as well.
You will learn more about all these features as you work through the lessons.

Exploring on your own
To learn more about InDesign, try the following within the postcard layout:

Change the text formatting by choosing other options in the Control panel.
Apply different paragraph and character styles to text. Apply the object style to different
objects.
Move and resize objects and graphics.
Double-click a paragraph, character, or object style and change its formatting. Notice how
the change affects the text or objects to which the style is applied.

Review questions
1 How can you tell if an aspect of a layout will cause output problems?
2 What tool allows you to create text frames?
3 What tool allows you to thread text frames?
4 What symbol indicates that a text frame has more text than it can display—that is, overset text?
5 What tool allows you to move both frames and graphics within frames?
6 What panel provides full options for modifying selected frames, graphics, and text?

Review answers
1 The Preflight panel reports errors when something in the layout does not comply with the
selected preflight profile. For example, if a text frame has overset text (text that doesn’t fit in
the frame), an error is reported. Preflight errors are also reported in the lower-left corner of the
document window.
2 You create text frames with the Type tool.
3 You thread text frames with the Selection tool.
4 A red plus sign in the lower-right corner of a text frame indicates overset text.
5 The Selection tool lets you drag a graphics frame (and its graphic) to move it, and it lets you
move a graphic within its frame.
6 The Control panel provides options for modifying the current selection: characters, paragraphs,
graphics, frames, tables, and more.

3 Setting Up a Document and Working with
Pages

Lesson overview
In this lesson, you’ll learn how to do the following:
Save custom document settings as a document preset.
Create a new document and set document defaults.
Lay out a master page.
Create an additional master page.
Apply a master page to document pages.
Add pages to a document.
Rearrange and delete pages.
Change the size of pages.
Create sections and specify page numbering.
Lay out document pages.
Prepare artwork to print to the edge of the paper.
Rotate a document page.

This lesson will take about 90 minutes to complete. Please log in to your account on
peachpit.com to download the files for this lesson, or go to the “Getting Started” section at the
beginning of this book and follow the instructions under “Accessing the Lesson Files and Web
Edition.” Store the files on your computer in a convenient location. Your Account page is also
where you’ll find any updates to the lessons or the lesson files. Look on the Lesson & Update
Files tab to access the most current content.

By taking advantage of features that help you set up the publications you create, you can ensure consistent page layout, simplify
your production process, and work as quickly and efficiently as possible.

Getting started
In this lesson, you’ll set up an eight-page newsletter with an insert and then place text and
graphics on one of the document’s facing-page spreads.
1. To ensure that the preferences and default settings of your Adobe InDesign CC program
match those used in this lesson, move the InDesign Defaults file to a different folder
following the procedure in “Saving and restoring the InDesign Defaults file” on pages 4–5.
2. Start InDesign. To ensure that the panels and menu commands match those used in this
lesson, choose Window > Workspace > [Advanced], and then choose Window >
Workspace > Reset Advanced. To begin working, you’ll learn how to create a new
document.

Note
If you have not already downloaded the project files for this lesson to your computer
from your Account page, make sure to do so now. See “Getting Started” at the
beginning of the book.

3. To see what the finished document looks like, open the 03_End.indd file in the Lesson03

folder, located inside the Lessons folder within the InDesign CIB folder on your hard drive.

Note
If an alert informs you that the document contains links to sources that have been
modified, click Update Links.

4. Scroll through the document to view other pages. To see the guidelines and placeholder
frames on the pages, choose View > Screen Mode > Normal. Navigate back to pages 2–3,
which are the only document pages you’ll lay out in this lesson. You will also lay out a pair
of master page spreads.
5. Close the 03_End.indd file after you have finished examining it, or you can leave this
document open for reference.

Creating and saving custom document settings
InDesign lets you save frequently used document settings, including the number of pages, page
size, columns, and margins. Choosing one of these saved document parameters, called document
presets, when creating a new document saves time and ensures consistency.
1. Choose Edit > Preferences > Units & Increments (Windows) or InDesign CC > Preferences
> Units & Increments (macOS). Change the Horizontal and Vertical setting to Inches in
order to follow along with the steps in this lesson.
2. Choose File > Document Presets > Define.
3. Click New in the Document Presets dialog box.
4. In the New Document Preset dialog box, set the following:
In the Document Preset box, type Newsletter.

In the Number Of Pages box, type 8.
Make sure that the Facing Pages option is selected.
Use the default Page Size (Letter).
In the Columns section, type 3 for Number, and for Gutter, click the down arrow once
to set the gutter at .125 inches.
In the Margins section, make sure that the Make All Settings The Same icon in the
center of the margin settings is deselected ( ) so that you can enter custom settings
for each margin. Type 1.3125 for Top; type .375 for the Bottom, .5 for the Inside, and
.25 for the Outside margins.

Note
You can use any supported unit of measurement in any dialog box or panel. If
you want to use a measurement unit that differs from the default, simply type
the indicator for the unit you want to use, such as p for picas, pt for points, cm
for centimeters, mm for millimeters, and either in or “ (inch marks) for inches,
after the value you enter into a box.

5. Click the triangle to the left of Bleed And Slug to display additional controls. Highlight or
delete the text (0 in) in the Top box of the Bleed option, and then enter 0p9 (the Picas
measurement system). Then ensure that the Make All Settings The Same icon ( ) is
selected (unbroken chain) so that the same value is used for the Bottom, Inside, and Outside
boxes. Click inside or tab to the Bottom box and notice that InDesign automatically
converts measurements expressed using other measurement units (in this case, picas and
points) to the default equivalents (in this case inches). (The default Bleed value is oneeighth of an inch, or 0p9.)

Tip
The bleed values specify an area outside the perimeter of each page that is used to
print design elements, such as pictures or a colored background, that extend to the
edge of the paper. The bleed area is trimmed and discarded after the printing
process.

6. Click OK in both dialog boxes to save the document preset.

Creating a new document
Each time you create a new document, the New Document dialog box lets you choose a
document preset as the starting point, or you can use this dialog box to specify several document
settings, including the number of pages, the page size, the number of columns, and more. In this
section, you’ll use the Newsletter preset that you just created.
1. Choose File > New > Document.
2. In the New Document dialog box, choose the Newsletter preset, which you’ll see when you
click Saved at the top of the dialog box.

3. Click Create.
InDesign creates a new document using all of the specifications from the document preset,
including the page size, margins, columns, and number of pages.

Tip
You can also create a new document based on a document preset by choosing File >
Document Presets > [Preset_Name]. If you press the Shift key when selecting a
preset, the New Document dialog box is bypassed and a new document based on
that preset opens.

4. Open the Pages panel by clicking its panel icon or choosing Window > Pages. If necessary,
drag the bottom of the panel downward until all eight document page icons are visible.
In the Pages panel, the icon for page 1 is highlighted, and the page number below the icon
is displayed within a highlighted rectangle to indicate that page 1 is currently displayed in
the document window.

About page numbering
There are two kinds of page numbering in any kind of multi-page publication. One is
the physical structure of the folded paper that creates the physical pages. The other is
the label placed on the pages. The label, or folio, can have sections, and can begin new
numbering with each section, in many possible configurations. Here we are concerned
with the physical structure.
Any printed material that has a spine, such as a magazine or a book, follows a structure
dictated by folding paper. The simplest example is to fold a piece of paper in half.
Each resulting rectangle is a page. If you nest two folded pieces of paper into each
other and staple them at the fold (the spine), you have created an 8-page booklet. The
first page (the cover) of this booklet is to the right of the fold (the spine). Open the first
page and you have one page to the left of the spine (or fold), page 2, and one page to
the right of the spine, page 3.
When you create a document with facing pages, InDesign shows you this structure in
the Pages panel. Page 1 is to the right of the center line, which represents the spine.
Page 2 is to the left. All odd number pages are to the right, and all even number pages
to the left. To begin a document to the left of the spine, you must enter an even number
in the Start Page # box in the Document Setup dialog box.

The Pages panel is divided into two sections by a horizontal line. The upper section
displays thumbnails of the document’s master pages. A master page is like a background
template that you can apply to any page in a document. Master pages contain elements,
such as headers, footers, and page numbers, that appear on all document pages. (You’ll
work with master pages later in this lesson.) The lower section of the Pages panel displays
thumbnails of document pages.
In this document, the default master page (which is automatically given the default name
“A-Master”) consists of a two-page spread of facing pages.

5. Choose File > Save As, name the file 03_Setup.indd, navigate to the Lesson03 folder, and
click Save.

Working with master pages
Before you add graphics and text frames to a document, you may want to set up the master
pages, which serve as backgrounds for your document pages. Any object that you add to a master
page automatically appears on the document pages to which the master page has been applied.
In this document, you’ll create two master page spreads to contain elements such as headers,
footers, and placeholder frames for text and graphics. By creating multiple master pages, you
allow for variation within a consistent design theme.

Tip
A header is text placed at the top of a page and is separate from the main body text. A
header can include information such as page number, publication name, or issue date.
When placed at the bottom of a page, such text is called a footer.

Adding guides to the master page

Guides are nonprinting lines that help you lay out a document precisely. Guides placed on a
master page appear on any document pages to which that master is applied. For this document,
you’ll add several guides that, along with the existing column guides, act as a grid to help you
position graphics frames, text frames, and other objects.
1. In the upper section of the Pages panel, double-click the name A-Master. The master
spread’s left and right pages are displayed in the document window.
2. Choose Layout > Create Guides.
3. Select Preview to display your changes as you make them.
4. For the Rows option, type 4 in the Number box and .125 in in the Gutter box.

Tip
If the two pages of the master page spread are not centered in the document window,
double-click the Hand tool in the Tools panel to center them.

5. For the Columns option, type 2 in the Number box and 0 in the Gutter box.

Note
Gutter is the term for the space between columns or rows.

6. For Fit Guides To, select Page and notice how the horizontal and vertical guides appear on
your master pages, along with the margin and column guides that you established when you
created the Newsletter preset.

Tip
Guides can also be added to a spread in a facing-page document by using the Create
Guides command (Layout menu) when working on a document page rather than a
master page.

Selecting Margins instead of Page causes the guides to fit within the margin boundaries
rather than the page boundaries. When you lay out document pages, you can use these
guides to help you position and align objects.
7. Click OK.

Dragging guides from rulers
You can drag guides from the horizontal (top) and vertical (left side) rulers at the edge of the
document window to provide additional alignment assistance on individual pages. Pressing Ctrl
(Windows) or Command (macOS) while dragging a horizontal guide applies the guide to the
entire spread. Pressing Alt (Windows) or Option (macOS) while dragging a guide from the
horizontal ruler changes it to a vertical guide and, likewise, changes a vertical guide to a
horizontal guide when dragging a guide from the vertical ruler.
In this lesson, you will place headers above the top margin of the page and footers below the
bottom margin. To position the headers and footers accurately, you will manually add two
horizontal guides and two vertical guides.
1. Open the Transform panel (Window > Object & Layout > Transform). Without clicking in
your document, move the pointer around the document window and watch the horizontal
and vertical rulers as the pointer moves. Notice how the hairline indicators in the rulers
correspond to the pointer’s position. Also notice that the dimmed X and Y values in the
Control panel and the Transform panel indicate the position of the pointer.

Tip
You can also drag a ruler guide without the Ctrl or Command key and release the
guide over the pasteboard to have a guide appear across all pages in a spread as well
as on the pasteboard.

2. Press Ctrl (Windows) or Command (macOS) and position your pointer on the horizontal
ruler anywhere above the spread. Drag a ruler guide down to .375. The Y value is displayed
next to the pointer while you drag and is also displayed in the Y box in the Control panel
and the Transform panel. Pressing Ctrl (Windows) or Command (macOS) when you create
a guide causes the guide to extend across both pages of the spread, as well as across the
pasteboard on either side. If you don’t press Ctrl or Command, the guide will extend only
across the page on which you release the mouse button.

Note
The controls in the Transform panel are similar to those in the Control panel. You
can use either panel to make many common modifications, such as changing
position, size, scale, and angle of rotation.

3. Press Ctrl (Windows) or Command (macOS) and drag one more ruler guide from the
horizontal ruler to 10.75.
4. Press Ctrl (Windows) or Command (macOS) and drag a ruler guide from the vertical ruler
to the .5 position. Watch the X value in the Control panel as you drag. If the X value
doesn’t display .5 as you drag, place the guide as close as you can, and then—with the
guide still selected—highlight the X value in the Control panel or Transform panel, enter
.5, and then press Enter or Return.

5. Press Ctrl (Windows) or Command (macOS) and drag another guide from the vertical ruler
to the 16.5 position.
6. Close or dock the Transform panel, and then choose File > Save.

Step and repeat, paste, and delete guides
A key concept to understand about guides in InDesign is that they behave like other objects. You
can use many of the same techniques with guides that you use for working with any objects. One
powerful technique is Step and Repeat.
In this lesson, you step and repeat guides, copy and paste guides, and delete guides.
1. Navigate to page 6 by double-clicking the icon for page 6 in the Pages panel. Drag a guide
from the vertical ruler to 1 inch from the left.

2. Open the Step And Repeat dialog box (Edit > Step And Repeat). Enter 3 for the repeat
count and .25 for the Horizontal offset. Click Preview to see the changes while you work.
Hold down the Shift key and click the up arrow in the Horizontal measurement two times
until you get an offset of .75, or just type .75. (If you don’t hold down the Shift key,
InDesign will change the measurement in increments of one-sixteenth of an inch, or .0625.)
Click OK.

Note
If you accidentally deselect this new guide, drag across the guide to select it (with
the Selection tool). When selected, the color of the guide will be darker.

3. Use the Selection tool and drag across all four guides you just created to select the guides.
Choose Copy from the Edit menu.
4. Double-click page 8 in the Pages panel. Choose Paste In Place from the Edit menu. The
guides will be in the exact same place on page 8 as they are on page 6. This technique can
be useful when you want to duplicate a design, but not on enough pages to warrant creating
another master page. You can also copy and paste guides between documents.
5. If you decide to change your layout, it’s often helpful to delete guides you no longer need.
Again, use the Selection tool and drag across the four guides you just pasted onto page 8 to
select them. Choose Edit > Clear, or press the Delete key.

Creating a text frame on the master page
Any text or graphic that you place on a master page appears on document pages to which the
master is applied. To create a header, you’ll add a publication title (“Garden News”) and a page
number marker to the top of the verso (left) and recto (right) pages of the document’s facingpage master spread.
1. Navigate to the left master page, and make sure that you can see the top of the page. If
necessary, zoom in and use the scroll bars or Hand tool ( ).

Note
Objects on master pages display with dotted lines to distinguish them from objects
on document pages.

2. Select the Type tool ( ) in the Tools panel. On the left master page, click near where the
two ruler guides intersect above the leftmost column and drag to create a text frame, as
shown here. You’ll position it exactly in a later step.

3. With the insertion point in the new text frame, choose Type > Insert Special Character >
Markers > Current Page Number.
The letter A appears in your text frame. On document pages based on this master page, the
correct page number is displayed, such as “2” on the document’s page 2.

Tip
An em space is the width of the current font size. For example, when working with
12-point text, an em space is 12 points wide. The term originated in the days of
metal type and described the width of the capital letter M.

4. To add an em space after the page number, right-click with the insertion point in the text
frame to display a context menu, and then choose Insert White Space > Em Space. Or you
can choose this same command from the Type menu.
5. Type Garden News after the em space.

6. Press the Escape key to change to the Selection tool while keeping the text frame selected.
Choose the Text tool and click the Character Formatting Controls icon ( ) in the Control
panel and choose Myriad Pro, and from the Font Style menu, select Bold. Then choose
Type > Change Case > UPPERCASE.

Note
You can apply text attributes with the frame selected rather than selecting text with
the cursor. This is a very useful feature. For example, you can select several text
frames and apply the same attributes to all of them at the same time.

7. With the frame still selected, choose Object > Text Frame Options. Under Inset Spacing,
turn off the same settings button ( ) and set the Left and Right insets to .125. Under
Vertical Justification, choose Center from the drop-down menu, and click OK.
8. To size and position the text frame, click the Selection Tool ( ) and set the reference point

on the Control panel to the center left position, and type these settings: X .25, Y .5, W 7.75,
and H .3125.

Next, you’ll duplicate the header on the left master page, position the copy on the right master
page, and adjust the text so that it’s a mirror opposite of the left header.
1. Choose View > Fit Spread In Window to display both master pages.

Tip
If you also press the Shift key while Alt-dragging (Windows) or Option-dragging
(macOS) a text frame, movement is constrained to vertical, horizontal, and 45degree angles.

2. Using the Selection tool ( ), select the header text frame on the left master page. Hold
down the Alt key (Windows) or Option key (macOS), and drag the text frame to the right
master page so that it snaps to the margin guides, mirroring the left master page as shown
here. The X measurement will be 9 in.

3. Select the Type tool ( ), click the Paragraph Formatting Controls (
panel, and then click the Align Right button.

) in the Control

Click Paragraph Formatting Controls at the left side of the Control panel to see the alignment options.

The text is now right-aligned within the header frame on the right master page. Now you’ll
modify the text on the right master page, placing the page number on the right side of the
words “Garden News” so that the page numbers will print on the outside edges of the
pages, not near the spine.
4. Delete the em space and page number at the beginning of the right page header.
5. Place the insertion point at the end of “Garden News” and then choose Type > Insert White
Space > Em Space. (Note: You won’t see this change until you add the Current Page
Number character in the next step.)
6. Choose Type > Insert Special Character > Markers > Current Page Number to insert the
Current Page Number character after the em space.

7. To create footers, select both headers with the Selection Tool ( ) and choose View > Fit
Spread In Window to display both master pages. Press Alt (Windows) or Option (macOS),
and drag down to the guide at the bottom of the page. This creates a copy of both text
frames.
8. With both frames still selected, select the Type tool ( ) and change the font from Bold to
Regular and change the size to 10 points. Then choose Type > Change Case > Title Case.
Switch back to the Selection tool ( ) and in the alignment area of the Control panel, click
the Align Bottom button.

Note
On smaller screens, fewer tools are available in the Control panel. If you don’t see
the text alignment tools in the Control panel, choose Object > Text Frame Options
and in the Vertical Justification area choose Bottom.

9. Switch back to the Type tool and place the insertion point in the left footer and triple-click
to select all of the text. Type Urban Garden Oasis, replacing the text. Copy this text,
select all of the text in the right footer, paste, and then click the Align Right button.

10. Choose Edit > Deselect All, and then choose File > Save.

Renaming the master page
When a document contains multiple master pages, you may want to assign a descriptive name to
each master page to make them all easier to identify. You will rename this first master page “3column Layout.”
1. Choose Window > Pages if the Pages panel is not open. Confirm that the A-Master page is
still selected. Choose Master Options For “A-Master” from the Pages panel flyout menu (
).
2. In the Name box, type 3-column Layout, and click OK.

Tip
In addition to changing the names of master pages, you can use the Master Options
dialog box to change other properties of a master page, such as the prefix, number of
pages in the master page spread, and whether or not the master page is based on
another master.

Adding placeholder frames for text
Each document page in the newsletter will contain text and graphics. The main text frame and
graphics frame are the same on each page, so you’ll create a placeholder text frame and a
placeholder graphics frame on the left and right pages of the A-3-column Layout master page.
1. Double-click the left page icon of the A-3-column Layout master in the Pages panel to
center the left page in the document window.

Tip
To set up a master page spread with different margin and column settings for the left
and right pages, you can double-click the individual page in the master page spread
and then change the selected page’s settings by choosing Layout > Margins And
Columns.

2. Select the Type tool ( ). Click where the top margin guide intersects the .5 in guide you
drew in the upper-left area of the page, and drag to create a text frame that extends
horizontally across two columns and vertically down about half of the page.

3. Double-click the right page icon of the A-3-column Layout master in the Pages panel to
center it in the document window.
4. With the Selection tool ( ), click the text frame you just created and then press Alt
(Windows) or Option (macOS), and drag across to the right page. Position this text frame
so that it begins at the second column. The left position will be approximately 11.625.
5. Click a blank area of the page or pasteboard, or choose Edit > Deselect All.
6. Choose File > Save.

Adding placeholder frames for graphics
You have now created placeholder text frames for the main text on each page. Next, you’ll add
two graphics frames to the A-3-column Layout master. Similar to the text frames you created,
these frames act as placeholders for graphics you’ll later place on document pages, helping you
to maintain a consistent design.
Although the Rectangle tool ( ) and the Rectangle Frame tool ( ) are more or less
interchangeable, the Rectangle Frame tool, which includes nonprinting diagonal lines within, is
commonly used to create placeholders for graphics.

Note
It’s not necessary to add placeholder frames to every document you create. For example,
one-page documents, such as posters, business cards, and ads, may not benefit from
master pages and placeholder frames.

1. Select the Rectangle Frame tool ( ) in the Tools panel.
2. Position the crosshair pointer at the intersection of the top margin guide and the left margin
guide on the right page.
Drag down and to the right to create a frame that extends horizontally one column width
and vertically to the ruler guide at 5.4375 in. The resulting frame will be 2.5 in wide (W)
and 4.125 in tall (H).

3. Create an identical placeholder graphics frame in the mirror position on the left page either

by drawing another frame or duplicating this frame.
4. Use the Selection tool to click a blank area of the page or pasteboard, or choose Edit >
Deselect All.
5. Choose File > Save.

Creating an additional master page
You can create multiple master pages within a document. You can build them independently or
base one master page on another master page. If you base a master page on another master, any
change made to the parent master is automatically applied to the child master.
For instance, the A-3-column Layout master page is useful for most pages in the newsletter and
can be used as the basis for another set of master pages that share key layout elements, such as
margins and the current page number character.
To accommodate different layouts, you will create a separate master page spread that uses a twocolumn format, and then you’ll modify the two-column layout.

Tip
The ability to create parent–child master pages is ideal for publications like newsletters
and magazines with folios that include the date of publication. Each time you create a
new publication, begin by changing the date on the parent master page, which
automatically changes the date on all children master pages.

1. In the Pages panel, choose New Master from the Pages panel flyout menu.
2. In the Name box, type 2-column Layout.
3. From the Based On Master menu, choose A-3-column Layout, and click OK.
Notice that the letter A is displayed on the B-2-column Layout master page thumbnails at
the top of the Pages panel. This letter indicates that the A-3-column Layout master serves
as the foundation for the B-2-column Layout master. If you were to change the A-3-column
Layout master, the changes would also be reflected in the B-2-column Layout master. You
may also notice that you cannot easily select objects, such as the footer frames, from parent
master pages. You’ll learn about selecting and overriding master page items later in this
lesson.

Note

If all of the master page icons are not visible in the Pages panel, click the horizontal
bar that separates the master page icons from document page icons and drag down
until the other master page icons are visible.

4. Choose Layout > Margins And Columns. In the Margins And Columns dialog box, set the
number of columns to 2, and then click OK.

Overriding master items
The document pages that will use the two-column layout do not require placeholder frames,
which means that only the footer text frames and the ruler guides from the A-3-column Layout
master are required. Next, you’ll remove the placeholder frames from the B-2-column Layout
master.
1. Using the Selection tool ( ), click within the graphics frame on the left page of the B-2column Layout master. Nothing happens. Because this frame is inherited from the parent
master, you can’t select it with a simple click.
2. Hold down Shift+Ctrl (Windows) or Shift+Command (macOS), and then click within the
graphics frame. The frame is now selected, and you have overridden its status as a master
item. Press Backspace or Delete to delete the frame.
3. Use the same method to delete the placeholder graphics frame on the right page, as well as
the placeholder text frame on the left and right pages.
4. Choose File > Save.

Tip
To override multiple master page items, hold down Shift+Ctrl (Windows) or
Shift+Command (macOS) and with the Selection tool, drag a marquee around the
objects you want to override.

Modifying a parent master
To complete your work laying out the newsletter’s master pages, you’ll add several header
elements to the top of the A-3-column Layout master. Then you’ll view the B-2-column Layout
master and see how the new objects are automatically added to that master page spread.
Rather than manually laying out the additional header and footer frames, you’ll import a snippet.
A snippet is a file that contains InDesign objects, including their location relative to one another
on a page or spread, and can be imported into a layout with the Place command (File menu) the
same way you import graphic files. InDesign lets you export selected objects as a snippet file and
place snippets into documents. (You’ll use snippets again later in this lesson, and you’ll learn
more about snippets in Lesson 10, “Importing and Modifying Graphics.”)
1. Double-click the name of the A-3-column Layout master in the Pages panel to display the

spread.
2. Choose File > Place. Open the Links folder in the Lesson03 folder, located inside the
Lessons folder within the InDesign CIB folder. Click the file named HeaderSnippet.idms,
and then click Open.
3. Position the loaded snippet icon ( ) outside the upper-left corner of the spread, where the
red bleed guides meet. Click to place the snippet.
The snippet places a header at the top of each page. Each header includes an empty blue
graphics frame, vector objects, and a text frame with white placeholder text.

Tip
To create a snippet, select one or more objects on a page or spread. Choose File >
Export, and then choose InDesign Snippet from the Save As Type menu (Windows)
or the Format menu (macOS). Choose the location of the file, assign a name, and
then click Save.

4. Double-click the name of the B-2-column Layout master in the Pages panel. Notice how
the new elements you just applied to the A-3-column Layout master have been
automatically applied to this child master.

Tip
The parent–child master structure enables you to quickly apply design changes to
common elements, without having to make the same change to several items.

5. Navigate back to the A-3-column Layout master. Click the left blue graphics frame to
select it. Open the Swatches panel, choose Fill color ( ) and click the Green-Brightest
swatch. Navigate to the B-2-column Layout master in the Pages panel again, and see that
the color of the left header box is now green as well.

6. Choose File > Save.

Applying master pages to document pages
Now that you have created all of the master pages, it’s time to apply them to the pages in the

document. By default, all of the document pages are formatted with the A-3-column Layout
master. You will apply the B-2-column Layout master to several pages in the newsletter, and
then you’ll apply the None master page to the cover page, which doesn’t require header or footer
information and thus does not require a master page.
You can apply master pages to document pages by dragging master page icons onto document
page icons in the Pages panel or by using an option in the Pages panel flyout menu.

Tip
In large documents, you may find it easier to display the page icons horizontally in the
Pages panel. To do this, choose View Pages > Horizontally from the Pages panel flyout
menu.

1. Double-click the name of the B-2-column Layout master in the Pages panel. Make sure that
all master pages and document pages are visible in the panel.

2. Drag either the highlighted master page name or the accompanying spread icon of the B-2column Layout master onto the icon of document page 4. When page 4 is displayed with a
black border, indicating it’s the page to which the selected master will be applied, release
the mouse button.
3. Drag either the highlighted master page name or the accompanying spread icon of the B-2column Layout master onto the icon of document page 5 and then onto document page 8.
4. Double-click the page numbers 4–5 (below the page icons) in the Pages panel to display
this spread. Notice that page 4 has the two-column layout of the applied master page, as
well as the header and footer elements that you placed on the parent master page. Also
notice that the correct page numbers are displayed on each page as a result of the Current
Page Number characters you placed on the A-3-column Layout master page spread.
5. Double-click the icon for document page 1. Because it’s based on the A-3-column Layout

master, it includes header and footer elements, which aren’t required on the cover of the
newsletter.
6. Choose Apply Master To Pages from the Pages panel flyout menu. In the Apply Master
dialog box, choose [None] from the Apply Master menu and make sure that 1 is the page
number in the To Pages box. Click OK.

7. Choose File > Save.

Adding new document pages
You can add new pages to your existing document. Next, you’ll add six additional pages to your
newsletter. Later in this lesson, you’ll use four of these pages for a “special section” within your
newsletter that uses a different page size and separate page numbering.
1. In the Pages panel flyout menu, choose Insert Pages.
2. In the Insert Pages dialog box, type 6 in the Pages box, choose After Page from the Insert
menu, and enter 4 in the accompanying (page number) box, and then choose [None] from
the Master menu.

3. Click OK. Six blank pages are added in the middle of the document. Lengthen the Pages
panel so that you can see as many document pages as possible.

Rearranging and deleting document pages
You can use the Pages panel to rearrange the sequence of pages and delete extra pages.
1. In the Pages panel, click page 12 to select it. Notice that it’s based on the A-3-column
Layout master. Drag the page 12 icon upward onto the icon for page 11, which is based on
the B-2-column Layout master. When the small arrow near the hand is pointing to the right,
indicating that page 11 will be “pushed” in that direction, release the mouse button.
Notice that page 11 is now based on the A-3-column Layout master, and the page that had
previously been page 11 is now page 12. Pages 13 and 14 remain unchanged.

2. Click page 5, and then press the Shift key and click page 6.
3. Click the Delete Selected Pages button icon ( ) at the bottom of the panel. Pages 5 and 6
are deleted from the document, leaving it with 12 pages.
4. Choose File > Save.

Changing the size of pages within one InDesign file
Next, you’ll create an insert within the newsletter by changing the size of four pages in a “special
section” of the publication. This section will be slightly narrower and shorter than the newsletter.
1. Select the Page tool ( ). Click page 5 in the Pages panel, and then press the Shift key and
click page 8. The icons for pages 5–8 are highlighted in the panel. These are the pages
whose size you will change.

2. In the Control panel, enter 7.5 for W (Width) and 10.5 for H (Height).
3. Double-click page 4 in the Pages panel, and then choose View > Fit Spread In Window.
Notice that the spread now contains pages of unequal size.

Using the Measure tool
1. Notice that the outside margins on the narrower page look the same as on the original,
wider page. InDesign has automatically adjusted the margins and columns. To understand
this adjustment, we’ll use the Measure tool ( ) to compare column widths.

Note

Hold down the Shift key as you drag the Measure tool to constrain the direction to
horizontal, vertical, or a 45-degree angle.

2. Double-click page 8 in the Pages panel, and then choose View > Fit Spread In Window.
Both pages show 3 columns within the outer margins. Press K on the keyboard to select the
Measure tool ( ), and then press the Shift key and drag the tool from left to right within
one column on page 8. The Shift key constrains the direction to exactly horizontal. The Info
panel pops up. Note the measurement for W (Width). Now measure a column on page 9.
Now you can see that InDesign has made the columns on page 8 narrower than the original,
while keeping the margins the same.

3. Choose File > Save.

Note
The Measure tool is also available from the Tools panel. It’s grouped with the Color
Theme tool and the Eyedropper tool. Press and hold the Color Theme tool to
activate the flyout menu and choose the Measure tool.

Adding sections to change page numbering
The special section you just created will use its own page-numbering system. You can use
different kinds of page numbering within a document by creating sections. Next, you’ll start a
new section on the first page of the special section, and then you’ll adjust the page numbering of
the subsequent newsletter pages so that they’re numbered correctly.
1. Choose the Selection tool ( ). In the Pages panel, double-click the page 5 icon to select
and display it.
2. Choose Numbering & Section Options from the Pages panel flyout menu, or choose Layout
> Numbering & Section Options. In the New Section dialog box, make sure that Start
Section and Start Page Numbering At are selected and that the Start Page Numbering At
value is 1.
3. Choose i, ii, iii, iv… from the Style menu in the Page Numbering section of the dialog box.
Click OK.

4. Examine the page icons in the Pages panel. Starting with the fifth document page, the
numbers below the page icons now appear as Roman numerals. The numbers in the footers
of the remaining document pages that contain footers also appear as Roman numerals.
Now you’ll specify for the document to use Arabic numerals for the newsletter pages that
follow the special section and to continue the numbering from the page prior to the first
page of the special section (page 4).
5. Select page v in the Pages panel by clicking its icon once.

Note
Single-clicking a master page icon or a document page icon targets the page for
editing purposes but does not cause that page to be displayed in the document
window. If you want to navigate to a page, double-click its icon in the Pages panel.

6. Choose Numbering & Section Options from the Pages panel flyout menu.

7. In the New Section dialog box, make sure that Start Section is selected.
8. Select Start Page Numbering At and specify a value of 5 in the accompanying box to start
section numbering on page 5 and resume the numbering of the document pages (1–4) that
precede the special section.
9. Make sure that 1, 2, 3, 4… is selected in the Style menu, and then click OK.
Now your pages are correctly renumbered. Notice that a small triangle is displayed above
pages 1, i, and 5 in the Pages panel, indicating the start of a new section. In this document,
the page numbering at page 5 continues the numbering from the first section, but the
numbering could be another pattern. The important point to note is that whenever you see
the triangle above a page in the Pages panel, it indicates a section change, regardless of the
particular numbering pattern in that file.

10. Choose File > Save.

Adjust Layout
Adjust Layout is a new feature in InDesign CC 2019. When the size of a document is
changed, this feature enables InDesign to do some of the work of scaling and realigning
elements automatically.

For example, you might have to publish in different regions of the world where standard
page sizes are different. An A4 size is the standard in many areas, and it’s narrower and
taller than an American Letter size. Another scenario where this feature would be useful is
when the specifications of a project change after you have already created many of the
pages. Or you might have to make a poster-size version of a magazine advertisement. There
are many situations where this feature will save you a lot of time.
Adjust Layout is available in the Document Setup dialog box, from the File menu, and in
the Margins And Columns dialog box.
1. Switch to the 03_End.indd file, or open it.
2. Choose File > Document Setup. In the Document Setup dialog box, click the Adjust
Layout button and explore the options. Try changing the newsletter to A4 size and
then examine how the objects have changed.
3. Choose File > Document Setup again. In the Document Setup dialog box, click the
Adjust Layout button—and this time make a dramatic change. Choose Tabloid from
the Page Size menu and select Adjust Font Size. Examine the results.

4. Choose Undo from the File menu or close the document without saving changes.

Overriding master page items and placing text and graphics
Now that the framework of the 12-page publication (the eight-page main section and four-page
narrow section) is in place, you’re ready to lay out document pages. To see how the work you’ve
done setting up the document’s master pages affects the document pages, you’ll add text and
graphics to the spread on pages 2 and 3. You’ll learn more about creating and modifying objects
in Lesson 4, so for this lesson, we’ve simplified the layout process to minimize your work.
1. Choose File > Save As, name the file 03_Newsletter.indd, navigate to the Lesson03 folder,
and click Save.
2. In the Pages panel, double-click the page 2 icon (not page ii), and then choose View > Fit

Spread In Window.
Notice that because the A-3-column Layout master is assigned to pages 2 and 3, these
pages include the guides, headers and footers, and placeholder frames from the A-3-column
Layout master.
To import text and graphics created with other applications, such as a text file from
Microsoft Word or an image from Adobe Photoshop, you use the Place command.
3. Choose File > Place. If necessary, open the Links folder in the Lesson03 folder, located
inside the Lessons folder within the InDesign CIB folder. Click the Article1.txt file, and
then Ctrl-click (Windows) or Command-click (macOS) Article2.txt, Graphic_1_HoneyBee1.jpg, and Graphic_2_GardenTools.jpg to select these four files. Click Open.
The pointer changes to a loaded text icon ( ), with a preview of the first few lines of the
Article1.txt text file that you are placing.

Note
Parentheses are displayed when InDesign recognizes a preexisting frame beneath the
loaded text icon or the loaded graphics icon when importing text or graphics into a
layout. If you click within an existing frame, InDesign uses that frame rather than
creating a new text or graphics frame.

4. Position the loaded text icon over the placeholder text frame on page 2 (not directly on the
guides). Notice that the icon changes to a type block with parentheses around it when you
hover over the text frame from the master page, and that there’s a (4) after the loaded text
icon, indicating that you have four items to place. Then click to place the Article1.txt text
into the frame.
5. To place the three remaining files, click within the text frame on page 3 to place the
Article2.txt text file, then click within the graphics frame on page 2 to place
Graphic_1_HoneyBee-1.jpg, and then click within the graphics frame on page 3 to place
Graphic_2_GardenTools.jpg.

6. Choose Edit > Deselect All.
You’ll import a snippet to complete the layout of the spread.
7. Choose File > Place. Click the Snippet2.idms file, and then click Open.
8. Position the loaded snippet icon ( ) outside the upper-left corner of the spread, where the
red bleed guides meet. Click to place the snippet.

9. Choose Edit > Deselect All, or click an empty area of the page or pasteboard to deselect all
objects.
10. Choose File > Save.
Next, you’ll override two master items on your spread—the two text frames that contain the
header text—and then replace the placeholder text with new text.

Replacing placeholder text
Graphic designers will often use placeholder text to establish the look of a document, and then
replace that text with the actual text when it’s available. You will do that now.
1. Select the Type tool (

). Hold down Shift+Ctrl (Windows) or Shift+Command (macOS),

and then click within the placeholder text frame on page 2 that contains “Placeholder Text.”
Replace the placeholder text with Bees and Bugs.
2. Repeat step 1 to change the header text on page 3 to Gardening Tips.

3. Notice that the frame boundaries are no longer dotted lines, indicating that the frames are
no longer master page objects. Choose Edit > Deselect All.
4. Choose File > Save.

Printing to the edge of the paper: using the bleed guides
A very important concept to keep in mind when setting up a document is whether any elements
will print all the way to the edge of the paper. If so, you need to account for how that is
accomplished in commercial printing. The bleed guides that we set up in the newsletter template
are there to enable you to do that.
In commercial printing, pages are printed on large paper, and pages are arranged to fold correctly
on bindery machines, rather than on single sheets as on an office printer. For example, the pages
could be 2-up on a small digital press, or 8-up on a typical large offset press. Throughout the
printing process, tolerances are built in to allow for slight variations, and one of those tolerances
is bleed.
Sheets of printed material are cut while in large stacks, and even with a very sharp industrial
blade, it’s impossible to cut exactly to the edge of an image hundreds or thousands of times. So
to get a perfect edge every time while allowing for the mechanics of cutting paper in stacks, any
artwork that will print to the edge must actually extend past where the blade will cut the printed
sheet.

Tip
A best practice is to consider bleed requirements right from the beginning of the design
and production process. There might be a photo that has to be enlarged or have the
background extended so that it can bleed. These issues are best dealt with early in the
process.

Therefore, to create a finished piece with photos or other elements that print right to the edge of
the page, you actually must extend those items in the InDesign file past where the blade will cut
the sheet to the final size. That produces a clean edge because the blade cuts through printed
image, not unprinted paper. It’s best to do this while you are building a file because you may
have a photo or other art that is not big enough to extend past the page edge, and it’s better to
deal with that early in the process, not right before it’s due to print. You will now learn how to
check that items extend sufficiently beyond the page edge, and fix them if they do not.
1. Using the Selection tool ( ), double-click the page 2 icon in the Pages panel to display it.
2. Choose View > Screen Mode > Normal and focus on the red bleed guides.
3. First look at the bottom photos on the left and right. Notice that the photos on the left of the
spider web and the ladybug extend to the red bleed guide, which means there is enough
image to get a clean edge when the paper is cut.
4. Now look at the photo of the strawberries on the right. See that the box ends exactly at the
edge of the page. This needs to be extended at least up to the red bleed guide. Click this
photo with the Selection tool. Pull the right handle farther to the right to make the picture
box big enough to meet or pass the red bleed guide.

5. Next look across the top of the spread. See how the green graphics frame on the left is
lower than the blue graphics frame on the right. Click it with the Selection tool. You won’t
be able to select it since this item is on a master spread. Navigate to the A-3-column Layout
master by double clicking it in the Pages panel. Now you can select the green box. Pull the
center handle upward to make the box bigger. Stop either at the red bleed guide or slightly
past it.
6. Navigate back to page 2 and notice that the green box is now big enough to bleed off the
top. Every document page that uses this master page will now bleed correctly without you
having to fix each one.
7. Choose File > Save.

Viewing the completed spread
At this point you’re ready to hide guides and frames and see what the completed spread looks
like.
1. Choose View > Fit Spread In Window, and hide any panels if necessary.

Tip
To hide all panels, including the Tools panel and Control panel, press Tab. Press
Tab again to redisplay all panels. (You can’t do this when you’re working with text
using the Type tool.)

2. Choose View > Screen Mode > Preview to hide the pasteboard and all guides, grids,
invisible characters, and frame edges. Preview is the closest onscreen view that best shows
how the pages will look when printed and trimmed to size.

You have formatted enough of the 12-page document to see how adding objects to the
master pages helps you maintain a consistent design throughout your document.
3. Choose File > Save.
Congratulations! You have finished the lesson.

Rotating spreads
In some cases, you may want to rotate a page or spread to make it easier to view and work
on its content. For example, a standard-sized magazine with portrait-oriented pages might
require a calendar page with a landscape orientation. You could lay out such a page by
rotating all objects 90 degrees, but then you would have to turn your head or rotate your
monitor to modify the layout and edit text. To make editing easier, you can rotate—and
unrotate—spreads. For an example of this feature, open the 03_End.indd document in the
Lesson03 folder (if it’s not already open).
1. In the Pages panel, double-click page 4 to display it in the document window.
2. Choose View > Fit Page In Window to center the page within the document window.
3. Choose View > Rotate Spread > 90° CW.

After you rotate the spread (clockwise), it’s easier to work with the objects on the
page. For example, editing or adding text is much easier.
4. Choose View > Rotate Spread > Clear Rotation.
5. Close the document without saving changes.

Exploring on your own
A good way to reinforce the skills you’ve learned in this lesson is to experiment with them. Try
some of the following exercises. They’ll give you more practice with InDesign techniques.

Tip
Choose View > Screen Mode > Normal to return to your normal display as you explore
on your own.

1. Create another master page for the document. Base it on the A-3-column Layout master,
name it C-4-column Layout, and then modify it so that it contains four columns instead of
three. Apply the new master page to any of the document’s full-sized pages that don’t
contain objects (1 or 5–8).
2. Not all types of printed materials have a spine like the newsletter example in this lesson.
Another common type is a trifold (or six-panel), where there are three panels that fold into
the size of one panel. The panel that folds behind the cover must actually be slightly
narrower so that the paper will lay flat when the trifold is closed. This example is also a
good illustration of using different page sizes within one InDesign file.

A sample file of a trifold is included with this lesson. Open the file named
03_Trifold_Template.indd in the Lesson03 folder, located inside the Lessons folder within
the InDesignCIB folder on your hard disk. Click the pages with the Pages tool and notice
which ones are narrower. Also examine the Pages panel, which shows three pages next to
each other and the page numbering. This is also an example of a document setup where
Facing Pages is turned off.

3. Try making a master page for the special section in the newsletter. This time, make it an
independent master page because the special section will look different. Make the page size
7.5 x 10.5 to match the size of the pages in the special section. Add elements, such as a
footer, that might be included. Apply this master page to pages i to iv in the newsletter.

InDesign will display a warning about the master page size. In this case the special section
is the same size as the new master, so there really isn’t an issue. Choose Use Master Page
Size or Keep Current Page Size.

The following example shows a footer added to the new master page.

Review questions
1 What are the advantages of adding objects to master pages?
2 How do you change the page-numbering scheme within a document?
3 How do you select a master page item on a document page?
4 What’s the advantage of basing a new master page on an existing master page?
5 How do you override a master page item?
6 How do you handle items that print to the edge of the paper?

Review answers

1 By adding objects such as guides, footers, and placeholder frames to master pages, you can
maintain a consistent layout on the pages to which the master is applied.
2 In the Pages panel, select the page icon where you want new page numbering to begin. Then,
choose Numbering & Section Options from the Pages panel flyout menu, or choose Layout >
Numbering & Section Options and specify the new page-numbering scheme.
3 Hold down Shift+Ctrl (Windows) or Shift+Command (macOS), and then click the object to
override it from the master page and select it. You can then edit, delete, or manipulate the
object.
4 By basing a new master page on an existing master page, you create a parent–child relationship
between the new master page and the existing one. Any changes you make to the parent
master page are automatically applied to the child master.
5 Hold down Shift+Ctrl (Windows) or Shift+Command (macOS), and then click the item you
want to change.
6 Items that will print up to the edge of paper must extend past the edge of the page in the file
and into the pasteboard area. The bleed guides show the minimum amount they must extend.

4 Working with Objects

Lesson overview
In this lesson, you’ll learn how to do the following:
Work with layers.
Create and edit text frames and graphics frames.
Import graphics into graphics frames.
Crop, move, and scale graphics.
Adjust the space between frames.
Add captions to graphics frames.
Place and link graphics frames.
Change the shape of frames.
Wrap text around an object or graphic.
Create complex frame shapes.
Convert frame shapes to other shapes.
Modify and align objects.
Select and modify multiple objects.
Add arrowheads to a line.
Create a QR code.

This lesson will take about 90 minutes. Please log in to your account on peachpit.com to
download the files for this lesson, or go to the “Getting Started” section at the beginning of
this book and follow the instructions under “Accessing the Lesson Files and Web Edition.”
Store the files on your computer in a convenient location. Your Account page is also where
you’ll find any updates to the lessons or the lesson files. Look on the Lesson & Update Files
tab to access the most current content.

Adobe InDesign CC frames can contain text, graphics, or color. As you work with frames, you’ll discover that InDesign provides
you with a great amount of flexibility and control over your design.

Getting started
In this lesson, you’ll work on a pair of spreads that make up a four-page newsletter. You’ll add
text and images and make several modifications to the objects on the two spreads.

Note
If you have not already downloaded the project files for this lesson to your computer
from your Account page, make sure to do so now. See “Getting Started” at the beginning
of the book.

1. To ensure that the preferences and default settings of your InDesign program match those
used in this lesson, move the InDesign Defaults file to a different folder following the
procedure in “Saving and restoring the InDesign Defaults file” on pages 4–5.
2. Start InDesign. To ensure that the panels and menu commands match those used in this
lesson, choose Window > Workspace > [Advanced], and then choose Window >
Workspace > Reset Advanced. To begin working, you’ll open an InDesign document that is
already partially completed.
3. Choose File > Open, and open the 04_Start.indd file in the Lesson04 folder, located inside

the Lessons folder within the InDesignCIB folder on your hard drive. (If the Update Links
message displays, click Update Links.)

Note
If an alert is displayed when you open the sample document, click Update Links.

4. Choose File > Save As, rename the file 04_Objects.indd, and save it in the Lesson04
folder.

Note
As you work through the lesson, move panels or change the zoom level to a
magnification that works best for you.

5. To see what the finished document looks like, open the 04_End.indd file in the same folder.
You can leave this document open to act as a guide as you work. When you’re ready to
resume working on the lesson document, choose Window > 04_Objects.indd or click its tab
at the top of the document window.

The newsletter that you will work on in this lesson contains two spreads: The spread on the left contains page 4 (the back
page on the left) and page 1 (the cover on the right); the spread on the right contains pages 2 and 3 (the center spread).
Keep this page arrangement in mind as you navigate from page to page. Here you see the finished newsletter.

Working with layers
Before you begin creating and modifying objects, you should understand how layers work in
InDesign. By default, every new InDesign document contains one layer (named Layer 1). You
can rename this layer and add more layers at any time as you work on a document. Placing
objects on different layers lets you organize them for easy selection and editing. In the Layers
panel, you can select, display, edit, and print different layers individually, in groups, or all
together.

Tip
Turn on Paste Remembers Layers, found in the Layers panel flyout menu. When you
copy and paste items to a different page or a different document, the layer structure
remains intact rather than all items pasting onto the topmost layer.

About layers
Think of layers as transparent sheets stacked on top of each other. When you create an
object, you can place it on the layer of your choice, and you can move objects between
layers. Each layer contains its own set of objects.
The Layers panel (Window > Layers) displays a list of a document’s layers and lets you
create, manage, and delete layers. The Layers panel also lets you display the names of all
objects on a layer and show, hide, or lock individual objects. Click the triangle to the left of
a layer name to alternately display and hide the names of the objects on the layer.
The order displayed in the Layers panel is the stacking order in the file. The topmost layer
in the panel is the topmost layer in the file, and so on. The objects within each layer follow
the same logic. One way to move an object in front of (above) or behind (below) another
object is to move it up or down in the Layers panel.
By using multiple layers, you can create and edit specific areas or kinds of content in your
document without affecting other areas or kinds of content. For example, you can dragselect and move items on one layer without affecting other items, such as selecting and
moving text boxes without moving the backgrounds. Another example: If a document prints
slowly because it contains many large graphics, you can use one layer for only the text in
the document; then, when it’s time to proofread the text, you can hide all other layers and
quickly print only the Text layer. You can also use layers to display alternate design ideas
for the same layout or different versions of an advertisement for different regions.

The 04_Objects.indd document has two layers. You’ll experiment with these layers to learn how
the arrangement of the layers and the placement of objects on layers can affect the design of your
document, and you’ll add a new layer.
1. Click the Layers panel icon or choose Window > Layers to open the Layers panel.
2. If the Text layer is not selected in the Layers panel, click to select it. The layer is
highlighted to indicate that it’s selected. Notice that a pen icon ( ) appears to the right of
the layer name. The pen icon indicates that this layer is the target layer, and while it’s
selected, anything you import or create is placed on this layer.
3. Click the small triangle to the left of the Text layer name. All the groups and objects on this
layer are now displayed below the layer name. Use the panel’s scroll bar to view the names
in the list, and then click the triangle again to hide them.
4. Click the eye icon ( ) to the far left of the Text layer name. All the objects on the Text
layer are hidden, leaving only the objects on the Graphics layer visible (since this file has
only two layers). The eye icon lets you hide or display individual layers. When you turn off
the visibility of a layer, the eye disappears from the Layers panel. Click the empty box to
the far left of the Text layer again to display the layer’s contents. Now click the eye icon of
the Graphics layer. All the objects on the Graphics layer are hidden. Click the empty box to
the far left of the Graphics layer to make it visible again.

5. Use the Zoom tool (

) to zoom in on the blue frame on the cover (page 1).

Tip
Layers are assigned colors as one of the Layer Options, which are available under
the Layer panel flyout menu.

6. Using the Selection tool ( ), move the pointer within the pink flower photo. Notice the
blue frame edge on the graphics frame. This blue border indicates that the frame is on the
Text layer, which has been assigned a blue color. A transparent doughnut shape, otherwise
known as the content grabber, is displayed in the center of the frame. When you move the
pointer within the content grabber, it changes to a hand.

7. Now move the pointer within the circular graphics frame below the pink flower and click.
Notice that this frame’s edge is red, the color assigned to the Graphics layer.

Tip
Frames are also called “containers” and the graphic within “content.” You can

choose the content when you have the container selected, and vice versa: choose
Object >Select.

8. Move the pointer back to the frame with the pink flower, make sure the arrow pointer is
displayed, and then click within the graphics frame to select it.
In the Layers panel, you’ll notice that the Text layer is selected, and a small blue square
appears to the right of the layer name. This indicates that the selected object is on this layer.
You can move objects from one layer to another by dragging this square in the panel
between layers.
9. In the Layers panel, drag the small blue square from the Text layer up to the Graphics layer,
and then release the mouse button. The image is now on the Graphics layer and is now the
topmost object on the top layer. Notice that the small square in the Layers panel turns red,
corresponding to the layer color.

Tip
To see the position of the pink flower in the Graphics layer relative to other objects
in the layer, expand the Graphics layer by clicking the triangle to the left of the layer
name. The topmost item in the list is the topmost item in the layer.

10. The Object > Arrange command operates within each layer, and not between layers. To see
this in action, choose Object > Arrange > Send To Back. The pink flower does not move
behind the blue background as you expect. This is because the pink flower is on the
Graphics layer, which is above the Text layer that contains the blue box. Now move the
small red square in the Layers panel back to the Text layer and choose Object > Arrange >
Send To Back again. Now the pink flower moves behind the blue box because they are on
the same layer. To move the pink flower back to the Graphics layer, choose Edit > Undo
twice.

Tip

The Object > Arrange command moves objects above or below each other, that is, in
front of or behind each other.

Creating and reordering layers
1. Click the empty layer lock box to the left of the Graphics layer to lock the layer.

2. Choose View > Fit Spread In Window.
Next, you will make a new layer and move existing content to it.
3. At the bottom of the Layers panel, click the Create New Layer button ( ). Because the
Graphics layer was selected when you created the new layer, the new layer is positioned
above the Graphics layer in the Layers panel.

4. Double-click the name of the new layer (Layer 3) to open the Layer Options dialog box.
Change the name to Background, and click OK.

Tip
You can also rename a layer by selecting the layer in the Layers panel and then
clicking its name.

5. In the Layers panel, drag the Background layer to the bottom of the layer stack. A thick
horizontal line appears when you move the pointer below the Text layer, indicating that the
layer will be moved to that position when you release the mouse button.

Move items to the Background layer

Now you’ll move objects to the Background layer and lock that layer so that you can work with
objects on the Text and Graphics layers without accidentally selecting or moving the
backgrounds.
1. Choose View > Fit Spread In Window. Click the light green background on the left-hand
page with the Selection tool ( ). Hold down the Shift key and select the large photo on the
cover page.
2. In the Layers panel, drag the blue square down from the Text layer to the Background
layer.
3. Navigate to the next spread (pages 2–3) by clicking the Next Spread arrow in the lower left
of the document window.

4. Select both the blue box on the left and the purple box on the right by dragging a small area
starting in the pasteboard above where the two boxes meet, down and across a small section
of each box. This is a quick way to select multiple items while being careful not to select
too many items.

5. In the Layers panel, drag the blue square down to the Background layer, moving both items
to the Background layer at the same time.
6. Click the lock box to the left of the Background layer.
7. Choose File > Save.

Creating and modifying text frames
In most cases, text is placed inside a frame. (You can also use the Type On A Path tool [ ] to
flow text along a path.) The size and location of a text frame determine where the text appears on
a page. Text frames can be created with the Type tool and can be modified using a variety of
tools—as you’ll do in this part of the lesson.

Creating and resizing text frames
Now you’ll create your own text frame, adjust its size, and then resize another frame.
1. In the Pages panel, double-click the icon for page 4 to center it in the document window.
2. In the Layers panel, click the Text layer to select it. Any content created when the Text
layer is selected will be placed on that layer.
3. Select the Type tool ( ) in the Tools panel. Position the pointer at .5 in on both the
horizontal and vertical rulers, which is the same as the margin guides. Drag to create a
frame that snaps to the right edge of the second column and has a height of about an inch.

4. Use the Zoom tool ( ) to magnify the text frame, and then select the Type tool.
5. In the new text frame, type Featured, press Shift+Enter (Windows) or Shift+Return
(macOS) to create a forced line break (without creating a new paragraph), and then type
Blossoms. Click anywhere within the text to select the paragraph.
Now you’ll apply a paragraph style to the text.
6. Click the Paragraph Styles panel icon ( ) or choose Type > Paragraph Styles to open the
panel. Click the style named Right Flush Title to apply it to the selected paragraph.

Tip
It isn’t necessary to highlight an entire paragraph before applying a paragraph style
to it. You can select a paragraph by clicking anywhere within it.

Read more about paragraph styles in Lesson 9, “Working with Styles.”
7. Using the Selection tool ( ), double-click the center-bottom handle of the selected text
frame to fit the frame to the text vertically.

8. Choose View > Fit Spread In Window, and then press Z to temporarily access the Zoom

tool and magnify the rightmost column on the front page (page 1). Use the Selection tool (
) to select the text frame that contains the headline “Botanical Gardens Worldwide.”
The red plus sign (+) at the lower-right corner of the text frame indicates that the frame
contains overset text. Overset text is not visible because the frame is too small to display it.
You’ll fix this by changing the size and shape of the text frame.
9. Drag the center-bottom handle of the selected text frame downward to resize the height of
the frame until the bottom is at about 6.5 inches on the vertical ruler guide. When the
pointer approaches the ruler guide, the arrows change in appearance from black to white,
indicating that the frame edge is about to snap to the guide.

10. Choose Edit > Deselect All, and then choose File > Save.

Reshaping a text frame
So far, you’ve resized a text frame with the Selection tool by dragging a handle. Now you’ll
reshape the frame using the Direct Selection tool to move one of the frame’s anchor points. Then
you’ll change the shape by changing the anchor point with the Pen tool.

Tip
The techniques in this lesson can also be used on graphics frames.

1. In the Tools panel, select the Direct Selection tool ( ), and then click within the text frame
you just resized. Four very small anchor points now appear at the corners of the selected
text frame. The anchor points are all hollow, indicating that none of them is selected.

2. Select the anchor point at the lower-right corner of the text frame, and pause for a moment
until the arrow pointer turns black. Drag up and to the left at about a 45 degree angle until
the point touches the next guide above and release the mouse button. As you drag, the text
reflows simultaneously to give you a real-time view. After you release the mouse button,
notice that the overset text indicator (the red plus sign) is displayed again.

3. Switch to the Convert Direction Point tool ( ) under the Pen tool ( ) in the Tools panel.
Press and hold on the point you just moved and drag up and to the right. The anchor point
will be converted from a corner point to a smooth point with handles. Release the mouse.

Note
Be sure to drag only the anchor point—if you drag just above or to the right of the
anchor point, you’ll move other corners of the text frame, too. If you accidentally
move the frame, choose Edit > Undo Move and try again.

4. Press the A key to switch back to the Direct Selection tool ( ), select the same anchor
point again, and drag down and to the right until the text is no longer overset.
5. Press the V key to switch to the Selection tool. Notice the difference between the guides
indicating the path and the bounding box of the object.

Tip
To resize a text frame and the text characters inside it simultaneously, select the
frame, and then double-click the Scale tool ( ), which is combined with the Free
Transform, Rotate, and Shear tools in the Tools panel. You can then specify values
in the Scale dialog box. You can also choose the Selection tool, hold down
Shift+Ctrl (Windows) or Shift+Command (macOS), and drag a text frame handle.
Including the Shift key ensures that the object and content are scaled proportionally.

6. Deselect all objects, and then choose File > Save.

Using Smart Guides
The Smart Guides feature gives you great flexibility in precisely creating and positioning
objects. With Smart Guides, you can snap objects to the edges and centers of other objects,
to the vertical and horizontal centers of pages, and to the midpoints of columns and gutters.
Plus, Smart Guides appear dynamically as you work to provide instant visual feedback. You
can align objects precisely without interrupting your creative process.
You can enable four Smart Guide options in the Guides & Pasteboard preferences (Edit >
Preferences > Guides & Pasteboard [Windows] or InDesign CC > Preferences > Guides &
Pasteboard [macOS]):
Align To Object Center. Causes object edges to snap to the center of other objects on
a page or spread when you create or move an object.
Align To Object Edges. Causes object edges to snap to the edge of other objects on a

page or spread when you create or move an object.
Smart Dimensions. Causes the width, height, or rotation of an object to snap to the
dimensions of other objects on a page or spread when you create, resize, or rotate an
object.
Smart Spacing. Lets you quickly arrange objects so that the space between them is
equal.
The Smart Guides command (View > Grids & Guides > Smart Guides) lets you turn Smart
Guides on and off. You can also enable/disable Smart Guides from the View Options menu
in the Application bar. Smart Guides are enabled by default.
To familiarize yourself with Smart Guides, create a new multicolumn one-page document.
(In the New Document dialog box, specify a value greater than 1 in the Columns Number
field.)
1. In the Tools panel, select the Rectangle Frame tool ( ). Drag from the left margin
guide to the right margin. As the pointer moves across the page, notice that a guide is
displayed when the pointer reaches the middle of a column, the midpoint within a
gutter, and the vertical center of the page. Release the mouse button when a Smart
Guide appears.
2. With the Rectangle Frame tool still selected, drag downward from the top margin
guide to the bottom margin. Notice that when the pointer reaches the top edge, center,
and bottom edge of the first object you created, as well as the horizontal center of the
page, a Smart Guide appears.
3. In an empty area of the page, create one more object with the Rectangle Frame tool.
Drag the mouse slowly and watch carefully. Smart Guides appear when the pointer
reaches the edge or center of any other objects. Also, when the height or width of the
new object equals the height or width of either of the other two objects, a vertical or
horizontal (or both) line with arrows at both ends appears next to the object you’re
creating and the object with the matching height or width.
4. Close the document without saving changes.

Creating multicolumn text frames
Now you’ll take an existing text frame and convert it to a multiple-column text frame.
1. Choose View > Fit Spread In Window, and then use the Zoom tool ( ) to display the
middle-right portion of the back cover (page 4). Use the Selection tool ( ) to select the
text frame that begins with “Rose.”
2. Choose Object > Text Frame Options. In the Text Frame Options dialog box, type 3 in the
Number box and 0.125 in in the Gutter box if necessary. The gutter controls the distance
between the columns. Click OK.

3. Choose Type > Show Hidden Characters to see the break characters. (If Hide Hidden
Characters is displayed—rather than Show Hidden Characters—at the bottom of the Type
menu, hidden characters are already showing.)

Tip
You can also display hidden characters by choosing Hidden Characters from the
View Options menu in the Application bar.

4. To begin each column with a heading, select the Type tool ( ) and place the cursor before
the “F” in “Foxglove,” and then choose Type > Insert Break Character > Column Break.
This forces “Foxglove” to the top of the second column. Insert another column break before
the name “Crocus.”

The small blue downward-pointing triangles within the red circles above are the Column Break characters.

5. Choose Type > Hide Hidden Characters.
6. In the Layers panel, click the lock icon (
you’ll work next.

) to unlock the Graphics layer, which is where

Adjusting text inset and vertical alignment
You’ll now finish the red title bar on the cover by fitting the text nicely into the frame. By
adjusting the space between the edge of the frame and the text, you make the text easier to read.
1. Choose View > Fit Spread In Window, and then use the Zoom tool (

) to magnify the

upper area of the cover (page 1). Using the Selection tool ( ), select the text frame with a
red fill and white text that says “Urban Oasis Garden Spring 2019.”
2. Choose Object > Text Frame Options. If necessary, drag the Text Frame Options dialog
box aside so that you can still see the selected text frame as you set options.
3. In the Text Frame Options dialog box, make sure that the Preview option in the lower-left
corner is selected. Then, in the Inset Spacing section, click the Make All Settings The Same
icon ( ) to disable it so that you can change settings independently. Change the Left value
to 2 in to move the left margin of the text frame 2 inches to the right and away from the left
edge of the frame, and then change the Right value to .625 in.
4. In the Vertical Justification section of the Text Frame Options dialog box, choose Center
from the Align menu. Click OK.

5. Select the Type tool ( ), and then click to the left of “Spring 2019” to establish an
insertion point. To move the URL text so that it aligns with the right inset you specified
above, choose Type > Insert Special Character > Other > Right Indent Tab.

6. Choose Edit > Deselect All, and then choose File > Save.

Creating and modifying graphics frames
Now you’re ready to add the logo and more images to the spread. In this section, you’ll focus on
different techniques for creating and modifying graphics frames and their contents.
Because you’ll be working on graphics rather than text, your first step is to make sure that the
graphics appear on the Graphics layer rather than on the Text layer. Isolating objects on different
layers streamlines your workflow and makes it easier to find and edit elements of your design.

Drawing a new graphics frame

To begin, you’ll create a frame for the logo at the top of the cover page (the page on the right in
the first spread).
1. If the Layers panel is not visible, click the Layers panel icon or choose Window > Layers.
2. In the Layers panel, click the lock icon ( ) to unlock the Graphics layer, if it is not
already, then lock the Text layer by clicking the box to the left of the layer name. Select the
Graphics layer by clicking the name of the layer so that the new elements are assigned to
this layer.

3. Choose View > Fit Spread In Window, and then use the Zoom tool ( ) to zoom in on the
upper-left corner of the cover (page 1).
4. In the Tools panel, select the Rectangle Frame tool ( ). Move the pointer to the upper-left
corner area of the page aligned with the left margin, drag down until the pointer crosses
over the red text frame a bit, and then drag across to the first margin guide.

Drag to create a graphics frame.

5. Switch to the Selection tool (

) and make sure that the graphics frame is still selected.

Placing a graphic within an existing frame
Now you’ll place the logo within the selected frame.
1. Choose File > Place, and then double-click urban-oasis-logo.ai in the Links folder in the
Lesson04 folder. The image appears in the graphics frame.

Note
If a graphics frame isn’t selected when you place an image, the pointer changes to
the loaded graphics icon ( ). In this case, you could click within the graphics frame
to place the image within the frame.

2. To ensure that the graphic is displayed at the highest possible resolution, choose Object >
Display Performance > High Quality Display.

Resizing a graphics frame to crop a graphic
The graphics frame you created isn’t quite wide enough to show the entire logo, so you’ll widen
it to reveal the hidden portion.
1. Using the Selection tool ( ), drag the center-right handle until the entire logo is visible. If
you pause just after you start to drag, you’ll see the cropped portion of the image as you
drag—a feature called Dynamic Preview—and easily determine when the frame edge is
beyond the edge of the logo.

Tip
You can also reveal the cropped portion of the graphic by choosing Object > Fitting
> Fit Frame To Content.

2. Choose Edit > Deselect All, and then choose File > Save.

Placing a graphic without an existing frame
The design of the newsletter uses two versions of the logo—one on the front cover and one on
the back cover. This time you’ll import the logo graphic without first creating a graphics frame.
1. Choose View > Fit Spread In Window, and then use the Zoom tool ( ) to display the
lower-right quarter of the back cover (page 4).
2. Choose File > Place, and then double-click the file urban-oasis-logo.ai in the Links folder
in the Lesson04 folder. The pointer changes to a thumbnail of the graphic you have chosen
with a loaded graphics icon in the upper-left corner. (The icon changes depending on the
file format of the graphic.)

Tip
If you click—rather than click and drag—an empty area of the page when you place
an image, the image is placed at 100 percent of its original size. The upper-left
corner of the image is placed where you click.

3. Position the loaded graphics icon at the left edge of the rightmost column slightly below the
rotated text frame that contains the return address. Drag until the pointer reaches the right
edge of the column, and then release the mouse button. Notice that as you drag, a rectangle
is displayed. This rectangle is proportional to the logo image.

You don’t need to resize the frame as you did earlier because the frame already shows the
entire image. The graphic still needs to be rotated, but you’ll do that later in the lesson.
4. Choose Edit > Deselect All, and then choose File > Save.

Placing multiple graphics in a grid of frames
The back cover of the newsletter should contain six photos. You could place the photos one by
one and then position each one individually, but because they will be arranged in a grid, you can
place all the photos and arrange them in a grid at the same time.
1. Choose View > Fit Spread In Window.
2. Choose File > Place. Navigate to the Links folder in the Lesson04 folder, click the graphic
file named 01Rose.jpg to select it, and then press Shift and click the file named
06CallaLily.jpg to select all six photos. Click Open.
3. Position the loaded graphics icon ( ) at the intersection of the horizontal ruler guide at the
top margin and the left edge of the third column.

Tip
When using any of the frame creation tools (Rectangle, Polygon, Type, and so on),
you can create multiple and equally spaced frames by using the same arrow key
gestures as you drag with the tool.

4. Drag down and toward the right margin. As you drag, press the up arrow key once and the
right arrow key twice. As you press the arrows, the proxy image changes to a grid of
rectangles to indicate the layout of the grid.

5. Continue dragging until the pointer snaps to the right margin guide, and then release the
mouse. A grid of six graphics frames displays the six photos you placed. With all six
frames still selected, move them slightly above the top margin by pressing the up arrow key
six times.

6. Choose Edit > Deselect All, and then choose File > Save.

Resizing and moving images within frames
Now that you’ve placed the six photos, you need to resize and reposition them so that they fill
the graphics frames and are cropped correctly.
The image and the frame for any placed graphic are separate elements. Unlike text frames, a
graphics frame and its content each have their own bounding box. To resize the image (without
resizing the frame), select the content by choosing Object > Select > Content, or use the content
grabber ( ), which displays as you hover over the graphic. You can see the different bounding
boxes when either the content or the frame is selected.
1. Using the Selection tool ( ), position the pointer over the content grabber within the
image of the rose (the top-left photo). When the pointer is within the content grabber, a
hand icon ( ) is displayed. Click to select the frame’s contents (the image itself).

Note

If you want, you can use the Zoom tool to magnify the area you’re working on as
you perform the tasks in this lesson.

2. While holding down the Shift key, drag the center-bottom handle past the bottom edge of
the graphics frame. Do the same with the center-top handle and drag it past the top edge of
the frame. The Shift key maintains the proportions of the graphic so that it is not distorted.
Remember that if you pause briefly just after you start dragging, you’ll see a ghosted image
of the cropped graphic contents. Also notice that the bounding box of the content (the
photo) becomes much larger than the frame. This tells you that the image is bigger than the
frame.

Tip
When resizing an image with the Selection tool, press Shift+Alt (Windows) or
Shift+Option (macOS) to size the image pro-portionately from the center outward.

3. The image now fills the frame but is poorly cropped. To fix this, position the pointer over
the content grabber within the image, and while holding down the Shift key, drag to the left
until the rose is more centered in the frame.

4. The image in the middle frame on the top row is too narrow to fill the frame. Click the
content grabber with the Selection tool to select the image. While holding down the Shift
key, drag the center-left handle to the left edge of the graphics frame. Do the same with the
center-right handle and drag to the right edge of the frame. Make sure that the image
entirely fills the graphics frame. Notice that the handles of the image bounding box extend

beyond the frame’s bounding box only at the top and bottom.
5. Repeat step 2 for the remaining photo in the top row to fill the frame with the image.

You’ll use a different method to resize the other three photos.
6. Use the Selection tool to select the graphic on the left of the second row. You can select
either the frame or its content.

Tip
You can also access the fitting commands from the context menu by right-clicking,
and you can click the fitting controls in the Control panel.

7. Choose Object > Fitting > Fill Frame Proportionally. This increases the scale of the graphic
so that the frame is filled. Small portions of the graphic are now cropped by the left and
right edges of the frame.

Tip
If you enable the Auto-Fit option for a graphics frame, the image within will
automatically resize when you resize the frame. To enable Auto-Fit for a selected
graphics frame, choose Object > Fitting > Frame Fitting Options, and then select
Auto-Fit, or select Auto-Fit in the Control panel.

8. Repeat steps 6 and 7 for the remaining two photos in the bottom row.

9. Choose Edit > Deselect All, and then choose File > Save.
Next, you’ll adjust the space between some of the photos to give the grid arrangement a visual

tweak.

Adjusting the space between frames
The Gap tool ( ) lets you select and adjust the space between frames. You’ll use it to adjust the
space between two of the photos in the top row and then two of the photos in the bottom row.
1. Choose View > Fit Page In Window. Hold down the Z key to temporarily access the Zoom
tool ( ), zoom in on the two photos at the top right, and then release the Z key to return to
the Selection tool.
2. Select the Gap tool ( ), and then move the pointer into the vertical gap between the center
and right pictures in the top row. The gap is highlighted—all the way down to the bottom
of the two photos below.
3. Hold down the Shift key and drag the gap one gutter width to the left, making the graphics
frame on the left one gutter width narrower and the one on the right one gutter width wider.
(Holding down Shift while dragging selects the gap between those two photos only;
otherwise, you’ll move the gap between the two photos below as well.)

4. Choose View > Fit Page In Window.

Tip
You can do addition (+), subtraction (–), multiplication (*)and division (/) in many
settings entry boxes. Taking advantage of this feature will make you much more
efficient when making changes.

5. Using the Selection tool ( ), drag-select the pictures in the top row. Set the Reference
Point in the Control panel to the lower left ( ). Click after the number in the Y: entry, type
–.0625, and then press Enter. InDesign does the subtraction for you, and by selecting the
reference point you control the direction of the move. In this case, the photos move up by
one-sixteenth of an inch. Using math in the Control panel is a powerful way to move and/or
scale objects precisely in InDesign.

6. Choose View > Fit Page In Window, and then choose File > Save.
You’ve completed the grid of images on the back cover (page 4).

Adding metadata captions to graphics frames
You can automatically generate captions for placed graphics based on metadata information
stored in the original graphic files. Next, you’ll use the captions feature to automatically add
captions to the pictures using metadata information.

Tip
If Adobe Bridge is installed on your computer, the Metadata panel lets you easily edit
metadata for images and see metadata associated with images.

InDesign lets you create either static captions, which generate caption text from a graphic’s
metadata and must be updated manually, or live captions, which are variables that retain links to
a graphic’s metadata and can be automatically updated.
1. With the Selection tool ( ), drag-select the six graphics frames by dragging across a
portion of all six photos (you don’t have to select all the way around them).
2. Click the Links panel icon to display the Links panel, and then choose Captions > Caption
Setup from the panel flyout menu.

Tip
You can also open the Caption Setup dialog box by choosing Object > Captions >
Caption Setup.

3. In the Caption Setup dialog box, specify the following settings:
In the Text After box, type Flower. (Make sure to enter a space character before the
word Flower. Don’t add a period after the space character.)
Choose Description from the Metadata menu; leave the Text Before box blank.
Choose Below Image from the Alignment menu.
Choose Photo Credit from the Paragraph Style menu.
In the Offset box, enter .02 in.

4. Click OK to save the settings and close the Caption Setup dialog box.
5. With the photos still selected, from the Links panel menu, choose Captions > Generate
Static Captions.

Each of the graphic files contains a metadata element named “Description,” which stores
the name of the flower. This metadata information is used when the caption is generated.
6. Choose Edit > Deselect All, and then choose File > Save.

Placing and linking graphics frames
The two imported graphics on the cover page within the “IN THIS ISSUE” frame are used again
on page 3 of the newsletter to accompany articles. Next, you’ll use the Place and Link feature to
create copies of these two graphics and place them on page 3.
Unlike the Copy and Paste commands, which simply create a duplicate of the original object, the
Place and Link feature creates a parent–child relationship between the original object and the
copy. If you make changes to the parent object, you have the option to update the child object.
1. Choose View > Fit Spread In Window.

Tip
In addition to placing and linking objects within a document, you can place and link
objects between documents.

2. Select the Content Collector tool ( ). Notice that an empty Content Conveyor is now
displayed at the bottom of the window.

Tip
You can also add objects to the Content Conveyor by selecting them and then
choosing Edit > Place And Link.

3. Move the pointer over the pink flower photo on page 1. Notice that a heavy red border is
displayed around the image, indicating that this graphics frame is on the Graphics layer
(because red was chosen as the color for the Graphics layer). Click within the frame. The
graphics frame is added to the Content Conveyor.

4. Click within the circular graphics frame below the pink flower photo to add it to the
Content Conveyor.

5. Open the Pages panel, and double-click page 3 to center it in the document window.

Note
Creating a link when placing content not only creates a link to the parent graphic but
also links the object’s appearance. Link Options can be set from the Links panel
menu.

6. Select the Content Placer tool ( ). (It’s paired with the Content Collector tool in the Tools
panel, and it’s also available in the lower-left corner of the Content Conveyor.) The pointer
changes to a loaded graphics icon with the pink flower photo active. Both graphics are
loaded.
7. Select Create Link at the lower-left corner of the Content Conveyor. If you don’t select
Create Link, you will simply create copies of the original objects without any parent–child
relationships.

8. Click the pasteboard to the right of the top article to place a copy of the pink flower photo,
and then click the pasteboard to the right of the bottom article to place a copy of the

circular graphic.

Tip
When you select the Content Placer tool, it is loaded with all objects in the Content
Conveyor. Press the arrow keys to move between objects in the Content Conveyor.
To remove an object from the Content Conveyor, press Esc.

9. Click the close box in the Content Conveyor to close it, or choose View > Extras > Hide
Conveyor.

Modifying and updating parent–child graphics frames
Now that you’ve placed and linked the two graphics frames, you’ll see how the parent–child
relationships work between the original objects and the copies.
1. Open the Links panel and adjust the panel so that all the filenames of the imported graphics
are visible in the scroll list. Select the pink flower photo (BleedingHeart.psd) in the
pasteboard. Notice that it is highlighted twice in the Links panel list and that one instance is
bracketed by greater than and less than characters. The greater than and less than characters
(<>) that bracket the filenames indicate that these graphics are linked to parent objects.
Notice that these two graphic files—the parent objects—are also listed and the next column
shows that the parent objects are on page 1 while the child objects are in the pasteboard
(PB).

2. Use the Selection tool ( ) to position the circular graphics frame to the left of the
“Planting Your Garden” article. Use the Smart Guides to align the top of the graphics frame
with the top of the article’s text frame; align the center point of the graphics frame with the
column guide to the left of the article’s text frame.

Tip
A Smart Guide appears when the top of the circular graphics frame is aligned with
the top of the text frame.

3. Navigate to page 1 (the front cover page), and then select the circular graphics frame.
4. Use the Control panel to apply a 5-point white [Paper] stroke to the frame.

5. In the Links panel, notice that the status of the <Planting.jpg> graphic on page 3 has
changed to Modified ( ). That’s because its parent object has been modified.
6. Navigate to page 3. Notice that the circular graphics frame no longer matches the version
on the cover, and its link badge (the yellow triangle with the exclamation mark) also
indicates it’s been modified. Select the circular graphics frame, and then click the Update
Link button ( ) in the Links panel. The frame now matches its parent.

Next, you’ll replace the pink flower photo with a newer version and then update its child
frame.

Tip
You can also click the modified link badge on the circular graphics frame on page 3
to update the link or double-click the modified link icon to the right of
<Planting.jpg> in the Links panel.

7. Navigate to page 1, and then select the pink flower photo with the Selection tool.
8. Choose File > Place. Make sure Replace Selected Item is selected in the lower-left quadrant
of the Place dialog box, and then double-click BleedingHeart-new.psd in the Links folder in
the Lesson04 folder.

In the Links panel, notice that the status of the file <BleedingHeart-new.psd> that’s on the
pasteboard of page 3 is modified. That’s because you replaced the parent graphic on page 1.
9. Select <BleedingHeart-new.psd> in the Links panel, and then click the Update Link button
( ) in the Links panel. If you want, navigate to page 3 to see the updated graphic on the
pasteboard, and then return to page 1.
10. Click the pasteboard to deselect all objects, choose View > Fit Spread In Window, and then
choose File > Save.

Wrapping text around a graphic
With InDesign, you can wrap text around the rectangular bounding box of any object, around
objects of any shape, and around the contours of imported images. As you wrap text around the
BleedingHeart-new.psd in this exercise, you’ll see the difference between wrapping around its
bounding box and around the shape of the graphic.
Your first task is to move the BleedingHeart-new.psd graphic. For precise positioning, you can
use the Smart Guides that are displayed dynamically when you create, move, or resize objects.
1. Open the Links Panel and click the BleedingHeart-new.psd that is on the pasteboard (PB).
Click PB to navigate to this graphic; then, press the Esc key to select the graphic’s frame
rather than the content.
2. Being careful not to select one of the handles, or the content grabber, drag the frame to the
left so that the center point of the frame is aligned with the guide to the left of the text
frame that contains the article text. Position it so that it overlaps the last two lines of the
first paragraph.
Notice that the graphic overlaps the text. You’ll change this by applying a text wrap.

3. Use the Zoom tool to zoom in on the frame you just moved. First we’ll enlarge the flower
graphic. Press Shift+Ctrl (Windows) or Shift+Command (macOS), and drag down and to
the right. Watch the Control panel values and release the mouse when the graphic is scaled
to about 175%. Using this key combination scales the graphic and its frame together and
proportionally.

4. Choose Window > Text Wrap. In the Text Wrap panel, select Wrap Around Bounding Box
( ) to wrap the text around the bounding box. If necessary, choose Show Options from the
panel menu to display all the controls in the Text Wrap panel.

This option leaves too much space for the desired design, so you’ll try another Text Wrap
option.

Note
The Wrap To menu in the Text Wrap panel is available only if you select Wrap
Around Bounding Box or Wrap Around Object Shape at the top of the panel.

5. In the Text Wrap panel, select Wrap Around Object Shape ( ). In the Wrap Options
section, choose Both Right & Left Sides from the Wrap To menu if it isn’t already selected.

In the Contour Options section, choose Detect Edges from the Type menu. Enter .25 in in
the Top Offset box to add space between the edge of the graphic and the text. This also
creates a gentler text wrap. Press Enter or Return.

6. Press Esc to select the frame and use the arrow keys to nudge the position of the graphic to
adjust how the text flows, using your judgment.
7. Click a blank area to deselect all, or choose Edit > Deselect All. Close the Text Wrap panel,
and choose File > Save.

Transforming the shape of frames
In this section, you’ll use various features that allow you to create nonrectangular frames. To
begin, you’ll subtract the area of one shape from another. After that, you’ll create a polygonshaped frame, and then you’ll add rounded corners to a frame.

Working with compound shapes
You can change the shape of an existing frame by adding other shapes to or subtracting other
shapes from its area. The shape of a frame can also be changed, even if the frame already
contains text or graphics. Now you’ll subtract a shape from the green background on page 3 to
create a white background for the article at the bottom of the page.
1. Choose View > Fit Page In Window to fit and center page 3 in the document window.
Open the Layers panel and unlock the Background layer. Click the Background layer so
that the next object will be on that layer.
2. Using the Rectangle Frame tool ( ), draw a frame around the story in the lower right. Start
from where the right edge of the first column meets the horizontal guide at 7.75 in on the
vertical ruler. Drag down and to the right past the intersection of the bleed guides that meet
outside the lower-right corner of the page. Look ahead to the illustrations in step 4 for
guidance.
3. With the Selection tool ( ), hold down the Shift key and click the purple background
shape that covers page 3 to simultaneously select the new rectangle and the background
box. Two frames are now selected.

4. Choose Window > Object & Layout > Pathfinder to display the panel. Choose the second
option under the Pathfinder section, Subtract, to subtract the top shape (the new rectangle)
from the purple shape. The text frame at the bottom of the page is now on a white
background.

5. Open the Layers panel and lock the Background layer again to avoid accidental
repositioning of the frame.
6. Choose File > Save.

Converting shapes
You can change the shape of an existing frame, even if the frame already contains text or
graphics. You’ll try this out by creating a perfect square and then converting it to a perfect circle
in one step.
Click the Layers panel icon or choose Window > Layers to open the Layers panel.
Click the Graphics layer to select it.
Select the Rectangle tool ( )
Click in the purple area between the stories on page 3. Hold down the Shift key and drag up
and to the left until the Width and Height values are about .5 in. Holding down the Shift
key constrains the rectangle to a perfect square.
5. Open the Swatches panel, click the fill color icon ( ), and choose Paper (White).
1.
2.
3.
4.

6. With the square still selected, choose Object > Convert Shape > Ellipse. You now have a
perfect circle. Check this by looking at the measurements in the Control panel. They are
still .5 in for both Width and Height.

Repeating shapes
1. With the circle still selected, choose Edit > Step And Repeat.
2. Under Offset, enter .875 in for Horizontal and 8 for Count. (Enter the Offset number first
because the default value may be too large to have enough room for eight repeats.) Leave
Vertical at Zero. Click OK.

3. Delete the third circle and the eighth circle.
4. Drag-select across all of the circles (make sure you locked the Background layer so that
you select only the circles).
5. Choose Distribute Horizontal Centers ( ) from the Align area of the Control panel, or
from the Align panel.

The circles are evenly distributed once again, with equal space between them.

Adding rounded corners to frames
Next, you’ll modify a text frame by rounding its corners.
1. Navigate to page 1 by choosing 1 from the page box at the bottom of the document
window. Choose View > Fit Page In Window. Unlock the Text layer.
2. With the Selection tool ( ) still selected, hold down the Z key to temporarily access the
Zoom tool ( ), zoom in on the dark blue text frame on page 1, and then release the Z key
to return to the Selection tool.

Tip
If the yellow square is not visible when selecting the frame, choose View > Extras >
Show Live Corners. Also ensure that Screen Mode is set to Normal (View > Screen
Mode > Normal).

3. Select the dark blue text frame, and then click the small yellow square that’s slightly below

the resizing handle at the upper-right corner of the frame. Four small yellow diamonds
replace the four resizing handles at the corners of the frame.

Tip
After you create rounded corners, you can Alt-click (Windows) or Option-click
(macOS) any of the diamonds to cycle through several different corner effects.

4. Drag the diamond at the upper-right corner of the frame to the left and release the mouse
button when the live radius (R:) value is approximately .2 in. As you drag, the other three
corners change, too. (If you hold down the Shift key when dragging, only the corner you
are working on changes.)

5. Choose Edit > Deselect All to exit live corner edit mode, and then choose File > Save.

Transforming and aligning objects
Various tools and commands in InDesign let you modify an object’s size or shape and change its
orientation on the page. All transformations—rotating, scaling, shearing, and flipping—are
available in the Transform and Control panels, where you can precisely specify transformations.
You can also align or distribute objects horizontally or vertically along the selection, margins,
page, or spread.
You’ll experiment with some of these features now.

Rotating an object
InDesign offers several methods for rotating objects. In this part of the lesson, you’ll use the
Control panel to rotate one of the logos you imported earlier in the lesson.
1. Use either the page box at the bottom of the document window or the Pages panel to
display page 4 (the first page of the document; the back page of the newsletter). Choose
View > Fit Page In Window.

2. Using the Selection tool ( ), select the logo you imported earlier in the lesson. (Make sure
you select the graphics frame and not the graphic within.)
3. At the left end of the Control panel, make sure that the center point is selected on the
Reference Point locator ( ) so that the object rotates around its center. Choose 180° from
the Rotation Angle menu in the Control panel.

Rotating an image within its frame
You can rotate the content of a graphics frame with the Selection tool.
1. Using the Selection tool ( ), select the image of the calla lily (second row, right) by
clicking within the content grabber. The arrow pointer changes to a hand when it’s within
the doughnut shape.

Tip
You can also rotate a selected object by choosing Object > Transform > Rotate and
entering a value in the Angle field of the Rotate dialog box.

2. Move the pointer slightly outside the resizing handle at the upper-right corner of the
picture. The rotate pointer ( ) is displayed.
3. Drag clockwise to rotate the image until the tip of the flower is pointing toward the lowerright corner of the frame (about –30°), and then release the mouse button. As you drag, the
angle of rotation is displayed along with the image.

4. In the Control panel, select the center point in the reference point locator ( ).
5. After being rotated, the image no longer fills the frame. To fix this, first make sure that the
Constrain Proportions For Scaling icon ( ) to the right of the Scale X and Scale Y
Percentage boxes in the Control panel is selected, and then enter 100 in the Scale X
Percentage box and press Enter or Return.

6. With Direct Selection tool or using the content grabber, make sure the Hand icon ( ) is
displayed and move the photo to the left within the frame to center the flower in the frame.
Choose Edit > Deselect All, and then choose File > Save.

Aligning multiple objects
Precise alignment is made easy when you use the Align tools. Next, you’ll use the Align panel to
horizontally center multiple objects on a page, and then you’ll align multiple images.
1. Choose View > Fit Page In Window, and then choose page 2 in the page box at the bottom
of the document window.
2. Using the Selection tool ( ), click the text frame at the top of the page containing the
“Partial Class Calendar” text and Shift-click the logo above it. (Unlike the two logos you
imported earlier, this logo is a group of InDesign objects. You’ll work with this group later
in the lesson.)
3. Choose Window > Object & Layout > Align to open the Align panel.
4. In the Align panel, choose Align To Page from the Align To menu, and then click the Align
Horizontal Centers button ( ). The objects are now aligned to the center of the page.

5. Click a blank area or choose Edit > Deselect All.
6. Use the scroll bar at the bottom of the document window to show more of the pasteboard
on the left of page 2. You’ll see nine icons.

Note
When you specify a key object, the alignment of the other selected objects will be
relative to the key object’s position.

7. Using the Selection tool ( ), Shift-drag-select the nine graphics frames in the pasteboard.
Press the Shift key and select the graphics frame with the tomato that is on the page.

Tip
InDesign automatically assigns the object you selected first as the key object. To
change the key object once you’ve selected all objects to be aligned, click the object
that should be the key object. A thicker selection border will then appear around that
object.

8. In the Align panel, choose Align To Key Object from the Align To menu. Click the tomato
graphic again. Notice that it now has a thick red border, indicating that it’s the key object.
9. Click the Align Right Edges button ( ).

10. Choose Edit > Deselect All, and then choose File > Save.

Scaling multiple objects
InDesign lets you scale multiple selected objects.
Next you’ll select two of the icons and resize both of them at once.
1. Use the Zoom tool ( ) to zoom in on the two icons that are smaller than the rest of the
icons in the column.
2. Using the Selection tool ( ), click the first of the icons to select it, and then Shift-click the
second icon to select both.
3. Press Shift+Ctrl (Windows) or Shift+Command (macOS), and then drag the handle at the
upper-left corner up and to the left to make the two icons the same width as the trowel icon
above or the tree icon below the selected icons. A Smart Guide is displayed when the left
edges of the selected frames align with the frame above. Note that you may have to repeat
the scaling more than once to get the size correct.

Note

If you press only the Shift key, the frames will scale proportionally, but the graphics
within will not scale.

4. Drag these icons down to adjust the vertical position of these icons, again watching how the
Smart Guides show you the space between adjacent objects. You will need to move them
individually to end up with equal space between. Choose Edit > Deselect All when you are
satisfied, and then choose File > Save.

Transforming multiple objects
InDesign lets you apply a transformation to multiple selected objects. Next, you’ll duplicate the
icons, apply a transformation to one of them, and then apply the same transformation to the rest
of them at once.
1. Choose View > Fit Page In Window.
2. Using the Selection tool ( ), select the trowel icon and press Alt (Windows) or Option
(macOS) while dragging it up to the area between the table and the calendar headline. This
technique makes a copy of the object.
3. Use the same technique to drag copies of the tomato, pot, tree, and sun icons to the same
area. Notice how the Smart Guides show you when the objects are aligned.
4. Move the sun icon to the right and align it with the guide on the right of the page. Then
drag-select all five icons and select Align To Selection from the Align panel or the Control
panel. Then select Distribute Horizontal Centers. The icons are now spread evenly across
the top of the table.

5. Choose Edit > Deselect All then select the trowel icon again. Set the reference point in the
Control panel to the center position. Choose 125% for the scale and 30° for the angle.
6. Drag across the other four icons (because the Background layer is locked, you won’t select
the background box). Then choose Object > Transform Again > Transform Sequence Again
Individually. InDesign applies the same scale and angle that you applied to the trowel icon
to the other four icons without you having to apply them one at a time to each object. A
sequence of many transformations can be applied to other objects using this command.

7. Select all five icons and nudge them up or down using the keyboard arrow keys so that they
are approximately centered between the table and the calendar headline, if necessary.

8. Choose Edit > Deselect All, and then choose File > Save.

Selecting and modifying grouped objects
Earlier you aligned the logo at the top of page 2 to the center of the page. Now you’ll change the
fill color of some of the logo’s shapes. Because they’re grouped, you can select and modify them
as a unit, or you can select individual objects within a group. You’ll now change the fill color of
just a few of the shapes without ungrouping or changing the other objects of the group.
The Direct Selection tool, the Select Content buttons, or a set of commands in the Object menu
(Object > Select) let you select individual objects in a grouped object.
1. Choose View > Fit Spread In Window.
2. With the Selection tool ( ), click the logo at the top of page 2. If you want, use the Zoom
tool ( ) to magnify the area you’re working on.

Tip
You can also select an object in a group by double-clicking the object with the
Selection tool, by selecting the group and choosing Object > Select > Content, or by
right-clicking the group and choosing Select > Content from the context menu.

3. Click the Select Content button (
without ungrouping.

) in the Control panel to select one object in the group

4. Click the Select Next Object button ( ) in the Control panel to select the first vertical leaf
in the logo. Note that the Select Previous Object button selects in the opposite direction.

5. Change the fill color of this object to Green-Bright-Medium from the Swatches panel. Then
click the Next Object button ( ) again and change this object to Green-Medium. Click the
Next Object button two more times to select the third large leaf object and change its fill
color to Green-Brightest.

6. Choose Edit > Deselect All, and then choose File > Save.

Drawing lines and modifying arrowheads
InDesign has the ability to scale arrowheads independently of line size. Next, you’ll use this
feature to complete the design of the newsletter.
1. Navigate to page 4. Select the Line tool ( ). Position the pointer on the left margin guide,
slightly below the text frame with the “Featured Blossoms” text.
2. With the Line tool selected, change the fill color to None and the stroke color to Black.
3. While pressing the Shift key, drag horizontally from the left margin guide to the vertical
column guide at the right of the second column. The Shift key constrains the line to be
perfectly horizontal.

4. Click the Stroke panel icon or choose Window > Stroke to open the Stroke panel. Choose 4
from the Weight menu, CircleSolid from the Start Arrowhead menu, and Curved from the
End Arrowhead menu.

Tip

In addition to adding arrowheads to straight lines created with the Line tool, you can
add arrowheads to curved lines created with the Pen tool.

5. Make sure Link Start And End Arrowhead Scales is not selected ( ) so that you can
independently scale the start and end arrowheads. Enter 75 in the Scale Factor For Start
Arrowhead box; enter 150 in the Scale Factor For End Arrowhead box, and press Enter or
Return.

6. Choose File > Save.

Creating a QR code
InDesign lets you quickly generate and edit high-quality quick response (QR) code graphics. QR
codes are machine-readable printed representations of data for various industry uses and have
become common in consumer advertising. A consumer with a smartphone can install a QR-code
scanner app that can read and decode the URL information and redirect the phone’s browser to a
company website. After scanning QR codes, users may receive text, add a business card contact
to their devices, open a web hyperlink, or compose an email or text message.
The QR code generated in InDesign is a high-fidelity graphic object that behaves exactly like
other InDesign objects. You can easily scale the object and fill it with color, apply transparency
effects, or copy and paste the object as a vector graphic into a standard graphics editor tool such
as Adobe Illustrator.
Next, you’ll add a QR code to the back page of the newsletter and configure it to open a web
page.
1. Navigate to page 4 of the document (the back cover), and then choose View > Fit Page In
Window to center the page.
2. Choose Object > Generate QR Code.

Tip
Click the Color tab in the Generate QR Code dialog box to apply a swatch color to
the code.

3. Choose each of the options in the Type menu to see the possibilities, and then choose Web
Hyperlink for this lesson.
4. In the URL field, enter http://www.adobe.com (or the complete URL for any website you
choose).

Tip
To edit a QR code, right-click the code with the Selection tool, and then choose Edit
QR Code from the context menu or choose Object > Edit QR Code.

5. Click OK to close the dialog box.
6. Click above the caption “SCAN for the latest information from Adobe.” The automatically
generated graphic is placed. Adjust its position to left-align with the caption.

Finishing up
Now it’s time to admire your work.
1. Choose Edit > Deselect All.
2. Choose View > Fit Spread In Window.
3. At the bottom of the Tools panel, hold down the current screen mode button (

) and

choose Preview from the menu that appears. Preview mode is an ideal way to see what a
document will look like when it’s printed. Preview mode displays artwork as if it were
printed and trimmed, with all nonprinting elements suppressed (grids, guides, frame edges,
nonprinting objects) and the pasteboard set to the preview color defined in Preferences.

4. Press the Tab key to close all the panels at the same time. Press the Tab key again when
you are ready to show all the panels.
5. Choose File > Save.
Congratulations! You have finished the lesson.

Exploring on your own
One of the best ways to learn about frames is to experiment on your own.
In this section, you’ll learn how to nest an object inside a frame. Follow these steps to learn more
about selecting and manipulating frames:
1. Create a new (Print) document using the default settings in the New Document dialog box.
2. Use the Ellipse Frame tool ( ) to create a small circular text frame, approximately 2 in x 2
in. (Press the Shift key as you drag to constrain the shape to a circle.)
3. Select the Type tool and then click within the frame to convert it to a text frame.
4. Choose Type > Fill With Placeholder Text to fill the frame with text.
5. Press the Esc key to switch to the Selection tool, and then use the Swatches panel to apply a
fill color to the text frame.
6. Select Edit > Deselect All, and then select the Polygon tool ( ). Draw a shape on the page.
(Before creating the polygon, you can double-click the Polygon tool to specify the number
of sides and optionally a star inset value if you want to create a starburst shape.)

7. Using the Selection tool ( ), select the text frame you created earlier, and then choose
Edit > Copy.
8. Select the polygon frame, and then choose Edit > Paste Into to nest the blue text frame
inside the polygon frame. (If you choose Edit > Paste, the copied text frame is not pasted
inside the selected frame.)

9. Use the Selection tool to move the text frame by positioning the pointer within the content
grabber in the center of the polygon frame and then dragging.

10. Use the Selection tool to move the polygon frame and its content by positioning the pointer
outside the content grabber and then dragging.
11. Choose Edit > Deselect All.
12. Use the Direct Selection tool ( ) to select the polygon frame, and then drag any of the
handles to change the shape of the polygon.
In this section, you’ll learn how create a compound path in InDesign. A compound path allows
objects behind to show through part of another object.
1. In another area of the page you’ve been working with, place one of the flower graphics
used in this lesson. Choose Object > Display Performance > High Quality Display so that

you can see the photo more clearly.
2. Select the Ellipse tool ( ) in the Tools panel and position the cursor over the photo. Then
press the Option and Shift keys while dragging outwards to draw a circle that expands from
the center.
3. Fill the circle with a color. Then in the Tools panel, select the Scale tool ( ), which is
grouped with the Free Transform tool. Press the Option key and click in the center of the
circle. In the Scale dialog box that pops open, enter 75% and make sure the Same Settings
icon ( ) is selected. Then click Copy. This creates another circle on top of the first circle
with the centers aligned.

4. Hold down the Shift key and with the Selection tool, select the large circle so that both
circles are now selected. Choose Object > Paths > Make Compound Path. The photo is now
visible inside the center of the smaller circle, which has been used to visually cut through
the larger circle.

Review questions
1 When should you use the Selection tool to select an object, and when should you use the Direct
Selection tool to select an object?
2 How do you rotate the graphic within a graphics frame without rotating the frame?
3 Without ungrouping objects, how do you select an object within a group?
4 How do you align objects to another specific object?

Review answers
1 Use the Selection tool for general layout tasks, such as positioning, rotating, and resizing

objects. Use the Direct Selection tool for tasks involving editing paths or frames, such as
moving an anchor point on a path or selecting an object within a group and then changing the
object’s fill or stroke color.
2 To rotate a graphic within a frame, use the Selection tool to select the graphic within the frame
by clicking within the content grabber. Then position the pointer slightly outside any of the
four corner handles and drag to rotate the graphic. Add the Shift key while dragging to
constrain rotation to increments of 45°. You can also rotate a selected graphic by changing the
Rotation Angle value in the Control panel.
3 To select an object within a group, use the Selection tool ( ) to select the group, and then
click the Select Content button ( ) in the Control panel to select one object in the group. You
can then click the Select Previous Object or Select Next Object button to select different
objects in the group. You can also select an object in a group by clicking the object with the
Direct Selection tool ( ) or double-clicking it with the Selection tool.
4 Select all of the objects you want to align. Then click the object to which you want all of the
other objects to align. This becomes the key object, which is indicated by a thicker highlight
around that object. Then choose Align To Key Object from the Control panel or the Align
panel. Click the alignment you want, such as Align Top Edges or Align Horizontal Centers, or
any of the other choices.

5 Flowing Text

Lesson overview
In this lesson, you’ll learn how to do the following:
Import and flow text into existing text frames.
Resize text frames automatically.
Link text frames to flow text across columns and pages.
Create linked frames automatically.
Add pages and linked frames automatically while flowing text.
Apply paragraph styles to text.
Control column breaks.
Align text to the baseline grid.
Make a jump line to indicate where an article continues.

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the files for this lesson, or go to the “Getting Started” section at the
beginning of this book and follow the instructions under “Accessing the Lesson Files and Web
Edition.” Store the files on your computer in a convenient location. Your Account page is also
where you’ll find any updates to the lessons or the lesson files. Look on the Lesson & Update
Files tab to access the most current content.

Adobe InDesign CC provides methods for flowing text into existing frames, creating frames while flowing text, and adding
frames and pages while flowing text. This makes it easy to flow copy for anything from a catalog to a magazine article to an
ebook.

Getting started
In this lesson, you’ll work on a booklet in progress. The design of the opening spread of the
article is almost finished, and several pages are ready for text. While working on this article, you
will experiment with various text-flow methods and create a “jump line” to indicate the page on
which an article continues.

Note
If you have not already down-loaded the project files for this lesson to your computer
from your Account page, make sure to do so now. See “Getting Started” at the beginning
of the book.

1. To ensure that the preferences and default settings of your InDesign program match those
used in this lesson, move the InDesign Defaults file to a different folder following the
procedure in “Saving and restoring the InDesign Defaults file” on pages 4–5.
2. The InDesign Start Screen displays. Click Open at left. (If the Start Screen does not
display, choose File > Open from the InDesign menu bar.)
3. Open the 05_Start.indd file in the Lesson05 folder, located inside the Lessons folder within
the InDesignCIB folder on your hard disk.

Note
For higher contrast in the printed manual, the screen captures in this book show the
Medium Light interface. Interface elements such as panels and dialog boxes may be
darker on your screen.

4. To ensure that the panels and menu commands match those used in this lesson, choose
Window > Workspace > [Advanced], and then choose Window > Workspace > Reset
Advanced.
5. To display the document at a higher resolution, choose View > Display Performance >
High Quality Display (if it’s not already enabled).
6. Choose File > Save As, rename the file 05_FlowText.indd, and save it in the Lesson05
folder.
7. If you want to see what the finished document looks like, open the 05_End.indd file in the
same folder. You can leave this document open to act as a guide as you work.

8. When you’re ready to resume working on the lesson document, display it by clicking its tab
in the upper-left corner of the document window.

Flowing text into an existing frame
When you import text, you can flow it into a new frame or an existing frame. If the frame is
empty, you can click the loaded text icon in the frame to flow the text. On the left page of the
opening spread of this booklet, an empty sidebar box is ready for text to be inserted. You will
import a Microsoft Word document into this frame, apply a paragraph style, and automatically
adjust the height of the text frame.

Tip
InDesign provides many features for automatically and manually controlling how text
flows through columns and frames. These include the paragraph Keep Options (Keep
With Previous, Keep With Next, and Keep Lines Together), along with Column Break
and Frame Break characters (Type > Insert Break Character).

Importing text into an existing text frame
1. Choose Type > Show Hidden Characters to see paragraph returns, spaces, tabs, and other
hidden characters onscreen. This helps you place and format text.
2. Zoom in to comfortably view the sidebar text frame on the left page of the opening spread.
The frame has a stroke and a sage green background.
3. Make sure no objects are selected.

Tip
You edit text with the Type tool and thread (link) text frames with the Selection tool,
but it does not matter what tool is selected when you import text.

4. Choose File > Place. At the bottom of the Place dialog box, make sure the three options are
deselected: Show Import Options, Replace Selected Item, and Create Static Captions. (If
necessary, click Options on macOS to see the options.)
5. Locate 05_Highlights.docx, in the Lesson05 folder, and then double-click it.
The pointer becomes a loaded text icon ( ), previewing the first few lines of text in the
article you are placing. When you move the loaded text icon over an empty text frame,
parentheses enclose the icon ( ).
6. Position the loaded text icon over the placeholder text frame.

7. Click to place the text.
8. Choose File > Save.
The text does not fit in the text frame and is considered “overset.” Overset text is indicated by a
red plus sign (+) in the out port, which is in the lower-right corner of the text frame. You will
resolve the overset text later in this exercise.

Applying a paragraph style

Now you will apply a paragraph style to the sidebar text. The paragraph style includes a nested
style that automatically applies bold to the beginning of a paragraph until InDesign encounters
the first colon.
1. Using the Type tool ( ), click in the sidebar text frame so you can format the text. Choose
Edit > Select All to select all the text in the frame (even the text you cannot see).
2. Choose Type > Paragraph Styles to open the Paragraph Styles panel.

Tip
Style groups help you organize styles in panels such as the Paragraph Styles and
Swatches panels. When the group is expanded, you can select options in the group.

3. Click the triangle to the left of the Body Text style group to open it.
4. Click the paragraph style Sidebar Text.
5. Click in the text to deselect it. Choose File > Save.

Resizing text frames automatically
While adding, deleting, and editing text, you often end up resizing text frames. With the AutoSize feature, you can specify that a text frame resize itself automatically according to your
specifications. You will now use the Auto-Size feature to automatically adjust the size of the
sidebar text frame based on the length of the text.
1. Using the Type tool ( ), click in the sidebar immediately before the word “Plant.”
2. Press the Caps Lock key on your keyboard, and then type PEAS, PLEASE and press Enter
(Windows) or Return (macOS). After adding the heading, the sidebar text is now overset.
3. Using the Selection tool ( ), click the text frame containing the sidebar text now starting
with “PEAS.”

Tip
The Auto-Size feature is ideal for individual text frames with a stroke and/or fill
providing a boundary for the text (for example, a sidebar or coupon). If the text is
shortened, the frame becomes smaller as well. If the text is lengthened, the frame
becomes bigger so text is not overset.

4. Choose Object > Text Frame Options. In the Text Frame Options dialog box, click the
Auto-Size tab and select Preview.
5. Choose Height Only from the Auto-Sizing menu.
6. If necessary, click the center icon in the top row ( ) to indicate that you want the text
frame to “grow down” as if you were manually dragging the bottom handle of the text
frame down.

7. Click OK.
8. Click the pasteboard to deselect objects on the page, and then choose View > Screen Mode
> Preview to see how the sidebar looks.

9. Choose View > Screen Mode > Normal to restore the layout aids, such as guides and
hidden characters.
10. Choose File > Save.

Flowing text manually
The process of taking an imported text file and flowing it across several connected text frames is
called threading text. InDesign lets you flow text manually for greater control, flow text
automatically to save time, and flow text while automatically adding enough pages to hold all the
text.

Tip
You can create columns by threading individual text frames or by dividing text frames
into multiple columns using the General tab of the Text Frame Options dialog box
(Object menu). Some designers prefer separate text frames for more layout flexibility.

In this exercise, you will flow the feature article text into the two columns on the right-hand
page. First, you will select a Word file to import into the existing text frame in the first column.
Second, you will thread the first text frame to the second text frame. Finally, you will create new
text frames on the third page of the document to contain more text.

Tip

To prepare to import text, you can pre-thread empty text frames. Using the Selection tool,
click a frame’s out port, and then click anywhere in the next frame. Repeat this process
until all the frames are threaded.

1. Choose View > Fit Spread In Window to locate the two text frames at right under the “How
to grow peas, please!” headline.
2. Zoom in as necessary to view these text frames.
3. Using the Type tool ( ), click in the text frame at the left as shown below.

4. Choose File > Place.
5. Locate and select 05_Peas.docx, in the Lesson05 folder.
6. Select Replace Selected Item at the bottom of the Place dialog box. (If necessary, click
Options on macOS to see this option.) Click Open.

The text flows into the existing frame in the left column. Notice that the text frame includes
an out port in the lower-right corner. The red plus sign (+) indicates that some of the text
you imported is overset, meaning that not all of the text fits into the existing text frame. You
will now flow the additional text into another text frame in the second column.

Tip
As you flow text, the Selection tool’s cursor changes to various loaded text icons.

7. Using the Selection tool ( ), click in the text frame’s out port to load the text icon. (If
necessary, first click the frame to select it, and then click the out port.)

8. Move the loaded cursor over the text frame to the right and click once in the frame as
shown.

Tip
If you change your mind and decide you don’t want to flow overset text, you can
press Esc or click any tool in the Tools panel to cancel the loaded text icon. No text
will be deleted.

9. The text flows into the second column. The out port in the text frame at the right contains a
red plus sign (+), indicating that there is still overset text.

10. Choose File > Save. Leave the page in this position for the next exercise.

Tip
You can also “load” the Type tool with graphics files and text files at the same time.

Loading the Type tool with multiple text files
In the Place dialog box, you can “load” the Type tool with multiple text files and then place
them individually. Loading the Type tool works as follows:
First, choose File > Place to open the Place dialog box.
Ctrl-click (Windows) or Command-click (macOS) to select multiple noncontiguous
files. Shift-click to select a contiguous range of files.

When you click Open, the loaded text icon shows in parentheses how many files are
loaded, such as (4).
Press the arrow keys on the keyboard to change which text file is loaded for placement,
and press Esc to remove a text file from the loaded text icon.
Click to place the text files one at a time.

Creating text frames while flowing text
Now, you will try two different text flow methods. First, you will use semi-autoflow to place text
into a column. Semi-autoflow lets you create threaded text frames one at a time. The pointer
becomes a loaded text icon that automatically reloads after each column of text is placed. After
that, you will use the loaded text icon to manually create a text frame.

Tip
The loaded text icon changes slightly in appearance, depending on whether you are
threading text manually or using semi-autoflow or autoflow.

Note that the success of these exercises relies on holding the correct modifier keys on the
keyboard and clicking in the correct place. Therefore, it may help to read all the steps in each
exercise before you perform them. If anything goes wrong, be sure to choose Edit > Undo, and
then repeat the step.

1. Using the Selection tool ( ), click the out port of the text frame in the second column on
the right page (page 1). This loads the text icon with the overset text.
You will create new text frames on page 2 to contain more of the text. Guides indicate
where to place the text frames.
2. Choose Layout > Next Spread to display pages 2 and 3, and then choose View > Fit Spread
In Window.
When the loaded text icon is active, you can still navigate to different document pages or
add new pages.
3. On the page at left, position the loaded text icon ( ) in the upper-left corner where the
guides intersect. For proper placement, watch for the black arrow in the loaded text icon to
turn white.

Tip
When the loaded text icon is over an empty text frame, a chain icon indicates that
you can thread to that frame. You can also flow overset text into an empty graphics
frame; the graphics frame is automatically converted to a text frame.

4. Hold down the Alt (Windows) or Option (macOS) key and click.

The text flows into the first column. Because you held down Alt or Option, the pointer is
still a loaded text icon, ready for you to flow text into another frame.
5. Release the Alt or Option key, and position the loaded text icon (
indicated by the guides.

) in the second column

Tip
When you create a text frame by clicking with the loaded text icon, InDesign creates
the new text frame as wide as the column where you click. Although these frames
are placed within the column guides, you can move, resize, and reshape these text
frames as necessary.

6. Click to create a frame within the column guides in the right column.

Clicking the loaded text icon creates text frames within the column guides and flows the
text.

Text remains overset, as indicated by the red plus sign (+) in the lower-right corner of the
second text frame. You will fix this later.
7. Choose File > Save. Leave the page in this position for the next exercise.

Creating threaded frames automatically
To speed up the creation of column-width linked text frames, InDesign provides a shortcut. If
you press the right arrow key as you drag the Type tool to create a new text frame, InDesign
automatically divides the text frame into multiple threaded frames. For example, if you press the
right arrow key once while creating a text frame, the text frame is divided into two text frames of
equal width. If you press the right arrow key five times, the text frame is divided five times,
resulting in six columns of equal width.
You will now create a two-column text frame on page 3. You can then thread the text frames to
help contain the overset text.
1. Choose View > Fit Spread In Window to center pages 2 and 3 in the window.
2. Select the Type tool ( ), and position it in the first column on the page at right, where the
column guide (purple) and margin guide (pink) intersect.

Note
If you accidentally press the right arrow key more than once—producing more than
two threaded text frames—choose Edit > Undo, and then try again. You can also
remove text frames by pressing the left arrow key as you drag.

3. Drag the Type tool down and to the right to create a text frame that spans the width of both
columns. As you drag, tap the right arrow key once.
InDesign automatically subdivides the text frame into two threaded text frames of equal
width.

4. Continue to drag down to position the text frame within the column and margin guides. If
necessary, use the Selection tool ( ) to adjust the text frames to fit within the guides as
shown.

5. Using the Selection tool, click the text frame in the second column on page 2. Click the
frame’s out port in the lower-right corner to load the text icon with overset text.
6. Click the loaded text icon ( ) in the new text frame on page 3.

The text flows through the two columns.

7. Choose File > Save. Leave the page in this position for the next exercise.

Flowing text automatically
You will now autoflow the remaining text into the booklet. When you autoflow text, InDesign
automatically creates new text frames within column guides on subsequent pages until all of the
overset text is placed. This is ideal for longer projects, such as books, but for this project it will
end up obscuring some of the images that are already placed. You can fix that easily by deleting
the text frames; the text flow is automatically rerouted through the remaining frames in the
thread.

Tip
Experiment with text-flowing options to find out what threading methods work best for
you and your projects. For example, if you are creating a template for a catalog, you
might thread several small text frames for item descriptions and then flow the text later.

1. Using the Selection tool ( ), click the out port in the lower-right corner of the text frame
in the second column on page 3. This loads the text icon with the overset text. (If necessary,
first click the frame to select it, and then click the out port.)
2. Choose Layout > Next Spread to display pages 4 and 5.
3. Position the loaded text icon ( ) in the first column on page 4, precisely where the column
and margin guides intersect.

Tip
Shift-clicking the loaded text icon creates and flows text into automatically created

text frames, adding pages as necessary to flow all the text into the document.

4. Hold down the Shift key and click.
Notice that new text frames are added to the remaining pages in the document, even on top
of the photos. This is because you held down the Shift key to autoflow text.

5. Using the Selection tool, Shift-click to select the two new text frames added to page 5 (the
frame on top of the image of the gardening tools).
6. Choose Edit > Clear to delete the text frames.
7. Choose Layout > Next Spread to display pages 6 and 7. As you can see, the text is flowing
from page 4 to page 6 to page 7.
8. Using the Selection tool, Shift-click the two new text frames added to page 7 (the frames on
top of the image of peas).
9. Choose Edit > Clear to delete the text frames.
Text is still overset, but you will resolve that with formatting in the next exercise.
10. Choose File > Save. Leave the page in this position for the next exercise.

Adding pages while flowing text
In addition to threading text frames on existing pages, you can add pages while flowing
text. This feature, called Smart Text Reflow, is ideal for flowing long passages of text such
as book chapters. With Smart Text Reflow, flowing text or typing into a primary text frame
automatically adds pages and threaded text frames to contain all the text. If text becomes
shorter through editing or reformatting, any extra pages can be automatically deleted as
well. To experiment with Smart Text Reflow, follow these steps:
1. Choose File > New > Document. In the New Document screen:

Click Print across the top.
Click the Letter - Half icon.
Click the Landscape icon for Orientation.
Select Primary Text Frame.
2. Click Create.
3. Choose Edit > Preferences > Type (Windows) or InDesign CC > Preferences > Type
(macOS) to open the Type preferences. The options in the Smart Text Reflow section
of the Type preferences let you specify how pages are handled when you use Smart
Text Reflow. Options include:
Where pages are added (to the end of a story, section, or document)
Whether Smart Text Reflow applies only to primary text frames or to other text
frames in a document
How pages are inserted into facing-page spreads
Whether empty pages are deleted as text becomes shorter
4. Smart Text Reflow is selected by default, but confirm that it is selected. The Smart
Text Reflow controls are at the bottom of the Type preferences. Click OK.
5. Choose File > Place. In the Place dialog box, locate and select 05_Peas.docx, in the
Lesson05 folder, and click Open.
6. On the first page of the new document, click the loaded text icon within the page
margins to flow all the text into the primary text frame, adding pages as necessary.
Note the number of pages (3) in the Pages panel.
7. Close the file without saving it.

Applying paragraph styles to text
Now that all the threaded text frames are in place and the text is flowing through them, you can
format the text. This gives you a clear view of how the text fits and how it looks with the layout.
Here, you will format the entire article with the Body Paragraphs style, and then you will format
the opening paragraph and subheads.
1. Using the Type tool ( ), click in any text frame containing the main article you just
imported.
2. Choose Edit > Select All to select all the text in the story (the text in the series of linked
frames).
3. Choose Type > Paragraph Styles to open the Paragraph Styles panel.
4. Click the paragraph style Body Paragraphs. (If necessary, open the Body Text style group
folder and scroll to locate the style.)

5. Choose Layout > Go to Page. Enter 1 in the Page field, and click OK.
6. On page 1, click in the first paragraph of the article, starting with “Peas grow well in
heavy.”
7. Click the Drop Cap paragraph style in the Paragraph Styles panel.

Now you will format the six subheads in the article.
8. Choose View > Fit Spread In Window.
9. Using the Type tool, click in the subhead that reads “Fertilizing” in the left column of page
1. This targets the paragraph for paragraph formatting.
10. Click the Body Head paragraph style in the Paragraph Styles panel.
11. Click in the next paragraph starting with “When dairy dressing,” and then click the Body
Paragraphs No Indent paragraph style in the Paragraphs Styles panel.

12. Follow steps 9–11 to apply the Body Head paragraph style to the remaining subheads in the
story. Apply Body Paragraphs No Indent to the paragraph following each subhead as well.
Page 2, left column: “Sowing”
Page 3, left column: “Thinning Out”
Page 3, right column: “Protection from Birds”
Page 3, right column: “Caring for the Vines”
Page 4, left column: “Picking Peas”
Page 4, right column: “Follow Crops”
13. Choose File > Save. Remain on this page for the next exercise.

Adjusting columns
InDesign provides many methods for adjusting the length of columns of text. You might do this
to suit the layout or to keep specific topics together. One way to do this is to resize the text frame
with the Selection tool. Another method is to manually “bump” text to the next column with the
Column Break character. Here, you will adjust the size of the text frames to suit the layout.
1. Double-click the page 4 icon on the Pages panel to center it in the document window.
2. Using the Selection tool ( ), click the text frame on the left containing the main article.

Note
If necessary, type 2.1 in in the Height field on the Control panel and press Enter
(Windows) or Return (macOS) to resize the frame.

3. Drag the bottom of the text frame up so that the height of the frame shows approximately
2.1 in.
4. Select the text frame at right, which contains the second column of text. Drag the bottom of
the frame up to match the height of the text frame at left.
Resizing these text frames keeps the article text from obscuring the shaded sidebar box.

Tip
To adjust how text flows within frames, you can enter break characters such as
Column Break and Frame Break (Type > Insert Break Character).

5. Choose Layout > Next Spread to see pages 6 and 7. The bottom of page 6 contains a box
with a quote from E.M. Forster.
6. Using the Selection tool, click the text frame at left on page 6. Drag the bottom of the text
frame up so the height of the frame shows 2.5 in.
7. Select the text frame at right, which contains the second column of text. Drag the bottom of
the frame up to match the height of the text frame at left.

8. Click the pasteboard to deselect all objects on the page, and choose File > Save.

Adjusting vertical spacing
InDesign provides several options for customizing and adjusting the vertical spacing of text
in a frame. You can do the following:
Set the space between lines of paragraphs using a baseline grid.
Set the space between lines using the Leading menu in the Character panel.
Set the space between paragraphs using the Space Before and Space After options in
the Paragraph panel.
Use the Vertical Justification and Balance Columns options in the Text Frame Options
dialog box to align text within a frame.
Control how paragraphs flow from one column to the next using the Keep Lines
Together, Keep With Previous, and Keep With Next settings available in the Keep
Options dialog box (choose Keep Options from the Paragraph panel menu).
In this section of the lesson, you will use the baseline grid to align text.

Using the baseline grid to align text
An aspect of vertical spacing is aligning lines horizontally across columns. You can do this using
a baseline grid (also called a leading grid) for the entire document. The baseline grid represents
the leading (line spacing) for your document’s body text and is used to align the baseline of type
in one column of text with the baseline of type in neighboring columns and pages. First, you set
up the grid and then you set a paragraph format that aligns paragraphs to the grid.

When paragraphs are aligned with the baseline grid, lines of type are aligned across columns.

Tip
You can set up a baseline grid at the text frame level, which is ideal for situations in

which different stories have different leading values. Choose Object > Text Frame
Options, and then click the Baseline Options tab.

Before you set up the baseline grid, you need to check the leading value for the body text.
1. Choose Layout > Go To Page, enter 1 in the field, and click OK.
2. Select the Type tool ( ) in the Tools panel.
3. Click to place an insertion point in the first full paragraph of the story, which starts with
“Peas grow well.” Look at the leading value ( ) in the Character panel. The leading is set
to 11 pt (11 points).
4. Choose Edit > Preferences > Grids (Windows) or InDesign CC > Preferences > Grids
(macOS) to set the baseline grid options.
5. In the Baseline Grid section, type 0 in the Start box and select Top Margin from the
Relative To menu.
This option sets the location of the first grid line for the document. If you use the default
value of 3p0, the first grid line would appear above the top margin.
6. In the Increment Every box, type 11 pt to match the leading.

The View Threshold menu sets the minimum zoom level at which you can see the grid
onscreen. When this setting is 100%, the grid appears in the document window only at
magnifications of 100% or higher.
7. Click OK.
8. Choose File > Save.

Viewing the baseline grid
Now you’ll make the new grid visible onscreen.
1. To view the baseline grid in the document window, choose View > Grids & Guides > Show
Baseline Grid, and then choose View > Actual Size.

You can align one paragraph, selected paragraphs, or all the paragraphs in a story to the
baseline grid. (A story is all the text in a series of threaded text frames.) In the following
steps, you will use the Paragraph panel to align the main story to the baseline grid.
2. Using the Type tool ( ), click to place an insertion point anywhere in the first paragraph
on the spread, and then choose Edit > Select All to select all the text in the main story.
3. If the Paragraph panel isn’t visible, choose Type > Paragraph.
If necessary, choose Show Options from the Paragraph panel menu to see all the options.

Tip
As with most other paragraph-formatting controls, the baseline grid controls are also
available on the Control panel.

4. In the Paragraph panel, click Align To Baseline Grid (
baselines of the characters rest on the grid lines.

). The text shifts so that the

5. Click the pasteboard to deselect the text. Choose File > Save.

Adding a jump line page number
When an article continues across multiple pages, forcing readers to turn pages, it helps to add a
jump line, such as “(Continued on page x).” You can create jump lines in InDesign that
automatically reflect the number of the next page in the text flow (that is, the next page to which
the text frame is linked).
1. Double-click the page 1 icon in the Pages panel to center the page in the document window.
Scroll to the right to view a portion of the pasteboard. Zoom in as necessary to see the text.

2. Using the Type tool ( ) and working on the pasteboard, drag to create a text frame
approximately 1.5 inches by 0.25 inches.
3. Using the Selection tool ( ), drag the new text frame to the bottom of the second column
on page 1. Be sure the top of the new text frame touches the bottom of the existing text
frame.

4. Using the Type tool, click to place an insertion point in the new frame. Type Peas
continued on followed by a space.

Note
For the Next Page Number character to work properly, the text frame containing the
jump line must touch or overlap the threaded frame.

5. Right-click to display a context menu, and then choose Insert Special Character > Markers
> Next Page Number. The jump line now reads “Peas continued on 2.”

6. Choose Type > Paragraph Styles to open the Paragraph Styles panel. With the text insertion
point still in the jump line, click the Continued From/To Line paragraph style to format the
text according to the template.

7. Choose File > Save.
8. Choose View > Fit Spread In Window.
9. Choose Preview from the Screen Mode menu in the Application bar at the top of the screen.
Congratulations, you have finished the lesson.

Exploring on your own
In this lesson, you learned how to create a jump line that indicates the page number on which an
article continues. You can also create a jump line that indicates the page number from which a
continued article originated.
1. Choose View > Screen Mode > Normal to see the frame edges.
2. Using the Selection tool ( ), duplicate the text frame containing the jump line on page 1.
(To duplicate an object, select it and choose Edit > Copy.)
3. Paste the jump line text frame on page 2. Drag the text frame so that it touches the top of
the text frame in the first column. (Drag the top of the main text frame down as necessary
so that the jump line isn’t touching the page header.)
4. Using the Type tool ( ), change the words in the text frame from “Peas continued on” to
“Peas continued from.”
5. Select the page number, 2, in the jump line.
At this point, you need to replace the Next Page Number character with the Previous Page
Number character.
6. Choose Type > Insert Special Character > Markers > Previous Page Number.
The jump line now reads “Peas continued from 1.”

Review questions
1 Which tool lets you thread text frames?
2 How do you load the text icon?
3 What happens when you click the loaded text icon between column guides?
4 Which key do you press to automatically divide a text frame into multiple threaded frames?
5 What is the name of the feature that automatically adds pages and threaded text frames to
contain all the text in an imported text file?
6 What feature automatically adjusts the size of a text frame based on the length of the text?
7 What do you need to do to ensure that the Next Page Number and Previous Page Number
characters work in a jump line?

Review answers
1 The Selection tool.
2 Choose File > Place and select a text file, or click in an out port that contains overset text. You
can also drag text files from the desktop onto a page.
3 InDesign creates a text frame where you click; the frame fits within the vertical column guides.
4 Press the right arrow key as you drag with the Type tool. (You can also press the left arrow key
to decrease the number of threaded text frames.)
5 Smart Text Reflow.
6 The Auto-Size feature, found in the Text Frame Options dialog box (Object menu).

7 The text frame containing the jump line must touch the threaded text frame containing the
story.

6 Editing Text

Lesson overview
In this lesson, you’ll learn how to do the following:
Sync fonts from Adobe Fonts.
Handle a missing font.
Enter and import text.
Find and change text and formatting.
Check the spelling in a document.
Edit a spelling dictionary.
Automatically correct misspelled words.
Use the Story Editor.
Move text by dragging and dropping.
Track changes.

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the files for this lesson, or go to the “Getting Started” section at the
beginning of this book and follow the instructions under “Accessing the Lesson Files and Web
Edition.” Store the files on your computer in a convenient location. Your Account page is also
where you’ll find any updates to the lessons or the lesson files. Look on the Lesson & Update
Files tab to access the most current content.

Adobe InDesign CC offers many of the text-editing features you find in dedicated word-processing software, including the ability
to search and replace text and formatting, check spelling, automatically correct spelling as you type, and track changes as you
edit.

Getting started
In this lesson, you will perform editorial tasks commonly expected of a graphic designer. These
include importing a Microsoft Word file containing an article and using the editorial features in
InDesign to search and replace text and formatting, check spelling, enter and track text changes,
and more.

Note:
If you have not already downloaded the project files for this lesson to your computer
from your Account page, make sure to do so now. See “Getting Started” at the beginning
of the book.

1. To ensure that the preferences and default settings of your InDesign program match those
used in this lesson, move the InDesign Defaults file to a different folder following the
procedure in “Saving and restoring the InDesign Defaults file” on pages 4–5.
2. Start InDesign.
3. The InDesign Start Screen displays. Click Open at left. (If the Start Screen does not
display, choose File > Open from the InDesign menu bar.)

4. Open the 06_Start.indd file in the Lesson06 folder, located inside the Lessons folder within
the InDesignCIB folder on your hard disk.
When you open a document, the Adobe Fonts service will attempt to locate and activate any
fonts used in the document that are not available on your system.

Note:
For higher contrast in the printed manual, the screen captures in this book show the
Medium Light interface. Interface elements such as panels and dialog boxes may be
darker on your screen.

5. The Missing Font dialog box displays with Urbana Light automatically selected because
it’s available from Adobe Fonts. Click Activate. Goudy Old Style is not available from
Adobe Fonts, so you will fix this problem later. Click Close.

Tip
In general, it is not necessary to display images at full resolution when working with
text. If you are working on a slower computer, you can leave the display at Typical
Display or even gray out the images with Fast Display.

6. If necessary, choose View > Display Performance > High Quality Display to display the
document at a higher resolution.
7. Choose File > Save As, rename the file 06_Text.indd, and save it in the Lesson06 folder.

8. If you want to see what the finished document looks like, open the 06_End.indd file in the
same folder. You can leave this document open to act as a guide as you work.

9. When you’re ready to resume working on the lesson document, 06_Text.indd, display it by
clicking its tab in the upper-left corner of the document window.

Finding and changing a missing font
When you opened the document in the previous exercise, the Goudy Old Style Italic font may
have been listed as missing. If this font is active on your computer, you did not receive an alert
message, but you can still follow the steps for future reference. You will now search for text
formatted with the Goudy Old Style font and replace it with the Myriad Pro Regular font.
1. Choose View > Screen Mode > Normal so that you can see layout aids such as guides.
Notice that once you leave Preview mode, the introductory sentence on the left facing page
is highlighted in pink. This indicates a missing font.
2. Choose Type > Find Font. The Find Font dialog box lists the fonts used in the document.
An alert icon ( ) appears next to any missing fonts.
3. Select Goudy Old Style Italic in the Fonts In Document list.
4. For the Replace With option at the bottom of the dialog box, choose Myriad Pro from the
Font Family menu.

Tip
If you select Redefine Style When Changing All in the Find Font dialog box, any
character styles or paragraph styles that specify the missing font will be updated to
include the Replace With font as well. This can be handy for quickly updating

documents and templates—as long as you’re sure the font change is appropriate.

5. If necessary, choose Regular from the Font Style menu.

Tip
To display more information about a missing font (such as character count, page
where it is used, and font type), click More Info in the Find Font dialog box.

6. Click Change All.
7. Click Done to close the dialog box and see the replaced font in the document.
8. Choose File > Save.

Adding missing fonts
If you are a Creative Cloud member, any missing fonts that are available through Adobe
Fonts will be activated automatically. If a missing font is not available through Adobe
Fonts, you can (1) substitute a font or (2) add the missing font to your system. For most
projects, adding the font to your system is preferred as it will maintain the original design.
You can do this in the following ways:
If you have the font, activate it on your system.
If you do not have the font, you can purchase it.
If you are a Creative Cloud member, you can see whether the font is available for

activation or purchase through the Adobe Font service.
Once you have the font, you can use font management software to activate it. You can also
add the font to your InDesign Fonts folder or a Document Fonts folder in the folder
containing the InDesign document.

Entering and importing text
You can enter text directly into your InDesign documents, or you can import text prepared in
other applications, such as word-processing software. To type text, you need to use the Type tool
and select a text frame or text path. Options for importing text include dragging files from the
desktop, “loading” the cursor with one or more text files to import, or importing text into a
selected text frame.

Entering text
While graphic designers are not generally responsible for the text in all their layouts, they are
often asked to enter edits from a marked-up hard copy or Adobe PDF. In this exercise, you will
use the Type tool to revise the headline.

Note
If you cannot see the frame edges, be sure that the screen mode is set to Normal (View >
Screen Mode > Normal).

1. Choose View > Extras > Show Frame Edges.
The text frames are outlined in gold so that you can see them. Locate the text frame on the
left-facing page under the images containing the headline “Protecting Your Peas.” You will
change “Protecting” to “Protect” in the headline.
2. Using the Type tool ( ), click in the text frame immediately to the right of the word
“Protecting.”
3. Press Backspace (Windows) or Delete (macOS) three times to delete the “ing.”

4. Choose File > Save.

Importing text
When working with a template for a project such as a magazine, designers generally import
article text into existing text frames. In this exercise, you will import a Microsoft Word file and
apply body-copy formatting to it.
1. Using the Type tool (
page.

), click in the first column of the text frame on the right-facing

Tip
In the Place dialog box, you can Shift-click to select multiple text files. When you
do this, the cursor is “loaded” with those files. You can then click in text frames or
on the page to import the text from each file. This works well with content such as
long captions that are saved in different text files.

2. Choose File > Place. In the Place dialog box, make sure Show Import Options is not
selected.
3. Navigate to and select the Gardening.docx file in the Lesson06 folder, located inside the
Lessons folder within the InDesignCIB folder on your hard disk.
4. Click Open. If the Missing Fonts dialog box displays, click Close to dismiss it. You will
apply a different font through a paragraph style.
The text flows from column to column, filling the first two columns.
5. Choose Edit > Select All to select all the text in the story.
6. Locate the Properties panel at right. In the Text Style area, click the Paragraph Styles tab.
Click the menu below and select the Body Paragraph style.
7. Click in the first body paragraph starting with “Peas are easy to grow.” Select First Body
Paragraph from the Paragraph Styles menu in the Properties panel as shown.

Now that you have changed the formatting, the story may no longer fit. In the lower-right
corner of the text frame on the right-facing page, a red plus sign (+) will indicate overset
text (additional text). Later, you will use the Story Editor to resolve this.
8. Choose Edit > Deselect All to deselect the text.
9. Choose File > Save.

Finding and changing text and formatting
Like most popular word-processing software, InDesign lets you search and replace text and
formatting. Often, while graphic designers are working on layouts, the copy is still being revised.
When editors request global changes, Find/Change helps ensure accurate and consistent changes.

Finding and changing text
For this article, an editor decided to change all instances of “bird” to “blackbird.” You will
change all instances of “bird” in the document.
1. Using the Type tool ( ), click at the beginning of the story before “Peas are easy to grow”
(on the right-facing page in the far-left column).
2. Choose Edit > Find/Change.
3. Click the menu in the Query field to see the built-in Find/Change options. Click each tab
across the top to view other options: Text, GREP, Glyph, and Object.
4. Click the Text tab for a simple search and replace of text.

Tip
You can toggle the search direction by pressing Ctrl+Alt+Enter (Windows) or
Command+Option+Return (macOS).

5. Click Forward for the search Direction.
6. Type bird in the Find What box.
Press Tab to navigate to the Change To box. Type blackbird.
Using the Search menu in the Find/Change dialog box, you can choose to search All
Documents, Document, Story, To Beginning Of Story, To End Of Story, or Selection (when
text is selected).
7. Select Story from the Search menu, which defines the scope of the search.
Point at each icon in the row below the Search menu to view its tool tip and see how it
affects the Find/Change operation. For example, clicking the Whole Word icon ( ) ensures
that instances of the Find What text within another word will not be found or changed.
8. Make sure that Case Sensitive (

) and Whole Word (

) are not selected.

Tip
When the Find/Change dialog box is open, you can still click in the text and make
edits with the Type tool. The Find/Change dialog box remains open so that you can
resume your search after editing the text.

9. Click Find Next. When the first instance of “bird” is highlighted, click Change All.
10. When the alert indicates that four additional replacements were made, click OK.

11. Click at the beginning of the story before “Peas” so no words are selected. Leave the
Find/Change dialog box open for the next exercise.

Finding and changing formatting

Tip
Another way to achieve the change from “Tip:” to “TIP:” through Find/Change would be
to apply the All Caps type style. Depending on how often this effect is used, you might
create a character style that specifies All Caps and the purple color. You can then apply
the character style through Find/Change.

The editors request one more global edit to this article; this one concerns formatting rather than
spelling. The gardening tips in the article are preceded by the word “Tip,” which should be in
purple and all capital letters.
1. Type Tip: in the Find What box. Press Tab to select the text in the Change To field and
press Backspace or Delete.
2. Type TIP: in the Change To box.
3. Click Case Sensitive ( ) below the Search menu.

4. If necessary, click the More Options button to display formatting options for the found text.
5. In the Change Format section at the bottom of the dialog box, click the Specify Attributes
To Change icon ( ).
6. On the left side of the Change Format Settings dialog box, select Character Color.
7. In the Character Color box, click Purple-Cool to select it.

8. Click OK to return to the Find/Change dialog box.

Notice the alert icon ( ) that appears above the Change To box. This icon indicates that
InDesign will change text to the specified formatting.

9. Test your settings by clicking Find Next and then clicking Change. Once you confirm that
“Tip:” changes to “TIP:” in purple, click Change All.
10. When the alert indicates that two changes were made, click OK. Click Done to close the
Find/Change dialog box.
11. Choose File > Save.

Checking spelling
Tip
Be sure to discuss with your client or editor whether you should be the one checking
spelling in InDesign. Many editors strongly prefer to check spelling themselves.

InDesign has features for checking spelling similar to the options in word-processing programs.
You can check the spelling in selected text, an entire story, all the stories in a document, or all
the stories in several open documents at once. To customize which words are flagged as possible
misspellings, you can add words to your document’s dictionary. In addition, you can have
InDesign flag possible spelling issues and correct spelling as you type.
The Check Spelling dialog box provides the following buttons to handle the words shown in the
Not In Dictionary field (otherwise known as suspect words):
Skip: Click Skip when you are confident of the spelling of the current suspect word but

would like to review any other instances of the spelling in context.
Change: Click Change to change the spelling of the current instance of the suspect word to
the spelling in the Change To field.
Ignore All: Click Ignore All when you are confident that the spelling of the suspect word is
appropriate for use throughout the selection, story, or document.
Change All: Click Change All when you are confident that changing the spelling of the
suspect word is appropriate for the entire selection, story, or document.

Checking spelling in the document

Note
Depending on the InDesign preferences set for Dictionary and Spelling, or whether
you’ve added words to a custom dictionary, different words may be flagged. Simply
experiment with the various Check Spelling options to get familiar with them.

Before a document is ready for print or electronic distribution, it’s a good idea to check spelling.
In this case, we suspect the newly imported story may be a little sloppy, so you will check the
spelling now.
1. If necessary, choose View > Fit Spread In Window to view both pages of the document.
2. Using the Type tool ( ), click before the first word of the article you’ve been working on:
“Peas are easy to grow.”
3. Choose Edit > Spelling > Check Spelling.
Using the Search menu in the Check Spelling dialog box, you can choose to check All
Documents, Document, Story, To End Of Story, or Selection.
4. Select Story from the Search menu at the bottom of the dialog box. The spell check starts
automatically.
5. InDesign highlights various words that do not match the spelling dictionary.
Handle the flagged words as follows:
coton: Select “cotton” in the Suggested Corrections list and click Change.
gardner: Type gardener in the Change To field and click Change.
Soupe, Pois: Click Ignore All.
Orzo: Click Add to add this fairly common word to your User Dictionary.
Fregola, Ricotta, Pancetta: Click Ignore All.
6. Click Done.
7. Choose File > Save.

Adding words to a document-specific dictionary
With InDesign, you can add words to your user dictionary or to a document-specific dictionary.
If you work with multiple clients who may have different spelling preferences, for example, it is
better to add words to a document-specific dictionary. In this case, you will add “ricotta” to your
User Dictionary.

Tip
If a word is not specific to one language—such as a person’s name—you can choose All
Languages to add the word to every language’s spelling dictionary.

1. Choose Edit > Spelling > User Dictionary to display the User Dictionary dialog box.

2.
3.
4.
5.

Select User Dictionary from the Target menu.
Type ricotta in the Word box.
Click Add.
Click Done

Checking spelling dynamically
It’s not necessary for you to wait until a document is finished before checking the spelling.
Enabling dynamic spelling allows you to see misspelled words in text. To see how this
works:
1. Choose Edit > Preferences > Spelling (Windows) or InDesign CC > Preferences >
Spelling (macOS) to display Spelling preferences.
2. In the Find section, select the possible errors you want highlighted.
3. Select Enable Dynamic Spelling.
4. In the Underline Color section, use the menus to customize how possible errors are
signified.
You can customize what the Check Spelling dialog box flags as possible errors:
Misspelled Words, Repeated Words, Uncapitalized Words, and Uncapitalized
Sentences. For example, if you’re working on a directory with hundreds of names, you
might want to select Uncapitalized Words but not Misspelled Words.

5. Click OK to close the Preferences dialog box and return to your document.
Words that may be misspelled (according to the default user dictionary) are now
underlined.
6. Right-click a word flagged by dynamic spelling to display a contextual menu from
which you can select an option to change the spelling.

Automatically correcting misspelled words
Autocorrect takes the concept of dynamically checking spelling to the next level. With
Autocorrect activated, InDesign automatically corrects misspelled words as you type them.
Changes are made based on an internal list of commonly misspelled words. You can add other
commonly misspelled words, including words in other languages, to this list if you like.
1. Choose Edit > Preferences > Autocorrect (Windows) or InDesign CC > Preferences >
Autocorrect (macOS) to display Autocorrect preferences.
2. Select the Enable Autocorrect option. By default, the list of commonly misspelled words is
for English: USA.
The editors have realized that “gardener” is frequently typed as “gardner,” missing an “e” in
the middle. You will prevent this mistake by adding the misspelling and correct spelling to
the Autocorrect list.
3. Click Add. In the Add To Autocorrect List dialog box, type gardner in the Misspelled
Word box and gardener in the Correction box.

4. Click OK to add the word, and then click OK again to close the Preferences dialog box.
5. Make sure that Edit > Spelling > Autocorrect is selected in the menu.

Tip
Words are autocorrected as soon as you finish a word, as indicated by typing a
space, period, comma, or forward slash.

6. Using the Type tool ( ), type the word gardner followed by a space anywhere in the text.
7. Notice that Autocorrect changes the spelling from “gardner” to “gardener.” Choose Edit >
Undo until the word you added is deleted.
8. Choose File > Save.

Editing text by dragging and dropping
To quickly cut and paste words in your document, InDesign allows you to drag and drop text
within the same story, between frames, and between documents. You’ll now use drag and drop to
move text from one paragraph to another in the magazine layout.
1. Choose Edit > Preferences > Type (Windows) or InDesign CC > Preferences > Type
(macOS) to display Type preferences.

Tip
When you drag and drop text, by default InDesign automatically adds and deletes

spaces before and after words as necessary. If you need to turn off this feature,
deselect Adjust Spacing Automatically When Cutting And Pasting Words in Type
preferences.

2. In the Drag And Drop Text Editing section, select Enable In Layout View. This option lets
you drag and drop text in Layout view in addition to the Story Editor. Click OK.
3. Locate the subhead below the “Protect Your Peas” headline. Adjust the zoom level as
necessary so that you can read the subhead text.
4. Using the Type tool ( ), drag to select the words “LOW-CALORIE” along with the
comma and the space after the comma.
5. Position the I-bar pointer over the selected word until the pointer changes to the drag and
drop icon ( ).

Tip
If you want to copy a selected word instead of moving it, hold down the Alt
(Windows) or Option (macOS) key after you start dragging.

6. Drag the pointer to the correct location for the words, after “HIGH-PROTEIN” and the
comma and space.

7. Choose File > Save.

Using the Story Editor
If you need to enter many text edits, rewrite a story, or cut a story, you can isolate the text with
the Story Editor. The Story Editor window works as follows:
Text displays without formatting—with the exception of the styles bold, italic, and bold
italic. Any graphics and other nontext elements are omitted to make editing easier.
The column to the left of the text displays a vertical depth ruler and the name of the
paragraph style applied to each paragraph.
Dynamic spelling (if enabled) highlights misspelled words, just like in the document
window.

If the Enable In Story Editor option is selected in Type preferences, you can also drag and
drop text in the Story Editor, just as you did in the previous exercise.
In Story Editor Display preferences, you can customize the font, size, background color,
and more for the Story Editor window.
The article on the right-facing page is too long to fit in the text frame. After you delete a sentence
in the Story Editor, the story will fit.
1. Choose View > Fit Spread In Window.
2. Using the Type tool ( ), click in the first full paragraph in the third column of the article.

Note
If the Story Editor window goes behind the document window, you can bring it to
the front by choosing its name from the bottom of the Window menu.

3. Choose Edit > Edit In Story Editor. Position the Story Editor window next to the far-right
column on the spread.
4. Drag the vertical scroll bar in the Story Editor to the end of the story. Note the red vertical
line that indicates the overset text.
5. In the Story Editor, scroll down to the paragraph starting with “Follow Crops.” Locate and
select the last sentence in the paragraph: “If the peas have been well enriched, two or three
pounds of commercial fertilizer for each hundred feet of row will be sufficient for the
second crop.” Be sure to select the final period.

6. Press Backspace or Delete. Leave the Story Editor open for the next set of steps.

7. Choose File > Save.

Tracking changes
For some projects, it’s important to see what changes are made to the text throughout the design
and review process. In addition, reviewers may suggest changes that another user can accept or
reject. As with a word-processing program, you can track text that is added, deleted, or moved
using the Story Editor.

Tip
In Track Changes preferences, you can customize which changes are tracked and how the
changes display in the Story Editor.

You will change one of the pea recipes listed.

Tip
InDesign provides a Notes panel and a Track Changes panel for reviewing and
collaborating on documents (Window > Editorial, Type > Notes, and Type > Track
Changes). The panel menus provide access to many of the controls.

1. Choose Type > Track Changes > Track Changes In Current Story.
2. In the Story Editor, locate the paragraph starting with “Recipes.”
3. Using the Type tool ( ) in the Story Editor, select “Seven Layer Salad” and type
Balsamic Pea Salad over it.
Notice how the changes are marked in the Story Editor window.

4. With the Story Editor window still open, choose Type > Track Changes, and review the
options for accepting and rejecting changes. Once you have reviewed the possibilities,
choose Accept All Changes > In This Story.
5. When the alert dialog box displays, click OK.
6. Click the Story Editor window’s close box. If necessary, choose Edit > Spelling >
Dynamic Spelling to disable this feature.
7. Choose View > Screen Mode > Normal, and then choose File > Save.
Congratulations. You have finished the lesson.

Exploring on your own
Now that you have tried the basic text-editing tools in InDesign, experiment with them more to
edit and format this document.

Tip
Companies generally follow a style guide that governs issues such as spacing and
punctuation. For example, The Associated Press Stylebook specifies a space on either side
of an em dash, while The Chicago Manual of Style does not.

1. Using the Type tool ( ), add subheads to the story and format them with options in the
Control panel.
2. If you have additional text files on your system, try dragging them from the desktop to the
layout to see how they’re imported. Choose Edit > Undo if you don’t want to keep them in
the document.
3. Use the Find/Change dialog box to find all em dashes in the story and replace them with an
em dash with a space on either side of it. Click the @ icon next to the Find What box to

search for special characters such as em dashes.
4. Edit the story using the Story Editor and Track Changes. See how the different changes are
marked, and experiment with accepting and rejecting the changes.
5. Experiment with changing Spelling, Autocorrect, Track Changes, and Story Editor Display
preferences.

Review questions
1 Which tool lets you edit text?
2 Where are most of the commands for editing text?
3 What is the InDesign search-and-replace feature called?
4 While checking the spelling in a document, InDesign flags words that are not in the dictionary
—but they may not actually be misspelled. How can you fix this?
5 If you seem to continually type a word incorrectly, what can you do?

Review answers
1 The Type tool allows you to edit text.
2 Most commands for editing text are in the Edit menu and the Type menu.
3 InDesign uses the term Find/Change (Edit menu).
4 Add those words to the document’s or InDesign’s default spelling dictionary for the language
or languages of your choice (Edit > Spelling > User Dictionary).
5 Add the word to your Autocorrect preferences.

7 Working with Typography

Lesson overview
In this lesson, you’ll learn how to do the following:
Adjust vertical and horizontal text spacing.
Change fonts and type styles.
Insert special characters.
Create a headline that spans multiple columns.
Adjust line and column breaks.
Hang punctuation outside a margin.
Add and format a drop cap.
Adjust line breaks.
Specify a tab with a leader and create a hanging indent.
Add a rule and shading to a paragraph.

This lesson will take about 60 minutes to complete. Please log in to your account on
peachpit.com to download the files for this lesson, or go to the “Getting Started” section at the
beginning of this book and follow the instructions under “Accessing the Lesson Files and Web
Edition.” Store the files on your computer in a convenient location. Your Account page is also
where you’ll find any updates to the lessons or the lesson files. Look on the Lesson & Update
Files tab to access the most current content.

The Adobe InDesign CC typography features make it easy to find just the right font for a document’s message; fine-tune

character, word, line, and paragraph spacing for a professional look; and add special touches such as fractions and drop caps.

Getting started
In this lesson, you’ll fine-tune the typography in a magazine layout for a botanic gardens. For the
rich look of the magazine, the typography includes precision formatting and spacing along with
decorative touches.

Note
If you have not already downloaded the project files for this lesson to your computer
from your Account page, make sure to do so now. See “Getting Started” at the beginning
of the book.

1. To ensure that the preferences and default settings of your InDesign program match those
used in this lesson, move the InDesign Defaults file to a different folder following the
procedure in “Saving and restoring the InDesign Defaults file” on pages 4–5.
2. Start InDesign.
3. The InDesign Start Screen displays. Click Open at left. (If the Start Screen does not
display, choose File > Open from the InDesign menu bar.)
4. Open the 07_Start.indd file in the Lesson07 folder, located inside the Lessons folder within
the InDesignCIB folder on your hard disk.

Note
For higher contrast in the printed manual, the screen captures in this book show the
Medium Light interface. Interface elements such as panels and dialog boxes may be
darker on your screen.

5. To ensure that the panels and menu commands match those used in this lesson, choose
Window > Workspace > [Essentials], and then choose Window > Workspace > Reset
Essentials.
6. To display the document at a higher resolution, choose View > Display Performance >
High Quality Display (if it’s not already enabled).
7. Choose File > Save As, rename the file 07_Type.indd, and save it in the Lesson07 folder.
8. If you want to see what the finished document looks like, open the 07_End.indd file in the
same folder. You can leave this document open to act as a guide as you work.

In this lesson, you will work intensively with text. You can use the character-formatting
controls and paragraph-formatting controls in the Control panel, or you can use the
Character panel and Paragraph panel. Using the individual Character and Paragraph panels
can be easier for formatting text because you can drag the panels to where you want them.

Note
Drag the Paragraph panel tab into the Character panel tab to create a panel group, if
you prefer.

9. Choose Type > Character and Type > Paragraph to open the two primary text-formatting
panels. Leave these panels open until you finish this lesson.
10. Choose Type > Show Hidden Characters so you can see spaces, paragraph returns, tabs,
and the like while you work on this lesson.

Adjusting vertical spacing
InDesign provides several options for customizing and adjusting the vertical spacing of text in a
frame. You can do the following:
Set the space between lines of paragraphs using a baseline grid (covered in Lesson 5,
“Flowing Text”).
Set the space between lines using the Leading menu in the Character panel.
Set the space between paragraphs using the Space Before and Space After options in the

Paragraph panel.
Use the Vertical Justification and Balance Columns options in the Text Frame Options
dialog box to align text within a frame.
Control how paragraphs flow from one column to the next using the Keep Lines Together,
Keep With Previous, and Keep With Next settings available in the Keep Options dialog box
(choose Keep Options from the Paragraph panel menu).

In this lesson, you will adjust the space between paragraphs and the line spacing within a
paragraph.

Changing the spacing between paragraphs
To adjust space between paragraphs, you select the paragraphs and specify a space before and/or
space after value. (The amount of space between paragraphs ends up being the sum of the space
after one paragraph and the space before the next paragraph. Therefore, it’s generally best to use
one or the other—space before or space after—to prevent confusion.) The space before/after
values can be saved in paragraph styles and applied consistently across a document.

Tip
Specifying space before/after values for paragraphs is preferable to typing extra
paragraph returns between paragraphs. A full paragraph return is often too much space,
and it can end up at the top of a page or column, leaving undesirable space.

Here, you’ll add more space between paragraphs in the Chocolate-Covered Strawberries recipe at
the bottom of the page.
1. Using the Zoom tool (

), drag a rectangle around the green box at the bottom of the page.

2. Using the Type tool ( ), click immediately in front of the first line of the recipe, “1/2 lb
strawberries with stems.”
3. Drag to select all the recipe text from “1/2 lb strawberries with stems” to “Protein 0g.”
4. In the Paragraph panel, click the up arrow once next to the Space After field ( ).
This adds .0625 in, or 4.5 points, of space between paragraphs. The text will overset the
frame, but this will be resolved later with the addition of columns.

5. Choose Edit > Deselect All.
6. Choose File > Save.

Working with fonts, type styles, and glyphs
Changing the fonts and type styles of text can make a dramatic difference in the appearance of
your document. InDesign automatically installs a few fonts, including several styles of Letter
Gothic and Myriad Pro. Creative Cloud members can access additional fonts through Adobe
Fonts, which offers select fonts for free and others for licensing. Once a font is installed, you can
apply it to text and change its size, select a style (such as bold or italic), and more. In addition,
you can access all the glyphs (every form of each character) in the font.

Adding a font from Adobe Fonts
This exercise uses Adobe Caslon Pro, which is available for free from Adobe Fonts. If the font is
already installed on your system, follow the steps to see how you can add another font.
1. In the Character panel, click the arrow to the right of the Font field to display the Font
menu.
2. Click Find More at the top of the menu.

3. Scroll down in the list to locate Adobe Caslon Pro.

Tip
A font family is a collection of styles of the same font. For example, the Adobe
Caslon Pro family includes the following fonts: Regular, Italic, Semibold, Semibold
Italic, Bold, and Bold Italic. You can activate the entire family or an individual style
within the font.

4. Click the Activate button ( ) to the right of the font family folder, and then click OK to
confirm.

5. Click Fonts at the top of the menu to see the new font you just added.

OpenType fonts
OpenType fonts, such as Adobe Caslon Pro, may display many more glyphs than you are
accustomed to seeing. (Glyphs are representations of characters within a font.) OpenType

fonts can contain many more characters and glyph alternates than other font formats. For
more information on OpenType fonts, visit www.adobe.com/products/type.html.

Applying a font, style, size, and leading
Here, you’ll apply a different font to the headline, and then to the first character of the headline.
Then, you’ll change the font family, style, size, and leading for the text in the quote on the left
side of the page.
1. Choose View > Fit Page In Window.
2. Using the Type tool ( ), select the story headline, “Strawberries,” at the top of the page.
3. Click the Font menu on the Control panel or on the Character panel. Scroll through the list
to see how “Strawberries” looks in various fonts.
4. In the list, find the font family you just activated: Adobe Caslon Pro.
5. Click the arrow to the left of Adobe Caslon Pro to open the font family, and select Regular
from the menu.

6. Using the Type tool, click immediately to the left of the “S” in the “Strawberries” headline.
Drag to select the “S.”
7. In the Character panel, select Bold Italic from the Style menu below the Font menu.

Now you will work on the quote on the left side of the page: “You stand out like a
strawberry in a bowl of peas.”
8. Using the Type tool ( ), click inside the quote’s text frame. To select the entire paragraph,
quadruple-click (click four times rapidly).

Tip
To quickly select a font, you can type the first few letters in the Font Name field
until it is recognized.

9. In the Character panel, set the following options:
Font: Adobe Caslon Pro
Style: Bold Italic
Size: 24 pt
Leading: 35 pt

Tip
In the OpenType menu, the options in brackets are not available for the selected
font.

10. Click the Character panel menu and select OpenType. Notice that Swash is already
selected, indicating that some glyphs have already been replaced with more ornate glyphs.
11. Select Swash to deactivate this feature, and notice the changes (such as the Y versus the ϒ
in Adobe Caslon Pro). Select Swash from the OpenType menu again to reactivate the
feature.
12. Click in the quote’s paragraph four times to reselect it and display the OpenType badge (
) somewhere on the paragraph.

13. Click the OpenType badge, which offers another way to access OpenType features
available in the font.

Tip
Ligatures combine two or three glyphs into a single glyph to achieve a more
harmonious look. Common ligatures include the “fi” and “fl” letter pairs.

14. Select Discretionary Ligatures along with Swash and note how the two “st” glyph pairs are
replaced with an “st” ligature: .
15. Choose Edit > Deselect All.
16. Choose File > Save.

Adding a special character
Many types of special characters—such as bullets, check boxes, accented characters, and
ornamental curlicues—are used in documents for useful and decorative purposes. Now you’ll
add a decorative character in the lower-left corner of the page.

Tip
You can access some of the more commonly used glyphs, such as the copyright and
trademark symbols, in the Type menu (Insert Special Character > Symbols) and the
context menu. To access the context menu, right-click at the insertion point.

1. If necessary, scroll down to see the text frame below the quote about peas.
2. Using the Type tool ( ), click to place an insertion point in the text frame.
3. Choose Type > Glyphs. You can use the Glyphs panel to view and insert OpenType
attributes, such as ornaments, swashes, fractions, and ligatures.
4. In the Glyphs panel, choose Ornaments from the Show menu.
5. Locate the heart-shaped character ( ), and double-click it.

6. Choose File > Save.

Finding fonts in the Type menu
InDesign provides multiple ways to quickly find fonts in the Font menus available in the
Control, Character, and Properties panels.
Name Search: A quick way to find a font is to start typing the font name in the Font
box. For example, as you type “Cas” for Adobe Caslon Pro, all fonts with those three
characters in it are listed. By default, InDesign searches by the entire font name. You
can click the search icon ( ) to the left of the font name to search by first word only.
In that case, you would need to type “Adobe Cas” for the same result.
Filter by Class: Select a font classification from the Filter menu ( ), such as Serif or
Script.
Favorites: For quick access to fonts you use frequently, click the star to the right of a
font name in any Font menu. Then, click Show Favorite Fonts ( ) at the top of the
menu.
Font Similarity: Click Show Similar Fonts ( ) to the right of a font to display
visually similar fonts in the menu.

Icons in the Filter menu indicate the visual characteristics of each font classification.

Applying a stroke and fill to text
Next, you’ll add a fill color and stroke to the drop-cap character you just created.
1. With the Type tool ( ) still selected, select the heart-shaped glyph.
2. Type 122 pt in the Font Size field in the Character panel. Press Enter (Windows) or Return
(macOS).
3. In the Appearance area of the Properties panel, do the following:
Click the up arrow next to the Weight field to apply a 1 pt stroke.
Select the Stroke box ( ) and click the Stem Green swatch.
Select the Fill box ( ) and click the Strawberry Red swatch.

4. Press Shift+Ctrl+A (Windows) or Shift+Command+A (macOS) to deselect the text so that
you can view the stroke effect.
5. Choose File > Save.

Inserting fraction characters
The recipes in this article do not use actual fraction characters—rather, the 1/2 is built with a
numeral 1, a slash, and a numeral 2. Most fonts contain individual characters for common
fractions such as ½, ¼, and ¾. When available, these elegant fractions look much more
professional than using numerals and slashes.

Tip
If you are working on a cookbook or other document that requires a variety of fractions,
the fractions built into most fonts will not cover all the values you need. You will need to
research numerator and denominator formatting options, which are available in some
OpenType fonts, or purchase a specific fraction font.

1. Using the Zoom tool ( ), drag a rectangle around the green box at the bottom of the page.
2. Using the Type tool ( ), drag to select the “1/2” in the first line “1/2 lb strawberries with
stems.”
3. If the Glyphs panel is not open, choose Type > Glyphs.
4. Choose Numbers from the Show menu.
5. Locate the ½ fraction. If necessary, resize the panel and scroll to see more characters.
6. Double-click the ½ fraction to replace the selected 1/2 in the text.

Tip
The Glyphs panel features many controls for filtering the options available within a
font—such as Punctuation or Ornaments. Some fonts may have hundreds of
alternates available, while others will have only a few.

Notice that the ½ fraction is stored in the Recently Used boxes at the top of the Glyphs
panel. Now you’ll replace the “1/2” in the second line of the recipe.
7.
8.
9.
10.

Drag to select the “1/2” in “1/2 cup chocolate chips” in the next line of the recipe.
Double-click the ½ fraction in the Recently Used box at the top of the Glyphs panel.
Drag to select the “1/4” in “1/4 cup sprinkles” in the third line of the recipe.
Locate the ¼ fraction in the Glyphs panel to replace the “1/4.”

11. Close the Glyphs panel, and choose Edit > Deselect All.
12. Choose File > Save.

Working with columns
You can specify the number of columns in a text frame, the width of the columns, and the space
between them. Once a text frame is divided into columns, you can create a heading that spans
multiple columns (also known as a “straddle head”). In this section, you will add columns and a

straddle head to a text frame.

Specifying columns for a text frame
The recipe in the green text frame will look better and be more legible if it’s divided into two
columns.
1. In the Tools panel, select the Selection tool ( ) and select the text box containing the
recipe.
2. Choose Object > Text Frame Options, and then click the General tab.
3. In the Columns area, enter 2 in the Number field.
4. Press Tab to select the Gutter field. If necessary, type .25 in.
5. Select Preview to review the changes.

6. Click OK, and choose File > Save.

Creating a straddle head
The heading for the recipe needs to span the two columns. You can do this with a paragraph
format rather than by placing the heading in its own text frame.
1. Using the Type tool ( ), click in the “Chocolate-Covered Strawberries” heading. This
selects the paragraph for formatting.

2.
3.
4.
5.

Click the Paragraph Formatting Controls icon ( ) in the Control panel.
Select Span Columns from the Paragraph panel menu.
In the Span Columns dialog box, select Span Columns from the Paragraph Layout menu.
Select All from the Span menu.

Tip
You can also access the Span Columns controls in the Control panel.

6. Select Preview to confirm the change, and then click OK.
7. Choose File > Save.

Adjusting columns
Now that the heading is positioned, you can complete the fine-tuning of the sidebar by balancing
the amount of text in each column. You can do this automatically by selecting Balance Columns
in the General tab of the Text Frame Options dialog box (Object menu) or by inserting a “break
character” that shifts text to the next column, frame, or page.

Tip
The break characters, however, remain if the text reflows, often forcing text into the
wrong column. Instead, you will balance the columns automatically.

1. Using the Type tool ( ), click immediately before “Nutritional Facts” in the recipe.
2. Choose Type > Insert Break Character > Column Break.
3. Choose File > Save.

Changing paragraph alignment
You can easily manipulate how a paragraph fits within its text frame by changing the horizontal
alignment. You can align text with one or both edges of a text frame, or you can apply inset
spacing. In this exercise, you’ll use different methods to apply paragraph alignments.
1. Choose View > Fit Page In Window to view the entire page.
2. Using the Type tool ( ), click to place an insertion point in the tagline at the top of the
page: “A BITE OF DELIGHT.”
3. In the Paragraph panel, click Align Center ( ).

4. Click in the first paragraph of the story below the “Strawberries” headline (starting with
“Heart-shaped fruit”).
5. Choose Edit > Select All, and then click Justify With Last Line Aligned Left ( ) on the
Properties panel.

6. Click in the “Chocolate-Covered Strawberries” recipe heading. Press Shift+Ctrl+C
(Windows) or Shift+Command+C (macOS) to center the one-line paragraph.
7. Click in the pea quote at left to select the paragraph. Click Align Center ( ) on the Control
panel.
8. Choose Edit > Deselect All.
9. Choose File > Save.

Hanging punctuation outside the margin
Sometimes, particularly with punctuation at the beginning and end of lines, margins that are in
fact even may appear uneven. To fix this visual discrepancy, designers use optical margin
alignment to “hang” punctuation and swashes on characters slightly outside the text frame. In
this exercise, you will apply optical margin alignment to the main story.

Note
When you select Optical Margin Alignment, it applies to all of the text in a story—
defined as all the text in a frame or a series of threaded text frames.

1. Using the Selection tool ( ), click to select the text frame containing the main story
starting with “Heart-shaped fruit that’s good for your heart?”
2. Choose Type > Story to open the Story panel.
3. Select Optical Margin Alignment. Enter 14 pt in the field and press Enter (Windows) or
Return (macOS).

Tip
When using Optical Margin Alignment, specifying an Align Based On Size setting
that matches the point size of the text in the frame produces the best results.

Without (left) and with (right) optical margin alignment. Notice the alignment of the
hyphens. The text looks more visually aligned on the right.
4. Choose File > Save.

Creating a drop cap
You can add creative touches to your document using InDesign typographic features. For
example, you can make the first character or word in a paragraph a drop cap, and then apply
additional formatting to the drop cap character. Here, you’ll create a drop cap out of the first
character in the first paragraph of the story.

Tip
Drop caps can be saved with paragraph styles so you can apply them quickly and
consistently.

1. Using the Type tool ( ), click to place an insertion point anywhere in the paragraph of the
story starting with “Heart-shaped fruit that’s good for your heart?”
2. In the Paragraph panel, type 2 in the Drop Cap Number Of Lines box ( ) to make the
letter drop down two lines. Press Enter or Return.
3. Note the 1 in the Drop Cap One Or More Characters box ( ) to see how you would
increase the number of characters that drop.

4. Using the Type tool, select the drop-cap character.
Now, you can apply any character formatting you want.
5. Select Stem Green from the Fill menu in the Properties panel.

Tip
You can create a drop cap and apply a character style in one step using the Drop
Caps And Nested Styles dialog box (Paragraph panel menu). You can then save that
formatting in a paragraph style.

6. Click the pasteboard to deselect the text and view the drop cap.
7. Choose File > Save.

Adjusting letter and word spacing
You can change the spacing between letters and words using kerning and tracking. You can also
control the overall spacing of text in a paragraph by using the Adobe Single-Line Composer and
the Adobe Paragraph Composer.

Adjusting the tracking and kerning
Tracking increases or decreases spacing across a range of selected letters. By adjusting kerning,
you can add or subtract space between specific letter pairs. You can use both kerning and
tracking on the same text.
Here, you’ll track out the “A BITE OF DELIGHT” heading for effect, and then track in the
“Strawberries” heading. Finally, you will manually kern the space between the swash “S” and
the remainder of the “Strawberries” headline.
1. To see the results of the tracking and kerning more clearly, select the Zoom tool ( ) in the
Tools panel, and drag a marquee around the top quarter of the page.
2. Using the Type tool ( ), click in the “A BITE OF DELIGHT” heading and click three
times to select the entire heading.
3. In the Character panel, choose 100 from the Tracking menu ( ).

Tip
When you kern text, the right arrow key adds space and the left arrow key removes
space when combined with the Alt (Windows) or Option (macOS) key. To change
the amount of kerning applied using the shortcuts, you can edit the Keyboard
Increments value in Preferences (Units & Increments).

4. Click in the “Strawberries” heading and click two times to select the entire word.
5. Type –20 in the Tracking field on the Control panel.
6. Click to place an insertion point between the “S” and the “t” in “Strawberries.”

7. Press Alt+left arrow (Windows) or Option+left arrow (macOS) on the keyboard three times
to decrease the amount of space between the two characters.
The Kerning field ( ) on the Character panel and the Control panel lets you see and adjust
the amount of space between characters.
8. Click the pasteboard to deselect the text.
9. Choose File > Save.

Adjusting line breaks
Hyphenation and line breaks at the end of each line affect readability and impact. For example,
when paragraphs are aligned left, the right edge remains ragged. Too much “rag” can make the
text easier or harder to read based on many factors, including the font, size, leading, column
width, and more. Three other paragraph formats affect the readability of the text:

Tip
For justified text, Justification settings combine with the Paragraph Composer and
hyphenation settings to control how dense paragraphs look. To adjust these settings for a
selected paragraph, choose Justification from the Paragraph panel menu.

The Adobe Single-Line Composer and Adobe Paragraph Composer, which automatically
determine line breaks
Hyphenation settings, such as whether to hyphenate capitalized words
The Balance Ragged Lines feature
Typically, a graphic designer will experiment with a combination of settings until a few
paragraphs of sample text look just right. Then, all these options can be saved in paragraph styles
and applied with one click.

Note the difference in line breaks with successive applications of line break methods. The first column shows a paragraph with
the Adobe Single-Line Composer applied. The middle column shows the same paragraph with the Adobe Paragraph Composer
applied. As you can see, the right edge is much less ragged. The column on the right shows the paragraph with both Adobe
Paragraph Composer and Balance Ragged Lines applied, which helps balance the length of the last line of the paragraph.

Hyphenation settings
Whether and how words are hyphenated at the ends of lines is a paragraph format. In general,
hyphenation settings are editorial decisions, not design decisions. A publication’s style guide, for
example, may specify that capitalized words should not be hyphenated.
1. Using the Type tool ( ), click to place an insertion point in the main story, starting with
“Heart-shaped fruit that’s good for your heart?”
2. Choose Edit > Select All to select all the paragraphs in the story.
3. From the Paragraph panel menu, select Hyphenation. Make sure Preview is selected so you
can see the changes.
4. Deselect Hyphenate to see how the text looks with no hyphenation.
5. Select Hyphenate again, and then type 2 in the Hyphen Limit field to prevent more than
two lines in a row ending with a hyphen.

Tip
When you’re editing text, you can use the Hyphenate option on the Control panel or
the Paragraph panel to quickly enable and disable hyphenation for selected
paragraphs.

6. Click OK to close the dialog box, and then choose File > Save.

Inserting a manual line break
Once the text and design of a layout is nearly complete, you may find a need to add manual line
breaks. Here, you will add a line break to the quote on the left side of the page.

1. Using the Type tool (

), click in the fourth line of the quote, immediately before the word

“of.”
2. Press Shift+Enter (Windows) or Shift+Return (macOS) to enter a line break character.
3. Choose Edit > Deselect All.
4. Choose File > Save.

Note
The Adobe World-Ready Single-Line Composer and the Adobe World-Ready Paragraph
Composer are intended for use with Middle Eastern languages. With these composers,
you can enter text in a combination of Arabic, Hebrew, English, French, German,
Russian, and other Latin languages.

Understanding the Adobe Paragraph and Single-Line
Composers
The density of a paragraph (sometimes called its color) is determined by the composition
method used. InDesign’s composition methods consider the word spacing, letter spacing,
glyph scaling, and hyphenation options you’ve selected and then determine the best line
breaks. InDesign provides two options for composing text: the Adobe Paragraph Composer,
which examines all of the lines in a paragraph before composing each line, and the Adobe
Single-Line Composer, which composes text one line at a time starting with the first line.
When you use the Paragraph Composer, InDesign composes a line while considering
the impact on other lines in the paragraph to set the best overall arrangement of the
paragraph. As you change type in a given line, previous and subsequent lines in the
same paragraph may break differently, making the overall paragraph appear more
evenly spaced. When you use the Single-Line Composer, which is the standard for
other layout and word-processing software, InDesign recomposes only the lines
following the edited text.
The Single-Line Composer handles each line individually. As a result, some lines in a
paragraph appear denser or more sparse than others. Because the Paragraph Composer
looks at multiple lines at once, it makes the density of the lines in a paragraph more
consistent.
The Adobe Paragraph Composer and Adobe Single-Line Composer—along with other
hyphenation and justification controls—are available in the Paragraph panel menu.

Setting tabs
You can use tabs to position text in specific horizontal locations in a column or frame. In the
Tabs panel, you can organize text and create tab leaders, indents, and hanging indents.

Tip
When working with tabs, it helps to view the tab characters by choosing Type > Show
Hidden Characters. It is common to receive word-processing files in which the writer or
editor has entered multiple tabs to align the text onscreen—or worse, entered spaces
rather than tabs. The only way to see what you’re dealing with (and fix it) is to view
hidden characters.

Aligning text to tabs and adding tab leaders
Here, you’ll format the tabbed Nutritional Facts list in the Chocolate-Covered Strawberries
recipe. The tab markers have already been entered in the text, so you will specify the final
location of the text. In addition, you will enter a leader character to fill the space between the text
and the tab stop.
1. Scroll and zoom as necessary to view the recipe.
2. To view the tab markers in the text, make sure that hidden characters are showing (Type >
Show Hidden Characters) and that Normal Mode ( ) is selected in the Tools panel.

3. Using the Type tool ( ), click immediately before “Serving Size” after the “Nutritional
Facts” heading. Drag to select the text through the last line, “Protein 0g.”
4. Choose Type > Tabs to open the Tabs panel.
When a text frame has an insertion point and enough space at the top, the Tabs panel snaps
to the top of the frame so that the measurements in the panel’s ruler exactly match the text.
Regardless of the position of the Tabs panel, you can enter values to set tabs with precision.

5. In the Tabs panel, click Right-Justified Tab ( ). This specifies that text aligns to the left of
the tab stop.
6. Type 2 in in the X (tab stop) box, and press Tab to jump to the Leader field.

Tip
Tab leaders are commonly used in tables of contents. Using a space between periods
creates a more open dot sequence in the tab leader.

7. Type a period (.) and a space in the Leader box, then press Enter (Windows) or Return
(macOS).
The information following each tab marker in the selected text now aligns to the new tab
stop, and a dotted line (of periods and spaces) helps lead the eye across the line.

8. Choose Edit > Deselect All, and choose Type > Tabs to close the Tabs panel.
9. Choose File > Save.

Working with tabs
The controls for creating and customizing tabs in InDesign are similar to those in a word
processor. You can precisely position tabs, repeat tabs across a column, create leaders for
tabs, specify how text aligns with tabs, and easily modify the tabs you’ve created. Tabs are
paragraph formats, so they apply to the paragraph containing the text insertion point or any
selected paragraphs. All the controls are in the Tabs panel, which you open by choosing
Type > Tabs. Here’s how the tabs controls work:
Enter tabs: To enter a tab in text, press the Tab key.
Specify tab alignment: To specify how text aligns with a tab stop—for example, to
the left of the tab stop (the traditional setting) or on a decimal point—click one of the
tab buttons in the upper-left corner of the Tabs panel: Left-Justified Tab, CenterJustified Tab, Right-Justified Tab, or Align To Decimal (Or Other Specified Character)
Tab.
Position tabs: To position a tab stop, click one of the tab buttons, type a value in the X
box, and press Enter or Return. You can also click a tab button, and then click just
above the ruler.
Repeat tabs: To create multiple tab stops the same distance apart, select a tab on the

ruler. Choose Repeat Tab from the Tabs panel menu. This creates tab stops across the
column based on the distance between the selected tab stop and the previous tab stop
(or the left indent).
Specify a character on which to align text: To align text on a specific character—for
example, a decimal point—click the Align To Decimal (Or Other Specified Character)
Tab button at left, and then type or paste the character into the Align On box. (If the
text does not contain that character, text will align to the left of the tab stop.)
Create a tab leader: To fill the white space between text and tabs—for example, to
add periods between text and page numbers in a table of contents—enter up to eight
characters to repeat in the Leader box.
Move tabs: To change the position of a tab stop, select the tab on the ruler, type a new
position in the X box, and press Enter (Windows) or Return (macOS). Or, drag the tab
on the ruler to a new location.
Delete tabs: To delete a tab, drag it off the tab ruler. Or, select the tab on the ruler, and
choose Delete Tab from the Tabs panel menu.
Reset default tabs: To return to the default tab stops, choose Clear All from the Tabs
panel menu. The default tab stop positions vary depending on the document’s settings
in the Units & Increments panel of the Preferences dialog box. For example, if the
Horizontal Ruler is set to Inches, default tab stops are placed at every half-inch.
Change tab alignment: To change a tab stop’s alignment, select it on the ruler, and
then click a different tab button. Or, press the Alt (Windows) or Option (macOS) key
while clicking the tab on the ruler to cycle through the four alignment options.

Creating a numbered list with a hanging indent
InDesign makes it easy to create bulleted lists and numbered lists to clearly delineate
information. Lists generally feature a “hanging indent” so the text hangs to the right of the tab
market. Here, you will add step numbers to the recipe instructions.
1. Using the Type tool ( ), click immediately before the first step in the recipe, “Wash the
strawberries.” Drag to select all four paragraphs through the words “30 minutes.”
2. Click the Numbered List button on the Properties panel.

3. Deselect the text, and view the numbered list with the hanging indent.
4. Choose File > Save.

Hanging indents and bulleted lists
You can adjust paragraph indents—including the Left Indent, Right Indent, First Line Left
Indent, and Last Line Right Indent—using controls in the Control panel, the Paragraph
panel (Type > Paragraph), and the tab ruler (Type > Tabs). In addition to specifying values,
you can create hanging indents in the following ways:
Press the Shift key while dragging the indent markers on the tab ruler. The Shift key
lets you drag the indent markers independently.
Insert an Indent To Here character to hang all the subsequent lines in the paragraph to
the right of the character. To do this, press Ctrl+\ (Windows) or Command+\ (macOS),
or choose Type > Insert Special Character > Other > Indent To Here.
You can use a combination of hanging indents and bullet characters or numerals to create
bulleted or numbered lists. A quicker way to do this, however, is to use the Bullets And
Numbering feature in the Properties panel or the Bulleted & Numbered Lists submenu of
the Type menu. You can save bulleted list and numbered list formatting as part of a
paragraph style.

Working with paragraph shading and rules
To call attention to text within a story, you can apply shading to a paragraph. InDesign provides
many options for fine-tuning the shading, including the tint of the shading and its offset from the
paragraph. To allow enough space above or below a paragraph for shading, apply a space before
or space after setting for the paragraph.
You can add a horizontal rule (line) above or below a paragraph. The advantage of using rules
rather than simply drawing a line is that rules can be applied with a paragraph style, and they
travel with the paragraph when text reflows. For example, you might use both a rule above and
rule below in a paragraph style for pull quotes. Or, you might use a rule above a subhead.
To quickly and consistently apply rules and shading, you can include these formats in a
paragraph style.

Applying shading to a paragraph
The final touch in this layout is using shading to create a reverse type effect for the recipe
heading.

Tip

The paragraph-shading controls are available in the Control panel as well. To fine-tune
the shading, choose Paragraph Borders And Shading from the Paragraph panel menu, and
click the Shading tab at the top. You can also open the Paragraph Shading dialog box by
Alt-clicking (Windows) or Option-clicking (macOS) the Shading Color button on the
Control panel or the Paragraph panel.

1. Using the Type tool ( ), click in the “Chocolate-Covered Strawberries” recipe heading.
This targets the paragraph for formatting.
2. Select Shading in the lower-left corner of the Paragraph panel.
3. To select the color of the shading, click the Shading Color menu to the right of the Shading
box. Select the Strawberry Red swatch.

4. Choose File > Save.

Applying a rule to a paragraph
Here you’ll add a rule below the “A BITE OF DELIGHT” tagline at the top of the page.
1. Choose View > Fit Page In Window.
2. Using the Type tool ( ), click to place an insertion point in the “A BITE OF DELIGHT”
tagline.

3. Choose Paragraph Rules from the Paragraph panel menu.
4. At the top of the Paragraph Rules dialog box, choose Rule Below from the menu, and select
Rule On to activate the rule.
5. Select the Preview option. Move the dialog box so that you can see the paragraph.
6. In the Paragraph Rules dialog box, set these options:
Weight: 8 pt

Color: Stem Green
Width: Text
Type: White Diamond
Offset: .0625 in (one click of the up arrow)

7. Click OK to apply the changes.
A rule now appears below the tagline.
8. Choose File > Save.
9. To view your results, choose Presentation from the Screen Mode menu (
Application bar at the top of the screen.

) in the

10. When you’re finished viewing the document, press Esc.
Congratulations, you have finished the lesson. To finalize this article, you would likely spend
time with an editor or proofreader to fix any tight or loose lines, awkward line breaks, widows,
and orphans.

Exploring on your own

Now that you have learned the basics of formatting text in an InDesign document, you’re ready
to apply these skills on your own. Try the following tasks to improve your typographic skills.
1. Place an insertion point in various paragraphs and experiment with turning hyphenation on
and off in the Paragraph panel. Select a hyphenated word and choose No Break from the
Character panel menu to stop an individual word from hyphenating.
2. Experiment with different hyphenation settings. First, select all the text in the main story.
Then, choose Hyphenation from the Paragraph panel menu. In the Hyphenation Settings
dialog box, select Preview, and then experiment with the settings. For example, drag the
Better Spacing/Fewer Hyphens slider to see how it affects the text.
3. Experiment with different justification settings. First, select all the text, and then choose
Justification from the Paragraph panel menu. In the Justification dialog box, select Preview
and experiment with the settings. For example, look at the difference that the Adobe
Single-Line Composer and the Adobe Paragraph Composer make when applied to justified
(rather than left-aligned) text.
4. Choose Type > Insert Special Character and view all the options available, such as Symbols
> Bullet Character and Hyphens And Dashes > Em Dash. Using these characters rather than
hyphens significantly enhances how professional the typography looks. Choose Type >
Insert White Space and notice the Nonbreaking Space. Use this to “glue” two words
together so they cannot split at the end of a line (such as “et al.”).

Review questions
1 What is the advantage of specifying a space before/after value for paragraphs rather than
entering extra paragraph returns to add space?
2 What is a glyph and how do you insert them into text?
3 A drop cap affects a character, so why is it specified as a paragraph format?
4 What is a tab leader?
5 What is the difference between kerning and tracking?
6 What is the difference between the Adobe Paragraph Composer and the Adobe Single-Line
Composer?

Review answers
1 Space before/after a paragraph allows for precision spacing that can be applied consistently
through paragraph styles. Paragraph returns often result in too much space between
paragraphs, and they can end up in undesirable locations, such as the top of a column.
2 A glyph is a representation of a character within a single font. For example, a font may provide
two different options for a dollar sign (such as $ and $ in the font in use now, Warnock Pro).
The Glyphs panel (Type menu) provides access to all the glyphs in a font.
3 Drop caps are paragraph formats because they are not specific to selected text—rather, they
can be applied to any paragraph. In addition, drop cap formatting can be applied consistently
through paragraph styles.
4 A tab leader is a character (or multiple characters) that fill the space between text and a tab

marker.
5 Kerning adjusts the space between two characters; tracking adjusts the space between a range
of selected characters. Kerning controls are available when the text insertion point is flashing;
tracking controls are available when a range of text is selected. The controls are available on
the Control panel and the Character panel.
6 The Paragraph Composer evaluates all lines in a paragraph when determining the best possible
line breaks. The Single-Line Composer evaluates only one line at a time when determining
line breaks.

8 Working with Color

Lesson overview
In this lesson, you’ll learn how to do the following:
Set up color management.
Specify output requirements.
Create color swatches.
Apply colors to objects, strokes, and text.
Create and apply a tint.
Create and apply a gradient swatch.
Work with color groups.
Create color themes and add them to CC Libraries.

This lesson will take about 60 minutes to complete. Please log in to your account on
peachpit.com to download the files for this lesson, or go to the “Getting Started” section at the
beginning of this book and follow the instructions under “Accessing the Lesson Files and Web
Edition.” Store the files on your computer in a convenient location. Your Account page is also
where you’ll find any updates to the lessons or the lesson files. Look on the Lesson & Update
Files tab to access the most current content.

You can create and apply process and spot color swatches to objects, strokes, and text. Color themes make it easy to achieve
color harmony in layouts. For consistent color usage across projects and workgroups, you can add color themes to CC Libraries.
Using a preflight profile helps ensure that colors output properly.

Getting started
In this lesson, you’ll add colors, tints, and gradients to a full-page advertisement for a gardening
clinic. The ad consists of CMYK colors and a spot color along with imported CMYK images.
(You’ll learn more about CMYK later in this lesson.) Before you get started, however, you will
do two things to ensure that the document looks as good in print as it does onscreen: You will
review color management settings and use a preflight profile to review the color modes of the
imported images. When the ad is finished, you will organize the colors into a color group.

Note

If you have not already downloaded the project files for this lesson to your computer
from your Account page, make sure to do so now. See “Getting Started” at the beginning
of the book.

1. To ensure that the preferences and default settings of your Adobe InDesign CC, program
match those used in this lesson, move the InDesign Defaults file to a different folder
following the procedure in “Saving and restoring the InDesign Defaults file” on pages 4–5.
2. Start InDesign.
3. The InDesign Start Screen displays. Click Open at left. (If the Start Screen does not
display, choose File > Open from the InDesign menu bar.)
4. Open the 08_Start.indd file, in the Lesson08 folder, located inside the Lessons folder in the
InDesignCIB folder on your hard disk.
5. If an alert informs you that the document contains links to sources that have been modified,
click Update Links.
6. To ensure that the panels and menu commands match those used in this lesson, choose
Window > Workspace > [Advanced], and then choose Window > Workspace > Reset
Advanced.
7. Choose File > Save As, rename the file 08_Color.indd, and save it in the Lesson08 folder.
8. If you want to see what the finished document looks like, open the 08_End.indd file located
in the same folder. You can leave this document open to act as a guide as you work.
9. When you’re ready to resume working on the lesson document, click its tab in the upperleft corner of the document window.

Managing color
Color management works to reproduce colors consistently across a range of output devices, such
as monitors, tablets, color printers, and offset presses. InDesign gives you easy-to-use color
management features that help you achieve good, consistent color without needing to become a
color management expert. With color management enabled out of the box, you’ll be able to view
colors consistently while ensuring more accurate color from edit to proof to final print or display
output.

Note
The screen captures in this book show the Medium Light interface. Interface elements
such as panels and dialog boxes may be darker on your screen.

The need for color management
No screen, film, printer, copier, or printing press can produce the full range of color visible to the
human eye. Each device has specific capabilities and makes different kinds of compromises in
reproducing color images. The unique color-rendering abilities of a specific output device are
known collectively as its “gamut.” InDesign and other graphics applications, such as Adobe
Photoshop CC and Adobe Illustrator CC, use color numbers to describe the color of each pixel in
an image. The color numbers correspond to the color model, such as the RGB values for red,
green, and blue, or the CMYK values for cyan, magenta, yellow, and black.

Tip
You can find additional information about color management in the InDesign Help file,
online at adobe.com (search for “color management”) and in DVDs/videos such as
Peachpit’s Color Management for Photographers and Designers: Learn by Video.

Color management is simply a way of translating the color numbers for each pixel from the
source (the document or image stored on your computer) to the output device (such as your
monitor, laptop, tablet, smartphone, color printer, or high-resolution printing press). Because
each source and output device has its own specific gamut (or range) of colors it is capable of
reproducing, the aim of the color translation is color accuracy across devices.

Creating a viewing environment for color management
Your work environment influences how you see color on your monitor and on printed
output. For best results, control the colors and light in your work environment by doing the
following:

View your documents in an environment that provides a consistent light level and
color temperature. For example, the color characteristics of sunlight change throughout
the day and alter the way colors appear onscreen, so keep shades closed or work in a
windowless room.
To eliminate the blue-green cast from fluorescent lighting, you can install D50 (5000°
Kelvin) lighting. You can also view printed documents using a D50 light box.
View your document in a room with neutral-colored walls and ceiling. A room’s color
can affect the perception of both monitor color and printed color. Neutral gray is the
best color for a viewing room.
The color of your clothing reflecting off your monitor may affect the appearance of
colors onscreen.
Remove colorful background patterns on your monitor desktop. Busy or bright patterns
surrounding a document interfere with accurate color perception. Set your desktop to
display neutral grays only.
View document proofs in the real-world conditions under which your audience will see
the final piece. For example, you might want to see how a housewares catalog looks
under the typical light bulbs used in homes, or view an office furniture catalog under
the fluorescent lighting used in offices.
Always make final color judgments under the lighting conditions specified by the legal
requirements for contract proofs in your country.
—From InDesign Help

Displaying images at full resolution
In a color management workflow, even using default color settings, you should display images at
high quality for the best possible color representation that your monitor is capable of showing.
To see the difference in one of your documents, experiment with the options in the View >
Display Performance menu.
Fast Display (ideal for quick text editing because images do not display)
Typical Display (displays images more quickly but colors are less precise; the default for
most computers)
High Quality Display (displays images at high resolution)

Note
If you have a compatible graphic processing unit on your Mac, High Quality Display is
the default.

For this lesson, choose View > Display Performance > High Quality Display.
You can specify Display Performance defaults in the Preferences dialog box, and you can change
the display of an individual object using the Object > Display Performance menu.

Specifying color settings in InDesign
For consistent color in InDesign, you can specify a color settings file (CSF) with preset color
management policies and default profiles. The default setting is North America General Purpose
2, which is the best option for beginners.

Tip
According to Adobe, “For most color-managed workflows, it is best to use a preset color
setting that has been tested by Adobe Systems. Changing specific options is
recommended only if you are knowledgeable about color management and very confident
about the changes you make.”

In this section, we review some of the preset color settings in InDesign that you can use to help
achieve consistent color in your projects. However, you will not change any color settings.
1. Choose Edit > Color Settings. These settings apply to the InDesign application rather than
to individual documents.
2. Click the various options in the Color Settings dialog box to see what is available.
3. Point at the Working Spaces title to see a description of this feature in the Description box
at the bottom of the dialog box.
4. Point at various other features to see their descriptions.

5. Click Cancel to close the Color Settings dialog box without making changes.

Proofing colors onscreen
When you proof colors onscreen, also known as “soft proofing,” InDesign attempts to display
colors according to specific output conditions. The accuracy of the simulation depends on
various factors, including the lighting conditions of the room and whether your monitor is
calibrated. To experiment with soft proofing, do the following:

Tip
To be sure that your screen is displaying colors to the best of its ability, be sure to
calibrate it. For more information, see “Calibrate and profile your monitor” in InDesign
Help.

1. Choose Window > Arrange > New Window for 08_Color.indd to open a second window
for your lesson document.
2. If necessary, click the 08_Color.indd:2 window to activate it. If necessary, choose View >
Display Performance > High Quality Display.

Note
The Proof Setup default is Document CMYK - U.S. Web Coated SWOP V2, which
reflects the typical output method for print documents in the United States. SWOP
stands for Specifications for Web Offset Publications.

3. Choose View > Proof Colors. You can see a soft proof of the colors according to the
current settings under View > Proof Setup.
4. To customize the soft proof, choose View > Proof Setup > Custom.
5. In the Customize Proof Condition dialog box, click the Device To Simulate menu and
review the available presses, desktop printers, and output devices such as monitors.
6. Scroll down in the menu and select Dot Gain 20% from the Device To Simulate menu, and
click OK.
Grayscale profiles such as Dot Gain 20% let you preview how a document will print in
black and white. Notice that the InDesign document’s title bar shows which device is being
simulated, such as (Dot Gain 20%) or (Document CMYK).

7. Try different soft proofing options.
8. When you’re finished reviewing the various soft proofing options, click 08_Color.indd:2’s
close box to close the second window. Resize and reposition the 08_Color.indd window as
necessary.

Defining printing requirements
Whether you are working on a document for delivery in a print or digital format, it’s a good idea
to know the output requirements before you start working. For example, for a print document,
meet with your printer and discuss your document’s design and use of color. Because printers
understand the capabilities of their equipment, they may suggest ways for you to save time and

money, increase quality, and avoid potentially costly printing or color problems. The ad used in
this lesson was designed to be printed by a commercial printer using CMYK colors and a spot
color. (Color modes are described in more detail later in this lesson.)

Tip
Your commercial printer may provide a preflight profile with all the necessary
specifications for output. You can import the profile and use it to check your work
against these criteria.

To confirm that your document matches the printing requirements, you can check it against a
preflight profile, which contains a set of rules regarding the document’s size, fonts, colors,
images, bleeds, and more. The Preflight panel can alert you to anything in the document that
does not follow the rules set in the profile. In this exercise, you will import a preflight profile,
select it in the Preflight panel, and resolve an issue with the document.

Loading a preflight profile
First, you will load a preflight profile provided by the printer.
1. Choose Window > Output > Preflight.
2. Choose Define Profiles from the Preflight panel menu button (

).

3. In the Preflight Profiles dialog box, click the Preflight Profile Menu button (
list of preflight profiles at left. Choose Load Profile.

) below the

4. Select the Ad Profile.idpp file, in the Lesson08 folder, located inside the Lessons folder
within the InDesignCIB folder on your hard disk. Click Open.
5. With the Ad Profile selected, look through the settings specified for the output of this ad.
Click the arrows next to the other categories to see all the options you can include in a
preflight profile.

InDesign will flag violations for the checked options. For example, under Color > Color
Spaces And Modes Not Allowed, RGB is selected. As a result, all uses of RGB colors will
be reported as errors.
6. Click OK to close the Preflight Profiles dialog box.

Selecting a preflight profile
Now, you will select the Ad Profile and review any errors that it flags.

Tip
The lower-left corner of the document window displays the number of preflight errors in
a document (provided that On is selected in the upper-left corner of the Preflight panel).
If you start to see a lot of errors, open the Preflight panel to see more information.

1. From the Profile menu in the Preflight panel, choose Ad Profile. Notice that the profile
detects one issue with the colors that currently exist in the document.
2. To view the error, click the triangle next to COLOR (6).
3. Click the triangle next to Color Space Not Allowed (1).
4. Double-click Line to select the line that is triggering the error.
5. If necessary, click the triangle next to Info to see details on the problem. Leave this panel
open for the next exercise.
Because this document is destined for CMYK printing, colors in the RGB color mode are

not allowed. The stroke color of the line is in the RGB color model.

Converting a color mode for a swatch
Now, you will resolve the preflight error by converting the color mode of the swatch applied to
the line.

Tip
When you package a document for final output (File > Package), InDesign may flag
issues with color models. You will change the color mode in the same way as shown
here.

1. Choose Window > Color > Swatches to display the Swatches panel.
2. In the list of colors in the Swatches panel, double-click the Green-Dark swatch to open the
Swatch Options dialog box.
3. Select CMYK from the Color Mode menu, and then click OK.

4. Notice that the error no longer displays in the Preflight panel.
5. Close the Preflight panel, and choose File > Save.

Creating colors
For maximum design flexibility, InDesign provides a variety of methods for creating colors.
Once you create colors and color swatches, you can apply them to objects, strokes, and text in
the layout. For consistent color usage, you can share colors among documents and users. You
can create colors in the following ways:

Note
As you work through the lesson, you can move panels around and change the zoom level
to a setting that works best for you. For more information, see “Working with panels”
and “Changing the magnification of a document” in Lesson 1.

Create colors on-the-fly using the Color panel.
Create named color swatches for repeated and consistent usage with the Swatches panel.
Select a color from an image using the Eyedropper tool.
Use the Color Theme tool to choose among color themes generated from images or objects.
Create and select themes from the Adobe Color Theme panel.
Use the CC Libraries feature to share colors with Photoshop and Illustrator, with other
members of your workgroup, and with other documents.
You can define colors in a variety of color modes, including RGB, CMYK, and “spot color”
modes such as PANTONE. The difference between spot and process (CMYK) colors is
discussed in detail later in this exercise.
This ad will be printed by a commercial printer using CMYK color, which requires four separate
plates for printing—one each for cyan, magenta, yellow, and black. However, the CMYK color
mode has a limited range of colors, which is where spot colors are useful. Spot colors are used to
add colors beyond the range of CMYK (for example, metallic and pastel inks) and to ensure
consistent color (for example, for use in company logos).

Tip
Many corporate identities, including logos, specify a PANTONE color. When working on
projects for clients, it’s a good idea to ask about any PANTONE colors and fonts required
to reproduce their corporate identity.

In this exercise, you will use the Swatches panel to create a PANTONE color for a logo. You
will then use the Eyedropper tool, Color panel, and Swatches panel to create a CMYK color
swatch for the ad’s background color. Finally, you will use the Color Theme tool to create a set
of complementary colors from one of the mosaic images in the document. The selected color
theme is added to the Swatches panel and to your CC Library.

Creating a PANTONE color swatch
In this ad, the organization’s name (Urban Oasis Gardens) calls for a PANTONE spot color ink.
You’ll now add a spot color from a color library. In a real-world scenario, you would need to
notify the printer that you plan to use a PANTONE spot color.
1. Using the Selection tool ( ), click the pasteboard surrounding the page to make sure
nothing is selected.
2. If necessary, choose Window > Color > Swatches to display the Swatches panel.
3. Choose New Color Swatch from the Swatches panel menu button ( ).
4. In the New Color Swatch dialog box, choose Spot from the Color Type menu.
5. Select PANTONE+ Solid Coated from the Color Mode menu.
6. In the PANTONE C box, type 266 to automatically scroll the list of Pantone swatches to
the color you want for this project, which is PANTONE 266 C.
7. Deselect Add To CC Library in the lower-left corner.

Tip
CC Libraries allow you to share assets, such as colors, among documents and users.
You will learn about CC Libraries in Lesson 10, “Importing and Modifying
Graphics.”

8. Click OK. The spot color is added to your Swatches panel.
The icon ( ) to the right of the color name in the Swatches panel indicates that it is a spot
color. New colors added to the Swatches panel are stored with the document in which they
are created.

Tip
When selecting PANTONE colors for print, it’s a good idea to select them from a
printed PANTONE color guide, available from www.pantone.com. Selecting
PANTONE colors from the screen may not be reliable.

9. Choose File > Save.
You’ll apply the newly added spot color to the “Urban Oasis Gardens” text later in this
lesson.

Creating CMYK color swatches
To create a CMYK color swatch from scratch, you need an understanding of color mixing and
color values. Alternatively, you can experiment with defining colors in the Colors panel and add
a color as a color swatch. You can also use the Eyedropper tool to “pick up” a color from an
image. In this exercise, you will use the Eyedropper tool to get a head start on creating a CMYK
color swatch. Then, you will create two additional colors by simply entering color values.

Tip
Using the Swatches panel to name colors makes it easy to apply, edit, and update colors
for objects in a document. Although you can also use the Color panel to apply colors to
objects, there is no quick way to update these colors, which are considered “unnamed
colors.” Instead, if you want to change an unnamed color on multiple objects, you need to
change each one individually.

1. Choose Window > Color > Color to display the Color panel.
2. On the Color panel, click the Fill box ( ) in the upper-left corner.

3. Click the Color Theme tool ( ) toward the bottom of the Tools panel. Hold the mouse
button down to view the pop-out menu, and then select the Eyedropper tool ( ).
4. Click the Eyedropper tool on a lighter area of the yellow flower in the lower-left corner of
the page as shown.

Note
When entering values in fields, click in the first field to activate it. You can then tab
between fields, and press Enter (Windows) or Return (macOS) to implement the
values.

5. The color picked up from the image displays in the Color panel. The color values may
differ depending on precisely where you clicked. To create the intended color, fine-tune the
values as necessary:

Cyan: 10
Magenta: 0
Yellow: 40
Black: 0
6. Choose Add To Swatches from the Color panel menu button (

).

A color swatch is added to the bottom of the list in the Swatches panel. It is automatically
selected.
7. Click the New Swatch icon ( ) at the bottom of the Swatches panel. This makes a copy of
any selected swatch.
8. Double-click the new swatch added to the bottom of the Swatches panel. This opens the
Swatch Options dialog box so that you can edit the swatch.

Tip
When you know the color definition, as with the PANTONE color, it’s easiest to use
the Swatches panel and create a swatch. When you’re trying to match a color in an
image, it can work better to use the Eyedropper tool and Color panel.

9. Make sure Color Type is Process and Color Mode is CMYK. Adjust the color by typing
values in the following fields; you can tab from field to field.
Cyan: 25
Magenta: 75
Yellow: 0
Black: 0
10. Click OK to close the Swatch Options dialog box.
11. Press Alt (Windows) or Option (macOS) while you click the New Swatch icon ( ) at the
bottom of the Swatches panel. This creates a new swatch and automatically opens the New
Color Swatch dialog box.

Tip
If you want to give a color a recognizable name, such as Aqua or Forest Green,
deselect Name With Color Value in the Swatch Options dialog box. You can then
enter a name in the Swatch Name field.

12. If necessary, select Name With Color Value. Make sure that Color Type is set to Process
and Color Mode is set to CMYK.
13. Enter the following values in the fields, tabbing between fields: Cyan = 90, Magenta = 70,
Yellow = 30, and Black = 10. Click OK to update the color.
14. Choose New Color Swatch from the Swatches panel menu button ( ). If necessary, select
Name With Color Value. Make sure that Color Type is set to Process and Color Mode is set
to CMYK. Enter the following values in the fields, tabbing between fields: Cyan = 65,
Magenta = 25, Yellow = 100, and Black = 0.
15. Click OK to update the color, and then choose File > Save.
You have now created a spot color swatch (purple) and three CMYK color swatches (pink, blue,
and green) in addition to the yellow swatch created with the Eyedropper tool. In the next
exercise, you will apply colors to objects on the page.

Tip
In addition to spot and process colors, InDesign provides Mixed Ink colors to expand the
color palette of a publication that uses multiple spot colors. To use this feature, select
New Mixed Ink Swatch from the Swatches panel menu. You can then mix a spot color
and black (or two spot colors) to create an additional color, offering the tonal range you
would see in a duotone image. If the New Mixed Ink Swatch option is not available,
make sure that the document includes a spot color swatch.

About spot and process colors
A spot color is a special premixed ink used instead of, or in addition to, CMYK process
inks. Each spot color requires its own printing plate on a printing press, so use spot colors
when few colors are specified and color accuracy is critical. Spot color inks can accurately
reproduce colors outside the gamut of process colors. However, the exact appearance of the
printed spot color is determined by the combination of the ink as mixed by the commercial
printer and the paper it’s printed on, not by color values you specify or by color
management.
A process color is printed using a combination of the four standard process inks: cyan,
magenta, yellow, and black (CMYK). Use process colors when a job requires so many
colors that using individual spot inks would be expensive or impractical, as when printing
color photographs.
For best results in a high-quality printed document, specify process colors using
CMYK values printed in process color reference charts, such as those available from a
commercial printer.
The final color values of a process color are its values in CMYK, so if you specify a
process color using RGB, those color values are converted to CMYK when you print
color separations. These conversions differ based on your color-management settings
and document profile.
Don’t specify a process color based on how it looks on your monitor, unless you are
sure you have set up a color-management system properly and you understand its
limitations for previewing color.
Avoid using process colors in documents intended for onscreen viewing because
CMYK has a smaller color gamut than that of a typical screen.
Sometimes it’s practical to use process and spot inks in the same job. For example, you
might use one spot ink to print the exact color of a company logo on the same pages of an
annual report where photographs are reproduced using process color. You can also use a
spot-color printing plate to apply a varnish over areas of a process color job. In both cases,
your print job would use a total of five inks—four process inks and one spot ink or varnish.
Each spot color you create generates an additional spot-color plate for the press. In general,
commercial printers produce either two-color (using black and one spot color) or four-color
CMYK work, with the possibility of adding one or more spot colors. Using spot colors
typically increases printing costs. It is a good idea to consult with your printer before using
spot colors in a document.
—Condensed from InDesign Help

Applying colors
Once you create color swatches, you can apply them to objects, text, and more. The Swatches

panel, Control panel, Properties panel, and CC Libraries panel offer the primary tools for
applying colors. There are three general steps to applying a color:
1. Select the text or object.
2. Select the stroke or fill option, depending on what you want to change.
3. Select a swatch.

Tip
The Control panel and Properties panel provide separate Fill and Stroke menus, which
can make it easier to apply colors.

You use the Stroke/Fill box ( ) to specify whether you want to apply color to a selection’s
stroke (outline) or fill (background). You can find the Stroke/Fill box on the Tools panel, the
Swatches panel, and the Color panel. Whenever you apply colors, keep an eye on this box, as it’s
easy to apply color to the wrong part of an object.
InDesign provides many other options for applying colors, including dragging swatches onto
objects, copying color from an object with the Eyedropper tool, and specifying colors in styles.
As you work with InDesign, you will discover which methods work best for you.
In this exercise, you will apply color swatches to strokes, fills, and text using various panels and
techniques.

Applying fill colors to objects
In this task, you will apply fill colors to various objects on the page by using the Swatches panel,
dragging a swatch, and using the Eyedropper tool.

Tip
Clicking the small arrow on the Fill/Stroke box ( ) swaps the stroke and fill colors of a
selected object.

1. If necessary, choose Window > Color > Swatches to display the Swatches panel. Leave this
panel open until you reach the end of this lesson.
2. Choose View > Screen Mode > Normal to see the frame edges.
3. Using the Selection tool ( ), click anywhere in the margin of the page (outside the margin
guides) to select the large background frame.

Click in the margins of the page to select the large text frame as shown above.

4. Click the Fill box ( ) on the Swatches panel.
5. Click the green color swatch named C=65 M=25 Y=100 K=0.
6. Type 50 in the Tint field on the Swatches panel, and then press Enter (Windows) or Return
(macOS).

7. Using the Selection tool, select the text frame at right containing the words “Urban Oasis
Gardens.”
8. With the Fill box still selected, click the yellow color swatch named C=10 M=0 Y=40 K=0.

9. Click the pasteboard to make sure nothing is selected on the page.
10. In the Swatches panel, drag the pink color swatch (C=25 M=75 Y=0 K=0) to the text frame
centered at the bottom of the page containing the “$75.”

11. Click the pasteboard to make sure nothing is selected.
12. Using the Selection tool, click “Orchid Clinic” at the top of the page.
13. With the Fill box still selected, click the blue color swatch named C=90 M=70 Y=30 K=10.

Tip
The “Orchid Clinic” text at the top of the page is actually an object created by
choosing Type > Create Outlines for a selected text frame. This actually creates a
frame (shaped like the text) that may be filled with a graphic or otherwise
manipulated.

14. Choose File > Save. To prepare for the next exercise, click the pasteboard to make sure
nothing is selected and choose View > Fit Page In Window.

Applying colors to strokes
The Stroke panel (Window > Stroke) lets you apply a border to lines, frames, and text. Here, you
will apply color to an existing line and a graphics frame stroke using options on the Control
panel.
1. Using the Selection tool ( ), click the horizontal line above the date in the middle of the
page.
2. Click the Stroke menu on the Control panel.

Note
If you apply color to the wrong object or the wrong part of an object, you can always
choose Edit > Undo and try again.

3. Scroll down and select the pink color: C=25 M=75 Y=0 K=0.

4. Using the Selection tool, click the graphics frame containing the orchid bud. Be sure to
click outside the content grabber to select the frame.
5. Click the Stroke box ( ) on the Swatches panel.
6. Scroll down and click the blue color swatch named C=90 Y=70 M=30 K=10.

7. Choose File > Save.

Applying colors to text
You will now select text with the Type tool and apply a fill color to it using the Swatches panel
and the Control panel.

Tip
To create reverse type, which is lighter text on a dark background, you apply a lighter
color to text and a darker color to the paragraph shading or text frame.

1. Using the Type tool ( ), click in the text frame containing the date “Tuesday • January 8 •
7–10 p.m.” Drag to select all the text.
On the Swatches panel, notice that the Fill box has changed to indicate that text is selected:
( ).
2. With the Fill box still selected, click the blue color swatch named C=90 Y=70 M=30 K=10.
3. Using the Type tool, click in the frame at left containing the words “Grow. Maintain.
Rebloom.” Press Ctrl+A (Windows) or Command+A (macOS) to select all the text in the
paragraph.
4. With the Fill box still selected, click the blue color swatch named C=90 Y=70 M=30 K=10.
5. Using the Type tool, click in the frame at right containing the words “Urban Oasis
Gardens.” Click four times to select all the text.
6. Locate the text Fill button on the Control panel. Click the Fill button and select the
PANTONE 266 C swatch.
7. Choose Window > Properties to display the Properties panel.
8. Using the Type tool, click in the text frame centered at the bottom of the page containing
the “$75.” Choose Edit > Select All to select all the text.
9. In the Properties panel, locate the field next to the Stroke control. Type 1 pt in the Weight
field. Press Enter (Windows) or Return (macOS).
10. Click the Stroke button, and then select the blue color swatch named C=90 Y=70 M=30
K=10.
11. Click the Fill button, and then select the green color swatch named C=65 M=25 Y=100
K=0.

Click the pasteboard to deselect the text and see the results. The middle of the page should
look something like this now.

12. Choose Edit > Deselect All, and then choose File > Save.

Working with tint swatches
A tint swatch is a screened (lighter) version of a color that you can apply quickly and
consistently. The tint swatch is available on the Swatches panel and in other color menus, such as
in the Control panel. You can share tint swatches with other documents through the Load
Swatches command on the Swatches panel menu. You will now create a light-green tint swatch
and apply it to the yellow text frame.

Creating a tint swatch
You create a tint swatch from an existing color swatch.

Tip
Tints are helpful because InDesign maintains the relationship between a tint and its
parent color. So if you change the parent color swatch to a different color, the tint swatch
becomes a lighter version of the new color.

1. Choose View > Fit Page In Window to center the page in the document window.
2. Using the Selection tool ( ), click the pasteboard surrounding the page to make sure
nothing is selected.

3. Select the pink color swatch named C=25 M=75 Y=0 K=0.
4. Choose New Tint Swatch from the Swatches panel menu ( ).
5. In the New Tint Swatch dialog box, the Tint option at the bottom is the only option you can
modify. Type 65 in the Tint box, and then click OK.
The new tint swatch appears at the bottom of the list of swatches. The top of the Swatches
panel displays information about the selected swatch, with a Fill/Stroke box showing that
the 65% tint is currently the selected fill color and a Tint box showing that the color is 65%
of the original color.

Applying a tint swatch
You will apply the tint swatch as a fill color.
1. Using the Selection tool ( ), click the text frame at the bottom containing the “$75.”
2. Click the Fill box ( ) on the Swatches panel.
3. Click the new tint you just created in the Swatches panel. Its tint swatch name will be C=25
M=75 Y=0 K=0 65%. Notice how the color changes.

4. Choose File > Save.

Working with gradients
A gradient is a graduated blend between two or more colors or between tints of the same color.
You can create either a linear or a radial gradient. In this exercise, you will create a linear
gradient swatch with the Swatches panel, apply it to an object, and adjust the gradient with the
Gradient Swatch tool.

Tip
It’s a good idea to test gradients on the intended output device, whether it’s a tablet,
inkjet printer, or press.

Creating a gradient swatch
When you create a gradient in the New Gradient Swatch dialog box, the gradient is defined by a
series of color stops in the gradient ramp. A stop is the point at which each color is at full

intensity between the transitions; it is identified by a square below the gradient ramp. Every
InDesign gradient has at least two color stops. By editing the color of each stop and adding
additional color stops, you can create custom gradients.
1. Choose Edit > Deselect All to make sure no objects are selected.
2. Choose New Gradient Swatch from the Swatches panel menu ( ).
3. For Swatch Name, type Pink/Yellow. Leave the Type menu set to Linear.

Tip
To create a gradient that uses a tint of a color, first create a tint swatch in the
Swatches panel.

4. Click the left stop marker ( ) on the Gradient Ramp.
5. From the Stop Color menu, select Swatches, and then scroll down the list and select the
pink color swatch named C=25 M=75 Y=0 K=0.
Notice that the left side of the gradient ramp is now pink.
6. With the left stop marker still selected, type 5 in the Location field.
7. Click the right stop marker ( ), and select the yellow color swatch named C=10 M=0 Y=40
K=0. Type 70 in the Location field.
The gradient ramp shows a color blend between pink and yellow.

8. Click OK. The new gradient swatch appears at the bottom of the list in the Swatches panel.

9. Choose File > Save.

Applying a gradient swatch
Now you’ll replace the fill in one of the text frames with the gradient.
1. Using the Selection tool ( ), click the text frame at left containing the words “Grow.
Maintain. Rebloom.”
2. Click the Fill box ( ) on the Swatches panel.
3. Click the new gradient you just created in the Swatches panel: Pink/Yellow.

4. Choose File > Save.

Adjusting the direction of the gradient blend
Once you have filled an object with a gradient, you can modify the gradient by using the
Gradient Swatch tool to “repaint” the gradient along an imaginary line that you draw. This tool
lets you change the direction of a gradient and change its beginning point and end point. You’ll
now change the direction of the gradient.

Tip
When using the Gradient Swatch tool, the farther away you start from the outer edges of

the object, the more gradual the gradient blend will be.

1. Make sure the “Grow. Maintain. Rebloom.” text frame is still selected, and then press G on
the keyboard to select the Gradient Swatch tool ( ) in the Tools panel.
2. To create a more gradual gradient effect, position the cursor slightly outside the left edge of
the selected text frame, and drag to the right as shown.

Tip
To constrain gradient angles to horizontal, vertical, or 45-degree angles, press the
Shift key while dragging with the Gradient tool.

When you release the mouse button, you’ll notice that the transition between pink and
yellow is more gradual than it was before you dragged the Gradient Swatch tool.

3. To create a diagonal gradient, drag from the upper-left corner to the lower-right corner
using the Gradient Swatch tool. Continue to experiment with the Gradient Swatch tool so
that you understand how it works.

4. When you are finished experimenting, drag from the top to the bottom of the text frame to
form a gradient from top to bottom. That’s how you’ll leave the gradient for the “Grow.
Maintain. Rebloom.” text frame.

5. Press V on the keyboard to switch to the Selection tool (
to make sure no objects are selected.
6. Choose File > Save.

), and then click the pasteboard

Working with color groups
If a document contains many color swatches intended for specific purposes (such as chapter
openers or divider pages), you can group the swatches in the Swatches panel. You can then
easily share the color group with other documents and with other designers working on the
campaign.

Tip
As you design a document, you often create more color swatches than you use. When you
settle on a final design and color palette, you will want to delete any unused colors to
make sure they aren’t applied accidentally. To do this, choose Select All Unused from the
Swatches panel menu ( ). Click the Delete Selected Swatch/Groups button ( ) at the
bottom of the panel.

Adding colors to a color group
You will organize the colors in this document into a new color group.
1. To create a new color group, choose New Color Group from the Swatches panel menu (
).
2. In the New Color Group dialog box, type Orchid Clinic Ad. Click OK.

3. To add the color swatches, tint swatch, and gradient swatch to the Orchid Clinic Ad color
group, select and drag the colors to the group.

To select the swatches, Shift-click the first and last swatch. (You do not need to move
[None], [Registration], [Paper], or [Black] into the group.)
Drag the selected colors below the Orchid Clinic Ad folder until a line displays.

4. Choose File > Save.

Previewing the final document
As a final step, you’ll preview the document in its finished state.
1.
2.
3.
4.

Choose View > Screen Mode > Preview.
Choose View > Fit Page In Window.
Press Tab to hide all the panels and review the results of your work.
Press Tab again to restore your panels.

Congratulations! You have now completed this lesson.

Exploring on your own
Follow these steps to learn more about working with color themes.

Creating a color theme
To create colors that complement an image you are using in a document, you can use the
InDesign Color Theme tool. The tool analyzes an image or object, selects representative colors,
and generates five different themes. You can select and apply swatches from a color theme, add a
color theme’s swatches to the Swatches panel, and share the color themes through CC Libraries.
To use the Color Theme tool:
Click an image or object with the Color Theme tool to create a color theme from a small
area.
Drag the Color Theme tool to marquee images and/or objects on a page from which to
create a color theme.
Alt-click (Windows) or Option-click (macOS) the Color Theme tool to clear the existing
color theme and create a new one.

Viewing color themes
First, you will view the possible color themes from the orchid bud image. Then, you will select
the color theme you want to use.

Tip
To select the Color Theme tool from the keyboard, press Shift+i.

1. On the Tools panel, click the Eyedropper tool ( ). Hold down the mouse button to view
the pop-out menu, and then select the Color Theme tool ( ).
2. Locate the orchid bud image in the center of the page.
3. Click the Color Theme tool anywhere on the image.
Notice that the Color Theme panel displays with a color theme picked up from the image.
4. On the Color Theme panel, click the Current Theme menu. Select the Muted theme.

You can select and use any of the swatches shown here, but instead you will add the entire
color theme to the Swatches panel.

Adding a theme to the Swatches panel
You can add a single color from a color theme to the Swatches panel in addition to adding an
entire theme. To add a single swatch, select it on the Color Theme panel, and then Alt-click
(Windows) or Option-click (macOS) the Add To Swatches button.
The Muted color theme will work best for the ad in progress. First, you will add it to the
Swatches panel and then view it in the Adobe Color Themes panel, which helps you manage
your themes. Then, you will share this color theme with others in your workgroup who are
working on other pieces in the marketing campaign.
1. With the Muted theme selected on the Color Theme panel, click the Add This Theme To
Swatches button ( ).

2. If necessary, choose Window > Color > Swatches to open the Swatches panel.

Note
The CMYK color values in the Muted theme’s colors may vary slightly. This will
not affect your ability to explore these features.

3. Scroll down as necessary to see the Muted theme added to the Swatches panel as a color
group (organized in a folder).

4. Choose File > Save.

Adding a color theme to your CC Library
The InDesign Creative Cloud Libraries feature makes it easy to share assets, such as color
swatches and themes, with a workgroup. If multiple designers are working on a magazine or
marketing campaign, this ensures that everyone on the creative team has easy access to the same
content. Here, you will add the Muted color theme to your Creative Cloud library. For more
information about CC Libraries, see Lesson 10.

Note
To use the Creative Cloud Libraries features, make sure the Adobe Creative Cloud
application is running on your system.

1. On the Color Themes panel, with the Muted theme still showing, click the Add This Theme
To My Current CC Library button ( ).

2. If necessary, choose Window > CC Libraries to see the Muted theme added to your CC
Libraries panel.

3. Click the CC Libraries panel menu to see the collaboration options: Share Link and
Collaborate.
4. The Muted theme is added to the Adobe Color Themes panel as well. To see it, choose
Window > Color > Adobe Color Themes.

Note
If necessary, select a different library from the My Themes panel.

5. In the Adobe Color Themes panel, click the My Themes button, and then select My Library
from the library menu.

6. Choose Window > Color > Adobe Color Themes to close the panel.
7. Choose File > Save.

Managing color themes
InDesign users have many options for creating and managing color themes. These tools help
you synchronize colors across your applications and projects and collaborate with other

users.

The Adobe Capture CC app for iPad, iPhone, and Android lets you create color themes
from anything you point at with your device’s camera.
The Adobe Color CC website at https://color.adobe.com lets you create your own color
themes, explore other users’ themes, and review your themes.
The Adobe Color Themes panel (Window > Color > Adobe Color Themes) lets you
create and explore themes within InDesign and other Creative Cloud applications, such
as Photoshop CC and Illustrator CC.
The CC Libraries panel (Window > CC Libraries) allows you to share color themes
with a workgroup and manage color themes by copying, moving, or deleting them.
For more information about any of these features, consult InDesign Help.

Review questions
1 What is the advantage of creating colors in the Swatches panel instead of the Color panel?
2 What are the three general steps involved in applying a swatch of color?
3 What are the pros and cons of using spot colors versus process colors?
4 After you create a gradient and apply it to an object, how do you adjust the direction of the
gradient blend?

Review answers

1 If you use the Swatches panel to apply a color to text and objects, and then decide you want to
use a different color, you don’t need to update each use of the color individually. Instead,
change the color’s definition in the Swatches panel, and the color changes automatically
throughout the layout.
2 The three general steps to applying a color swatch are: (1) selecting the text or object, (2)
selecting the stroke or fill box, depending on what you want to change, and (3) selecting the
color. You can access color swatches in various panels, including Swatches, Control,
Properties, and Tools.
3 By using a spot color, you can ensure color accuracy. However, each spot color requires its
own plate on the press, so using spot colors can be more costly. Use process colors when a job
requires so many colors that using individual spot inks would be expensive or impractical,
such as when printing color photographs.
4 To adjust the direction of the gradient blend, use the Gradient Swatch tool to repaint the fill
along an imaginary line in the direction you want.

9 Working with Styles

Lesson overview
In this lesson, you’ll learn how to do the following:
Create and apply paragraph styles.
Create and apply character styles.
Nest character styles inside paragraph styles.
Create and apply object styles.
Create and apply cell styles.
Create and apply table styles.
Globally update paragraph, character, object, cell, and table styles.
Import and apply styles from other InDesign documents.
Create style groups.

This lesson will take about 60 minutes to complete. Please log in to your account on
peachpit.com to download the files for this lesson, or go to the “Getting Started” section at the
beginning of this book and follow the instructions under “Accessing the Lesson Files and Web
Edition.” Store the files on your computer in a convenient location. Your Account page is also
where you’ll find any updates to the lessons or the lesson files. Look on the Lesson & Update
Files tab to access the most current content.

With Adobe InDesign CC, you can create styles—sets of formatting attributes—and apply them in one step to text, objects,
tables, and more. Any changes to a style automatically affect all the text or objects to which the style is applied. Styles offer a
quick, consistent method for formatting layouts.

Getting started
In this lesson, you’ll create and apply styles for a few pages of a catalog for the Urban Oasis
Gardens. Styles are collections of attributes that allow you to quickly and consistently apply
formatting to text and objects throughout a document. (For example, a Body Text paragraph style
specifies attributes such as font, size, leading, and alignment.) The catalog pages here contain
text, tables, and objects that you will manually format and then use as the basis for creating
styles. Later, if you were to place more catalog content, you could format the new text, tables,
and objects with one click using styles.

Note
If you have not already downloaded the project files for this lesson to your computer
from your Account page, make sure to do so now. See “Getting Started” at the beginning
of the book.

1. To ensure that the preferences and default settings of your InDesign program match those
used in this lesson, move the InDesign Defaults file to a different folder following the
procedure in “Saving and restoring the InDesign Defaults file” on pages 4–5.
2. Start InDesign.
3. The InDesign Start Screen displays. Click Open at left. (If the Start Screen does not
display, choose File > Open from the InDesign menu bar.)
4. Open the 09_Start.indd file in the Lesson09 folder, located inside the Lessons folder within
the InDesignCIB folder on your hard disk.
5. Choose File > Save As, rename the file 09_Styles.indd, and save it in the Lesson09 folder.
Scroll to view all the pages.

Note
The screen captures in this book show the Medium Light interface. Interface
elements such as panels and dialog boxes may be darker on your screen.

6. To display the document at a higher resolution, choose View > Display Performance >
High Quality Display.
7. Confirm that Window > Workspace > Essentials is selected.
8. If you want to see what the finished document will look like, open the 09_End.indd file in
the same folder. You can leave this document open to act as a guide as you work.

When you’re ready to resume working on the lesson document, click its tab in the upper-left
corner of the document window.

Tip
On all the styles panels (Paragraph, Object, etc.), the panel menu provides a Load option
for importing styles from other InDesign documents. You can also share paragraph styles

and character styles with a workgroup through InDesign CC Libraries.

Understanding styles
InDesign provides styles for automating nearly all text and object formatting. Creating,
applying, modifying, and sharing styles works the same way for all types of styles:
paragraph, character, object, table, and cell styles.
Basic styles

The default formatting of everything in a new InDesign document is determined by its
respective “basic” style. For example, when you create a new text frame, its formatting is
determined by the [Basic Text Frame] object style. Therefore, if you wanted to specify that
all new text frames have a 1-pt stroke, you would modify [Basic Text Frame]. To create a
new default for all new InDesign documents, modify the “basic” style when no documents
are open. Whenever you find yourself repeating a formatting task, stop and think about
whether it makes sense to modify the relevant basic style or create a new style.
Applying styles
Applying a style is as simple as making a selection and then clicking a style name in the
relevant Styles panel. For example, to format a table, you select the table and then click a
style name in the Table Styles panel. If you are working with an extended keyboard, you
can set up keyboard shortcuts for applying styles as well.
Overriding manual formatting with styles
In most cases, you will want an object, a table, or some text to match a style’s specifications precisely. To do this, you need to override any manual formatting. If a selection
does not precisely match its style, a plus sign appears next to the style name. This is referred
to as a style override. For example, if a paragraph style specifies left-aligned paragraphs but
you center a paragraph, the centering is a style override.
To see how the formatting varies from the style, point at the style name in the Styles panel;
a tool tip describes the overrides applied. (To see text formatting overrides, you can choose
Toggle Style Override Highlighter from the Character Styles or Paragraph Styles panel
menu.) Each Styles panel has a Clear Overrides control at the bottom, indicated by an icon
and a plus sign. Move your mouse over the icon to learn how to clear overrides in the

selection. (Note that if you are having trouble clearing overrides while applying a paragraph
style, check to see whether a character style is applied to the text.)
Modifying and redefining styles
A primary benefit of using styles is the ability to apply formatting consistently and quickly
make global changes. To modify a style, double-click its name in its respective Styles panel;
this displays its Options dialog box so that you can make changes. You can also modify the
formatting of text, a table, or an object with a style applied, and then choose Redefine Style
from the respective Styles panel menu.

Note
Keyboard shortcuts are especially handy for formatting text. A quick way to remember
shortcuts is to include a hierarchical number in the style name. For example, if you create
a paragraph style named “1 Headline” with the shortcut Ctrl+1, it’s easy to remember the
shortcut because it’s often the first style you apply.

Creating and applying paragraph styles
Paragraph styles let you apply and globally update text formatting to speed up production and
create a more consistent overall design. Paragraph styles incorporate all elements of text
formatting, including character attributes such as font, size, style, and color, along with
paragraph attributes such as indents, alignment, tabs, and hyphenation. They differ from
character styles in that they are applied to entire paragraphs at once, not just to selected
characters.

Tip
When working on longer documents, such as books and catalogs, using styles can save
hours of time in manual formatting. A common way to get started is to select all the text
in a document and apply a “body text” paragraph style with one click. You can then go
through the text and apply heading paragraph styles and character styles with keyboard
shortcuts.

Creating a paragraph style
In this exercise, you’ll create and apply a paragraph style to selected paragraphs. First, you will
manually format the text in the document locally (that is, not based on a style). Then, you will
have InDesign pick up this formatting and build it into a new paragraph style.
1. Navigate to page 2 in the 09_Styles.indd document. Adjust the view scale so you can easily

see the text.
2. Using the Type tool ( ), drag to select the “Heirloom Vegetable Seeds” subhead, which
follows the introductory paragraph on page 2.

Tip
The easiest way to create a paragraph style is to format a sample paragraph using
local (not style-based) formatting and then create a new style based on that sample
paragraph. Effectively, this lets you see the style before you build it. You can then
efficiently use the new style in the rest of the document.

3. In the Appearance area of the Properties panel at right, click the character Fill box ( ) and
click the Red-Tomato swatch.

4. In the Character area, enter 18 pt in the Font Size field.
5. In the Paragraph area of the Properties panel, click the More ( ) button. Increase the Space
Before ( ) to .05 in and decrease the Space After ( ) to .025 in.
Now you’ll create a paragraph style using this formatting so that you can use it to format the
other subheads in the document.

Note
In this document, the Paragraph Styles panel already has a few styles provided for
you, including the default, [Basic Paragraph].

6. Make sure that the “Heirloom Vegetable Seeds” subhead is still selected. If it’s not already
visible, open the Paragraph Styles panel by choosing Type > Paragraph Styles.
7. In the Paragraph Styles panel, create a new paragraph style by choosing New Paragraph
Style from the panel menu. The New Paragraph Style dialog box opens, displaying the
formatting you just applied to the subhead in the Style Settings section.

8. In the Style Name box at the top of the dialog box, type Head 2 to name this style as the
second largest headline.

Tip
If you change the Based On style—for example, by changing the font—the changes
update all styles based on that style. Unique characteristics of styles based on other
styles are maintained. Basing styles on other styles is helpful when creating a series
of related styles, such as Body Copy, Bulleted Body Copy, and so on. If the font of
the Body Copy style changes, InDesign updates the font in all related styles as well.

Below the Style Name, notice that the new style is based on the Intro Body style. Since
Intro Body was applied to the subhead when you created the style, the new style is
automatically based on Intro Body. By using the Based On option in the General section of
the New Paragraph Style dialog box, you can use an existing style as a starting point for a
new style. In this case, the Intro Body formatting is unrelated to the heading style, so you
will change the Based On style to No Style.
9. Select [No Paragraph Style] from the Based On menu.
To speed up text formatting while typing in InDesign, you can specify a Next Style for a
paragraph style. Each time you press Enter or Return, InDesign automatically applies the
Next Style. For example, your headline style might automatically be followed by your body
paragraph style.

10. Select Intro Body from the Next Style menu, because this is the style used for the text
following each Head 2 headline.
You can also create keyboard shortcuts for easily applying styles in InDesign.

Note
If your keyboard lacks a numeric keypad, you can skip this step.

11. Click in the Shortcut box, hold down Shift (Windows) or Command (macOS), and press 9
on the numeric keypad of your keyboard. (InDesign requires the use of a modifier key for
style shortcuts.) Note that in Windows the Num Lock key on the keypad must be down to
create or apply style shortcuts.

Tip
If you don’t select Apply Style To Selection, the new style appears in your
Paragraph Styles panel, but it is not automatically applied to the selected text you
used to create the style.

12. Select Apply Style To Selection to apply this new style to the text you just formatted.

13. In the lower-left corner, deselect Add To CC Library.
14. Click OK to close the New Paragraph Style dialog box.
The new Head 2 style appears in the Paragraph Styles panel and is highlighted to indicate
that it’s applied to the selected paragraph.
15. In the Paragraph Styles panel, click the arrow next to the Heads style group to open it.
Then, drag the Head 2 style up between Head 1 and Head 3.
16. Choose Edit > Deselect All, and then choose File > Save.

Applying a paragraph style
Now you’ll apply your paragraph style to other paragraphs in the document.
1. If necessary, scroll to the right to see the right page of the spread.
2. Using the Type tool ( ), click to place an insertion point anywhere within “Fruits &
Flowers.”

Note
You can use the keyboard shortcut you defined earlier (Shift+9 or Command+9) to
apply the Head 2 style as well. To apply styles in Windows, be sure the Num Lock
key on the keypad is down.

3. Click the Head 2 style in the Paragraph Styles panel to apply the style to the paragraph. The
text attributes change to reflect the paragraph style.
4. Repeat steps 2 and 3 to apply the Head 2 style to “Tools & Accessories” on page 3.

5. Choose Edit > Deselect All, and then choose File > Save.

Creating and applying character styles
In the previous exercise, paragraph styles allowed you to apply character and paragraph
formatting to text with a single click or a keystroke. Similarly, character styles are a way to apply
multiple attributes—such as font, size, and color—to text using a single action. Unlike paragraph
styles, which format the entire paragraph, character styles apply formatting only to selected
characters such as a word or phrase.

Tip
Character styles are helpful for lead-in characters such as bullet characters, numbers in
numbered lists, and drop caps. They are also useful for emphasizing text within body
copy—for example, the names of stocks (investments) are often formatted in bold and
small caps.

Character styles include only differences, such as italic, from the attributes specified in the
paragraph style. The benefit of this is that you can use the same character style with different
paragraph styles. For example, say that a newsletter’s style is to italicize the names of books and
movies. The newsletter has a body text style in Minion Pro and a sidebar body text style in
Myriad Pro. You need only one character style that specifies Italic for use with both paragraph
styles. InDesign will know to use the italic version of the correct font.

Creating a character style
Now you will create and apply a character style to selected text in the document. This
demonstrates how character styles can make your work more efficient and consistent.
1. Scroll to view the first paragraph on page 2 at left.
2. If it’s not already visible, open the Character Styles panel by choosing Type > Character
Styles. The only style listed in this panel is the default, [None].
As you did with the paragraph style in the previous section, you’ll build a character style
based on existing text formatting. This approach lets you see the formatting before you
create the style. In this case, you’ll format the Urban Oasis Gardens name and build it into a
character style so that it can be reused efficiently throughout the document.
3. Using the Type tool ( ), select the words “Urban Oasis Gardens” on page 2.
4. In the Appearance area of the Properties panel at right, click the character Fill box ( ) and
click the Green-Medium swatch.
5. In the Character area of the Properties, click the More Options button (the three dots) and
then click Small Caps ( ).

Now that the text is formatted, you’ll create a new character style.
6. Click Create New Style at the bottom of the Character Styles panel.
7. Double-click the new Character Style 1 that displays in the Character Styles panel. The
Character Style Options dialog box opens.

8. In the Style Name box at the top of the dialog box, type Garden Name to define the style’s
purpose.
As you did for the paragraph style you created, now you’ll create a keyboard shortcut for
easy application of this character style.

Note
If your keyboard lacks a numeric keypad, you can skip this step.

9. Click in the Shortcut box, hold down Shift (Windows) or Command (macOS), and press 8
on the numeric keypad of your keyboard. In Windows, be sure that the Num Lock key on
the keypad is down.

10. Notice the character style formatting listed in the Style Settings box.
11. Click OK to close the Character Style Options dialog box. The new Garden Name style
appears in the Character Styles panel and is now applied to the text.
12. Choose Edit > Deselect All, and then choose File > Save.

Applying a character style
You’re ready to apply your character style to selected text already placed in the document. As
with paragraph styles, using character styles prevents you from having to manually apply
multiple type attributes to each instance of text.

Tip
You can use Find/Change (Edit menu) to search for all instances of a word or phrase, and
then apply a character style to it.

1. Scroll to the right to view the right page of the first spread.

To maintain a consistent look for the company name, you’ll apply the Garden Name
character style.
2. Using the Type tool (
body text.

), select the words “Urban Oasis Gardens” in the first paragraph of

Note
You can also use the keyboard shortcut you defined earlier (Shift+8 or Command+8)
to apply the Garden Name style.

3. In the Character Styles panel, click the Garden Name style to apply it to this text. You
should see the text change to reflect the character style you created.
4. Using either the Character Styles panel or the keyboard shortcut, apply the Garden Name
style to the words “Urban Oasis Gardens” in the second body paragraph as well.

Leave the Character Styles panel open for the next exercise.
5. Choose Edit > Deselect All, and then choose File > Save.

Applying styles with Quick Apply

A quick way to apply styles without lifting your hands from the keyboard is by using Quick
Apply. To use it, press Ctrl+Enter (Windows) or Command+Return (macOS). In the Quick
Apply dialog box, start typing the name of the style until it’s recognized. Use the arrow

keys to select it in the list, and then press Enter (Windows) or Return (macOS).
To display the Quick Apply dialog box, you can also choose Edit > Quick Apply or click
the Quick Apply ( ) button on the Control panel.

Nesting character styles inside paragraph styles
To make the use of styles more convenient and powerful, InDesign lets you nest character styles
within paragraph styles. These nested styles allow you to apply distinct character formatting to
specific portions of a paragraph—such as the first character, the second word, or the first line—
at the same time you apply a paragraph style. This makes nested styles ideal for creating run-in
headings, where the first portion of a line or paragraph is styled differently from the rest of the
line or paragraph. In fact, anytime you can define a pattern of formatting within a paragraph,
such as applying an italic type style until reaching the first period, you can probably automate the
formatting with a nested style.

Tip
You can use the powerful nested styles feature to automatically apply different formatting
within a paragraph according to a specific set of rules. For example, in a table of
contents, you can automatically apply bold to the text, change the tracking in the tab
leader (the dots that lead to the page number), and change the font and color of the page
number.

Creating character styles for nesting
To create a nested style, you need to first create both a character style and a paragraph style in
which to nest it. In this section, you’ll create two character styles for nesting and then nest them
within the paragraph style Catalog Body, which already exists.
1. Double-click page 4 in the Pages panel, and then choose View > Fit Page In Window. If the
body copy is too small to view, zoom in to the first paragraph under the “Beans” heading,
beginning with “Green: Black Valentine.”
2. Review the text and punctuation:
In this exercise, you’ll create two nested styles to distinguish the vegetable’s variety
from its name.
A colon (:) separates the vegetable’s variety and name.
A period appears after the name and before the description.
These characters will be important when creating your nested styles later in this
section.
3. Using the Type tool (

), select the first instance of “Green” and the colon following it.

4. In the Character Styles panel, choose New Character Style from the panel menu.
5. In the Style Name box at the top of the dialog box, type Variety to define the text to which
the style will be applied.
To make the name of each vegetable variety stand out more, you will change the font, style,
and color.
6. From the categories on the left side of the dialog box, click Basic Character Formats.
7. From the Font Family menu, select Myriad Pro. From the Font Style menu, select Bold.

8. From the categories on the left side of the dialog box, click Character Color.
9. In the Character Color settings that appear on the right side of the dialog box, select the
Green-Medium swatch.

10. In the lower-left corner, deselect Add To CC Library if necessary.
11. Click OK to close the New Character Style dialog box. The new Variety style appears in
the Character Styles panel.
Now you’ll create a second character style for nesting.
12. To the right of the “Green:” text you just formatted, select the text “Black Valentine” and
the period after it. Using the Character panel (Type menu) or the Control panel, change the
Font to Myriad Pro and the Style to Italic.

13. With “Black Valentine.” still selected, choose New Character Style from the Character
Styles panel menu. Type Vegetable Name in the Style Name box. Click OK to create the
character style based on the formatting applied in step 12.
14. Choose Edit > Deselect All, and then choose File > Save.
You have created two new character styles. Using these along with the existing Catalog
Body paragraph style, you are ready to create and apply your nested style.

Creating a nested style
When you create a nested style within an existing paragraph style, you’re basically specifying a
secondary set of rules for InDesign to follow while formatting a paragraph. In this exercise,
you’ll build a nested style into the Catalog Body style using the character styles you created in
the previous exercise.

Tip
In addition to nested styles, InDesign provides nested line styles. These let you specify
formatting for individual lines in a paragraph—such as a drop cap followed by small
caps, which are common in the lead paragraphs of magazine articles. If the text reflows,
InDesign adjusts the formatting to encompass only the specified lines. The controls for
creating nested line styles are in the Drop Caps And Nested Styles panel of the Paragraph
Style Options dialog box.

1. If necessary, position page 4 in the center of the document window.
2. If the Paragraph Styles panel is not visible, choose Type > Paragraph Styles.
3. In the Paragraph Styles panel, double-click the Catalog Body style to open the Paragraph
Style Options dialog box.
4. From the categories on the left side of the dialog box, select Drop Caps And Nested Styles.
5. In the Nested Styles section, click the New Nested Style button to create a new nested style.

A nested style that applies the [None] character style through 1 Words appears.
6. Click the [None] style to display a menu. Select the Variety character style; this is the first
nested style in the sequence.
7. Click the word “through” to reveal another menu. This menu contains only two choices:
Through and Up To. The Variety character style needs to be applied through the first colon
(:) after Green, so select Through.

Tip
Using nested styles can automate some very tedious formatting. When making style
decisions for longer documents, think about establishing a pattern that will enable
automatic formatting through nested styles.

8. Click Words to reveal a text box and menu. Click the menu button to the right of the box to
view elements to which the style can be applied, including sentences, characters, and
spaces. Click in the field and delete “Words”; then type a colon (:) in the box.

9. In the lower-left corner, select Preview. Move the Paragraph Style Options dialog box so
that you can see the columns of text.
Now you’ll add another nested style to format the vegetable names.
10. Click the New Nested Style button.
11. Repeat steps 6 through 8 to set up an additional nested style with the following formatting:
First option: Choose Vegetable Name.
Second option: Choose Up To.
Third option: Leave as the default, 1.
Fourth option: Select Sentences to apply the formatting up to a period.

12. Review the changes in the text, and then click OK.

13. Choose Edit > Deselect All, and then choose File > Save.

Creating and applying object styles
Object styles let you apply and globally update formatting to objects, such as frames. Combining
formatting attributes—including fill, stroke, transparency, and text wrap options—into object
styles helps create a more consistent overall design and speeds up tedious production tasks.

Tip

All of the InDesign Styles panels (Character, Object, Table, and so on) let you group
similar styles in folders called style groups. To create a style group, click the Create New
Style Group button at the bottom of the panel. Click in the group’s folder to name it. You
can drag styles into the folder to organize them, and you can drag styles up and down in
the list to organize them.

Formatting an object for a style
In this section, you will create an object style that quickly applies a drop shadow to objects. In
this case, the headlines are actually objects created by selecting text and choosing Type > Create
Outlines. With outlines, you no longer need the font active on your system and you have more
flexibility, such as importing images into the shape.
Double-click page 1 in the Pages panel to center the page in the document window.
Using the Selection tool ( ), click “Urban Oasis Gardens” to select the text-shaped object.
Choose Object > Effects > Drop Shadow.
Select Drop Shadow in the Transparency list at left. Leave the other options at their default
settings.
5. Select Preview to see the changes, and click OK.
1.
2.
3.
4.

6. Choose Edit > Deselect All to see the effect, and choose File > Save.

Creating an object style
Now that the object is formatted properly, you are ready to create the object style from its
formatting.

Tip
Just as with paragraph and character styles, you can base an object style on another object
style. Changes made to the Based On style update all object styles based on that style.
(Unique characteristics of styles based on other styles are maintained.) The controls for
basing a style on another are in the General panel of the New Object Style dialog box.

1. Using the Selection tool ( ), click “Urban Oasis Gardens” with the drop shadow effect.
2. Choose Window > Styles > Object Styles to open the Object Styles panel.
3. In the Object Styles panel, hold down the Alt (Windows) or Option (macOS) key while you
click Create New Style in the lower-right corner.
When you Alt-click or Option-click the Create New Style button, the New Object Style
dialog box opens automatically. The selected boxes on the left side of this dialog box
indicate which attributes will be applied when this style is used.

4. In the Style Name box at the top of the New Object Style dialog box, type Drop Shadow to
describe the purpose of the style.

Note
Click through the options you can set for an object style in the list at left. In addition
to formatting attributes, object styles can include size (Width, Height) and
placement (X, Y) attributes.

5. Select Apply Style To Selection, and click OK.

Applying an object style
Now you’ll apply your new object style to the headline on the back page of the catalog.
Remember, the advantage to using styles is that when you modify a style, the text, table, or
objects to which the style is applied will update automatically. If you have a specific instance of
text, a table, or an object that you do not want to update, you can break its link to the style. Each
styles panel (Paragraph Styles, Cell Styles, and so on) has a Break Link To Style command in the
panel menu.

Tip
Once you have even a rough idea of how you want text, objects, and tables to look, you
can start creating styles and applying them. Then, as you experiment with a design and
make changes, you can simply update the style definitions using the Redefine Style
option, which automatically updates the formatting of anything to which the style is
applied. The panel menus for all of the InDesign Styles panels, such as Paragraph Styles
and Table Styles, provide the Redefine Style option.

1. Double-click the page 6 icon on the Pages panel to display the last page in the document
window.

2. If necessary, choose View > Fit Page In Window.
3. Using the Selection tool ( ), select the “How to Grow” text-shaped object.
As with the previous headline, this text has been converted to curves using Type > Create
Outlines.
4. Click Drop Shadow on the Object Styles panel.
5. If the formatting does not match the new style, choose Clear Overrides from the Object
Styles panel menu.

6. Choose Edit > Deselect All, and then choose File > Save.

Creating and applying table and cell styles
Table and cell styles let you format tables with the same convenience and consistency you get
from styling text with paragraph and character styles. Table styles let you control the visual
attributes of the table, including the table border, space before and after the table, row and
column strokes, and alternating fill patterns. Cell styles let you control cell inset spacing, vertical
justification, individual cell strokes and fills, and diagonal lines. You’ll learn more about creating
tables in Lesson 11, “Creating Tables.”
In this exercise, you’ll create and apply a table style and two cell styles to tables in the catalog
document to help distinguish the different descriptions of plants.

Creating cell styles
You’ll begin by creating a cell style for the header row of the table at the bottom of page 3.
Later, you’ll nest this style inside the table style, a process similar to how you nested character
styles inside a paragraph style earlier in this lesson. You’ll now create a cell style.
1. Double-click page 3 in the Pages panel.
2. Using the Zoom tool ( ), zoom in on the table at the bottom of the page to make it easily
visible.
3. Using the Type tool ( ), hover the pointer to the left of the first row of the table until the
pointer becomes a right-facing arrow. Click to select the entire first row.

4. Choose Table > Cell Options > Strokes And Fills. For Cell Fill, select the Green-Brightest
swatch. Click OK.

5. With the cells still selected, open the Cell Styles panel by choosing Window > Styles > Cell
Styles.

Tip
You can create new styles from any InDesign Styles panel (Character, Object,

Table, and so on) by choosing New Style from the panel menu or by clicking the
Create New Style button at the bottom of the panel.

6. From the Cell Styles panel menu, choose New Cell Style.

The cell formatting you applied to the selected cells is displayed in the Style Settings box.
You’ll also notice additional cell formatting options on the left side of the dialog box. In
this exercise, however, you will only set the desired paragraph style to use for the text
within the header row.
7. In the Style Name box at the top of the New Cell Style dialog box, type Table Head.
8. From the Paragraph Style pop-up menu, choose Head 4. This paragraph style was already
created in the document. Click OK.

The new cell style appears in the Cell Styles panel.

9. With the header row still selected, click Table Head in the Cell Styles panel to apply it.
10. If a plus sign (+) displays next to the Table Head style (indicating that the formatting does
not exactly match the style), choose Clear Overrides from the Cell Styles panel menu.
11. Choose Edit > Deselect All, and then choose File > Save.

Creating a table style
Now you’ll create a table style that formats the overall look of the table and applies the cell style
you just created to the header row.
1. Choose Window > Styles > Table Styles. From the Table Styles panel menu, choose New
Table Style.

2. In the Style Name box, type Garden Table.
3. In the Cell Styles section, select Table Head from the Header Rows menu.

You’ll now set up the table style to apply alternating rows of color to the body rows.
4. Select the Fills category on the left side of the New Table Style dialog box.
5. Choose Every Other Row from the Alternating Pattern pop-up menu. The options for
alternating rows appear.
6. Specify the following Alternating options in the list at left:
First Rows: 1
Color: Paper
7. Specify the following Alternating options in the list at right:
Next Rows: 1
Color: Green-Brightest
Tint: 30%

8. Click OK. The new table style, Garden Table, appears in the Table Styles panel.

9. Choose Edit > Deselect All, and then choose File > Save.

Applying a table style
Now you’ll apply the table style you just created to the two tables in the document.

Tip
If you create a table from existing text (using Table > Convert Text To Table), you can
apply a table style as you convert the text.

1. With the table still easily visible onscreen, select the Type tool ( ). Click to place an
insertion point anywhere in the table, and select Table > Select > Table.
2. In the Table Styles panel, click the Garden Table style. The table is reformatted with the
table and cell styles you created.

3. Double-click page 6 in the Pages panel, and then choose View > Fit Page In Window. Click
to place an insertion point anywhere in the “Drop-In Gardening Clinics” table, and then
select Table > Select > Table.
4. In the Table Styles panel, click the Garden Table style. The table is reformatted with the
table and cell styles you created.

5. Choose Edit > Deselect All, and then choose File > Save.

Globally updating styles
InDesign features two ways to update paragraph, character, object, table, and cell styles. The first
way is to open a style options dialog box and make changes to the formatting options. The other
way to update a style is to use local formatting to modify some formatting and then redefine the
style based on the updated formatting. In either case, formatting is updated wherever the style is
applied.
In this exercise, you’ll make a change to the Head 3 style to include a paragraph rule below it.
1. Double-click page 4 in the Pages panel, and then choose View > Fit Page In Window.
2. Using the Type tool ( ), drag to select the “Beans” subhead at the top of the first column.
3. Choose Type > Paragraph to display the Paragraph panel. Choose Paragraph Rules from the
panel menu.

4. In the Paragraph Rules dialog box, choose Rule Below from the menu at the top of the
dialog box, and select Rule On. Make sure that Preview is selected, and move the dialog
box so you can see “Beans” on your screen.
5. Format the rule using the following settings:
Weight: 1 pt
Color: Red-Tomato
Offset: .025 in
Leave all other settings at their defaults.

6. Click OK. A thin red line now appears below “Beans.”
7. If it’s not already visible, choose Type > Paragraph Styles to view the Paragraph Styles
panel.
In the Paragraph Styles panel, notice that the Head 3 style is selected, indicating that it is
applied to the selected text. You will also see a plus sign (+) next to the Head 3 style name.
This indicates that the selected text has local formatting applied to it, which is overriding
the applied style.

Now you’ll redefine the paragraph style so that the local changes are incorporated in the
paragraph style definition and automatically applied to all the headlines previously
formatted with the Head 3 style.

Note
You can use the process in steps 7–8 to redefine any type of style based on local
formatting.

8. In the Paragraph Styles panel menu, choose Redefine Style. The + should no longer appear
next to the Head 3 style name. All headlines in the document that have been styled with
Head 3 should globally update to reflect the changes you made.

9. Choose Edit > Deselect All, and then choose File > Save.

Loading styles from another document
Styles are available in the document in which you create them. However, it’s easy to share styles
between InDesign documents by loading (importing) styles from other InDesign documents. In
this exercise, you’ll import a paragraph style and character style from the finished document
09_End.indd and apply the style to the first body paragraph on page 2.

Tip
In addition to loading styles from another document, you can share paragraph and
character styles among multiple documents through CC Libraries. To do this, select a
style in the Paragraph Styles panel and click the Add Selected Style To My Current CC
Library button at the bottom of the panel. To use this style in another document, apply it
from the CC Library. It is then automatically added to the document’s Paragraph Styles

panel.

1. Double-click page 2 in the Pages panel, and then choose View > Fit Page In Window.
2. If it’s not already visible, choose Type > Paragraph Styles to view the Paragraph Styles
panel.
3. Choose Load All Text Styles from the Paragraph Styles panel menu.
4. In the Open A File dialog box, double-click 09_End.indd, in the Lesson09 folder. The Load
Styles dialog box displays.
5. Click Uncheck All; you do not need to import all the styles because most already exist in
this document.
6. Select the box to the left of the Drop Cap Body paragraph style. Scroll down and note that
the character style that Drop Cap Body uses (Drop Cap) is automatically selected.

Because the selected paragraph style uses the Drop Caps And Nested Style feature to
automatically apply the Drop Cap character style, this style is also selected.
7. Click OK to import the two styles.
8. Using the Type tool ( ), place an insertion point in the third body paragraph, which starts
with “Look for your tried-and-true favorites.”
9. Click the new Drop Cap Body style in the Paragraph Styles panel.
The initial “L” in “Look” should become a khaki drop cap in Myriad Pro Italic.

10. Choose Edit > Deselect All, and then choose File > Save.

Finishing up
As a final step, you’ll preview the document in its finished state.
1. At the bottom of the Tools panel, select Preview.
2. Choose View > Fit Page In Window.
3. Press Tab to hide all of the panels and review the results of your work.
Congratulations! You have now completed this lesson.

Exploring on your own
When you’re creating a long document or a template to use as the basis for other documents, you
want to take full advantage of all features related to styles. To fine-tune the styles further, try the
following:
Rearrange styles in the Paragraph Styles panel. For example, drag the new Drop Cap Body
style into the Body Text group.
Experiment with modifying the formatting of styles, including object, table, character, and
paragraph styles. For example, change the font in a paragraph style or change the
background color of a table style.

Create additional character styles that change only one attribute of formatting—such as
creating a character style that applies only a different color.
Add keyboard shortcuts to the existing styles.

Review questions
1 How can using object styles speed up your workflow?
2 What must you create before you can create a nested style?
3 What are the two ways to globally update a style you’ve applied in an InDesign document?
4 How would you import styles from another InDesign document?

Review answers
1 Object styles save time by allowing you to group formatting attributes and quickly apply them
to frames and lines. If you need to update the formatting, you don’t have to change each object
formatted with the style individually. Instead, you can simply modify the object style to
automatically update all the objects to which it is applied.
2 The two prerequisites for creating a nested style are (1) that you have first created a character
style and (2) that you have built a paragraph style in which to nest it.
3 InDesign offers two ways to update styles. The first is to edit the style itself by making changes
to the formatting options. The other is to use local formatting to change an instance and then
redefine the style based on that instance.
4 From any Styles panel (Paragraph, Object, Cell, etc.), choose Load Styles from the panel
menu. Locate the InDesign document from which you want to load the styles. The styles are
then loaded into the respective panels and are immediately available for use in your document.

10 Importing and Modifying Graphics

Lesson overview
In this lesson, you’ll learn how to do the following:
Distinguish between vector and bitmap graphics.
Manage imported graphic files using the Links panel.
Adjust the display quality of graphics.
Import Adobe Photoshop and Adobe Illustrator graphics using different techniques.
Use various sizing and fitting techniques.
Work with different types of dropped backgrounds.
Adjust the appearance of graphics by manipulating paths and layers.
Create an anchored graphics frame that flows with text.
Create and use libraries of objects.

This lesson will take about 75 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this chapter, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the Lesson
Files and Web Edition.” Store the files on your computer in a convenient location. Your
Account page is also where you’ll find any updates to the lessons or the lesson files. Look on
the Lesson & Update Files tab to access the most current content.

Adobe InDesign CC makes it easy to enhance your document with photographs and artwork imported from Adobe Photoshop,
Adobe Illustrator, and other graphics applications. If these imported graphics change, InDesign can notify you that a newer
version of a graphic is available. You can update or replace imported graphics at any time.

Getting started
In this lesson, you’ll work on a three-panel folding brochure for a CD by importing,
manipulating, and managing graphics from Adobe Photoshop and Adobe Illustrator. The insert is
designed so that after printing and folding, it fits into a CD case.
This lesson includes steps that you can perform using Photoshop if you have it installed on your
computer.

Note
If you have not already downloaded the project files for this lesson to your computer
from your Account page, make sure to do so now. See “Getting Started” at the beginning
of the book.

1. To ensure that the preferences and default settings of your InDesign program match those
used in this lesson, move the InDesign Defaults file to a different folder following the
procedure in “Saving and restoring the InDesign Defaults file” on pages 4–5.
2. Start Adobe InDesign. To ensure that the panels and menu commands match those used in
this lesson, choose Window > Workspace > [Advanced], and then choose Window >
Workspace > Reset Advanced.
3. Choose File > Open, and open the 10_Start.indd file in the Lesson10 folder, located inside
the Lessons folder within the InDesignCIB folder on your hard drive. A message appears
saying that the document contains links to sources that have been modified.
4. Click Don’t Update Links. You will fix the modified links later in the lesson.
5. If necessary, close the Links panel so that it doesn’t obscure your view of the document.
The Links panel opens automatically whenever you open an InDesign document that
contains missing or modified links.

6. To see what the finished document looks like, open the 10_End.indd file in the same folder.
If you prefer, you can leave the document open as you work to act as a guide. If you leave
it open, choose 10_Start.indd from the Window menu or click the 10_Start.indd document
tab to return to that document.

Note
As you work through the lesson, move panels around or change the magnification to
a level that works best for you. For more information, see “Changing the
magnification of a document” in Lesson 1, “Introducing the Workspace.”

7. Choose File > Save As, rename the file 10_cdinsert.indd, and save it in the Lesson10
folder.

Adding graphics from other programs
InDesign supports many common graphic file formats. While this means that you can use
graphics that were created using a wide range of applications, InDesign works best with other
Adobe professional graphics applications, such as Photoshop, Illustrator, and Acrobat.
By default, imported graphics are linked to an InDesign document, which means that InDesign
displays a preview of the graphic file in your layout without actually copying the entire graphic
file into the InDesign file.
There are three major advantages to linking graphic files. First, it reduces the size of InDesign
files because they don’t need to include embedded image data. Second, it saves disk space, and
third, you can edit a linked graphic in the application you used to create it and then simply
update the link in the InDesign Links panel. Updating a linked file that has been modified
maintains the current location and settings for the graphic file and replaces the preview image in
InDesign with the updated graphic.
All linked graphics and text files are listed in the Links panel (Window > Links), which provides

buttons and commands for managing links. When you print an InDesign document or export a
document as an Adobe Portable Document Format (PDF) file, InDesign uses the links to produce
the highest level of quality available from the original, externally stored versions of the placed
graphics.

Comparing vector and bitmap graphics
The drawing tools of Adobe InDesign and Adobe Illustrator create vector graphics, which are
made up of shapes based on mathematical expressions, like plotting points on a graph. Vector
graphics consist of smooth lines that retain their clarity when resized. They are appropriate for
illustrations, type, and graphics such as logos, all of which are typically scaled to different sizes.
Vector graphics can be scaled to any size with no loss of quality.
Bitmap images, or raster graphics, are made up of a grid of pixels and are typically created with
digital cameras and scanners and then modified using an image-editing application, such as
Adobe Photoshop. In working with bitmap images, you edit pixels rather than objects or shapes.
Raster graphics are appropriate for continuous-tone images, such as photographs and artwork
created in painting applications. A disadvantage of raster graphics is that they lose definition and
appear “jagged” when enlarged. Additionally, bitmap images are typically larger in file size than
a similar vector graphic. Raster graphics do lose quality when enlarged.

Logo drawn as vector art (left) and rasterized as 300 dpi bitmap art (right).

In general, use vector-drawing tools to create art or type with clean lines that look good at any
size, such as a logo used on a business card and also on a poster. You can create vector artwork
using the InDesign drawing tools, or you might prefer to take advantage of the wider range of
vector-drawing tools available in Illustrator. Use Photoshop to create bitmap images that have
the soft edges of painted or photographic art, to retouch or alter photographs, and to apply special
effects to artwork.

Managing links to imported files
When you opened the lesson file, you saw an alert message about problems with the linked files.
You’ll resolve those issues using the Links panel, which provides complete information about
the status of all linked text and graphic files in a document.

Note
By default, InDesign does not create links to imported text files and spreadsheet files.
You can change this behavior in the File Handling section of the Preferences dialog box
by selecting Create Links When Placing Text And Spreadsheet Files.

You can use the Links panel to manage placed graphics and text files in many other ways. For
example, you can update graphics and text files that have been modified since they were placed,
and you can replace graphic and text files with different files.

Identifying imported images
To identify some of the graphics that have already been imported into the document, you’ll use
two different techniques involving the Links panel. Later in this lesson, you’ll also use the Links
panel to edit and update imported graphics.

1. Center page 4 in the document window by choosing it from the Page Number box at the
lower-left corner of the document window. Chose View > Fit Page In Window.
2. If the Links panel is not visible, choose Window > Links.
3. Using the Selection tool ( ), select the Songs of the Garden logo type on page 4. (Click
outside the content grabber in the center of the frame so that you select the frame and not
the graphic.) Notice that the graphic’s filename, Title.ai, becomes selected in the Links
panel when you select the graphic in the layout.

A. Filename column
B. Status column
C. Page column
D. Show/Hide Link Information button
E. Relink From CC Libraries button
F. Relink button
G. Go To Link button
H. Edit Original button
I. Select Next Link In The List button
J. Select Previous Link In The List button
K. Update Link button
Now you’ll use the Links panel to locate another graphic in the layout.

Tip
You can click the page number to the right of a filename in the Links panel to jump
to that link and center it in the document window.

4. In the Links panel, select milky-way-background.tif, and then click the Go To Link button (
). The graphic becomes selected and centered on the screen. This is a quick way to find a
graphic in a document when you know its filename.
These techniques for identifying and locating linked graphics are useful throughout this
lesson and whenever you work with a large number of imported files.

Viewing information about linked files
The Links panel makes it easy to work with linked graphics and text files and to display
additional information about linked files.

Tip
You can detach the Links panel from its group of panels by dragging its tab. Once you’ve
detached the panel, you can resize it by dragging an edge or lower corner.

1. Make sure that the graphic named milky-way-background.tif is selected in the Links panel.
If you cannot see the names of all the linked files without scrolling, drag the horizontal
divider bar in the Links panel downward to enlarge the top half of the panel so that all the
links are visible. The Link Info section at the bottom half of the panel displays information
about the selected link.
2. In the Links panel, click the Select Next Link In The List triangle ( ) to view information
about the following file in the Links panel list, RR-logo.ai. You can quickly examine all the

links in the list this way. Currently, every link displays an alert icon ( ) in the Status
column. This icon indicates a linking problem, which you’ll address later. After you’ve
examined the link information for various images, choose Edit > Deselect All, and then
click the Show/Hide Link Information button ( ) above Link Info to hide the Link Info
section.
By default, files are sorted in the Links panel by page number, with files used multiple
times in a document listed at the top. You can sort the file list in different ways by clicking
on the column headings. Next, we’ll add more column headings to make more information
available at a glance.
3. Another and faster way to view link information is to customize the information displayed
in the Links panel columns. Click the flyout menu in the Links panel and choose Panel
Options. Click Color Space, Actual PPI, Effective PPI, and Transparency, under Show
Column. Click OK. (The important information in your workflow may vary from this
example.)

Tip
Effective resolution combines the actual resolution of the image with the amount it’s
been enlarged or reduced in size within InDesign. The standard minimum resolution
for high-quality printing is 300 for the effective resolution. Therefore, caution must
be used when enlarging images so that the effective resolution does not fall below
300.

4. Pull out the panel to the left to see the new columns. The Links panel now shows this
information in additional columns. Drag the first column divider to the right to make the
first column wide enough to see the filenames. This customized view is a fast way to see
important information about imported graphics, such as whether something has been scaled
up so much that it will look bad (jagged edges, blurry, or pixelated) when printed.

Showing files in Explorer (Windows) or Finder (macOS)
Although the Links panel gives you information about the attributes and location of a specific
imported graphic file, it does not let you make changes to the file or change the name of the file.
You can access the original file of an imported graphic file by using the Reveal In Explorer
(Windows) or Reveal In Finder (macOS) option.

Note
The Reveal In Explorer (Windows) or Reveal In Finder (macOS) command is not
available for missing links.

Tip
You can also choose Reveal In Bridge from the Links panel menu to locate an imported
graphics file.

1. Select milky-way-background.tif. From the Links panel flyout menu, choose Reveal In
Explorer (Windows) or Reveal In Finder (macOS). The folder where the linked file is
currently stored on your computer opens, and the file is selected. This feature is useful for
locating files on your hard drive.
2. Close the window and return to InDesign.

Updating revised graphics
Even after you place text or graphic files in your InDesign document, you can still use other
applications to modify those files. The Links panel indicates which files have been modified
outside of InDesign and gives you the choice of updating your document with the latest versions
of those files.
In the Links panel, the file Title.ai has an alert icon (

), indicating that the original file has been

modified. This is one of the files that caused the alert message to appear when you first opened
this document. You’ll update the link for this file so that the InDesign document uses the current
version.

Tip
You can update multiple instances of a graphic at the same time by updating when the
disclosure triangle is closed.

1. If necessary, click the disclosure triangle ( ) in the Links panel to the left of the file
Title.ai to reveal two instances of the imported file. Select the instance of the Title.ai file
that’s on page 4, and click the Go To Link button ( ) to view the graphic in magnified
view. You don’t have to do this step, but it’s a quick way to double-check which imported
file you are about to update and see the results.

Tip
You can also double-click the modified alert icon in the Links panel or click the
modified alert icon displayed in the upper-left corner of the graphics frame to update
the link.

2. Click the Update Link button ( ). The appearance of the image in the document changes
to represent its newer version, the modified alert icon is no longer displayed in the Links
panel, and the icon near the upper-left corner of the graphics frame changes from Modified
( ) to OK ( ).

3. To update the rest of the modified graphic files, choose Update All Links from the Links
panel flyout menu.
Now you’ll replace the image of the butterfly on the first spread (pages 2–4) with a modified
image. You’ll use the Relink button to reassign the link to another graphic.
1. Go to pages 2–4 (the first spread), and choose View > Fit Spread In Window.
2. Use the Selection tool ( ) to select the Butterfly-on-flower.psd image on page 4. (If you
click on the content grabber, you’ll select the graphic rather than the frame, but for this
task, you can select either.) You can tell when you’ve selected the right image because the
filename becomes selected in the Links panel.

Note
When you relink the image, an animated tool tip may pop up that introduces a new
feature in InDesign CC 2019 called Content-Aware Fit. You’ll learn about this
feature later in the lesson. For now, click OK to close the animation.

3. Click the Relink button (

) in the Links panel.

4. Browse to find the Cover-PinkFlower.psd file in the Lesson10 folder, and then click Open.
The new image replaces the original image, and the Links panel is updated accordingly.
5. Click a blank area of the pasteboard to deselect all the objects on the spread.
6. Choose File > Save to save your work.

Link status icons in the Links panel
A linked file can appear in the Links panel in any of the following ways:
In the Status column, an up-to-date graphic displays only the filename and the page on
which it’s used.
A modified file displays a yellow triangle with an exclamation point ( ). This icon
means that the version of the file on disk is more recent than the version in your
document. For example, this icon appears if you place a Photoshop graphic into
InDesign, and then you or someone else edits and saves the original graphic in
Photoshop. To update a modified graphic, select it in the Links panel, and then choose
Update Link from the panel menu, double-click the modified alert icon in the panel or
on the graphic frame, or click the Update Link button ( ).
A missing file displays a red hexagon with a question mark ( ). This icon means the
graphic is no longer in the location from which it was placed, although it may still exist
somewhere. Missing links can happen if someone deletes the original file or moves it
to a different folder or server after it’s been placed in the document. You can’t know
whether a missing file is up to date until its original is located. If you print or export a
document when this icon is displayed, the file will not print or export at full resolution.
To fix a missing graphic, select it in the Links panel and then choose Relink from the
panel menu. Use the Relink dialog box to locate the correct graphic file, and then click
Open.
A graphic that has been embedded in the InDesign document (by selecting the
filename in the Links panel and choosing Embed Link from the panel menu) displays
an embedded icon ( ). Embedding the contents of a linked file suspends management
operations for that link. Unembedding the file restores management operations to the
link.

Display performance and GPUs
InDesign CC provides support for computers with video cards that include a graphics
processing unit (GPU). If your computer has a compatible GPU card, InDesign
automatically displays documents using the GPU and sets the default Display Performance
to High Quality. If your computer does not have a compatible GPU card, the default
Display Performance setting is Typical. This book presumes that readers are using
computers without a GPU. If your computer has a compatible GPU, you can ignore steps
that ask you to switch to High Quality display. For more information about GPU support in
InDesign CC, go to https://helpx.adobe.com/indesign/using/gpu_performance.html.

Adjusting display quality

Now that you’ve resolved all of the links, you’re ready to start adding more graphics. First,
however, you will adjust the view quality of the Illustrator file (Title.ai) that you updated earlier
in this lesson.
When you place an image in a document, InDesign automatically creates a low-resolution
(proxy) view of it, corresponding to the current settings in the Display Performance section of
the Preferences dialog box. The images in this document are currently low-resolution proxies,
which is why they appear to have jagged edges. Reducing the onscreen quality of placed
graphics enables pages to display faster and doesn’t affect the quality of the final output. You
can control the degree of detail InDesign uses to display placed graphics.
1. In the Links panel, select the Title.ai file you updated in the previous exercise (the instance
on page 4). Click the Go To Link button ( ) to view the graphic in magnified view.
2. Right-click the Songs of the Garden graphic, and then choose Display Performance > High
Quality Display from the context menu. The image appears at full resolution. You can use
this process to confirm the clarity, appearance, and position of a placed graphic in your
InDesign layout.

Tip
On older computers and for designs with many imported graphics, this setting can
sometimes result in slower screen redraw. In many cases, it is advisable to set your
Display Performance to Typical Display and then change the display quality of
individual graphics as needed.

3. To change the display performance for the entire document, choose View > Display
Performance > High Quality Display. All graphics are displayed at the highest quality.

Importing and sizing graphics
The simplest way to import a graphic into InDesign is to use File > Place. There are several ways
to use this feature, which this lesson will introduce.

Import, size, and crop

Note

If necessary, after you zoom in, navigate to the top of the page with a bit of the
pasteboard visible.

1. Navigate to page 2 and press Ctrl+Plus Sign (Windows) or Command+Plus Sign (macOS)
a couple of times to zoom in. Open the Layers panel and click the Photos layer so that the
imported images will be placed on that layer. Choose File > Place and navigate to the
Lesson10 folder. Select the file Blue-Hydrangea.psd and click Open.
2. Move the loaded raster graphics icon ( ) into the pasteboard area just above the page and
click once. This places the graphic independently of any existing frame. InDesign
automatically creates a frame around the graphic and scales it to actual size (100%).

3. This photo is much too large at actual size, so you’ll need to resize it. In this case, it needs
to be scaled down. To do this, you can type a percentage or measurements in the Control
panel and InDesign will scale the graphic to those numbers, in the direction of the selected
reference point. Or, you can scale the graphic visually. Choose the Selection tool ( ) and
hold down Shift+Ctrl (Windows) or Shift+Command (macOS). Drag the lower-right handle
up and to the left. Watch the Control panel Size and Scale (or the numbers in the gray box
next to the Selection tool) until the image is about 2 inches high. Holding down the Ctrl or
Command key while dragging scales both the frame and the image within. Adding the Shift
key keeps the image proportions so that the image is not distorted while it’s changing size.

4. Move the image down and to right until you see the Smart Guide appear that shows the top
aligned with the empty frame to the left.
5. Now we want to crop out most of the leaves. To do this, you change the size of the frame
without changing the size of the graphic inside. Drag the lower-right corner handle in
toward the flower so that most of the leaves are no longer visible. Then click the Content
Grabber icon ( ) and notice that the handles of the image are now much larger than the
frame, indicating that the image is larger than the frame. Drag the image up and to the left
so that the flower is centered in the frame.

Place a graphic into an existing frame and use frame fitting options
The next way to use File > Place is to place a graphic into an existing frame.
1. Click the empty frame to the left of the Blue-Hydrangea.psd image. Choose File > Place,
select Sunflower.jpg, and click Open. This time the image is imported into the frame. Once
again, it’s at actual size (100%) and that’s too large since the intention is to show the whole
flower.

Tip
All frame fitting options are also available as buttons on the Control panel.

2. Choose Object > Fitting > Fit Content To Frame, which seems like the right choice. But
examine the result: the image is indeed within the frame, but the sunflower is distorted
(stretched vertically). Confirm this by clicking the Content Grabber icon ( ) in the center
of the frame (so that you are viewing data about the image rather than the frame), and then
look at the scale values in the Control panel. The horizontal and vertical numbers are very
different, showing the distortion.

3. To scale the image without distortion, choose Object > Fitting > Fit Content Proportionally.

The image is not distorted, but now it’s too small. Choose Object > Fitting > Fill Frame
Proportionally. This option sizes the image without distortion within the frame, and it crops
part of the image if it’s a different shape than the frame (as in this case). However, the main
part of the flower is still cropped out of the frame.

4. InDesign CC has a new frame-fitting feature: Content-Aware Fit. This feature intelligently
fits the best part from the image when you place it inside a frame by evaluating various
parts of the image. Choose Object > Fitting > Content-Aware Fit. The sunflower is now
nearly centered in the frame automatically. You can nudge it over if you’d like.

5. Select the circular picture frame in the lower left and place the image Calla-Lilly.psd. This
frame was set up to center the image at 100% size. The picture is centered within the frame,
but the subject of the photo (the flower) is not centered in the photo itself. Select either the
circular frame or the image within and choose Object > Fitting > Content-Aware Fit. The
flower is now centered in the circle.

Place a graphic into an existing frame by dropping from the desktop
1. Another way to import graphics is to drop them onto a page from your desktop. Switch to
File Explorer (Windows) or the Finder (macOS), and open the Lesson10 folder, which

contains the Starflower.jpg file.
Resize and arrange your File Explorer window (Windows) or Finder window (macOS) and
your InDesign window, as needed, so that you can simultaneously see the list of files in the
Lesson10 folder and the InDesign document window. Make sure that the right side of page
2 in your document is visible.
2. Select the empty frame to the right of the circular frame. Drag the Starflower.jpg file over
this empty frame and release the mouse button.

3. This picture is smaller than the placeholder frame. Choose Object > Fitting > Fit Frame To
Content. Then with the Selection tool, move the picture to a pleasing position in the group
as you wish.

Using Adobe Bridge to import graphics
Adobe Bridge is a separate application available to Creative Cloud users with an All Apps
subscription. Adobe Bridge is a cross-platform application that lets you browse your local and
networked computers for graphics and then place them into an InDesign layout. (You can also
use Bridge to import text files.) This is just one of many features the application provides. (If you
don’t have Bridge available, you can complete this section using the Place command in the File
menu.)

Note
If you do not already have Bridge installed, Creative Cloud will install it when you
choose Browse In Bridge.

1. Choose File > Browse In Bridge to launch Adobe Bridge. Click the folder icons in the
Favorites panel or double-click in the Folder panel to navigate to the Lesson10 folder.

Adobe Bridge lets you view the thumbnails of all your images. Use the slider in the lower right to make the previews
larger or smaller.

2. Adobe Bridge provides an easy way to locate and rename files. Because you see a preview,
you can locate graphics visually without knowing the exact name. Click the graphic mapleleaf-.psd once, and then click the filename to select the filename box. Rename the file
maple-leaf-yellow, and press Enter or Return to commit the change.

Tip
To learn more about what you can do with Bridge, start at the Bridge page on the
Adobe website: https://helpx.adobe.com/support/bridge.html.

3. Make the Bridge window smaller by dragging the lower-right corner, and position it so that
you can see page 4 of the InDesign document. Drag the maple-leaf-yellow.psd file into
your InDesign document and onto an open area of the pasteboard. Click the pasteboard to
place the image at full size and return to InDesign (Windows), or click the pasteboard to
return to InDesign, and then click the pasteboard again to place the image at full size
(macOS).

4. Use the Selection tool ( ) to position the leaf graphic in the upper-left corner of page 4, on
top of the empty Blue-Bright frame. Press Shift+Ctrl (Windows) or Shift+Command
(macOS) and drag a corner of the frame to scale both the frame and its contents. Scale to
about the size of the empty Blue-Bright frame. Align the top and right edges of the graphic
frame with the top and right edges of the Blue-Bright frame.
A very useful feature of dragging photos from Bridge is that you can quickly change
pictures in a frame, while seeing the new image in Bridge and then the result in InDesign.
This is very useful in projects where the layout repeats but you need to import different
pictures. You’ll try this now.
5. With the yellow maple leaf still selected, bring the Bridge window to the front again (if
needed) and choose the file maple-leaf-red.psd. Drag and drop it right over the yellow
maple leaf. InDesign retains the scaling, and now you’ve switched out the image with the
new one, in position, in just a few seconds. Try it again with maple-leaf-orange.psd. Select
the image with the content grabber and set the Reference Point to the center position ( ).
Then rotate the image within the frame a bit to the left, to about 6 degrees. Drag and drop
the red leaf again. The image is switched while both the scaling and rotation are retained.

6. To see how the Reference Point affects the center of rotation, experiment with rotating the
image again using different reference points, such as the upper left or lower right.
7. Choose File > Save to save your work.

Editing placed pictures
The quickest way to make a change to an imported graphic while you’re working in InDesign is
to use the Edit Original feature. This opens the graphic in the corresponding image program

(usually Adobe Illustrator or Adobe Photoshop). You can make the desired changes, save the
file, and it will be automatically updated in InDesign.

Note
The Edit Original button may open an image in an application other than Photoshop or
the application in which it was created. When you install software, some installer utilities
change your operating system’s settings that associate file types with applications. The
Edit Original command uses these settings for associating files with applications. To
change these settings, see the documentation for your operating system.

1. Using the Selection tool ( ), select the Blue-Hydrangea.psd image you imported onto
page 2.
2. If the Links panel is not already open, choose Window > Links. The image filename
appears selected in the Links panel. Click the page number following the name to center it
in your window.
3. In the Links panel, click the Edit Original button ( ). This opens the image in an
application that can view or edit it. This image was saved from Photoshop, so if Photoshop
is installed on your computer, InDesign starts Photoshop and opens the selected file.

4. In Photoshop, make a change to the image such as applying a filter or making a dramatic
change with an Adjustment Layer. Save the file, and it is automatically updated in
InDesign. In the example you see in the 10_End.indd file, a filter was applied to blur the
background more than it was originally.

Relinking mulitple files at the same time
In many workflows, the situation arises where the linked files for a project are moved to a
new location. When you open that InDesign project, all of the links are broken and the
missing icon ( ) shows in the Links panel for many images. InDesign can handle that
situation in two ways.
One, when you relink one image, InDesign looks for all other missing images in the new

folder to which you just relinked that one image. Be sure to click the Search For Missing
Links In This Folder option at the bottom of the relink window. It is turned on by default.
Two, select the missing images in the Links panel and use the Relink To Folder option from
the panel flyout menu. Navigate to the folder where the links are now, select its name, and
click Choose.

Working with dropped backgrounds
There are two basic types of images with white, or “dropped,” backgrounds, both of which are
widely used. The difference is whether the edge between the foreground and background is a
crisp, sharp edge or a soft, blending edge. The type of edge used depends on what is appropriate
for the image content.

Tip
A mask is a shape that’s used to contain and crop an image. The portion of the image
within the mask shape is visible; any areas outside the mask shape are not visible.

Images with sharp edges between the foreground and background can use a vector path to
separate the foreground from the background. This is called a clipping path.
If you draw a path in Photoshop and save it with the image, you can choose this path in
InDesign, and you can choose different paths from within the same image.
If the image has a relatively light or white background (or a relatively dark background if
the subject matter is light), InDesign can automatically detect the edge between the subject
and the background and create a clipping path. However, this technique works best for
simple shapes or for creating a path to use for Text Wrap, as we did in Lesson 4.
Images with a soft, blending edge between the foreground and background use transparency and
soft brushes to delete the background in Photoshop.

Working with clipping paths from Photoshop in InDesign
1. Navigate to page 7 of the document by double-clicking page 7 in the Pages panel, and
choose View > Fit Page In Window.
2. In the Layers panel, make sure that the Photos layer is selected so that the imported image
is placed on that layer. You can lock the Background photos layer to be sure you don’t
accidentally click into that frame. Choose File > Place, and double-click the file Pears.psd
in the Lesson10 folder.

Tip

If you accidentally click within the existing frame, choose Edit > Undo Place and try
again.

3. Position the loaded raster graphics icon ( ) outside the blue square in the center of page 7
—to the left and slightly below the top edge (make sure you are not placing the pointer in
the square itself)—and click to place an image of two pears. If you need to reposition the
graphics frame to match the following image, do so now.

4. Choose Object > Clipping Path > Options. Move the Clipping Path dialog box, if
necessary, so that you can see the pear image.
5. Choose Photoshop Path from the Type menu. Choose the path named “Two Pears.” If
Preview is not selected, select it now. The background is now hidden, or clipped out, by the
path.
6. Click OK.

7. Switch to the Selection tool ( ) and click the lower-right corner handle. Press Shift+Ctrl
(Windows) or Shift+Command (macOS) and drag up and to the left to scale both the frame
and its contents. Make the pears fit inside the purple box as shown. Then choose Object >
Fitting > Fit Frame To Content, and then use the Selection tool to move the pears toward
the bottom of the blue square.

8. Press Alt (Windows) or Option (macOS) and drag up and to the right. This creates a copy
of the image. Choose Object > Clipping Path > Options, and choose Photoshop Path from
the Type menu. This time choose the path named “Right Pear” and click OK. Then choose
Object > Fitting > Fit Frame To Content. Switch back to the Selection tool ( ), click to
select the frame, and use the same technique to scale this pear to about 80% of the original
size (the Control panel shows the scale amount as you scale the object). Then move the
pointer outside the bounding box until it changes to the Rotate Pointer ( ). Rotate the
photo to the right about –28 degrees and move it down and slightly inside the box as
shown.

Note
Notice the double arrows that appear when you press Alt (Windows) or Option
(macOS) and click an object, indicating that a copy of the object will be made when
you drag, leaving the original object in place.

9. Press Alt (Windows) or Option (macOS) and drag down and to the left to create a copy of
the single pear. Choose Object > Clipping Path > Options and choose Photoshop Path from
the Type menu. This time choose the path named “Left Pear” and click OK. Then choose
Object > Fitting > Fit Frame To Content. Switch back to the Selection tool, click to select

the frame, and move the pointer outside the bounding box until it changes to the Rotate
Pointer ( ). Rotate the photo to the left about 22 degrees and move it down and a little to
the right.

10. Notice how a clipping path allows an image to overlap multiple other objects. You can also
move images in front of or behind other objects. Take a few moments to experiment.
11. Choose File > Save to save the file.

Working with transparent backgrounds from Photoshop in InDesign
1. Navigate to page 5 of the document by sliding page 7 to the right. Do this by holding down
the spacebar. The hand icon ( ) appears. Keep the spacebar pressed and drag until page 5
is centered in your window.
2. Select the Rectangle Frame tool ( ) in the Tools panel and draw a frame in the lower area
as shown, crossing over the border between page 5 and page 6.
3. Then choose Object > Fitting > Frame Fitting Options. Choose Fit Content Proportionally
and then click the top center point in the Align From area. Click OK.

4. Choose File > Place and double-click the Tulips.psd file in the Lesson10 folder. InDesign
fits the image proportionally to the frame as specified. Choose Edit > Deselect All.
5. Now we want to scale the picture without scaling the frame. Switch to the Selection tool,

and notice that when you move the pointer over the right area of the picture, the red frame
of the text lights up. This is because the Text layer is above the Graphics layer. Open the
Layers panel and lock the Text layer so that you can easily work with the photo. Click the
photo over the circle of the content grabber ( ) to select the contents of the frame, in this
case the photo of the tulips. The handles of the bounding box of the photo (not the frame)
will be active. In the Control panel, set the Reference Point to the upper center ( )
position, type 70% in the Scale box, and Press Enter (Windows) or Return (macOS). Use
the arrow keys to nudge the photo up slightly. Use the Selection tool to make the frame
wider if necessary. Most of the image will be cropped out, with just the tops of the flowers
and leaves showing.
6. Notice how different the edges of the tulip image are compared to the edges of the pears
image. Here, the edges blend softly into the background. This is the purpose of using
transparency in Photoshop to remove a background: to create a soft edge by painting away
the background with a soft-edge brush.

Importing native Adobe graphic files
InDesign allows you to import files saved from Adobe applications, such as Photoshop (.psd),
Illustrator (.ai), and Acrobat (.pdf), in unique ways and provides options for controlling how the
files are displayed. For example, you can adjust the visibility of Photoshop and Illustrator layers
in InDesign.

Working with a Photoshop file with layers
In the previous exercise, you worked with a Photoshop file with several saved paths; however,
the file had only a single background layer. When you work with a layered Photoshop file, you
can adjust the visibility of the individual layers. If you locked the Background photos layer in the
previous exercise, go to the Layers panel and unlock it now.
1. In the Links panel, click the link for Cover-PinkFlower.psd, and click the Go To Link
button ( ) to select the file and center it in your document window. This file, which you
relinked in a previous exercise, has four layers.
2. Choose Object > Object Layer Options to open the Object Layer Options dialog box. This
dialog box allows you to show and hide layers.
3. Move the Object Layer Options dialog box so that you can see as much as possible of the

selected image. Select the Preview option to view changes while keeping the dialog box
open.
4. In the Object Layer Options dialog box, click the eye icon ( ) to the left of the
Cobblestones layer. This turns off the layer, leaving only the Pink Flower layer visible.

5. Click the eye icon ( ) to the left of the Green Texture layer to turn the layer on. Turn that
layer off and turn on Purple Texture layer. Click OK.
6. Choose File > Save to save your work so far.

Creating an anchored graphics frame
An anchored graphics frame moves with the text to which it’s anchored if editing causes the text
to reflow. In this exercise, you’ll anchor the CD title to a text frame on page 6.
1. In the Pages panel, double-click the second spread, and choose View > Fit Spread In
Window. Open the Layers panel and unlock the Text layer if necessary. At the bottom of
the pasteboard is the Songs of the Garden logo. You’ll insert this graphic into a paragraph
on the page.

Tip
If the Anchored Object Control square is not visible when selecting the logo, choose
View > Extras > Show Anchored Object Control.

2. Press and hold Z to temporarily access the Zoom tool, or select the Zoom tool ( ) and
click so that you can see the logo and the text frame above it.
3. Using the Selection tool ( ), click the logo. (Be careful to click outside the content
grabber so that you select the frame and not the graphic within.) Notice the small, solid-red
square near the upper-right corner of the frame. You can drag this square into a text frame
to anchor an object to text.

Note

Showing hidden characters is not a necessary step when placing anchored graphics;
it is used here to help identify the structure of the text.

4. Choose Type > Show Hidden Characters to view the spaces and paragraph returns in the
text. This helps you locate where you want to anchor the frame.

5. Select the Type tool ( ) and click in front of the word “Addie” at the beginning of the
second paragraph. Press Enter (Windows) or Return (macOS) so that the anchored graphic
will be in a paragraph by itself.
6. Use the Selection tool and click the logo again. Hold down the Shift key and drag the red
square near the upper right of the logo to the beginning of the second paragraph. Holding
the Shift key creates an inline graphic that flows with the text (as opposed to floating
outside the text frame). You’ll see a bold cursor indicating the point where the graphic
anchor will be inserted. After the graphic is anchored, the red square on the graphic frame
changes to an anchor symbol. Now if the text in the paragraph above is edited, the graphic
will stay where you positioned it between the two paragraphs without you having to adjust
its position.

Now you’ll create space between the graphic and the surrounding text with the Space
Before option. Once a graphic is anchored, you can select it with the Type tool and apply
text attributes that affect its position.
7. Select the Type tool ( ) and then click to the right of the inline graphic to establish the
insertion point in that paragraph.

Tip
When you hold down the Shift key and click the arrow button, InDesign changes the
measurement in larger increments than when you do not hold down the Shift key.
The amount varies with the measurement units you are using. When using inches,
the amount is .25 in. versus .0625 in. without the Shift key; when you are using
millimeters, the amount is 10 mm. versus 1 mm.

8. Click the Paragraph Formatting Controls button ( ) in the Control panel. In the Space
Before option ( ), hold down the Shift key and click the up arrow button to the right of
the icon to change the value to 1 in. As you increase the value, the anchored graphics frame
and the text below it shift downward.
9. To see how the anchored graphic flows when text is edited, click to the right of the period
that ends the first paragraph, and then press Enter or Return twice. Notice how the graphic
moves down each time you press the key. Press Backspace (Windows) or Delete (macOS)
twice to remove the extra paragraph returns.
10. Choose File > Save to save your work so far.

Adding text wrap to an anchored graphics frame
You can easily add text wrap to an anchored graphics frame. Text wrap allows you to flow text
around a graphic frame or the shape of the graphic within using many different options.
1. Using the Selection tool ( ), select the graphics frame with the Songs of the Garden logo
you placed in the previous exercise.
2. Press Shift+Ctrl (Windows) or Shift+Command (macOS), and drag the upper-right handle
of the frame up and to the right until you’ve scaled the graphic and its frame roughly 20%
across the second column. With the graphic still selected, drag it downward so that the top
is below the first paragraph.
3. Choose Window > Text Wrap to access the Text Wrap panel. In the Text Wrap panel,
select Wrap Around Object Shape ( ) to add text wrap to the graphic.

4. To increase space around the bounding box of the graphic, click the up arrow button in the
Top Offset option ( ) and change the value to 0.1875 in.

Text can also wrap around a graphic’s shape rather than around the rectangular bounding
box.
5. In the Text Wrap panel under Contour Options, choose Detect Edges from the Type menu.
Detect Edges creates a vector path. Because this image is a vector graphic, the text wrap is
determined by the shape formed by the letters.

6. To view the document clearly, choose Edit > Deselect All, and choose Type > Hide Hidden
Characters to hide the paragraph returns and spaces.
7. Using the Selection tool ( ), select the graphics frame with the Songs of the Garden logo
again.
8. In the Text Wrap panel, experiment with the available options from the Wrap To menu.
Keep Largest Area as your final choice. The text moves into the largest area to one side of
the text wrap boundary.
The path created when using the Detect Edges contour option is an editable path. For
example, you can manually adjust the anchor points by dragging them to a new position.
You can also add or delete points, and convert them from corner points to smooth points

(and vice versa) with the Pen tool ( ). You can change the shape of curves by adjusting
the anchor point handles with the Direct Selection tool ( ).
9. Select the Direct Selection tool ( ), and then click the graphic to view the anchor points
used for the text wrap. Experiment with moving individual points and notice how that
reflows the text.

Tip
When you hover over an anchor point with the Pen tool, the icon adds a minus sign
to indicate that if you click that point, it will be deleted.

10. Examine this path in the 10_End.indd file, where many points along the bottom of the
graphic were deleted to better control the text flow of the first line of the next paragraph.
11. Close the Text Wrap panel.
12. Choose File > Save.

Importing an Illustrator file
InDesign takes full advantage of the smooth edges of vector graphics, such as those from Adobe
Illustrator. Most vector graphics don’t require a clipping path, because most applications save
them with transparent backgrounds. In this section, you’ll place an Illustrator graphic into your
InDesign document.

Tip
When you use High Quality Display setting, vector graphics and type appear with smooth
edges at any size or magnification.

1. In the Layers panel, select the Graphics layer. Choose Edit > Deselect All to make sure
nothing is selected in your document.
2. Choose View > Fit Spread In Window to see the entire spread.
3. Choose File > Place, and select the Illustrator file Garland.ai from the Lesson10 folder.
Make sure that Show Import Options is not selected. Click Open.

Note
If an Illustrator file imports with a white background, delete it and import it again,
but turn on Show Import Options and then turn on Transparent Background.

4. Click in the upper-left corner of page 5 with the loaded vector graphics icon ( ) to add the
Illustrator file to the page. Use the Selection tool ( ) to position it as shown here.
Graphics created in Illustrator have transparent backgrounds by default.

5. Choose File > Save to save your work.

Importing an Illustrator file with layers
You can import native Illustrator files with layers into an InDesign layout and control the
visibility of the layers and reposition the graphic. However, you cannot edit the paths, objects, or
text.
1. Deselect all objects by clicking in the pasteboard of the document window. Click the empty
frame to the left of the red box on the far left of the spread.
2. Choose File > Place. In the lower-left corner of the Place dialog box, select Show Import
Options. Select the file Flower-Title.ai, and click Open. The Place PDF dialog box appears
when Show Import Options is selected (because Illustrator files are written in PDF file
format).
3. In the Place PDF dialog box, make sure that Show Preview is selected. In the General tab
choose Bounding Box (All Layers) from the Crop To menu and make sure that Transparent
Background is selected.
4. Click the Layers tab to view the layers. This file has three layers: a background image of a
flower (Layer 3), a layer of text in English (English Title), and a layer of text in Spanish
(Spanish Title).

Although you can designate now which layers you would like to display in the imported
graphic, the small Preview area makes it difficult to see the results.
5. Click OK. You’ll select the layers to display while working in the layout.
6. Use the Zoom tool ( ) to zoom in on the graphic.

7. In the Control panel, click the center Reference Point ( ) and then click the content
grabber. Enter 70% for the scale.
8. Switch to the Selection tool ( ) and drag or nudge with the arrow keys to position the
graphic so that it is visually centered over the red box.
9. With the graphic still selected, choose Object > Object Layer Options. Move the dialog box
if necessary so that you can see the graphic in the document.
10. Select Preview, and then click the eye icon ( ) next to the English Title layer to turn it off.

11. Click the empty box next to Spanish Title to turn on that layer. Click OK, and then choose
Edit > Deselect All.

Using layered Illustrator files allows you to repurpose illustrations without having to create
separate files for each variation.
12. Choose File > Save to save your work.

Using an InDesign library to manage objects
Object libraries let you store and organize graphics, text, and design elements that you use
frequently. InDesign libraries are stored as files on your hard drive or a shared device. You can
also add ruler guides, grids, drawn shapes, and grouped images to a library. Each library appears
as a separate panel that you can group with other panels any way you like. You can create as
many libraries as you need—for example, different libraries for each of your projects or clients.
In this section, you’ll import a graphic currently stored in a library, and then you’ll create your
own library.

Tip
You might use a library to store boilerplate text, a photo of each writer who contributes to
a publication, or frequently used page elements such as a logo or an image with a caption.

1. If you’re not already on page 5, type 5 into the Page Number box at the bottom of the
document window, and then press Enter or Return to go to that page.
2. Choose View > Fit Page In Window to see the entire page.

Note
When you open it, the Lesson_10_Elements Library may be grouped with the
default Sample Buttons And Forms library. You can drag the default library off the
docked panel and close it.

3. Choose File > Open, select the file Lesson_10_Elements.indl in the Lesson10 folder, and
then click Open to open the library file. Drag the lower-right corner of the
Lesson_10_Elements Library panel to reveal all of the items it contains.

4. In the Lesson_10_Elements Library panel, select the Show Library Subset button ( ). In
the last box for the Parameters option, type flower, and click OK. This searches the library

for all objects that have the word “flower” in their name. Three objects are found.

Note
After you drag the flower image onto the page, the Links panel may display a
missing link icon ( ) or a modified link icon ( ) because you moved the BlueFlower.ai file from its original location to your hard drive. To remove the warning,
click the Update Link button in the Links panel, or click the Relink button in the
Links panel and navigate to the Lesson10 folder to find Blue-Flower.ai.

5. In the Layers panel, make sure the Graphics layer is selected. Open the Links panel.
6. Of the three objects visible in the Lesson_10_Elements Library panel, drag Blue-Flower.ai
anywhere on page 5. The file is added to the page. Notice that the filename appears in the
Links panel.

7. Using the Selection tool ( ), position the Blue-Flower.ai image so that it’s on top of the
light blue background frame on the far left of the page.
8. Choose File > Save to save your work.

Creating and using CC Libraries
Creative Cloud Libraries make your favorite assets available to you anywhere. You can use
CC Libraries to create and share colors, character and paragraph styles, graphics, Adobe
Stock assets, and more using your favorite Creative Cloud desktop and mobile apps and
then access them across other Creative Cloud apps whenever you need them. You can also
share libraries with anyone who has a Creative Cloud account, so it’s easy to collaborate,
keep designs consistent, and even create style guides to use across projects.
CC Libraries work much like the InDesign libraries you use in this lesson. To create a new
CC Library, follow these steps:
1. Choose Window > CC Libraries to display the CC Libraries panel, or click the CC

Libraries panel icon ( ).
2. Click the Library panel menu, and choose Create New Library.
3. Enter CD Elements in the Create New Library field, and then click Create.

Note
The CC Libraries menu includes several commands that let you create and
manage CC Libraries and control how library elements are displayed in the
panel.

4. Use the Type tool to select all of the text in the address at the bottom of page 3, click
the plus sign at the bottom of the CC Library panel, and then click the Add button.
Both the text and the paragraph style will be added to the library. You can add both
formatted and unformatted text to a library, as well as the styles and color associated
with the text.

5. Use the Selection tool ( ) to select the “Songs of the Garden” graphic on page 4, and
then drag it into the library window. Double-click the name “Artwork 1” and type to
change the name to Songs of the Garden logo. Be sure to click the name and not the
icon of the graphic itself. Drag another graphic to the library and name it, such as the
red maple leaf at the top of page 4. Examine the organization of the library.

Tip
When you add an asset to a CC Library, it’s assigned a default name. If you
want to change the name of an asset, double-click its name and then enter a
new one.

After you’ve saved assets to a CC Library, you can use them in other InDesign
documents, as well as in other Adobe CC applications, such as Photoshop and
Illustrator.
6. Choose File > New > Document to open a new InDesign document. Click Create to
use the default settings.
7. Drag the “Address” asset in the CC Library to the page. The Address paragraph style
uses Paper as the fill color, so you’ll need to add a fill color to the text frame to see the

white text. The Address paragraph style is also added to the list of styles in the
Paragraph Styles panel.
8. Drag the “Songs of the Garden logo” asset from the CC Library to the page, and then
click with the loaded graphics icon to place the graphic.
9. Close the document without saving changes and return to the document you were
working on.
You can also share CC Libraries with team members and other colleagues. For more
information, see the “Exploring on your own” section at the end of this lesson.

Creating an InDesign library
Now you’ll create your own library and add text and a graphic to it. When you add a graphic to
an InDesign library, the original graphic file is not copied into the library; instead, InDesign
maintains a link to the original source file. Graphics stored in a library still require the original,
high-resolution file for high-resolution display and printing.
1. Choose File > New > Library. (If the CC Libraries alert displays asking whether you want
to try out CC libraries now, click No.) Type CD Projects as the library filename, navigate
to the Lesson10 folder, and click Save.
2. Navigate to page 3. Using the Selection tool ( ), drag the Ricky Records logo to the
library you just created. The logo is now saved in the library for use in other InDesign
documents.

Tip
If you Alt-drag (Windows) or Option-drag (macOS) an object into a library, the Item
Information dialog box appears as soon as you drag the item into the library, and
you can assign a name to the object as you add each item.

3. In the CD Projects library, double-click the Ricky Records logo. For Item Name, type
Ricky Records Logo, and click OK.
4. Using the Selection tool, drag the address text block to the CD Projects library.

5. In the CD Projects library, double-click the address text block. For Item Name, type Ricky
Records Address, and click OK. Click the panel flyout menu and choose Large Thumbnail
View so that it’s easier to see the items.

Now your library contains both text and graphics. As soon as you make changes to the
library, InDesign saves the changes.
6. Close both libraries by clicking the close button at the top of the library panel group.
Congratulations! You have completed this lesson.

Using snippets
A snippet is a file that holds objects and describes their location relative to one another on a
page or page spread. Snippets are a way to conveniently reuse and place objects in position,
and can be shared with others. You create a snippet by exporting objects to a snippet file,
which has the .idms extension. (Earlier InDesign versions use the .inds extension.) When
you place a snippet file in InDesign, you can determine whether the objects are placed in
their original positions or where you click. You can store snippets in an object library and
Adobe Bridge as well as on your hard disk. Artwork added to CC Libraries from InDesign
is also stored as a snippet.
To create a snippet, do one of the following:
Using a selection tool, select one or more objects, and then choose File > Export. From
the Save As Type (Windows) or Format (macOS) menu, choose InDesign Snippet.
Type a name for the file, and click Save.
Using a selection tool, select one or more objects, and then drag the selection to your
desktop. A snippet file is created. Rename the file.
To add a snippet to a document, follow these steps:
1. Choose File > Place.
2. Select one or more snippet (IDMS or INDS) files, and then click Open.
3. Click the loaded snippet cursor where you want the upper-left corner of the snippet
file to be.
If you placed the insertion point in a text frame, the snippet is placed in the text as an
anchored object.
All objects remain selected after you place the snippet. By dragging, you can adjust the
position of all objects.

4. If you loaded more than one snippet, change the snippet loaded in the cursor by
pressing the arrow keys, and click the loaded snippet cursor to place the currently
selected snippet.
Rather than place snippet objects according to where you click on a page, you can place
them in their original locations. For example, a text frame that appeared in the middle of a
page when it was saved as a snippet can appear in the same location when you place it as a
snippet. To place snippets in their original location:
Open the File Handling section of the Preferences dialog box. Within the Snippet
Import area, choose Original Location.
The default is Position At: Cursor Location, which places the object based on where
you click on a page.
Or, press Alt (Windows) or Option (macOS) when you click with the loaded snippet
cursor to override the current Snippet Import settings. If your preferences are set to
Current Location, the snippet will be placed in its original location instead.

Exploring on your own
Now that you’ve had some practice working with imported graphics, here are some exercises to
try on your own:
1. Place different file formats with Show Import Options selected in the Place dialog box, and
see what options appear for each format. You can use any of the sample graphics files for
this lesson or any other lessons or any other available graphics. For a full description of all
the options available for each format, see InDesign Help.
2. Place a multiple-page PDF file or an Adobe Illustrator (.ai) file with multiple artboards with
Show Import Options selected in the Place dialog box, and import different pages from the
PDF or different artboards from the Illustrator file.
3. Create libraries of text and graphics for your work.
4. During this lesson, you created a CC Library named “CD Elements.” In addition to being
able to access assets in CC Libraries using several Adobe graphics applications, you can
share these libraries with team members and other colleagues to ensure that everyone is
using the latest iterations.
Choose Window > CC Libraries to open the CC Libraries panel, and then select CD
Elements from the Libraries menu at the top of the panel. Choose Collaborate from the
panel menu. In the Invite Collaborators window that opens in your browser, enter the email
addresses of the colleagues with whom you want to share your library. Choose Can Edit or
Can View from the menu to specify whether recipients can view and edit elements (Can
Edit) or view only (Can View). Click Invite. The recipients will receive an email invitation
to collaborate on the library.
5. Another way to import Illustrator graphics into InDesign is to copy the vector shapes from
Illustrator and switch over to InDesign and paste. The Illustrator vector objects are
converted into InDesign vector objects. You can use these objects as if you had drawn them

in InDesign. If you have Illustrator, try this yourself. After you paste the objects into
InDesign, change the color with the colors from your InDesign Swatches panel. Then use
the Pen tool to select points and change the vector shape.
If you do not have Illustrator, you can use the vector art of a butterfly that is in the
pasteboard of the Start.indd file, to the left of page 2.
6. Experiment further with the Object > Fitting options, especially the new option ContentAware Fit. Use the pictures from this lesson or any other lesson, or use other images you
have.

Review questions
1 How can you determine the filename of an imported graphic in your document?
2 What is the difference between dropping a background with a clipping path versus with
transparency?
3 What is the difference between updating a graphic file’s link and relinking the file?
4 When an updated version of a graphic becomes available, how do you make sure that it’s up to
date in your InDesign document?
5 How do you scale an imported graphic and its frame at the same time?
6 What is a quick technique to make a duplicate of an object and place it in position at the same
time?

Review answers
1 Select the graphic, and then choose Window > Links to see the graphic’s filename highlighted
in the Links panel. The graphic appears in the Links panel if it was imported by choosing File
> Place or dragged into the layout from Explorer (Windows), Finder (macOS), or Bridge.
2 Clipping paths are vector drawn paths that create a crisp, sharp edge. Photoshop images that
use transparency to remove the background create a soft, blended edge using soft-edge brushes
to paint away the background.
3 Updating a file’s link simply uses the Links panel to update the onscreen representation of a
graphic so that it represents the most recent version of the original. Relinking a selected
graphic uses the Place command to allow you to insert a different graphic in place of the
selected graphic. You might do this, for example, to replace a PNG graphic with an identical
graphic in the JPEG format.
4 In the Links panel, make sure that no alert icon is displayed for the file. If an alert icon is
displayed, you can simply select the link and click the Update Link button. If the file has been
moved, you must locate it again using the Relink button.
5 Press Shift+Ctrl (Windows) or Shift+Command (macOS) and drag to scale either larger or
smaller.
6 With the Selection tool, press Alt (Windows) or Option (macOS) and drag to the desired
location. A copy of the object is created at the new location and the original object remains in
place.

11 Creating Tables

Lesson overview
In this lesson, you’ll learn how to do the following:
Convert text to a table, import tables from other applications, and create tables from
scratch.
Change the number of rows and columns in a table.
Rearrange rows and columns.
Adjust row and column sizes.
Format tables with strokes and fills.
Specify repeating header rows for long tables.
Place graphics in table cells.
Create and apply table and cell styles.

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the files for this lesson, or go to the “Getting Started” section at the
beginning of this book and follow the instructions under “Accessing the Lesson Files and Web
Edition.” Store the files on your computer in a convenient location. Your Account page is also
where you’ll find any updates to the lessons or the lesson files. Look on the Lesson & Update
Files tab to access the most current content.

With Adobe InDesign CC, you can easily create tables, convert text to tables, and import tables from other applications. Rich
formatting options—including headers, footers, and alternating row and column patterns—can be saved as table styles and cell
styles.

Getting started
In this lesson, you’ll work on a fictional botanic gardens activity flyer designed to be attractive,
easy to use, and easy to revise. You’ll convert text to a table, and then format the table using
options in the Table menu, Control panel, and Table panel. The table will include header rows
that repeat when the table flows across multiple pages. Finally, you will create a table style and a
cell style so the formatting can be quickly and consistently applied to other tables.
1. To ensure that the preferences and default settings of your InDesign program match those
used in this lesson, move the InDesign Defaults file to a different folder following the
procedure in “Saving and restoring the InDesign Defaults file” on pages 4–5.
2. Start InDesign.

3. The InDesign Start Screen displays. Click Open at left. (If the Start Screen does not
display, choose File > Open from the InDesign menu bar.)

Note
If you have not already downloaded the project files for this lesson to your computer
from your Account page, make sure to do so now. See “Getting Started” at the
beginning of the book.

4. Open the 11_Start.indd file in the Lesson11 folder, located inside the Lessons folder within
the InDesignCIB folder on your hard disk.
5. To display the document at a higher resolution, choose View > Display Performance >
High Quality Display (if it’s not already enabled).

Note
For higher contrast in the printed manual, the screen captures in this book show the
Medium Light interface. Interface elements such as panels and dialog boxes may be
darker on your screen. 5 To ensure that the panels and menu commands match those
used in this lesson, choose Window > Workspace > [Advanced], and then choose
Window > Workspace > Reset Advanced.

6. Choose File > Save As, rename the file 11_Tables.indd, and save it in the Lesson11 folder.
7. If you want to see what the finished document looks like, open the 11_End.indd file in the
same folder. You can leave this document open to act as a guide as you work.

Creating a table
Tables are grids of individual cells set in vertical columns and horizontal rows. To create a table,
you can convert existing text into a table, insert a new table at a text insertion point in a text
frame (which adds the table to the text flow), or create a new freestanding table. Here, you will
experiment with creating a new table. You will then delete that table because the table you will
use in this exercise is created by converting text into a table.
1. With page 1 of the 11_Tables.indd document centered in the document window, choose
Table > Create Table.

Tip
If you click the table creation pointer between column guides, the new table will
span the width of the column.

2. In the Create Table dialog box, leave the default settings for Body Rows and Columns as is.
Click OK.
3. Drag the table creation pointer ( ) anywhere on the page. When you release the mouse
button, InDesign creates a table that matches the dimensions of the rectangle you draw.

4. Using the Selection tool ( ), select the text frame containing the new table you just
created.
5. Choose Edit > Clear to delete the new text frame and table.
6. Choose File > Save.

Converting text to a table
Often, the text for a table already exists in the form of “tab-delimited text,” in which the columns
of information are separated by tab characters and the rows of information are separated by
paragraph returns. In this case, the document was received from the botanic gardens in its current
state. You will select this text and convert it to a table.

Tip
Always use the Type tool to edit and format tables.

1. Using the Type tool (
IN ACTIVITIES.”

), click in the text frame starting with the words “DAILY DROP-

Note
As you work through this lesson, change the zoom level to suit your display size and
vision.

2. Choose Edit > Select All.

3. Choose Table > Convert Text To Table.
In the Convert Text To Table dialog box, you will indicate how the selected text is currently
separated. Because Hidden Characters (Type menu) is selected, you can see that the
columns of information are separated by tabs ( ) and that the rows are separated by
paragraph returns ( ).

Note
If you do not see the paragraph returns, tabs, and spaces, choose Type > Show
Hidden Characters.

4. From the Column Separator menu, choose Tab. From the Row Separator menu, choose
Paragraph.

Tip
If a table style is already created in a document, you can select it while converting
text to a table. This produces an automatically formatted table.

5. Confirm that Table Style is set to [No Table Style], and then click OK.

The new table is automatically anchored in the frame that contained the text.

6. Choose File > Save.

Importing tables
InDesign can import tables from other applications, including Microsoft Word and
Microsoft Excel. When you place a table, you can create a link to the external file. Then, if
you update the Word or Excel file, you can easily update that information in the InDesign
document.
To import a table, follow these steps:
Using the Type tool ( ), click to place an insertion point in a text frame.
Choose File > Place.
In the Place dialog box, select Show Import Options.
Select a Word file (.doc or .docx) that contains a table, or select an Excel file (.xls or
.xlsx).
5. Click Open.
6. Use the Import Options dialog box to specify how to handle the formatting in Word
tables. For Excel files, you can specify what worksheet and cell range to import along
with how to handle the formatting.
1.
2.
3.
4.

To link to tables when they are imported, you would follow these steps:
1. Choose Edit > Preferences > File Handling (Windows) or InDesign CC > Preferences
> File Handling (macOS).
2. In the Links section, select Create Links When Placing Text And Spreadsheet Files,
and then click OK.
3. If the data in the source file changes, use the Links panel to update the table in the
InDesign document.
Note that for tables to retain their InDesign-applied formatting when the Excel file is
updated, all cells in the InDesign table must be formatted with table and cell styles. Header
and footer rows must be reapplied when updating a link.

The Import Options dialog box for specifying the spreadsheet, cells, and formatting to import.

Changing rows and columns
When you start with source data from a client, you will often need to add a few rows, rearrange
text, and more to complete the table. Once a table is created, you can easily add rows and
columns, delete rows and columns, merge cells, rearrange rows, adjust row height and column
width, and specify text inset for cells. In this section, you will complete the shell of the table so
you know its size before you start formatting it.

Adding and deleting rows
You can add rows above or below a selected row. The controls for adding and deleting columns
work the same as for adding and deleting rows. Here, you will add a row to the top of the table to
contain the column descriptions.

Tip
Throughout this lesson, you will experiment with different options for selecting table
elements and modifying tables. These include using the Table menu, Table panel, and
Control panel. Once you become accustomed to working with tables, you can use the
options that work best for you.

1. Using the Type tool ( ), click in the first row of the table, which starts with “DAILY,” to
activate a cell. You can click in any cell.
2. Choose Table > Insert > Row.
3. In the Insert Row(s) dialog box, type 1 in the Number box, and click Below. Click OK to
add the row.

4. Click in the first new cell, and type Activity. To add column heads to the remaining cells,
click with the Type tool in each empty cell, or press the Tab key to navigate from cell to
cell. Type the following text in each cell, as shown:
Second cell: Day
Third cell: Time
Fourth cell: Fee

5. Using the Type tool, click in the first cell of the second row, and then drag to the right to
select all cells in the row with the new column headings.
6. Choose Type > Paragraph Styles.
7. Click Table Column Heads in the Paragraph Styles panel.

8. Click in the cell containing the word “Fee” to activate the cell.
You will insert a column to the right of this column to contain images.
9. Choose Table > Insert > Column.
10. In the Insert Column(s) dialog box, type 1 in the Number box, and click Right. Click OK to
add the column.
The table is now wider than the frame and the page; you will resolve that later.

11. Choose File > Save.

Deleting rows
You can delete selected rows and columns. Here, you will delete the blank row at the bottom of
the table.

Tip
To activate a row or column, click in it. To select multiple rows to delete, position the
Type tool on the left edge of the table until the arrow displays, then drag to select the
rows. To select multiple columns to delete, position the Type tool on the top edge of the
table until the arrow displays, then drag to select the columns.

1. Using the Type tool (

), click the left edge of the last row of the table, which is blank.

2. Choose Table > Delete > Row.
3. Choose File > Save.

Rearranging rows and columns
While working on a table, you may find that information works better in a different order, or you
may discover a mistake. In that case, you can select and drag rows or columns to a new location.

This table is in day-of-the-week order, but the Friday row is in the wrong location.

Tip
To drag and drop rows or columns, you must select the entire row or column. To drag a
copy of a row or column to a new position, press Alt (Windows) or Option (macOS)
while dragging.

1. Locate the last row of the table, which starts with “Growing.”
2. Using the Type tool ( ), move the pointer over the left edge of the “Growing” row until it
appears as a horizontal arrow ( ). Click to select the row.
3. Hover the pointer over the selected row, and then drag the “Growing Edible Flowers” row
up and drop it just under the “Tending Flowers” row. A bold blue line indicates where the
row will be inserted.

4. Choose File > Save.

Adjusting column widths, row heights, and text placement
Columns and rows, and the way text fits within them, often need fine-tuning according to the
content and the design. By default, table cells expand vertically to fit their content—so if you
keep typing within a cell, it gets taller. You can, however, specify a fixed row height or have
InDesign create columns or rows of equal size within the table. If you want columns of the same
width, rows of the same height, or both, choose Table > Distribute Columns Evenly or Table >
Distribute Rows Evenly.
In this exercise, you will manually adjust the column widths, and then you will modify how the
text fits within the cells.
1. Using the Type tool ( ), point at a vertical divider between any two columns. When the
double-arrow icon ( ) displays, drag to the left or right to resize the column.
2. Choose Edit > Undo. Experiment with resizing columns a few more times to get a feel for
the tool. Choose Edit > Undo after each move. As you drag, keep an eye on the horizontal
ruler at the top of the document window.
3. Place the final columns by dragging the right edge of each column, using the horizontal
ruler at the top of the window as a guide.
Activity column: 3.5"
Day column: 4.25"
Time column: 5.5"

Fee column: 6.25"
Blank image column: 7.75"

Tip
Dragging the cell boundary between two columns changes the size of the column
and moves the remainder of the columns out or in (depending on whether you
increase or decrease the column size). To retain the overall table width when
dragging cell boundaries, press Shift and then drag the boundary. The columns
adjoining the boundary are now increased or decreased in size while the table
dimensions remain the same.

Now that the column widths better fit the text, you will add a little space around the text in
the cells. In this case, you will change the entire table, but you can modify selected cells
only.

4. Choose Window > Type & Tables > Table to open the Table panel.
5. Click anywhere in the table, and choose Table > Select > Table.

Tip
You can click the arrows ( ) next to any field to increase or decrease its value.

6. Type .125 in in the Top Cell Inset field ( ), and press Enter (Windows) or Return
(macOS). If necessary, click Make All Settings The Same ( ) to increase the inset on all
four edges of each cell.
7. With the table still selected, click Align Center ( ) in the Table panel.
This centers the text vertically within each cell.

8. Click anywhere in the table to deselect the cells.
9. Choose File > Save.

Merging cells
You can merge adjacent selected cells to produce a single cell. Here, you will merge the cells in
the top row so the header “DAILY DROP-IN ACTIVITIES” spans the table.
1. Using the Type tool ( ), click in the first cell of the first row, and then drag to select all
the cells in the row.
2. Choose Table > Merge Cells.

Tip
The Control panel has a Merge Cells icon for easy access.

3. Choose File > Save.

Formatting a table
The border of a table is a stroke that lies outside the entire table. Cell strokes are lines within the
table that set the individual cells apart from each other. InDesign includes many easy-to-use
formatting options for tables. You can use these to make tables attractive and help them convey
information to readers. In this section, you will specify fills and strokes for the table.

Adding a fill pattern
To achieve effects such as shading every other row, InDesign provides fill patterns for both rows
and columns. You can specify where the pattern starts, which allows you to exclude any header
rows. As you add, delete, and move rows and columns, the pattern updates automatically. You
will add a fill to every other row in this table.
1. Using the Type tool ( ), click anywhere in the table to activate it.
2. Choose Table > Table Options > Alternating Fills.
3. From the Alternating Pattern menu, choose Every Other Row. Leave the default settings for
the remaining options.

4. Click OK. Every other row now has a gray background.

5. Choose File > Save.

Applying a fill color to cells
An entire table can have a fill color, and each cell can have its own fill color. Using the Type
tool, you can drag to select any contiguous cells to apply a fill color. In this section, you will
apply a fill color to the header row.
1. Using the Type tool ( ), move the pointer over the left edge of the “DAILY DROP-IN
ACTIVITIES” row until it appears as a horizontal arrow ( ). Click to select the row.
2. Choose Window > Color > Swatches.

Tip
You can use the Fill box on the Control panel to apply color to cells as well.

3. Select the Fill box ( ) in the Swatches panel, and then click the Purple Cool swatch.
4. Drag the Tint slider to 50%.

5. Choose Edit > Deselect All to view the color. Choose File > Save.

Editing cell strokes
Cell strokes are the lines around individual cells. You can remove or change the stroke for

selected cells or for the entire table. In this section, you will remove the stroke width from all the
horizontal strokes, as the alternating pattern provides enough delineation.
1. Using the Type tool ( ), click anywhere in the table, and then choose Table > Select >
Table.
2. Locate the proxy preview (
) in the center of the Control panel (at the top of the
screen).
Each horizontal and vertical line represents a row stroke, column stroke, or border stroke.
You can click the lines to toggle the selection on or off. Clicking a line on selects that
particular stroke for formatting.
3. Click all three horizontal lines in the proxy to select them. Ensure that all horizontal lines
(and no vertical lines) are selected (toggled on) on the proxy. The selected lines are darker
and blue.
4. Type 0 in the Control panel’s Stroke field. Press Enter (Windows) or Return (macOS).
5. Click all three vertical lines in the proxy to select them. Deselect the horizontal lines.
6. Select 0.5 pt from the Stroke menu on the Control panel.

7. Choose Edit > Deselect All to see the results.
8. Choose File > Save.

Adding table borders
A table border is a stroke around the entire table. As with other strokes, you can customize the
border’s width, style, color, and more. In this section, you will apply a border to the table.
1. Using the Type tool ( ), click anywhere in the table.
2. Choose Table > Select > Table.

3. Choose Table > Table Options > Table Setup. This opens the Table Options dialog box and
displays the Table Setup tab.
4. Select Preview in the lower-left corner.
5. In the Table Setup tab, in the Table Border section, choose 0.5 pt from the Weight menu.

6. Click OK, and then choose Edit > Deselect All.
7. Choose View > Screen Mode > Preview to see the results of your formatting.
8. Choose View > Screen Mode > Normal, and then choose File > Save.

Adding graphics to table cells
You can use InDesign to create effective tables that combine text, photographs, and illustrations.
By default, table cells are essentially small text frames, but you can convert a text cell to a
graphic cell. At that point, the cell essentially functions as a graphics frame whose dimensions
are governed by the table. In this exercise, you will add photos to some of the course
descriptions.

Tip
In addition to converting a cell to a graphic cell, you can anchor objects and images
within the text of a table cell.

Converting cells to graphic cells
First, you will convert a selected cell to a graphic cell using the Table menu and the Table panel.
Later, you will see how to automatically convert a cell to a graphic cell by placing an image.
1. Using the Type tool ( ), click inside the far-right cell of the table’s first body row (the
row describing Attracting Butterflies).
2. Choose Table > Select > Cell to select the cell.
3. With the cell selected, choose Table > Convert Cell To Graphic Cell.

Tip
You can convert a text cell to a graphic cell simply by placing an image in it.
However, if you are creating a template that indicates where images should be
placed, you can do this by converting the cells to graphic cells.

4. With the converted cell still selected, choose Table > Cell Options > Graphic to see the
options for positioning a graphic within a cell.
5. After viewing the options in the Graphic tab of the Cell Options dialog box, click Cancel.
6. Click inside the far-right cell in the third body row (the row describing Creating Garden
Flags). Drag to the right to select the cell.
7. If necessary, choose Window > Type & Tables > Table to display the Table panel.

Tip
To edit Cell Options or convert a graphic cell to a text cell, you must first select the
cell. To select a graphic cell with the Type tool, drag across the graphic cell.

8. Choose Convert Cell To Graphic Cell from the Table panel menu.

Placing images in graphic cells
Now, you will place images in the two cells converted to graphic cells. You will then
automatically convert two text cells to graphic cells as you place images.
1. Using the Selection tool ( ), click inside the new graphic cell in the Attracting Butterflies
row.
2. Choose File > Place. In the Place dialog box, select the Butterfly.jpg file in the Lesson11
folder.

Note
If necessary, deselect Show Import Options in the Place dialog box.

3. Select Replace Selected Item, and then click Open.

Tip
Use options in the Control panel, such as Fit Content Proportionally, to adjust the
image size and placement within the cell.

4. To fit the cell to the image, choose Object > Fitting > Fit Frame To Content.

5. Click inside the new graphic cell in the Creating Garden Flags row.

6. Choose File > Place. In the Place dialog box, select the GardenFlag.jpg file in the Lesson11
folder, and click Open.
7. To fit the cell to the image, use the keyboard shortcut for Fit Frame To Content:
Ctrl+Alt+C (Windows) or Command+Option+C (macOS).
8. Using the Type tool ( ), double-click the far-right cell in the Tending Flowers row.
9. Choose File > Place. In the Place dialog box, select the WateringCan.jpg file. Then, Ctrlclick (Windows) or Command-click (macOS) the Kite.jpg file to load the pointer with both
the WateringCan.jpg and Kite.jpg files. Click Open.

Note
If you place the wrong image in a cell, choose Edit > Undo and try again.

10. Click the loaded graphics icon ( ) in the last cell of the Making and Flying Kites row.
11. Click the loaded graphics icon in the last cell of the Tending Flowers row.
12. Using the Selection tool, click the image of the watering can and fit the cell to the image
using the keyboard shortcut or the Object > Fitting > Fit Frame To Content command.
Repeat the process for the kite image.

13. Choose File > Save.

Adjusting the row heights
The images are 1" in height, so you will now make all the table body rows 1" high.
1. If necessary, choose Window > Type & Tables > Table to open the Table panel.
2. Using the Type tool ( ), move the pointer over the left edge of the first body row until it
appears as a horizontal arrow ( ).
3. Drag from the first table body row, starting with “Attracting Butterflies,” to the last table
row, ending with “Free.”
4. With the table body rows selected, choose Exactly from the Row Height menu. Then, type
1 in in the Row Height field to the right of the menu. Press Enter (Windows) or Return
(macOS).

5. Choose Edit > Deselect All to see the results.
6. Choose File > Save.

Anchoring graphics in table cells
You can have both text and graphics in a cell by anchoring images in the text. In this exercise,
you will place a leaf icon next to the classes that are held off-campus.
1. Choose View > Fit Page In Window to center page 1 in the document window.
2. Using the Selection tool ( ), select the leaf icon immediately to the left of the header row.

3. Choose Edit > Cut.
4. Select the Type tool ( ), or double-click inside the table to automatically switch to the
Type tool.
5. In the second body row of the table, click immediately after “Illustrating Botanicals.”
6. Choose Edit > Paste.

7. Click after “Making and Flying Kites” and choose Edit > Paste.
8. Choose File > Save.

Creating a header row
A table’s name and the column headings are often formatted to stand out from the rest of the
table. To do this, you can select and format the cells that contain the header information. This
header information may need to repeat if the table flows across multiple pages. With InDesign,
you can specify header and footer rows that repeat when a table continues to the next column,
frame, or page. Here, you will format the first two rows of the table—which often contain the
table name and the column headings—and specify them as header rows that repeat.

Tip
When you edit text in a header row, the text is automatically updated in other instances of
the header row. You can edit the text in the original header only; the other instances of
the header are locked.

1. Using the Type tool ( ), move the pointer over the left edge of the first row until it
appears as a horizontal arrow ( ).
2. Click to select the entire first row, and then drag to include the second row. You will have
selected “DAILY” through “Fee.”

3.
4.
5.
6.

With the two rows still selected, choose Table > Convert Rows > To Header.
Click the Type tool in the last row of the table.
Choose Table > Insert > Row.
In the Insert Row(s) dialog box, type 4 in the Number box, and click Below. Click OK to
add the rows.

Note
You can use these new blank rows to practice typing text in cells. Remember to use
the Type tool, press Tab to jump to the next cell, and press Shift+Tab to go back to
the previous cell.

7. Choose Layout > Next Page to view the table on page 2. Notice that the continuation of the
table has the same header rows.

8. Choose Layout > Previous Page to return to page 1, and then choose File > Save.

Creating and applying table and cell styles
To quickly and consistently apply formatting to tables, you can create table styles and cell styles.
A table style applies to the entire table, whereas cell styles can be applied to selected cells, rows,
and columns. Here, you will create a table style and a cell style so the formatting can be quickly
applied in other tables.

Creating table and cell styles

In this exercise, you will create a table style for the basic table formatting and a cell style for the
header rows. Rather than specify formatting in the styles, you will simply create styles based on
the formatting of the table.

Tip
The Table panel is grouped with the Table Styles and Cell Styles panels by default.

1. Using the Type tool ( ), click anywhere in the table.
2. Choose Window > Styles > Table Styles, and then choose New Table Style from the panel
menu.

3. Name the style Activity Table in the Style Name box.

4. Click OK. The new style appears in the Table Styles panel.

5. Using the Type tool, click in the first row of the table, which says “DAILY DROP-IN
ACTIVITIES.”
6. Choose Window > Styles > Cell Styles, and then click Create New Style at the bottom of
the panel.

7. Double-click the new Cell Style 1 to open the Cell Style Options dialog box. Name the
style Table Header in the Style Name box.
You will now specify a different paragraph style for the text in cells with the Table Header
style applied.
8. From the Paragraph Style menu, select Table Head. This is the paragraph style already
applied to the text in the header rows.

9. Click OK.
10. Choose File > Save.

Applying table and cell styles
Now, you will apply the styles to the table. To make global changes to table formatting later, you
can simply edit the table or cell styles.

Tip
To automate formatting, you can specify a paragraph style for header rows within a table
style.

1. Using the Type tool ( ), click anywhere in the table.
2. Click the Activity Table style in the Table Styles panel.
3. Using the Type tool, click in the first header row of the table. Choose Table > Select > Row
to select the row.
4. Click the Table Header style in the Cell Styles panel. To see the difference, click [None] in
the Cell Styles panel. Then click Table Header again.

5. Deselect all, choose View > Fit Page In Window, and choose File > Save.
As a final step, you’ll preview the flyer in its current state. If you were going to complete
this flyer, you might enter data into the table cells in the blank rows on page 2 and add more
rows as necessary.
6. On the Application bar, select Preview from the Screen Mode menu to view the final table.

Congratulations! You have now completed this lesson.

Exploring on your own
Now that you’re skilled in the basics of working with tables in InDesign, you can experiment
with other techniques for building tables.
1. First, create a new document. The page size and other specifications do not matter.
2. Choose Table > Create Table, and enter the number of rows and columns you want. Click
OK. Click and drag to create a table of any size.
3. Using the Type tool ( ), click the insertion point in the first cell and then type. Use the
arrow keys on the keyboard to navigate among the cells.
4. To add a new column by dragging, position the Type tool over the right edge of one of the
columns in your table so that the pointer becomes a double-arrow icon ( ) and begin
dragging to the right. Hold down Alt (Windows) or Option (macOS) and drag a short
distance to the right, perhaps half an inch or so. When you release the mouse button, a new
column appears. (The column has the same width as the distance you dragged.)
5. To rotate text within a cell, click with the Type tool to place an insertion point in a cell.
Choose Window > Type & Tables > Table. In the Table panel, select the Rotate Text 270° (
) option. Then type the text you want in this cell. Increase the height of the cell as
necessary to see the text.
6. To convert the table to text, choose Table > Convert Table To Text. Tabs can separate what
were previously columns, and paragraph breaks can separate rows. You can also modify
these options. Similarly, you can convert tabbed text to a table by selecting the text and
choosing Table > Convert Text To Table.

Review questions
1 What are the advantages of using tables rather than just typing text and using tabs to separate
the columns?
2 How can you ensure that a table’s title and column headings repeat if a table continues on
multiple pages?
3 What tool is used most frequently when you work with tables?

Review answers
1 Tables give you much more flexibility and are far easier to format. In a table, text can wrap
within a cell, so you don’t have to add extra lines to accommodate cells that contain a lot of
text. Also, you can assign styles to selected cells, rows, and columns—including character
styles and even paragraph styles—because each cell functions like a separate text frame.
2 Select the heading rows you want to repeat and then select Table > Convert Rows > To
Header. You can also repeat footer rows using Table > Convert Rows > To Footer.
3 The Type tool must be selected to work with a table. You can use other tools to work with the
graphics within table cells, but to work with the table itself, such as selecting rows or columns,
inserting text or graphics, adjusting table dimensions, and so forth, you use the Type tool.

12 Working with Transparency

Lesson overview
In this lesson, you’ll learn how to do the following:
Colorize an imported grayscale image.
Change the opacity of objects drawn in InDesign.
Apply transparency settings to imported graphics.
Apply transparency settings to text.
Apply blending modes to overlapping objects.
Apply feathering effects to objects.
Add a drop shadow to text.
Apply multiple effects to an object.
Edit and remove effects.

This lesson will take about 75 minutes to complete. Please log in to your account on
peachpit.com to download the files for this lesson, or go to the “Getting Started” section at the
beginning of this book and follow the instructions under “Accessing the Lesson Files and Web
Edition.” Store the files on your computer in a convenient location. Your Account page is also
where you’ll find any updates to the lessons or the lesson files. Look on the Lesson & Update
Files tab to access the most current content.

Adobe InDesign CC offers an array of transparency features to feed your imagination and creativity. These include controls over
opacity, special effects, and color blends. You can also import graphic files that use transparency and apply additional
transparenc y effects.

Getting started
The project for this lesson is the cover of a menu for a fictional restaurant, Edible Blossoms
Bistro & Bar. By applying transparency effects and using multiple layers, you’ll create a visually
rich design.

Note
If you have not already downloaded the project files for this lesson to your computer
from your Account page, make sure to do so now. See “Getting Started” at the beginning
of the book.

1. To ensure that the preferences and default settings of your InDesign program match those
used in this lesson, move the InDesign Defaults file to a different folder following the
procedure in “Saving and restoring the InDesign Defaults file” on pages 4–5.
2. Start InDesign. To ensure that the panels and menu commands match those used in this
lesson, choose Window > Workspace > [Advanced], and then choose Window >

Workspace > Reset Advanced. To begin working, you’ll open an InDesign document that is
already partially completed.
3. Choose File > Open, and open the 12_Start.indd file in the Lesson12 folder, which is
located within the Lessons folder in the InDesignCIB folder on your hard drive.
4. Choose File > Save As, name the file 12_Menu.indd, and save it in the Lesson12 folder.
The menu appears as a long, blank page because all the layers that contain objects are
currently hidden. You’ll reveal these layers one by one as you need them, so it will be easy
to focus on the specific objects and tasks in this lesson.
5. To see what the finished project looks like, open the 12_End.indd file in the Lesson12
folder.

6. When you are ready to start working, either close the 12_End.indd file or leave it open for
your reference. Then return to your lesson document by choosing 12_Menu.indd from the
Window menu or clicking the 12_Menu.indd tab in the upper-left corner of the document
window.

Importing and colorizing a grayscale image
You’ll begin by working with the Background layer for the restaurant menu. This layer serves as
a textured background visible through the objects above it that have transparency effects. By
applying transparency effects, you can create see-through objects that reveal any objects
underneath.
Because nothing is below the Background layer in the layer stack, you won’t apply any
transparency effects to objects on this layer.
1. Choose Window > Layers to display the Layers panel.
2. In the Layers panel, select the layer labeled Background, scrolling as necessary to find it at
the bottom of the layer stack. You’ll place the image you import on this layer.
3. Make sure that the two boxes to the left of the layer name show that the layer is visible (the

eye icon [

] appears) and unlocked (the layer lock icon [

] does not appear).

The pen icon ( ) to the right of the layer name indicates that this is the layer on which the
imported objects will be placed and new frames will be created.

4. Choose View > Grids & Guides > Show Guides. You’ll use the guides on the page to align
the background image that you import.

Tip
TIFF stands for Tagged Image File Format, a common bitmap graphic format often
used for print publishing. TIFF files use the .tif file extension.

5. Choose File > Place, and then open the 12_Background.tif file in your Lesson12 folder.
This file is a grayscale TIFF.
6. Move the loaded raster graphics icon ( ) slightly outside the upper-left corner of the page;
then click the corner where the red bleed guides meet so that the placed image fills the
entire page, including the margins and bleed area. Keep the graphics frame selected.

7. Choose Window > Color > Swatches or click the Swatches icon in the panel to the right of
the document. You’ll use the Swatches panel to colorize the graphics frame and the image.
8. In the Swatches panel, select Fill color ( ). Scroll down the list of swatches to find the
Green-Bright-Medium swatch and select it. Click the arrow to the right of the Tint box, and
drag the slider to 80%.

Tip
InDesign offers many convenient ways to apply colors. You can also double-click
the Fill box at the bottom of the Tools panel, and you can choose a fill color from
the Fill menu in the Control panel.

The white background of the graphics frame is now a 80% tint of the green color, but the
gray areas of the graphic remain unchanged.

After applying a fill color and tint to the frame.

9. Using the Direct Selection tool ( ), move the pointer within the frame. When the hand
pointer ( ) appears, click to select the graphic instead of the frame, and then select GreenMedium in the Swatches panel. Green-Medium replaces gray in the image, leaving the fill
color for the frame unchanged. Set the tint of the image color to 73%.

After applying a fill color and tint to the frame.

InDesign lets you apply color to grayscale or bitmap images saved in PSD, TIFF, BMP, or
JPEG format. When you select the graphic within a graphics frame and then apply a fill
color, the color is applied to the gray portions of the image rather than to the background of
the frame, as it was in step 8, when the frame was selected.
10. In the Layers panel, click the empty box to the left of the Background layer name to lock
the layer. Leave the Background layer visible so that you can see the results of the
transparent objects you will be placing above this layer.

11. Choose File > Save to save your work.
You’ve just learned a quick method for colorizing a grayscale image. While this method works
well for creating composites, you may find the color controls available in Adobe Photoshop CC
more effective for creating your final artwork.

Applying transparency settings
InDesign has extensive transparency controls. For example, by lowering the opacity of objects,
text, and even imported graphics, you can reveal underlying objects that would otherwise not be
visible. Additional transparency features, such as blending modes, drop shadows, feathered and
glowing edges, and bevel and emboss effects, provide a wide range of options for creating
special visual effects. You’ll learn about these additional features later in the lesson.

Tip
Applying a blending mode lets you vary the ways in which the colors of overlapping
objects blend with each other.

In this part of the project, you’ll practice using a variety of transparency features on several
objects placed on the various layers in the menu.

About the Effects panel
You use the Effects panel (Window > Effects) to specify the opacity and blending mode of
objects and groups, apply a transparency effect, isolate blending to a particular group, and knock
out objects in a group.

Effects panel overview
Blending mode—Specifies how colors in transparent objects interact with the objects
behind them.
Opacity—Determines the opacity of an object, stroke, fill, or text, from 100% (completely
opaque) to 0% (completely transparent). As you lower the opacity value of an object, the
object becomes increasingly translucent and underlying objects become increasingly visible.
Levels—Indicates the opacity settings and any transparency effects applied to the selected
page element—for example, an object’s stroke may have 20% opacity and an effect applied,
while the fill has no transparency settings. Click the triangle to the left of the word Object
(or Group or Graphic) to hide or display these level settings. The FX icon appears on a level
after you apply transparency settings there, and you can double-click the FX icon to edit the
settings.
Clear effects—Clears effects (object, stroke, fill, or text) from an object, sets the blend
mode to Normal, and changes the Opacity setting to 100% throughout the object—that is,
removes all transparency.
FX button—Displays a list of transparency effects.
Delete—Removes effects, but not a blending mode or opacity, from an object.
Isolate Blending—Applies a blending mode to a selected group of objects.
Knockout Group—Makes the opacity and blending attributes of every object in a group
knock out, or block out, underlying objects in the group.
— Adapted from InDesign Help

Changing the opacity of solid-color objects

With the background graphic complete, you can start applying transparency effects to objects on
layers stacked above it. You’ll start with a series of simple shapes that were drawn using
InDesign.
1. In the Layers panel, select the Art1 layer so that it becomes the active layer, and click the
lock icon ( ) to the left of the layer name to unlock the layer. Click the empty box on the
far left of the Art1 layer name so that the eye icon ( ) appears, indicating that the layer is
now visible.

2. Using the Selection tool ( ), click the full circle filled with the Red-Dark swatch in the
center of the page. This ellipse frame with a solid fill was drawn in InDesign.
3. Choose Window > Effects to display the panel or click on the Effects icon in the panel to
the right of the document.

Note
The shapes mentioned are named by the color swatch applied to the fill of the object.
If the Swatches panel is not open, choose Window > Color > Swatches to open it.

4. In the Effects panel, click the arrow on the right side of the Opacity percentage. An Opacity
slider adjustment appears. Drag the slider to 70%. Alternatively, enter 70% in the Opacity
box and press Enter or Return.

After you change the opacity of the Red-Dark circle, it becomes translucent, and the
resulting color is a combination of the Red-Dark fill of the circle and the rectangle below it
that covers the right half of the page, as well as the background image.

5. Select the Green-Brightest–filled semicircle in the upper-left area of the page, and then go
to the Effects panel and set the Opacity value to 50%. The semicircle now appears as a
subtle variation in color against the background.

6. Repeat step 5 for the following two circles on the Art1 layer, using the following settings to
change the opacity of each circle:
Left side circle filled with the Green-Medium swatch, Opacity = 60%
Upper right circle filled with the Purple-Warm swatch, Opacity = 70%
7. Choose File > Save to save your work.

Applying a blending mode
Changing an object’s opacity creates a color that combines the color applied to an object with the
colors applied to objects below it. Using blending modes is a way to change how the colors in
stacked objects interact.
In this procedure, you’ll apply a blending mode to objects on the page.
1. Using the Selection tool ( ), select the circle filled with the Red-Dark swatch in the center
of the page.
2. In the Effects panel, choose Overlay from the Blending Mode menu. Notice how the
appearance of the colors changes.

3. Select the Green-Brightest–filled semicircle in the upper-left corner of the page. In the
Effects panel, choose Multiply from the Blending Mode menu.

4. Choose File > Save.
For more information on the different blending modes, see “Specify how colors blend” in
InDesign Help.

Adding transparency effects to imported vector and bitmap
graphics
So far in this lesson, you have applied various transparency settings to objects drawn using
InDesign. You can also apply opacity values and blending modes to imported graphics created
with other applications, such as Adobe Illustrator and Adobe Photoshop.

Applying transparency to a vector graphic
1. In the Layers panel, select the Art2 layer. Unlock this layer and make it visible.
2. In the Tools panel, choose the Selection tool ( ). On the left side of the page, select the
graphics frame that contains the black spiral image by clicking within the frame. This frame
is in front of a Green-Medium–colored circle.
3. With the black spiral frame still selected, hold down the Shift key and click to select the
graphics frame that contains a black spiral on the right side of the page. This frame is in
front of and within a Purple-Cool–colored circle. Both of the graphics frames with spirals
should now be selected.
4. In the Effects panel, choose Color Dodge from the Blending Mode menu and set the
Opacity value to 30%.

Note
The effects display more clearly when you use High Quality Display. However, this
may slow down your computer. To set the whole document to High Quality Display,
choose View > Display Performance > High Quality Display. To set High Quality
Display on individual objects, choose Object> Display Performance > High Quality
Display while that object is selected.

Next you will apply a blending mode to the stroke around the salad image.
5. With the Selection tool ( ), select the circular graphics frame with the salad image in the
center of the page.
6. In the Effects panel, click Stroke (beneath Object) to select it. Selecting the Stroke level
applies any blending mode or opacity changes you make only to the stroke of the selected
object.
A level indicates the Object, Stroke, Fill, and Text opacity settings of the selected object
and the applied blending mode, as well as whether transparency effects have been applied.
This means you can apply different transparency effects to the stroke or fill or text of the
same object. You can hide or display these level settings by clicking the triangle to the left
of the word Object (or Group or Graphic, depending on the selection).
7. From the Blending Mode drop-down menu, choose Hard Light. Notice how the result is
different when the stroke is over different backgrounds

8. Choose Edit > Deselect All, and then choose File > Save to save your work.

Applying transparency to a bitmap graphic
Next you’ll apply transparency effects to an imported bitmap graphic. Although this example
uses a monochromatic image, you can also apply transparency settings to multicolor
photographs. The process is the same as applying transparency effects to any other InDesign
object.
1. In the Layers panel, select the Art3 layer. Unlock this layer and make it visible. You can
hide or lock either the Art1 layer or the Art2 layer to make it easier to work. Be sure to
keep at least one underlying layer visible so that you can see the results of the transparency
interactions.

2. Using the Selection tool ( ), select the graphics frame with the black starburst image in
the center of the page. Because it’s on the Art3 layer, the frame edge is displayed in blue,
the color of the layer.
3. In the Effects panel, enter 70% as the Opacity value and press Enter or Return.

4. Double-click within the black starburst image to select the content rather than the frame, or
select the content with the Direct Selection tool ( ). When the content is selected rather
than the frame, the handles show the size of the content, and change to a color opposite of
the layer color.
5. In the Swatches panel, select Fill color ( ), and then select the Red-Bright color swatch so
that red replaces the black areas of the image.
6. In the Effects panel, choose Screen from the Blending Mode menu and leave the Opacity
value at 100%. The starburst changes colors based on the layers visible beneath it.

7. Choose Edit > Deselect All, and then choose File > Save to save your work.

Importing and adjusting Illustrator files that use transparency
When you import Adobe Illustrator (.ai) files into an InDesign layout, InDesign recognizes and
preserves any transparency settings that were applied in Illustrator. You can also adjust opacity,
add a blending mode, and apply additional transparency effects in InDesign.
Now you will place an image of some drinking glasses, and then adjust its transparency.
1. Choose View > Fit Page In Window.
2. In the Layers panel, make sure that the Art3 layer is the active layer and that the Art3, Art2,

Art1, and Background layers are visible (

).

3. Lock the Art2, Art1, and Background layers to prevent them from being modified.
4. Select the Selection tool ( ) in the Tools panel, and then choose Edit > Deselect All to
ensure that the image you import is not placed into a selected frame.

Tip
To enable Show Import Options without selecting the option in the Place dialog box,
select the graphic to import; then press the Shift key and click Open.

5. Choose File > Place. Select Show Import Options at the bottom of the Place dialog box.
(You might have to click the Options button to see this choice.)
6. Locate the 12_Glasses.ai file in your Lesson12 folder, and double-click or click Open.
7. In the Place PDF dialog box, choose Bounding Box (All Layers) from the Crop To menu,
and make sure that Transparent Background is selected.

8. Click OK. The dialog box closes, and the pointer becomes a loaded vector graphics icon (
) with a preview of the file.

Tip
When repositioning the image, Smart Guides can help you center the image
perfectly within the purple circle.

9. Position the loaded vector graphics icon ( ) within the Purple-Cool–colored circle on the
right side of the page, and then click to place the graphic at full size. Drag the graphics
frame to center it visually within the purple circle. Smart Guides are displayed when the
frame is centered.

10. In the Layers panel, click to hide the Art2, Art1, and Background layers so that only the
Art3 layer is visible, and you can view the placed image on its own and see the transparent
color interactions within the Illustrator image itself (with no effects applied in InDesign).

Tip
To show only the Art3 layer and hide all other layers, Alt-click (Windows) or
Option-click (macOS) the Toggle Visibility icon for the Art3 layer in the Layers
panel.

11. Click to redisplay the Art2, Art1, and Background layers. Notice that the white “olive”
shape is completely opaque, whereas the other shapes of the drinking glasses are partly
transparent.
12. With the glasses image still selected, change the Opacity setting in the Effects panel to
60%. Keep the image selected.
13. In the Effects panel, choose Color Burn from the Blending Mode menu. Now the colors and
interactions of the image take on a completely different appearance.
14. Choose Edit > Deselect All, and then choose File > Save.

Applying transparency settings to text
Changing the opacity of text is as easy as applying transparency settings to graphic objects in
your layout. You’ll try the technique now as you change the color of text.
1. In the Layers panel, lock the Art3 layer, and then unlock the Type layer if necessary, and
make it visible.
2. In the Tools panel, select the Selection tool ( ) and then click the text frame “URBAN
OASIS GARDENS.” If necessary, zoom in so that you can read the text easily.

To apply transparency settings to text or to a text frame and its contents, you must select the
frame with the Selection tool. You cannot specify transparency settings when text is
selected with the Type tool.
3. In the Effects panel, select the Text level so that any opacity and blending mode changes
you make will apply to the text only.
4. Choose Overlay from the Blending Mode menu and change the Opacity to 70%.

5. Double-click the Hand tool to fit the page in the window, and then choose Edit > Deselect
All.
Now you’ll change the opacity of a text frame’s fill.
1. Using the Selection tool ( ), click the text frame at the bottom of the page that contains
“Breakfast | Lunch | Dinner | Events | Catering.” If necessary, zoom in so that you can read
the text easily.
2. Select the Fill level in the Effects panel and change Opacity to 70%. Notice that this
changes the white background while the text remains black.

3. Try the same effect with the Object level selected, and notice how this time the text turns
gray as well, which is not what we want. This demonstrates the advantage of the ability to
apply effects to different parts of the same object. Choose Edit > Undo Set Transparency
Parameters.
4. Choose Edit > Deselect All, and then choose File > Save.

Working with effects
So far in this lesson, you’ve learned how to apply transparency by changing the blending mode
and the opacity of objects drawn in InDesign, imported graphics, and text. Another way to apply
transparency is by using the nine transparency effects in InDesign. Many of the settings and
options for creating these effects are similar.

You’ll try some of these effects now, as you fine-tune the menu’s artwork.

Transparency effects
Drop Shadow—Adds a shadow that falls behind the object, stroke, fill, or text.
Inner Shadow—Adds a shadow that falls just inside the edges of the object, stroke, fill, or
text, giving it a recessed appearance.
Outer Glow and Inner Glow—Add glows that emanate from the outside or inside edges of
the object, stroke, fill, or text.
Bevel and Emboss—Adds various combinations of highlights and shadows to give text and
images a three-dimensional appearance.
Satin—Adds interior shading that makes a satiny finish.
Basic Feather, Directional Feather, and Gradient Feather—Soften the edges of an object
by fading them to transparent.
—From InDesign Help

Applying a basic feather to the edges of an image
Feathering is another way to apply transparency to an object. Feathering creates a subtle
transition from opaque to transparent around the edge of an object so that any underlying object
or the page background is visible through the feathered area. InDesign features three types of
feathering:
Basic Feather softens or fades the edges of an object over a distance that you specify.
Directional Feather softens the edges of an object by fading the edges to transparent from
directions that you specify.
Gradient Feather softens the areas of an object by fading them to transparent.
First, you’ll apply Basic Feather, and then you’ll move on to Gradient Feather.
1. In the Layers panel, unlock the Art1 layer if it’s locked.
2. If necessary, choose View > Fit Page In Window to see the entire page.
3. Select the Selection tool ( ), and then select the Purple-Warm–filled circle on the upper-

right side of the page.
4. Choose Object > Effects > Basic Feather. The Effects dialog box appears, displaying a list
of the transparency effects on the left and an accompanying set of controls on the right.
5. In the Options section of the Effects dialog box, set these options:
In the Feather Width box, type 0.375 in.
Change both the Choke value and Noise value to 10%.
Leave the Corners option set at Diffused.
6. Make sure that Preview is selected and, if necessary, move the dialog box to view the
effects of your changes. Notice how the edges of the purple circle are now blurred.

7. Click OK to apply the settings, and close the Effects dialog box.
8. Choose File > Save.

Applying a gradient feather
You can use the Gradient Feather effect to fade an object from opaque to transparent.
1. Using the Selection tool (
the right half of the page.

), click the Purple-Warm–filled vertical rectangle that covers

Note
In addition to applying transparency effects by choosing Object > Effects and then
choosing an option from the submenu, you can add effects from the Effects panel
menu, or you can click the FX button at the bottom of the Effects panel and then
choose an option from the submenu.

2. At the bottom of the Effects panel, click the FX button (
from the menu.

) and choose Gradient Feather

The Effects dialog box appears, displaying Gradient Feather options.

3. In the Gradient Stops section of the Effects dialog box, click the Reverse Gradient button (
) to reverse the solid and transparent colors.

4. Click OK. The purple rectangle should fade to transparent from right to left.
Now you will use the Gradient Feather tool to adjust the direction of the fade.
5. In the Tools panel, select the Gradient Feather tool ( ). (Be careful not to choose the
Gradient Swatch tool.) Hold down the Shift key, and drag the pointer from the bottom to
about two-thirds up to the top of the rectangle to change the gradient direction. The Shift
key constrains the direction to exactly vertical.

6. Choose Edit > Deselect All, and then choose File > Save.
Next, you will apply multiple effects to a single object and then edit them.

Adding a drop shadow to text
When you add a drop shadow to an object, the result is a 3D effect that makes the object appear
to float above the page and cast a shadow on the page and objects below. You can add a drop
shadow to any object, and you have the option to assign a shadow independently to an object’s
stroke or fill or to the text within a text frame.

Note
The Effects dialog box allows you to apply multiple effects to a single object and shows
you which effects are applied to a selected object (indicated by a check mark on the left
side of the dialog box).

Now you’ll try this technique by adding a drop shadow to the “edible blossoms” text. It’s
important to note that effects can only be applied to a whole text frame, not to some of the words
within a frame.
1. Using the Selection tool ( ), select the text frame that contains the words “edible
blossoms.” Hold down the Z key to temporarily access the Zoom tool, or select the Zoom
tool ( ) and magnify the frame so that you can see the text clearly.
2. At the bottom of the Effects panel, click the FX button ( ), and choose Drop Shadow
from the menu.
3. In the Blending section of the Effects dialog box, enter 55% for Opacity. In the Options
section, enter 0.125 in for Size and 20% for Spread. Make sure that Preview is selected so
that you can see the effects on your page.

4. Click OK to apply the drop shadow to the text.
5. Choose File > Save to save your work.

Applying multiple effects to an object
You can apply several different types of transparency effects to an object. For example, you can
create the impression that an object is embossed and that it has a glow around it by applying two
transparency effects.
In this exercise, you’ll apply an embossed effect and an outer glow effect to two vector objects
on the page.
1. Choose View > Fit Page In Window.
2. Using the Selection tool ( ), select the Green-Brightest–filled semicircle in the upper-left
corner of the page.
3. At the bottom of the Effects panel, click the FX button ( ), and choose Bevel And
Emboss from the menu.
4. In the Effects dialog box, make sure that Preview is selected so that you can view the
effects on the page. Then specify the following settings in the Structure section:
Size: 0.3125 in
Soften: 0.3125 in
Depth: 30%

5. Leave the rest of the settings as they are, and keep the Effects dialog box open.
6. On the left side of the dialog box, click the check box to the left of Outer Glow to add an
outer glow effect to the semicircle.
7. Click the words Outer Glow to edit the effect, and specify these settings:
Mode: Multiply
Opacity: 80%
Size: 0.25 in
Spread: 10%

8. Click the Set Glow Color box to the right of the Mode menu. In the Effect Color dialog
box, make sure that Swatches is selected in the Color menu, choose Black from the list of
colors, and then click OK.

9. Click OK to apply the settings for the multiple effects.
Next, you will apply the same effects to the other semicircle on the page, simply by
dragging the FX icon from the Effects panel to the semicircle.

Copying effects between objects
1. Double-click the Hand tool ( ) to fit the page in the window.
2. Using the Selection tool ( ), select the green semicircle in the upper-left corner of the
page, if necessary.
3. With the Effects panel open, drag the FX icon ( ) on the right side of the Object level to
the page and directly on top of the small green circle to the left of the semicircle with the
multiple effects.

Tip
You can also open the Effects dialog box by double-clicking the FX icon to the right
of the Object level in the Effects panel.

4. Choose Edit > Deselect All, and then choose the Preview view to see the results without
guides and frame edges.
5. Choose File > Save.
You can also use this same technique to apply effects to objects in other documents.
1. Go to File > Open and open the file 12_Start.indd again.
2. Go to Window > Arrange > Tile so that you can see both files side by side.

3. In the file 12_Start.indd, navigate to page 2 and then make sure that the Background layer
is active (since it is already unlocked).

Transparency settings and options
Many transparency effect settings and options are the same across different effects.
Common transparency settings and options include the following:
Angle and Altitude—Determines the lighting angle at which a lighting effect is
applied. A setting of 0 is equivalent to ground level; 90 is directly above the object.
Click the angle radius or enter a degree measurement. Select Use Global Light if you
want a uniform lighting angle for all objects.
Blending Mode—Specifies how colors in transparent objects interact with the objects
behind them.
Choke—Along with the Size setting, determines how much of the shadow or glow is
opaque and how much is transparent; large settings increase opacity and small settings
increase transparency.
Distance—Specifies the offset distance for the Drop Shadow, Inner Shadow, or Satin
effect.
Noise—Specifies the amount of random elements in the opacity of a glow or shadow
as you enter a value or drag the slider.
Opacity—Determines the opacity of an effect; drag the slider or enter a percentage
measurement.
Size—Specifies the amount of shadow or glow.
Spread—Determines the transparency of the blur within the shadow or glow effect as
established by the Size setting. A higher percentage makes the blur more opaque.
Technique—These settings determine how the edge of a transparency effect interacts
with background colors. Softer and Precise are available for the Outer Glow and Inner
Glow effects:
Softer—Applies a blur to the edge of the effect. At larger sizes, doesn’t preserve
detailed features.
Precise—Preserves the edge of the effect, including its corners and other sharp
details. Preserves features better than the Softer technique.
Use Global Light—Applies the global light setting to the shadow.
X Offset and Y Offset—Offsets the shadow on the x- or y-axis by the amount you
specify.
—From InDesign Help

4. Draw a shape, such as a rectangle or ellipse frame, with one of the drawing tools, and

choose a color for the fill from the Swatches panel.
5. Click back on the 12_Menu.indd file and select the Green-Brightest–filled semicircle in the
upper-left corner of the page, which now has multiple effects applied.
6. Use the same technique as in step 3 of the previous procedure: With the Effects panel open,
drag the FX icon ( ) on the right side of the Object level, and drop it directly on top of the
shape you just drew.

7. Close the 12_Start.indd file without saving.
Another way to apply effects to other objects is to create an object style, as you learned in
Lesson 9.

Editing and removing effects
Applied effects can easily be edited or removed. You can also quickly check whether any effects
have been applied to an object.
First you’ll edit the gradient fill behind the restaurant title, and then you’ll remove the effects
applied to one of the circles.
1. In the Layers panel, make sure that the Art1 layer is unlocked and that it is visible.
2. Using the Selection tool ( ), click the frame with the gradient fill that’s behind the text
“edible blossoms.”
3. Go to Window > Properties to display the Properties panel. One of the properties available
is Effects. In this case, the effect is Gradient Feather, which is displayed with an underline
to the right of the FX button ( ). Click it, and the Effects panel opens. In the menu that
appears, the Gradient Feather effect has a check mark next to it, which indicates that it is
already applied to the selected object.

Tip
To quickly see which pages in your document contain transparency, choose Panel
Options from the Pages panel menu, and then select Transparency. A small icon ( )
is displayed next to any pages containing transparency.

4. In the Effects dialog box, under Gradient Stops, click the color stop (the small black

square) at the left end of the gradient ramp. Change the Opacity to 80%.

When not to use transparency
Transparency vs. Tints: Transparency effects are great creative tools, but they do
result in a more complex file. They should be used purposefully, and not used when
the visual style can be accomplished more simply.
The most common place this happens is when you want to make the color of a frame
lighter and that frame has nothing behind it that needs to show through, such as on a
white background. In those cases you should use a tint of the color, not an Opacity
setting. Use the slider in the Color panel or the Swatches panel, or use a tint swatch.
See Lesson 8 for more details on tints.

Tip
If you like to use the sliding function of the Opacity slider to see a color change
before making a choice, note that you can also use the same slider functionality in
the Color panel to create a tint. The only difference is that you must release the
mouse as you move along the slider to see the change.

5. Click OK to update the Gradient Feather effect.
Now you will remove all of the effects applied to an object.
1. In the Layers panel, turn on visibility for all layers and unlock all layers.

Tip
When you hold down the Ctrl key (Windows) or Command key (macOS) and click
overlapping objects, the first click selects the topmost object, and each successive
click selects the next object below in the stacking order.

2. Select the Selection tool ( ). While holding down the Ctrl key (Windows) or Command
key (macOS), click the small Purple-Warm circle to the right and below the salad image in
the center of the page. Your first click may select the rectangular frame above the circle.
Click again a bit farther to the right within the small circle to select it. Or, lock the Art3
layer (the larger rectangle is on this layer) to more easily work with objects on the Art2
layer below.
3. In the Effects Panel flyout menu, choose Clear Effects. This will remove the Drop Shadow
effect applied to the circle, while leaving the Opacity setting applied.

Note
The Clear Effects button also removes blending mode and opacity setting changes
from the object.

4. Choose File > Save.
Congratulations! You have completed the lesson.

Exploring on your own
Try some of the following ways of working with InDesign transparency options:
1. Scroll to a blank area of the pasteboard and create some shapes (by using the drawing tools
or by importing new copies of some of the image files used in this lesson) on a new layer.
Apply fill colors to any shapes that don’t have content, and position your shapes so that
they overlap each other, at least partially. Then:
Select the uppermost object in your arrangement of shapes. Using the controls in the
Effects panel, experiment with other blending modes, such as Luminosity, Hard
Light, and Difference. Then select a different object and choose the same blending
modes in the Effects panel to compare the results.
In the Effects panel, change the Opacity value of some of the objects but not others.
Then select different objects in your arrangement and use the Object > Arrange >
Send Backward and Object > Arrange > Bring Forward commands to observe
different results.
Experiment with combinations of different opacities and different blending modes
applied to an object. Do the same with other objects that partially overlap the first
object to explore the variety of effects you can create.
2. In the Pages panel, double-click page 1 to center it in the document window. Open the
Layers panel and then click the eye icon for the different Art layers one at a time to see the
differences this creates in the overall effect of the layout.
3. In the Layers panel, make sure that all the layers are unlocked. In the layout, click the
image of the glasses to select it. Use the Effects panel to apply a drop shadow.
4. Select the red flower on the lower-left side of the page. This shows another use of the Bevel
and Emboss effect. Open the Effects panel and experiment with different settings.

Review questions
1 How do you change the color of the white areas of a grayscale image? How do you change the
gray areas?
2 If you’ve applied transparency effects to an object, what is the easiest way to apply the same
effects to a different object?
3 What is the importance of the stacking order of layers and of objects within layers when you
work with transparency?
4 What’s the quickest and easiest way to remove transparency effects from an object to which
multiple effects are applied?
5 What is a limitation of applying effects to text?
6 When is it better to use a tint instead of an opacity setting?

Review answers
1 To change the white areas, select the graphics frame with the Selection tool, click the Fill box

in the Tools panel or Swatches panel, and then select a color in the Swatches panel. To change
the gray areas, select the content within the frame by clicking the content grabber, and then
select a color from the Swatches panel.
2 Select the object to which you’ve applied transparency effects, and then drag the FX icon
displayed on the right side of the Effects panel to another object.
3 The transparency of an object affects the view of objects below (behind) it in the stacking
order. For example, objects below a semitransparent object can be seen behind it—like objects
behind a colored plastic film. An opaque object blocks the view of the area behind it in the
stacking order, regardless of whether the objects behind it have reduced opacity values,
feathering, blending modes, or other effects.
4 Select the object, and then click the Clear Effects button at the bottom of the Effects panel.
5 Effects can only be applied to the entire text frame. They cannot be applied to separate words
within a text frame.
6 When the object has nothing below it with which a transparency effect will interact, such as
when it’s on top of a white background. In other words, if you simply want to make the object
lighter, and not have anything behind show through, use a tint.

13 Printing and Exporting

Lesson overview
In this lesson, you’ll learn how to do the following:
Check a document for potential printing issues.
Manage the colors used in a document.
Confirm that an InDesign file and all of its elements are ready for printing.
Preview a document onscreen before printing.
Create different Adobe PDFs for proofing and for press.
Create an Adobe PDF preset for press-ready PDFs.
Print a proof of a document.
Create a print preset to streamline the printing process.
Assemble all necessary files for printing or delivery to a service provider or commercial
printer.

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the files for this lesson, or go to the “Getting Started” section at the
beginning of this book and follow the instructions under “Accessing the Lesson Files and Web
Edition.” Store the files on your computer in a convenient location. Your Account page is also
where you’ll find any updates to the lessons or the lesson files. Look on the Lesson & Update
Files tab to access the most current content.

Adobe InDesign CC provides advanced print-preparation and printing controls to help you manage the printing process,

regardless of the output device. You can easily output your work to a laser or inkjet printer, a screen proof PDF, a press-ready
PDF, or a computer-to-plate imaging device.

Getting started
In this lesson, you’ll do some print-preparation work on a magazine cover that contains a fullcolor image and also uses a spot color. The document will be printed on a color inkjet or laser
printer for proofing and also on a high-resolution imaging device, such as a platesetter used in
offset printing. Prior to printing, you will export the document to a PDF file that can be used in a
review process.
1. To ensure that the preferences and default settings of your InDesign program match those
used in this lesson, move the InDesign Defaults file to a different folder following the
procedure in “Saving and restoring the InDesign Defaults file” on pages 4–5.
2. Start InDesign. To ensure that the panels and menu commands match those used in this
lesson, choose Window > Workspace > [Printing And Proofing], and then choose Window
> Workspace > Reset Printing And Proofing.

Note
If you have not already downloaded the project files for this lesson to your computer
from your Account page, make sure to do so now. See “Getting Started” at the
beginning of the book.

3. Choose File > Open and open the 13_Start.indd file in the Lesson13 folder, located inside
the Lessons folder within the InDesignCIB folder on your hard drive.
4. An alert message informs you that the document contains missing and modified links. Click
Don’t Update Links. You will correct these problems later in this lesson.
When you print an InDesign document or export a PDF file for printing, InDesign must
access the original artwork that was placed in the layout. If imported artwork has been
moved, graphic filenames have changed, or the original files are no longer available,
InDesign alerts you that the original artwork cannot be located or has been modified. This
alert appears when a document is opened, printed, exported, or checked for printing using
the Preflight panel. InDesign shows the status of all files necessary for printing in the Links
panel.
5. Choose File > Save As, rename the file 13_Press.indd, and save it in the Lesson13 folder.
6. To see what the finished project looks like, open the 13_End.indd file in the Lesson13
folder. For this lesson, the difference between the Start and End files is not visible in a
preview; instead, you’ll need to examine the Links and Color Swatches panels to see the
differences.
7. When you are ready to start working, either close the 13_End.indd file or leave it open for
your reference. Then return to your lesson document by choosing 13_Press.indd from the
Window menu or by clicking the 13_Press.indd tab in the upper-left corner of the document

window.

Preflighting files
InDesign provides controls for performing a quality check on a document prior to printing,
handing off the document to a print service provider, or publishing to a digital format. Preflight
is the standard industry term for this process. In “Preflighting as you work,” in Lesson 2, you
learned how you can take advantage of the live preflight capabilities in InDesign. This lets you
monitor a document as you create it to prevent potential printing problems.
You can use the Preflight panel to confirm that all graphics and fonts used in the file are
available for printing and exporting and that there are no instances of overset text. Here, you’ll
use the Preflight panel to identify a pair of missing graphics and overset text in the sample
layout.
1. Choose Window > Output > Preflight, or click the Preflight button ( ) on the panel dock.
2. In the Preflight panel, make sure that On is selected and confirm that [Basic] (working) is
selected in the Profile menu. Notice that two types of errors are listed, LINKS and TEXT.
The number following in parentheses indicates two link-related errors and one text-related
error.

Tip
You can also access the Preflight panel by double-clicking “2 errors” at the bottom
of the document window or by choosing Preflight Panel from the menu to the right
of “2 errors.”

3. Click the triangle to the left of LINKS and then to the left of TEXT to reveal more
information about the errors. Click the triangle to the left of Missing Link to display the
name of the missing graphic file. Double-click the GardenNews-Masthead-Spring.ai link
name; this centers the graphic in the document window and selects the graphics frame. If
you look carefully at the frame that contains the magazine title, you’ll notice a red-circled
question mark in the upper-left corner, which indicates that the original graphic file is
missing.

4. A typical problem in production might be that the decision was made to change the color of
the masthead for this issue, but the InDesign file is still linked to the graphic with the
previous color. You will link to this new version of the masthead. To fix this error, open the
Links panel and scroll down or expand the panel until you see this graphic name.

Note
Modified or missing graphics are displayed in low resolution regardless of the
current Display Performance setting.

5. Make sure that the GardenNews-Masthead-Spring.ai file is selected in the Links panel.
Notice that it shows the red-circled question mark ( ) here as well, and then choose
Relink from the panel flyout menu. Browse to the Links folder inside the Lesson13 folder.
Double-click the GardenNews-Masthead-Summer.ai file. The new file is now linked,
replacing the original file.
Notice that after you relink the GardenNews-Masthead-Summer.ai graphic, it is a different
color, which was the design change. Notice that the red-circled question mark in the upperleft corner has changed to a link symbol ( ), meaning that the graphic is linked to the
InDesign file and is not missing or modified.
6. To display the document at high resolution, choose View > Display Performance > High
Quality Display. It’s a best practice to view a document at High Quality Display when
checking it for production quality.

7. Click the Status icon ( ) at the top of the Links panel. This sorts the links by status rather
than name or page. Status includes whether a link is missing, modified, or embedded. The
graphics that might be a problem sort to the top of the list. You’ll see that the graphic

named Lily.jpg displays the modified graphic alert ( ). Click the page number to the right
of the filename, and InDesign navigates to the page where the modified graphic is located,
selects it, and centers it on your screen.

Tip
The Display Performance section of the Preferences dialog box lets you change
default settings for the display of raster images, vector graphics, and objects to
which transparency is applied. Choose Edit > Preferences > Display Performance
(Windows) or InDesign CC > Preferences > Display Performance (macOS)to open
the Preferences dialog box.

8. Notice that the modified graphic alert ( ) is also displayed in the upper-left corner of the
graphic frame. You can click this alert button or double-click the one in the Links panel to
update this graphic. Click one of those now.
Notice that after you relink the Lily.jpg graphic, the color has changed. Another typical
scenario in production is that the photographer did some color correction to this photo. The
file was replaced in the Links folder but was never updated in the InDesign file. Also notice
that the modified graphic alert in the upper-left corner has changed to a link symbol,
meaning that the graphic is linked to the InDesign file and is not missing or modified.

9. Open the Preflight panel again. Now we’ll examine the TEXT error. In the same way you
clicked the missing or modified graphic to locate it, click the triangle to the left of Overset
Text (1). Then click the page number to the right of the listed text frame. This navigates to
the text frame and selects it, centering it in the document window.
10. The red square with a plus sign inside indicates that there is more text that does not fit into
the frame. There should be no overset text in a file that is ready to be reviewed, published,
or printed.
11. Using the Selection tool ( ), pull down the center handle on the text frame enough to
display the last line of the paragraph.

12. Now the Preflight panel status shows No Errors (
) at the bottom. Every document
should have No Errors in the preflight status when you are finished preflighting.

Note
If any links remain modified at this point, open the Links panel flyout menu and
choose Update All Links.

13. Choose File > Save to save the changes you’ve made to the document, and close the
Preflight panel.

Previewing separations
If your documents need to be prepared for commercial printing, you can use the Separations
Preview panel to check whether the colors are set up properly for the particular printing process
that will be used for this particular document. For example, will the document be printed with
process CMYK inks, with spot-color inks, or with a combination of those? The answer
determines what you need to check for and fix. You’ll try out this feature now.
1. Navigate to page 1 and choose Window > Output > Separations Preview. Or click the
Separations Preview button ( ) in the panel dock to open the panel.
2. Choose Separations from the View menu in the Separations Preview panel. Adjust your
view so that you can see the page, and adjust the panel’s height so that all of the listed
colors are visible. If necessary, choose View > Fit Page In Window.

Tip
If you choose Ink Limit from the View menu in the Separations Preview panel,
InDesign displays in red any areas that exceed the specified maximum ink
percentage. (The default Ink Limit value is 300%.)

3. Click the eye icon ( ) next to CMYK to hide all page elements that use CMYK colors.
The elements that are still visible are elements that use something other than CMYK color.
In this case, spot (PANTONE) colors are applied.

Tip
Sometimes special effects are achieved in printing with spot color inks by printing
the same ink twice. This is called a second hit and must be set up in the file like an
additional color.

4. Next, notice that two of the PANTONE colors used in the layout share the same number
(PANTONE 136). These are the same ink. The difference represents what this ink looks
like when printed on different kinds of paper: Coated (C) and Uncoated (U). In the vast
majority of projects printed with spot color inks, there is only one plate for each ink. So if
this file were to print using Pantone 136, you would need to make sure that only one 136
printing plate (separation) would be produced. You’ll correct this problem later using the
Ink Manager.
5. Click the eye icon next to PANTONE 136 C. The title disappears. This means that the title
is using the ink you turned off. Click the eye icon again to turn this ink back on.
6. Click the eye icon next to PANTONE 136 U. Now the text on the right disappears,
meaning it’s using this other version of the same ink. If this project is indeed printing with
CMYK plus PANTONE 136, you need to correct the file so that both of these items print
on the same 136 plate.
7. Click the eye icon next to CMYK to show all colors again, and navigate to page 2. Click
the eye icon next to Black to turn it off. Notice that the headline disappears but some of the
body text is still visible. This means that the body text will print on several plates when it
should be black only.

8. To investigate why and fix this, turn Black back on. Slide the page to the left so that you
can see part of the body text from page 3. The text on both pages is supposed to be the
same, but something is wrong. Open the Paragraph Styles panel (Window > Styles >
Paragraph Styles) and click in the body text on page 3. The style Body Copy No Indent is
highlighted. Now click in the body copy on page 2. No paragraph style is highlighted.
Somewhere in the process, this text was formatted without using the paragraph style.
Select some text at the end of the first paragraph and drag-select through the beginning of
the third paragraph. Click the Body Copy No Indent paragraph style to apply it to all
paragraphs.
9. Turn off Black again in the Separations Preview panel. Now all of the text that you expect
to be black disappears. This is because the character color is part of the paragraph style, and
that color is Black. You can see how using paragraph styles can prevent many errors,
including text in the wrong color.

10. Choose Off from the View menu in the Separations Preview panel to enable viewing of all
colors, and then close the panel.
11. Choose File > Save.

Coated vs. uncoated
The photo to the right shows how different the same CMYK color looks when printed on

coated paper (left) and on uncoated paper (right). The same difference happens with any
kind of ink, including PANTONE inks.
This difference in appearance is caused by the physical characteristics of the paper.
Uncoated paper absorbs more ink than coated paper, so it looks more matte and less glossy
when the ink dries. The same color can look darker on uncoated paper and brighter on
coated paper.

Creating a preflight profile
When the live preflight feature is enabled (that is, when On is selected in the Preflight
panel), the default working profile, called [Basic], is used to preflight your InDesign
documents. This profile checks for basic output conditions, such as missing or modified
graphic files, unresolved caption variables, inaccessible URL links, overset text, and
missing fonts.
You can also create your own custom preflight profiles or load profiles from your print
service provider or another source. When you create a custom preflight profile, you specify
the conditions you want to detect. Here’s how to create a profile that alerts you when nonCMYK colors are used in a layout:
1. If the Preflight panel is not open, choose Window > Output > Preflight, and then
choose Define Profiles from the Preflight panel flyout menu.
2. Click the New Preflight Profile button ( ) on the lower-left side of the Preflight
Profiles dialog box to create a new preflight profile. In the Profile Name box, enter
CMYK Colors Only.
3. Click the triangle to the left of Color to display color-related options, and select Color
Spaces And Modes Not Allowed.
4. Click the triangle to the left of Color Spaces And Modes Not Allowed, and then select
all of the available options except CMYK and Gray (RGB, Lab, and Spot Color). Gray
works with CMYK because it prints on the black plate only. Deselect Cyan, Magenta
or Yellow Plates Not Allowed. (This would be perfect for a spot color preflight
profile.)

5. Leave existing preflight criteria for Links, Images And Objects, Text, and Document
as is. Click Save, and then click OK.
6. Choose CMYK Colors Only from the Profile menu in the Preflight panel. Notice the
additional errors listed in the Error section of the panel.
7. Click the triangle next to Color to expand the display, and then click the triangle next
to Color Space Not Allowed to see a list of objects that do not use the CMYK color
model. Click various objects to view information about the problem and how to fix it.
(Make sure the Info section of the Preflight panel is visible. If not, click the triangle to
the left of Info to display it.)
8. When you’re done viewing information, choose [Basic] (working) from the Profile
menu to return to the default profile used for this lesson.

Managing colors
One of the best practices when making sure a file is ready for commercial printing is to make
sure that only the colors actually used appear in the Swatches panel and that all colors used are
shown in the panel.

Tip
Notice the color called TRUMATCH 38-b. TRUMATCH is a library of color swatches
built into InDesign that is specific to the CMYK printing process.

1. Choose Window > Color > Swatches to open the Swatches panel. To quickly find all
unused swatches, choose Select All Unused from the Swatches panel flyout menu. Notice
that several versions of the yellow color are used in the file, including an RGB version.
This commonly happens in the creative process, but in production it should be the same
yellow throughout, so this must be fixed. Choose Delete Swatch from the panel menu to
remove the unused swatches.
2. Choose Add Unnamed Colors from the Swatches panel flyout menu. Three colors appear
that were not there before. (This happens when you create colors in the Color panel and use
them but don’t take the step of adding them to the Swatches panel.) What we are concerned

with here is whether these colors are using inks that will or will not work with this file’s
printing process. These are CMYK colors, so they are not a problem.

Using the Ink Manager
The Ink Manager provides control over the inks used at output time. Changes you make using
the Ink Manager affect the output, not how the colors are defined in the document.
The Ink Manager options are especially useful to clean up how inks will print without having to
go back and change imported graphics. For example, if a publication will be printed with CMYK
process inks but it uses a spot color, the Ink Manager provides the option of changing the spot
color to the equivalent CMYK process color. If a document contains two similar spot colors
when only one is required, or if the same spot color has two different names, the Ink Manager
lets you map the variations to a single spot color.
Next, you’ll learn how to use the Ink Manager to convert a spot color to a CMYK color, and
you’ll create an ink alias so that the desired number of separations is created when the document
is color separated to create printing plates.

Note
You can also open the Ink Manager by choosing Ink Manager from the Separations
Preview panel menu (Window > Output > Separations Preview).

1. Choose Window > Color > Swatches to open the Swatches panel if necessary, and then
choose Ink Manager from the Swatches panel flyout menu.
2. In the Ink Manager dialog box, click the spot icon ( ) to the left of the PANTONE 136 C

color swatch. It changes to a CMYK icon ( ). The color will now print as a combination
of CMYK colors instead of printing on a separate color plate. Click OK and close the Ink
Manager.
3. Now open the Separations Preview again, and see that PANTONE 136 C is no longer there.
PANTONE 136 U still shows as a separate ink. We’ll deal with that next.

Tip
If the file will in fact print with spot inks, you can use transparency effects without a
problem, as long as you are careful that the effect uses the same inks as the rest of
the file.

The All Spots To Process option at the bottom of the Ink Manager dialog box lets you
convert all spot colors to process colors. This is a good solution if you want to limit the
printing to four-color process without having to change the spot colors in the source files of
the imported graphics. However, if the spot color graphics use transparency, the results
from Ink Manager are not reliable. In those cases, you must open the graphic and change the
spot colors to process in the original application. In fact, Adobe Illustrator displays the
following warning when you save a file in which transparency effects have been applied to
spot color objects.

4. Now we’ll combine the two versions of the same spot color so that only one spot ink plate
will be produced. This is what you would do if the file were printing with CMYK plus
PANTONE 136. Open the Ink Manager again and click the CMYK icon ( ) to the left of
the PANTONE 136 C color swatch to change it back to a spot ink. Then click PANTONE
136 U. Click the Ink Alias drop-down menu and choose PANTONE 136 C. This remaps all
136 U objects to print on the same plate as 136 C. Click OK.

5. Choose File > Save.

Choose the right swatch library
Swatch libraries are a way to have a large array of colors ready to choose from when
creating a design. But be aware that some swatch libraries consist of custom inks, and if
your project is not actually printing with those inks, you may not get the result you expect.
The most popular custom ink swatch library is the Pantone Solid Coated library. Pantone
inks (and all spot colors) are like custom-mixed paint. They are not created with CMYK ink
mixes. Some can be matched with CMYK ink mixes, but many cannot. You should know
the printing process that will be used to produce your document and use a swatch library
that corresponds to that process.

Previewing transparency effects
In the past, documents that contain objects to which transparency effects had been applied, such
as drop shadows, opacity, and blending modes, needed to undergo a process called flattening
when they were printed or exported. Flattening divides transparent artwork into vector-based
areas and rasterized areas. Even if you use the High Resolution setting when flattening,
rasterized areas will be a much lower resolution than the image processor at a commercial
printer, and the effect won’t look as good when printed compared to not flattening. The
flattening strategy was needed before image processors at commercial printers and office laser
printers could process transparency.
Modern image processors can process transparency without flattening, leaving the transparency
live. You will get the best results by not flattening at any point in the production process. The
Flattener Preview panel in InDesign can help you see which objects in the file are using
transparency effects so that you can make sure you’ve used them purposefully and not by
accident.
Some of the objects in this magazine use transparency effects. Next, you’ll use the Flattener

Preview panel to determine the objects to which transparency effects have been applied and the
areas on the page that are affected by transparency.
1. Navigate to page 1 and choose View > Fit Spread In Window.
2. Choose Window > Output > Flattener Preview, or click the Flattener Preview button ( )
in the panel dock, and then position the Flattener Preview panel so that you can see the
entire page.
3. In the Flattener Preview panel, choose Transparent Objects from the Highlight menu. The
entire page is displayed with a dimmed grayscale preview, except for the areas with
transparency effects.
4. If it’s not already selected, choose [High Resolution] from the Preset menu.
Notice how the masthead at the top of the page is displayed with a red highlight. This object
has a transparency effect, such as a blending mode, opacity, drop shadow, or any of nine
additional special effects applied (in this case, a drop shadow). You can use this highlight to
help identify areas of your layout that may be unintentionally affected by transparency so
that you can adjust either your layout or your transparency settings accordingly.

Tip
Transparency can be applied in Adobe Photoshop, in Adobe Illustrator, or directly in
an InDesign layout. The Flattener Preview panel identifies transparent objects,
regardless of whether the transparency was created using InDesign or imported from
another application.

5. Scroll or click through to the next spread. Now nothing is highlighted in red, and the spread
looks the same as when the Flattener preview is off. That’s because there are no objects
with transparency on this spread.
6. Choose None from the Highlight menu to disable the Flattener preview, and then close the
panel.

Previewing the pages
Now that you’ve previewed the color separations and areas of transparency in the layout, you’ll
preview the page to get an idea of how the magazine will look when printed.
1. At the bottom of the Tools panel, hold down the Screen Mode button (

) and then choose

Preview from the menu. The guides, frame edges, invisible characters, pasteboard, and
other nonprinting items are hidden. This is the best onscreen view of how the document
will look when it is printed and trimmed.

Tip
You can also toggle between the different screen modes by choosing a mode from
the Screen Mode control in the Application bar.

2. Hold down the Screen Mode button again, and then choose Bleed. Additional space outside
the perimeter of the final document trim size is displayed. This confirms that the color
background extends beyond the edge of the document, ensuring complete coverage in the
printed piece. After the job is printed, this excess area is trimmed to the final printed size.

Note
Review the section about printing to the edge of the paper in Lesson 3 for more
information about bleed.

3. Scroll through the entire document and look over everything before printing or exporting.
In Bleed mode, you can see whether items at the edge are extended far enough into the
pasteboard, in addition to looking at everything else you can see in Preview mode. Confirm
once again that the Preflight status shows No Errors (
).
4. Choose Normal from the Screen Mode menu and then choose File > Save.
After confirming that the file looks acceptable, you are ready to print it.

Creating an Adobe PDF proof
If your documents need to be reviewed by others, you can easily create Adobe PDF (Portable
Document Format) files to transfer and share. There are several benefits to this convenient
format. Files are compressed to a smaller size, all fonts and graphic links are self-contained in a
single composite file, and files are displayed onscreen and print the same whether opened in
Windows or macOS. InDesign exports directly to Adobe PDF.
Exporting your publication as an Adobe PDF document also has many advantages for
commercial printing. You can create a compact, reliable file that contains all of the elements in

the InDesign file, including high-resolution graphics and all of the fonts, so that you or your
service provider can work with the file and get the same high-quality results that they would
from working directly with the InDesign file. A properly exported PDF from InDesign is ready
for your service provider to use with the tools for commercial printing such as preflight checks,
trapping, imposition, and color separation.
These two different purposes for using a PDF have different requirements. You can use presets
to save settings that are appropriate for different purposes so that you don’t have to select
multiple choices in the export dialog box each time you export. In other words, presets allow you
to carefully set up requirements for different purposes and then use them every time without
worry. You can also share presets with colleagues to ensure that all PDFs are exported with the
same settings by everyone.
You will now create an Adobe PDF file suitable for review and proofing purposes using one of
the built-in presets.
1. Choose File > Export.
2. Choose Adobe PDF (Print) from the Save As Type (Windows) or Format (macOS) menu.
For the filename, type 13_Proof.pdf. If necessary, navigate to the Lesson13 folder, and
then click Save. The Export Adobe PDF dialog box opens.
3. In the Adobe PDF Preset menu, choose [High Quality Print]. This setting creates PDF files
suitable for output on desktop printers and proofers and for onscreen proofing, without
creating a file that is too large to easily share or whose resolution is too low for a reviewer
to evaluate any raster graphics.

Tip
The presets available in the Adobe PDF Preset menu are used for creating a range of

Adobe PDF files, from small files suitable for onscreen viewing to press-ready files
suitable for high-resolution output.

Note
Adobe PDF (Print) export in InDesign is performed in the background, which
enables you to continue working while an Adobe PDF is being created. If you try to
close your document before the background process is completed, InDesign will
display a warning message.

Select View PDF After Exporting. This will open the PDF file in Acrobat as soon as it’s
finished exporting, which saves you the step of switching to Acrobat and opening the file.
The Export Layers menu lets you choose the layers to be exported when creating the PDF.
For this exercise, use the default option: Visible & Printable Layers.
4. Click Export. An Adobe PDF file is generated and displays on your monitor in Adobe
Acrobat Pro DC or Adobe Acrobat Reader DC.
5. Review the Adobe PDF. This type of PDF is appropriate to share with colleagues or
customers for review purposes, or to print to an office printer for review on paper.

Tip
You can view the PDF export progress by opening the Background Tasks panel
(Window > Utilities > Background Tasks).

6. Return to InDesign. A tip about a new feature, PDF Comments may have opened on your
screen. This is an important new feature for the review process that enables you to work
with Acrobat-created comments directly in InDesign, rather than working back and forth
between InDesign and Acrobat. We will not be using this feature in this lesson, but the
figure that follows shows what the process looks like.

The PDF Comments panel enables you to import the comments from an InDesign CC 2019–created PDF. As you click
each comment, InDesign navigates to that object in the file.

Tip
To learn more about using PDF comments in InDesign CC 2019, start at the online
help here: https://helpx.adobe.com/indesign/using/import-pdf-comments.html.

7. Close the tip and the PDF Comments panel and choose File > Save.

Creating a press-ready PDF and saving a PDF preset
InDesign files are submitted to commercial printers either as native files (which we’ll learn about
later in this lesson) or as press-ready PDFs. Press-ready PDFs are high resolution and include the
bleed area. In this exercise, you will learn about creating an Adobe PDF file suitable for
commercial printing.
InDesign includes a PDF export preset called [Press Quality] that has most of the necessary
settings already defined. However, it does not work for documents that include any objects that
bleed. You will start with that preset and modify it so that you have a press-ready preset that
includes the bleed.
1. Choose File > Adobe PDF Presets > Define. The Adobe PDF Presets dialog box opens.
Scroll down to [Press Quality], select it, and click New. This enables you to create a new
preset based on the options already set up in the default Press Quality preset.
2. In Preset Name, type Press Quality With Bleed.
3. Under Marks And Bleeds make the following changes: Under Marks, select Crop Marks. In
Offset, type .125. In the Bleed And Slug area, for Bleed, enter .125 in the Top box and
click the Same Settings icon ( ) to set the same bleed settings on all sides.

Note
You can also choose Use Document Bleed Settings, but by setting a bleed amount in
the preset, even documents without a bleed amount set in Document Setup will
export with the specified bleed area.

4. Click OK and then Done. This preset will now be available whenever you export to PDF.
5. Choose File > Adobe PDF Presets > Press Quality With Bleed. Name the file
13_Press_HighRes.pdf, click Save, and then click Export. When the PDF opens in
Acrobat, notice how the cover photo extends past the crop marks. The crop marks indicate
where the blade will cut through the paper to trim the magazine to the final size. In this
case, it will cut through the printed image and produce a clean edge with no paper showing
at the edge.

The most important required characteristics of a PDF for commercial printing are:
High-resolution raster graphics
Bleed included
PDF compatibility of at least Acrobat 5 so that transparency effects are not flattened
The preset you have made does all of these things. However, you may want to edit it. For
example, you may want to increase the version of Acrobat compatibility because you know that
everyone in your production workflow is up to date and there is no reason to be compatible back
to Acrobat 5.
In order to check whether the PDF will have live transparency or will be flattened, examine the
different options available when compatibilty with Acrobat 4 is selected, compared to later
versions of Acrobat.
1. Choose File > Adobe PDF Presets > Define. The Adobe PDF Presets dialog box opens.
Scroll down to Press Quality With Bleed and choose Edit.

Tip
If you need to create a flattened press-ready PDF, use the [High Resolution] flattener
preset in the Advanced panel of the Export Adobe PDF dialog box.

2. Click the Advanced category on the left. Notice that the Transparency Flattener settings are
dimmed and not available. This means the transparency will not be flattened. Now change
the Compatibility setting to Acrobat 4. The Transparency Flattener settings are now
available because exporting to Acrobat 4 means exporting to a file format that can’t process
transparency effects, and therefore you must compensate for that by flattening these effects.
Click Cancel and then Done.

Sharing a preset
1. Choose File > Adobe PDF Presets > Define. The Adobe PDF Presets dialog box opens.
Scroll down to Press Quality With Bleed. Click this name and then choose Save As.
2. Choose a name for your preset and navigate to a location on your hard drive where you
wish to save it. You can now share this file with others.
3. To share a preset, choose File > Adobe PDF Presets > Define again. This time, in the
Adobe PDF Presets dialog box choose Load and navigate to the location where the preset
file exists. Select it and then click Open. Click Done to exit the Adobe PDF Presets dialog
box. The preset is now available.

Printing a proof and saving a print preset
InDesign makes it easy to print documents to a variety of output devices. In this part of the
lesson, you’ll create a print preset to save settings—and save time in the future—without having
to individually set each option for the same device. The process is similar to saving a PDF preset.
You will use this preset for proofing on your office printer, assuming the printer has only Letter
or A4 paper.

Note
If you do not have access to a printer, you can choose PostScript File from the Printer
menu. If you do, you can choose an Adobe PDF PPD (if available) and complete all of
the steps in the remainder of the lesson. If no other PPDs are available, you can choose
the Device Independent PPD; however, some of the controls covered in the remainder of
the lesson are not available if you choose Device Independent.

1. Choose File > Print.
2. From the Printer menu in the Print dialog box, choose your inkjet or laser printer.
The options you see throughout this lesson will be different depending on the device
selected. Follow the steps with your printer’s options as best as you can.

3. On the left side of the Print dialog box, select the Setup category, and then choose the
following options:
Paper Size: US Letter (or A4)
Orientation: Portrait
Scale To Fit

4. On the left side of the Print dialog box, click the Marks And Bleed category, and then
choose these options:
Crop Marks
Page Information
Use Document Bleed Settings
In the Offset box, enter a value of .125.

Tip
The preview pane in the lower-left corner of the Print dialog box shows how the
page area, marks, and bleed area will print.

The crop marks print outside of the page area and provide guides showing where the final
document is trimmed after printing, just as we saw in the press-ready PDF. The page
information automatically adds the document name and the page number, along with the
date and time it was printed, to the bottom of the printout. Because the crop marks and page
information are printed outside the page edges, you must select Scale To Fit in order to fit
the page, bleed, and marks onto a Letter or A4 piece of paper.

Selecting Use Document Bleed Settings causes InDesign to print objects that extend outside
the edge of the page area, if that value is specified in the Document Setup dialog box. If you
didn’t specify a bleed value there, you must enter bleed values here.
5. On the left side of the Print dialog box, click the Output category. Choose Composite
CMYK or Composite RGB from the Color menu. (If you are printing to a black-and-white
printer, choose Composite Gray.)

Tip
If your document contains transparency that is flattened during the printing process,
select Simulate Overprint in the Output section of the Print dialog box when printing
for the best print result.

Choosing Composite CMYK causes any RGB colors, including those in RGB graphics, to
be converted to CMYK at the time of printing. This setting changes neither the original,
placed graphic files nor any colors applied to objects. Which setting you should choose
depends on your particular device.
6. On the left side of the Print dialog box, click the Graphics category. Choose Optimized
Subsampling from the Send Data menu.
When Optimized Subsampling is selected, InDesign sends only the image data necessary
for the printer selected in the Print dialog box. This can reduce the time it takes to send the
file to print. To send the complete high-resolution graphic information to the printer, which
may take longer to print, select All from the Send Data menu.

Note
The Optimized Subsampling option cannot be selected if you are using the Device
Independent PPD, because this generic driver can’t determine what information a

selected printer may need later.

7. Choose Subset from the Fonts Download menu. This causes only the fonts and characters
that are actually used in the document to be sent to the output device and can reduce the
time it takes to print single-page documents and short documents without much text.
The Color Management category enables you to set options that provide control over how
colors are printed across different devices. You’ll use the default settings for this lesson.
8. On the left side of the Print dialog box, click the Advanced category and choose [Medium
Resolution] from the Transparency Flattener Preset menu.
9. Click Save Preset at the bottom of the Print dialog box, name the preset Proof fit to page in
the Save Preset dialog box, and click OK. InDesign returns to the Print dialog box, with
your settings in place. Next time you want to print with these settings, you now can do that
in one step by choosing the preset you just made.

Tip
To quickly print using a preset, choose File > Print Presets and select the device
preset. Holding down the Shift key while doing this will print using the settings in
the selected preset without opening the Print dialog box.

10. Click Print.
Creating a print preset saves Print dialog box settings so that you don’t need to individually set
every option each time you print to the same device. You can create multiple presets to meet
various quality needs of individual printers and to meet your various project needs. When you
want to use these settings in the future, you can choose them from the Print Preset menu at the
top of the Print dialog box. You can also share print presets with colleagues.

Print Booklet
A very useful way to proof documents that will be stitched into a booklet is to use the Print
Booklet feature. This feature enables you to make a proof on paper that will be constructed
similarly to the commercially printed booklet. When you print a document this way, you can fold
the stack of pages in half, staple them on the fold (spine), and page through the proof to review
it.
1. Choose File > Print Booklet to open the Print Booklet dialog box.
2. Click the Print Settings button at the bottom of the dialog box. In the Print dialog box,
select the Setup category and change Orientation to Landscape (Horizontal). Click OK.

InDesign returns to the Print Booklet dialog box.

3. Leave Booklet Type set to 2-up Saddle Stitch, then click Preview on the left side of the
dialog box. Notice how the last page is next to the cover. This is called a printer’s spread—
in this case, the outside covers.

4. Click Cancel (or print the document if you choose). Open the file named
13_SixteenPager.indd. Choose File > Print Booklet and follow the same steps as in steps 2
and 3 above. Click through the spreads using the arrows and slider at the bottom of the
preview window. This file has large page numbers on it so that you can easily see how the
pages fit together in printer spreads. Click Cancel (or print the document if you choose),
and then close the 13_SixteenPager.indd file.

Packaging files
The Package command assembles a copy of your InDesign document and all linked items,
including graphics, into a single, convenient folder. InDesign also copies the fonts needed for
printing when you package a document. Packaging ensures that all project components required
for output are provided. This process and using a press-ready PDF are the two industry-standard
ways of providing an InDesign project to a commercial printer.
Packaging is also used to archive finished projects in a way that gathers all components together.
This is convenient and efficient when you want to create a new version at a later date or share the
project with others.
Now you’ll package the files for the magazine in preparation for sending them to your print
provider.
1. Choose File > Package. The Summary section of the Package dialog box notifies you of
one more printing-related issue.

Because the document contains RGB images, InDesign alerts you to their presence. This
alert is standard because some printers want you to convert all images to CMYK before
submitting the file. But others want to do the conversion from RGB to CMYK using
standards for their presses, so read this alert but don’t change anything. A best practice is to
talk to your print provider and ask what they prefer.

Note
Adobe Fonts available as part of your Creative Cloud membership are not included
when you use the Package command.

2. Leave Create Printing Instructions unchecked.
InDesign can create a text file of instructions and your contact information that will
accompany the InDesign file, links, and fonts in the package folder. The recipient of the
package can use the instructions file to better understand what you want done and how to
contact you if there are questions.

Tip
When Copy Fonts (Except activated from Adobe Fonts and non-Adobe CJK fonts)
is selected in the Create Package Folder dialog box, InDesign generates a folder
called Document fonts in the package folder. If you open an InDesign file located in
the same folder with the Document fonts folder, InDesign will activate these fonts
for you and make them available only for that document while it’s open.

3. Click Package. If asked to save the document, click Save.
4. In the Create Package Folder dialog box, browse to locate the Lesson13 folder. Notice that

the folder that will be created for the package is named 13_Press Folder. InDesign
automatically names the folder based on the document name, which you assigned at the
beginning of this lesson. You can change this name as you wish.
5. Confirm that the following options are selected:
Copy Fonts (Except activated from Adobe Fonts and non-Adobe CJK fonts)
Copy Linked Graphics
Update Graphic Links In Package
Include IDML (so that others can open the file in a previous version of InDesign if
necessary)
Include PDF(Print) (so that you can’t forget to send a PDF proof along with the native
files)

Note
IDML stands for InDesign Markup Language. IDML files can be opened in an
earlier version of InDesign.

6. Choose [High Quality Print] for the Select PDF Preset.
7. Click Package.
8. Read the warning message that informs you about the licensing restrictions that may affect
your ability to include the fonts when you send the file, and then click OK.
9. Switch to Explorer (Windows) or Finder (macOS), and then navigate to the 13_Press
Folder in the Lesson13 folder (located inside the Lessons folder within the InDesignCIB
folder on your hard drive). Open the folder.
Notice that InDesign created a duplicate of the InDesign document, the IDML version, and
the PDF of your document. It also copied all fonts into a Fonts folder and all graphics and
other linked files necessary for high-resolution printing into a Links folder. Because you
selected Update Graphic Links In Package, the duplicate InDesign file now links to the
copied graphic files located in the package folder instead of to the original linked files on
your hard drive or server. This makes the document easier for a printer or service provider
to manage and also makes the packaged folder ideal for archiving.
10. When you have finished viewing its contents, close 13_Press Folder and return to InDesign.
Also review the PDF created by the packaging process to check that all text and graphics
are correct. Typically, this folder is zipped and uploaded to the service provider, with the
included PDF serving as the proof for them to check their work.

Congratulations! You’ve completed this lesson.

Exploring on your own
1. Create new print presets by choosing File > Print Presets > Define. Define presets to use for
oversized formats or for printing to various color or black-and-white output devices you
may use. For example, if you have a printer that uses tabloid paper, create a preset that
allows you to print letter-size pages at full size with a specified bleed amount.
2. Practice using the Press Quality With Bleed preset you saved with other documents, such as
those from other lessons in this book or your own files.
3. Practice using the Package feature with other documents, such as those from other lessons
in this book or your own files. Examine the contents of the resulting folder to become
familiar with what is needed when sending your file to a service provider such as a
commercial printer.
4. Learn how to open imported graphics that need to be fixed for printing. Click a graphic
from the Links panel. Choose Edit With from the Links panel flyout menu. Choose
Photoshop to open raster images and Illustrator to open vector graphics. Make changes to
the imported art, then save and close the file. Go back to InDesign and update the links.

Review questions
1 What problems does InDesign look for when using the [Basic] (working) profile in the
Preflight panel?
2 What elements does InDesign gather when it packages a file?
3 What are the three most important characteristics of a press-ready PDF file?
4 What functions does the Ink Manager provide?
5 What are the two industry-standard ways of sending files to a service provider such as a
commercial printer?

Review answers
1 By default, the [Basic] (working) profile in the Preflight panel confirms that all fonts used in
the document or inside placed graphics are available. It also looks for linked graphic files and
linked text files to confirm that they have not been modified since they were initially imported,
and it warns you of missing graphic files, unresolved caption variables, inaccessible URL
links, missing fonts, and overset text frames.
2 InDesign gathers a copy of the InDesign document along with copies of all the fonts and
graphics used in the original document. The original files remain untouched. If you select
Include IDML, InDesign creates an IDML version of the document that can be opened in
previous versions of InDesign. If you select Include PDF(Print), InDesign creates an Adobe
PDF (Print) version of the document. If you choose to include a PDF, you can also choose a
PDF preset.
3 The three most important characteristics are ensuring high resolution for raster graphics,
including the bleed, and using a later version of Acrobat (version 5 or newer) as the file format

so that transparency effects remain live and are not flattened.
4 The Ink Manager provides control over inks at output time, including the ability to convert spot
colors to process colors and to map individual ink colors to different colors, without changing
the colors in InDesign or in imported graphics.
5 The two standard methods are using a press-ready PDF with a bleed and using an InDesign
Package folder.

14 Creating Adobe PDF Files with Form Fields

Lesson overview
In this lesson, you’ll learn to do the following:
Set up a workspace for forms.
Add and configure different form field types.
Learn the differences between different types of form fields.
Use prebuilt form elements.
Set the tab order of form fields.
Add a Submit button to a form.
Export an Adobe PDF (Interactive) file with form fields.
Test your form in Adobe Acrobat Reader.

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the files for this lesson, or go to the “Getting Started” section at the
beginning of this book and follow the instructions under “Accessing the Lesson Files and Web
Edition.” Store the files on your computer in a convenient location. Your Account page is also
where you’ll find any updates to the lessons or the lesson files. Look on the Lesson & Update
Files tab to access the most current content.

Adobe InDesign CC provides all the tools you need to create simple PDF forms, and you have the option of using Adobe Acrobat
Pro DC to add features and functionality that aren’t available in InDesign.

Getting started
In this lesson, you’ll add several different types of form fields to a volunteer registration form,
export an Adobe PDF (Interactive) file, and then open the exported file in Adobe Acrobat Reader
and test the fields you created.
1. To ensure that the preferences and default settings of your InDesign program match those
used in this lesson, move the InDesign Defaults file to a different folder following the
procedure in “Saving and restoring the InDesign Defaults file” on pages 4–5.
2. Start InDesign. To ensure that the panels and menu commands match those used in this
lesson, choose Window > Workspace > [Interactive For PDF], and then choose Window >
Workspace > Reset Interactive For PDF. To begin working, you’ll open an InDesign

document that is already partially completed.

Note
If you have not already downloaded the project files for this lesson to your computer
from your Account page, make sure to do so now. See “Getting Started” at the
beginning of the book.

3. Choose File > Open, and open the 14_Start.indd file in the Lesson14 folder, located inside
the Lessons folder within the InDesignCIB folder on your hard drive. This one-page
document is a registration form.

Note
If an alert informs you that the document contains links to sources that have been
modified, click Update Links.

4. To see what the finished document looks like, open the 14_End.indd file in the Lesson14
folder.
5. Close the 14_End.indd file after you have finished examining it, or you can leave this
document open for reference.

6. Return to the 14_Start.indd file and choose File > Save As, rename the document
14_PDF_Form.indd, and save it in the Lesson14 folder.

Set up a workspace for forms
When creating a fillable form with InDesign, you’ll start with a page that has already been

designed. The step of taking a designed form and turning it into a form that can be filled out in a
PDF uses specific tools. The Interactive For PDF workspace has many of the tools you’ll need
readily available. But if you customize the workspace a little, you will be that much more
efficient.
1. First, drag panels off the panel dock that are not needed for forms: Page Transitions,
Hyperlinks, Bookmarks, Media, and SWF Preview. Drag each panel to the left over the
pasteboard. These are useful for other types of interactive PDFs but are not needed for
forms. Also drag the Links, Color, and Gradient panels to the pasteboard, as they won’t be
used for forms. It doesn’t matter if some of them dock together as you drag them.
2. Close each of the panels you just dragged to the pasteboard.

3. Drag the Sample Buttons And Forms panel under the Buttons And Forms panel. This
InDesign library includes prebuilt form fields as well as buttons for check boxes, radio
buttons, and buttons that can be used to submit or print a form.
4. Save this workspace so you can use it again. Choose Window > Workspace > New
Workspace. Use a name like PDF Forms-Basic or whatever makes sense to you. (For more
complicated and long forms, you will want additional tools, including the Paragraph Styles,
Character Styles, and Object Styles panels, as well as the Articles panel.) Click OK.

Adding form fields
Some setup work on the form fields has already been done. You’ll complete the form by adding
some more fields and then modifying some of them.

Adding text fields
In a PDF form, a text field is a container into which the person who fills out the form can enter

text. All but two of the frames have already been converted into text fields. You’ll add two new
frames and convert them into text fields.
1. Open the Layers panel. Notice that the file is set up with a separate layer, Form Elements,
for the objects that are part of the form. Lock the other layer, Layer 1, so that you can work
with the form objects without accidentally moving anything else.

Note
You can simplify the display of the page by hiding Layer 1 in the Layers panel.
Only the objects in the form area are displayed when you hide Layer 1.

2. Use the Zoom tool ( ) to zoom in on the area in the top half of the page that contains the
form objects. This is where all of your work in this lesson will be done.
3. Select the Selection tool ( ), and move the pointer over the text field below “First Name.”
Notice that a red dotted line is displayed around the object, and a small graphic of a text
field is displayed at the lower right. The dotted line indicates that the object is a PDF form
element; the icon of the text frame indicates that the element is a text field. Click in the text
field to select the object.
4. Click the Buttons And Forms panel icon ( ) to display the Buttons And Forms panel.
Notice the settings for the text field. Text Field is selected in the Type menu, and the Name
of the element is First Name. Text entered in the Description field is displayed when the
pointer rolls over a field to provide additional guidance to viewers who fill out a form. The
Description for this field is also First Name. Printable is selected to enable printing of this
form. Leave the font setting at the default, but change Font Size to 10.

Note
When adjust-ing the appearance of a combo box, list box, text field, or signature

field, keep in mind that only a solid stroke and fill are retained when you export as
Adobe PDF. These attributes are visible in an exported PDF file when Highlight
Existing Fields is not selected in Adobe Acrobat Reader DC or Adobe Acrobat Pro
DC when the form is opened.

5. Select the frame of the First Name form field, press Alt (Windows) or Option (macOS), and
drag a copy of it to below Last Name. Resize it to make it longer, ending in alignment with
the fields below, by dragging the center-right handle to the right. The Smart Guides will
appear when the pointer is aligned.
6. In the Buttons And Forms panel, notice that the name of this field is First Name 1. This is
an InDesign behavior to be aware of when creating forms: No fields can have the same
name. InDesign enforces this rule by adding sequential numbers to the name of duplicated
fields. To make this a unique field with the correct information, change both the Name and
Description fields to Last Name.
7. To create a field from scratch, choose the Rectangle tool ( ) in the Tools panel and draw a
frame under the text frame under E-mail Address. Align the right edge with the City frame
above and the top edge with the bottom of the E-mail Address text frame. You can convert
any kind of frame—text, graphics, or unassigned—into a PDF form field. A text field does
not have to be made from a text frame.

Notice how the Smart Guides help you align and size objects.

8. Now we will assign the same fill and stroke as the other text fields. An object style for the
text field boxes has already been created for this lesson. Choose Window > Styles > Object
Styles to open the Object Styles panel. Choose the Selection tool ( ), and click the box
you just drew if it’s not still selected. Click the object style called Text Field Box. Now the
same fill and stroke have been applied to the new frame. Next, make the text field the same
height as the other fields by dragging slightly up and left. Watch for the Smart Guides to
display again. The size changed slightly because the object style added a stroke to the
frame. Close the Object Styles panel.
9. In the Buttons And Forms panel, choose Text Field from the Type menu, and assign it the
Name and Description E-mail Address. Make Font Size 10 point and make sure that
Printable and Scrollable are selected. Scrollable means that if the user types more
characters than will fit in the box, the field will allow the user to keep typing, but not all of
the text will be visible in the field. This option is appropriate for email addresses since they
can be very long.
10. Choose File > Save.

Adding either/or choices: radio buttons

Radio buttons are often simple circles; however, you can design your own buttons or choose
from several sample buttons included with InDesign. In this lesson, you’ll use one of the sample
radio buttons. The prebuilt buttons in this library are simply vector shapes with various attributes
for fill, stroke, and effects.
Radio buttons present the person filling out the form with two or more choices, but only one
choice can be selected as the response. A group of radio buttons functions as one field, with a
unique value for each button. Check boxes can appear similar to radio buttons, but every check
box in the list can be either on or off.

Note
Use a radio button for either/or choices, such as whether someone must specify a status
that can have only one answer—for example, whether they are a member, non-member,
or student member of an organization.

Radio button in Acrobat.

1. Choose View > Fit Page In Window, and then use the Zoom tool ( ) to magnify the “In
what way are you best able to help?” portion of the form.
2. Click the Sample Buttons And Forms icon ( ) that you dragged below the Buttons And
Forms icon ( ) in the dock to open the Sample Buttons And Forms panel.
3. Drag the radio button group named “016” from the Sample Buttons And Forms panel and
position it below the text frame with the text “In what way are you best able to help?”
Close the panel by clicking the double arrows ( ) at the upper right of the panel. Align the
top of the topmost radio button with the top of the line of text to the right. Refer to the
following figure for the correct position.
4. In the Control panel, make sure that the upper-left reference point is selected in the
reference point locator ( ), enter 40% in either of the Scale Percentage boxes, make sure
that the link for the Same Settings button ( ) is selected, and then press Enter or Return. If
necessary, move the buttons to match the following figure.

5. With all three buttons still selected, in the Buttons And Forms panel, enter Form of

Assistance in the Name and Description boxes, and then press Enter or Return. Notice that
Type is already set to Radio Button.
6. Choose Edit > Deselect All, or click an empty area of the page or pasteboard.
7. Use the Selection tool ( ) to select the first radio button (to the left of Education).
8. In the Buttons And Forms panel, enter Education in the Button Value field at the bottom of
the panel, and then press Enter or Return. Under Appearance, click [Normal Off]. This
means that when the user first opens the form, the button will be unselected.

Note
You may need to use the scroll bar in the Appearance section to scroll up to the top
to find the state [Normal Off].

9. Repeat steps 7 and 8 to change the Button Value setting of the middle button to Garden
maintenance and the bottom button to Financial donation. Notice that the name of the
field is the same for all three buttons; only the Button Value changes.
10. Choose File > Save.

Adding yes or no choices: check boxes
A check box presents a yes-or-no choice for an individual item. A user of the form can click the
empty check box (the default setting in the exported PDF) to add a check mark or leave it
unchecked. Now you’ll add a check box.

Note

Use a check box when a question can be followed by “check as many as apply.” For
example, a training school might ask, “Which programs are you interested in?” and then
list several, such as InDesign, Photoshop, Illustrator, and Acrobat. The person filling out
the form could be interested in more than one.

1. Use the Selection tool ( ) to drag the check box named “001” from the Sample Buttons
And Forms panel, and place it so that the top of the check mark that extends above the box
aligns with the top of the text frame that contains “Yes, I would like to receive your
quarterly newsletter.”
2. Press Shift+Ctrl (Windows) or Shift+Command (macOS) and scale the check box graphic
so that it is the same height as the text frame to the right.
3. In the Buttons And Forms panel, enter Receive Newsletter in the Name field, and then
press Enter or Return. Notice that Type is already set to Check Box. Under Appearance,
click [Normal Off]. In the Description field, enter Check here if you’d like to receive our
newsletter.

Check box after being scaled.

4. The check box and radio buttons that you dragged from the Sample Buttons And Forms
panel should have red highlights because they should be on the Form Elements layer. Items
that you drag from the library should be added to the active layer. As you work, it’s a good
practice to check that elements are on the layer where they belong. This helps keep your
work organized and will be especially important when you work on complicated forms.
Select all the buttons you dragged from the library with the Selection tool ( ) and open
the Layers panel. If the new items are not on the Form Elements layer, correct this by
dragging the square in the Layers panel to the Form Elements layer.

5. Choose File > Save.

Adding a list of choices: combo box
A combo box is a menu that lists multiple predefined choices. The user of the form can select
only one of the choices. Next, you’ll create a combo box that offers three choices.
1. Use the Selection tool ( ) to select the text frame below the heading “Please send me your
newsletter in the following format:.”
2. In the Buttons And Forms panel, choose Combo Box from the Type menu, and then enter
Newsletter Format in the Name field. In the Description field, enter Choose which way
you’d like to receive our newsletter. Change Font Size to 10. To provide the viewer of the
PDF form with different choices, you’ll add three list items.

Note
List boxes are similar to combo boxes in that you add list items; however, combo
boxes allow you to select only one item from a list in the PDF form. If you select
Multiple Selection for a list box, a viewer of the PDF can select more than one
choice.

3. In the lower half of the Buttons And Forms panel, in the List Items box, enter Print
Publication: Standard Mail, and then click the plus sign ( ) to the right of the box.
Notice that the text you entered is now displayed in the list below the box.
4. Repeat the previous step to add Adobe PDF: E-mail Attachment and Link to online
newsletter: E-mail to the list. Select Sort Items to sort list items alphabetically.

Tip
To sort list items alphabetically, select Sort Items in the Buttons And Forms panel.
You can also modify the order of list items by dragging them up or down in the list.

5. Click Print Publication: Standard Mail in the list of items to make it the default selection.
When a viewer opens the exported PDF file, Print Publication: Standard Mail will already
be selected.
6. Choose File > Save.

Tip
To display a combo box without a default selection, make sure that none of the list
items is selected. When a list item is selected, it becomes the default selection when
the PDF is opened.

Setting the tab order of the fields
The tab order you establish for a PDF form determines the order in which fields are selected as a
user of the form presses the Tab key. These must be in a logical order to make the form userfriendly. Next, you’ll set the tab order for the fields on the page.
1. From the Object menu, choose Interactive > Set Tab Order.
2. In the Tab Order dialog box, click Last Name (the name of the text field you created that
holds the surname of the person filling out the form), and then click Move Up until it
appears below First Name near the top of the list. Use the Move Up and Move Down
buttons or drag field names up or down to rearrange them so that they match the order on
the page. Click OK to close the dialog box.

3. Choose File > Save.

Adding a button to submit the form
If you distribute a PDF form, you’ll want to include a way for anybody who fills out the form to
return it to you electronically. To accomplish this, you’ll create a button that sends the filled-out
PDF form to your email address.

Tip
Any object or group can be converted into a button. For example, a text frame with a fill
color and the text “Submit” could become a Submit button. To convert a selected object
or group into a button, choose Button from the Type menu in the Buttons And Forms
panel.

1. Use the Selection tool ( ) to select the rounded-corner text frame with a red fill and the
text “Submit.”
2. In the Buttons And Forms panel, choose Button from the Type menu, enter Submit Form
in the Name field, and then press Enter or Return. Enter Send the completed form via
email for the Description.
3. Click the Add New Action For Selected Event ( ) button, and then choose Submit Form
from the drop-down menu.
4. In the URL field, enter mailto:. Make sure you enter a colon after “mailto.” Do not enter a
space or a period before or after the colon.
5. Enter your email address (for example, pat_smith@domain.com) after mailto:. This will
return the completed form to you.
6. To cause the button’s appearance to change when a user of the PDF form moves the pointer
over the Submit button, you’ll add a Rollover appearance.
Click [Rollover] in the Buttons And Forms panel. Open the Swatches panel, select Fill color
( ) and enter 50 in the Tint field, press Enter or Return, and then close the panel.

Tip
A button’s appearance can have three different states. The state that’s displayed
depends on the user’s interaction. The Normal state is the default display when no
interaction occurs, the Rollover state displays when the mouse pointer is over the
button, and the Click state displays when the mouse button is clicked.

7. Return to the Buttons And Forms panel. Notice that the [Rollover] appearance is now
lighter than the [Normal] appearance, reflecting the tint change you just made. Click
[Normal] to display the default appearance.

8. Open the Layers panel (Windows > Layers) and make sure all layers are visible (in case
you hid Layer 1 earlier in the lesson).
9. Choose File > Save.

Form field types
Button: The most versatile interactive element. A button can trigger many actions.
Check box: For yes or no choices, a check box is either checked or not checked. Use
check boxes for “Check all that apply” questions.
Combo box: The user can choose only one answer from a list.
List box: Similar to a combo Box except that the user can choose more than one
answer.
Radio button: For either/or choices, the user can choose only one answer.

Signature field: Enables the user to sign a form with a digital signature.
Text field: For the user to type text information.

Exporting an interactive Adobe PDF file
Now that you’ve finished work on the form fields, you’re ready to export an interactive Adobe
PDF file and then test the exported file.
1. Choose File > Export.
2. In the Export dialog box, choose Adobe PDF (Interactive) from the Save As Type menu
(Windows) or Format menu (macOS). Name the file 14_PDF_Form.pdf and save it to the
Lesson14 folder, located inside the Lessons folder within the InDesignCIB folder on your
hard drive. Click Save.
3. In the General tab, in the Options section of the Export To Interactive PDF dialog box,
make sure that Include All is selected for Forms And Media. This is the most important
setting to make the form fields work in the PDF.

4. Choose Fit Page from the View menu to display the entire page when the exported PDF is
opened. Leave all other settings unchanged. Click Export. The PDF will open in Acrobat or
Acrobat Reader when it finishes exporting.

Testing your form in Adobe Acrobat Reader
You should always test your forms in Adobe Acrobat Reader because the end user is most likely
to use that when filling out the form. (Most people do not have Adobe Acrobat Pro.) If you do
not have Adobe Acrobat Reader, install it now. The current version is called Adobe Acrobat

Reader DC. It’s a free download at https://get.adobe.com/reader.
1. Open Adobe Acrobat Reader and open the PDF you just exported. First, click in the First
Name field and press the Tab key. Continue to tab through all the fields to make sure that
the tab order is correct.
2. Next, click the radio buttons under “In what way are you best able to help?” and notice that
you can turn on only one choice at a time.
3. Click the check box for “Yes, I would like to receive your quarterly newsletter” to see that
it turns on. Then choose one of the newsletter formats from the drop-down menu below.
4. Move the pointer across each field, pausing for a moment, and notice the tips that pop up.
These are the descriptions that you entered in the Buttons And Forms panel for each field.

If you find any errors, go back to the InDesign file and fix them. Then export and test again.
5. When you’re done, click the Submit button that emails the filled-out form to you. (A
security warning dialog box may display when Acrobat creates an email message with the
completed form as an attachment.) Click Allow and then click Continue in the next dialog
box to submit the form information, or click Cancel. Return to InDesign.
6. Look at the email you received and notice the subject line: Form Returned:
14_PDF_Form.pdf. This is a default function of the Submit Form action within the Submit
button. Therefore, it’s important to consider the name of the PDF when you create forms to
be emailed.
Congratulations! You’ve created a PDF form and tested it.

Exploring on your own
1. Open a new document, create a text frame, and then use the Buttons And Forms panel to
convert it to a signature field. A signature field in a PDF form lets the user apply a digital
signature to the PDF file. Assign the field a name, and then export an Adobe PDF
(Interactive) file. Open Adobe Acrobat Pro DC or Adobe Acrobat Reader DC to test the
signature field by clicking it and then following the onscreen instructions to create a digital
signature. Click Cancel if you get a dialog box about Trusted Certificates. That is part of a
system of securely identifying signatures, which is not needed for creating a signature.
2. Use the Ellipse tool ( ) to create a small circular frame. Use the Gradient panel to fill the
circle with a radial gradient. Use the Swatches panel to change the colors of the gradient.
Use the Buttons And Forms panel to convert the frame into a button. Assign the button the
Go To URL action and enter a complete URL in the URL field (for example,
http://www.adobe.com). To test this button, export an Adobe PDF (Interactive) file and
click the button.
3. Experiment with one of the other prebuilt form fields in the Sample Buttons And Forms
panel. Drag one onto the page, and then view its properties in the Buttons And Forms
panel. Try different modifications to its appearance, change some of its properties, or both.
Export and test the result.

Review questions
1 What panel lets you convert an object into a PDF form field and specify settings for form
fields?
2 What is the difference between a radio button and a check box?
3 What action can you assign to a button that enables a viewer of the exported PDF form to send
a copy of the filled-out form to an email address?
4 What programs can be used to open and fill out an Adobe PDF form?
5 What are the two most important things to do when exporting your InDesign file to create a
fillable form PDF?

Review answers
1 The Buttons And Forms panel (Window > Interactive > Buttons And Forms) lets you convert
objects into PDF form fields and specify settings for them.
2 Radio buttons are for questions that have an either/or answer; the user of the form can choose
only one. Check boxes are either checked or not checked individually. So a question for which
the user can choose more than one answer, or whose answer is a simple yes if the box is
checked, needs a check box, not a radio button.
3 To enable the viewer of a PDF form to return a filled-out form, use the Buttons And Forms
panel to assign the Submit Form action to the button. After you assign the Submit Form
action, enter mailto: followed by an email address (for example,
mailto:pat_smith@domain.com) in the URL field.
4 You can open and fill out PDF forms using Adobe Acrobat Pro DC or Adobe Acrobat Reader
DC.
5 First, in the Export dialog box, choose Adobe PDF (Interactive) from the Save As Type menu
(Windows) or Format menu (macOS). Then in the Options section of the General tab, make
sure that Include All is selected for Forms And Media.

15 Creating a fixed-Layout epub

Lesson overview
In this lesson, you’ll learn how to do the following:
Create a new document for mobile delivery.
Create animations using a motion preset and a motion path.
Configure the timing of multiple animations.
Create buttons that trigger various actions.
Preview animations and interactivity within InDesign.
Add a movie, a sound, a slideshow, buttons, and a hyperlink.
Export a fixed-layout EPUB and preview it in a viewing app.

This lesson will take about 60 minutes to complete. Please log in to your account on
peachpit.com to download the files for this lesson, or go to the “Getting Started” section at the
beginning of this book and follow the instructions under “Accessing the Lesson Files and Web
Edition.” Store the files on your computer in a convenient location. Your Account page is also
where you’ll find any updates to the lessons or the lesson files. Look on the Lesson & Update
Files tab to access the most current content.

The fixed-layout EPUB capabilities of Adobe InDesign CC let you create media-rich publications with animations, movies,
slideshows, sounds, and hyperlinks, and you can include buttons that enable viewers to perform a variety of actions, from
clicking through a slideshow to playing a sound file.

Getting started
In this lesson, you’ll begin by creating a new InDesign document using settings appropriate for a
fixed-layout EPUB. After you’ve set up the new document, you’ll open a partially completed
version of the publication, add several multimedia and interactive elements, and then save and
preview a fixed-layout EPUB that can be viewed on a variety of EPUB readers.

Note
If you have not already downloaded the project files for this lesson to your computer
from your Account page, make sure to do so now. See “Getting Started” at the beginning
of the book.

1. To ensure that the preferences and default settings of your InDesign program match those
used in this lesson, move the InDesign Defaults file to a different folder following the

procedure in “Saving and restoring the InDesign Defaults file” on pages 4–5.
2. Start InDesign. To ensure that the panels and menu commands match those used in this
lesson, choose Window > Workspace > [Digital Publishing], and then choose Window >
Workspace > Reset Digital Publishing. This optimizes the panel arrangement for the work
you’ll do in this lesson and provides quick access to several of the controls you’ll use.
3. To see what the finished document looks like, open the 15_End.indd file in the Lesson15
folder. If an alert informs you that the document contains links to sources that have been
modified, click Update Links.
4. Navigate through the finished document to view the cover page and the page that follows.
In all previous lessons that use sample print documents, the completed InDesign layouts
look the same onscreen and in print; however, because the exported publication in this
lesson is intended for display on an EPUB reader, what you seen onscreen when you open
the sample files in InDesign doesn’t exactly match the appearance of the exported EPUB.
The following images show what the completed lesson file looks like when displayed in a
reader.

5. Close the 15_End.indd file after you have finished examining it, or you can leave this
document open for reference.

Creating a new document for fixed-layout export
Because exported EPUBs are viewed onscreen (on mobile devices such as tablets or on desktop
computers, for example) and can include elements such as buttons, animations, and video that
can’t be included in print documents, creating a document that’s intended for export in the EPUB
format differs in some ways from creating a print document. That said, all the typographic and
page-layout features covered in this book are available and work the same when creating digital
publications. To begin, you’ll create a new mobile document.

Note
Setting a new document’s Intent to Mobile (or Web) deselects the Facing Pages option
and changes the unit of measurement to pixels. It also sets the Transparency Blend Space
(Edit > Transparency Blend Space) to RGB and the default color swatches in the
Swatches panel to Process RGB for the new document.

1. Choose File > New > Document.
2. In the New Document dialog box, click the Mobile tab, click View All Presets, and then
select iPad from the available choices. Also specify the following:
In the Pages box, type 2, and deselect Primary Text Frame. Leave all other settings
unchanged, and click Create.

3. Choose File > Save As, name the file 15_Setup.indd, navigate to the Lesson15 folder, and
click Save.
Rather than creating the remainder of the document from scratch, you’ll continue this lesson
by opening a partially completed document that already contains most of the required
objects. You can keep the 15_Setup.indd document open or close it and continue.

EPUB: Reflowable versus fixed-layout
An EPUB is a document created for viewing on a device such as a tablet, rather than for printing
on paper. This allows for capabilities such as adding many kinds of multimedia elements and
interactive features or reflowing text for the particular device.
The biggest difference between a fixed-layout EPUB and a reflowable EPUB, which is the other
option for exporting EPUBs, is that a fixed-layout EPUB retains the design of the InDesign
document (like a PDF) regardless of the device on which it’s displayed. In contrast, a reflowable
EPUB displays content in a continuous thread and reflows the content based on the size of the
reader screen and the zoom level. Readers of reflowable EPUBs can change the font and font
size to suit their preference.
The fixed-layout format lets you include buttons, animations, video, and audio in your
publications, and viewers of fixed-layout EPUBs can view the pages and interact with the
buttons and multimedia elements. This format is better suited for more design-intensive
publications, such as children’s books, textbooks, and comic books—anything for which the
visual layout is critical to the experience for the reader. The reflowable format is the preferred
choice for text-intensive publications such as fiction and non-fiction books where the visual
layout is not as important.

Adding animation
Animation effects let you add movement and other visual effects to InDesign objects and groups.
For example, you can animate a graphics frame by making it fly into place from outside the
page, or you can fade in a text frame so that it turns from invisible to opaque. InDesign includes
several motion presets, which are preset animations that you can quickly apply to objects. You
can also use any object as a motion path for another object or group.
Next, you’ll examine a group that has already been assigned animation settings that cause it to
automatically “fly” onto the page when a viewer opens the exported EPUB file. You’ll preview
this animation within InDesign, and then you’ll create some animations of your own that
automatically play when the page is displayed. To complete this section, you’ll adjust the timing
of the animations so that they play in the desired sequence.

Using a motion preset to create animation
The quickest and easiest way to animate an object or group is to apply any of more than 40 builtin motion presets. After you apply a preset, you have several options for controlling how the
animation is played, including the event that triggers the animation and the duration.
1. Choose File > Open, and then open the 15_FixedLayout_Partial file in the Lesson15 folder.
2. Choose File > Save As, name the file 15_FixedLayout.indd, and save it in the Lesson15
folder.
Before you create an animation, you’ll take a look at a group that’s already had animation
effects applied to it.
3. Use the Zoom tool to zoom in on the text frame in the top half of page 1 beneath the main
heading that begins “and we can provide it …” and then use the Selection tool ( ) to click
the text frame. A dotted-line border indicates that you’ve selected a group, which includes
the text frame and the red, heart-shaped object.
Notice the small icon in the lower-right corner of this group of objects. This indicates that
an animation has been applied to the group. Notice, too, that a green line extends from the
pasteboard to the center of the group. The circle at the right end of the green line indicates
the starting point of the path; the arrowhead at the left end is the end point of the path.

4. Choose Window > Interactive > Animation, or click the Animation icon ( ), to open the
Animation panel. Notice that the group has a name (Animated Group), and Custom (Fly In

From Right) is selected from the Preset menu. (The word “Custom” at the beginning of the
preset name indicates that the default settings for this preset have been modified. You’ll
modify other presets later in this lesson.) On Page Load is selected in the Event(s) menu,
which means the animation will start playing automatically as the page is displayed.

5. To preview the animation, click the Preview Spread button ( ) at the bottom left of the
Animation panel. The EPUB Interactivity Preview panel opens. Drag the lower-right or left corner of the panel to make it large enough to view the publication. Click the Play
Preview button, which is the farthest left along the bottom control panel, and the animated
headline flies in from the right side of the page. See the sidebar on the next page for a full
explanation of the EPUB Interactivity Preview panel.

6. Drag the EPUB Interactivity Preview panel to the bottom of the dock, as you’ll use it
throughout this lesson. The panel icon ( ) displays in the dock.

Next, you’ll add a preset to another group and then to a text frame, and you’ll customize the
settings of both animations.
1. Choose View > Fit Page In Window.
2. With the Selection tool ( ), click any of the dog or cat graphics at the bottom of the page
except the one on the far left, which you will work with separately later in the lesson.

Clicking any of the graphics selects the group of four graphics.

Tip
When you choose a motion preset, a proxy preview of the animation is displayed at
the top of the Animation panel. Move the pointer within the proxy window to repeat
the preview of the selected preset.

3. Open the Animation panel ( ) and choose Fly In From Bottom from the Preset menu.
Notice how the proxy preview shows you what the preset does using a pink butterfly
image. Try several presets and then return to Fly In From Bottom. Ensure that On Page
Load is selected in the Event(s) menu.

4. Select the red text frame with white text. Choose the Fade In preset and set the Duration to
2 seconds. The word Custom will appear before Fade In when you change the Duration.

5. Click the Play Preview button in the lower-left corner of the EPUB Interactivity Preview
panel to view the animations. Notice that the group at the top of the page appears first,
followed shortly by the group of graphics at the bottom of the page, and finally the red text
frame. The sequence is a result of the order in which the animations were created. Next,
you’ll modify the order in which these animations play.

Adjusting the timing of animations
The Timing panel lists the animations on a page or spread and lets you change the order in which
animations are played, play animations simultaneously, or delay animations. You’ll use the
Timing panel to change the order in which the three animations on page 1 are played, and to play
two of the animations simultaneously.

The EPUB Interactivity Preview panel

The EPUB Interactivity Preview panel lets you preview an InDesign document that includes
multimedia, animation, and interactivity without having to switch to a separate program.
You can display the panel by choosing Window > Interactive > EPUB Interactivity Preview
or by clicking the Preview Spread button in the lower-left corner of the Animation, Timing,
Media, Object States, or Buttons And Forms panels.
You can perform the following functions in the EPUB Interactivity Preview panel:
Play Preview ( ): Click to play a preview of the document. Alt-click (Windows) or
Option-click (macOS) to replay the preview.
Clear Preview ( ): Click to clear the preview.
Navigate between previous page ( ) and next page ( ): Click the left or right arrows
to navigate between previous and next pages. Preview Document Mode must be
enabled to navigate to the previous or next page. Click Play to enable the previous
page and next page buttons.
Set Preview Spread Mode ( ): Click to set the mode to preview spread mode. This is
the default mode and is especially useful for testing interactive elements on the current
page.
Set Preview Document Mode ( ): Click to set the mode to preview document mode.
This mode allows you to run through each page of the document and test the
interactive elements.
Collapse/Expand panel ( ): Click to expand/collapse the EPUB Interactivity Preview
panel.

1. Choose Window > Interactive > Timing or click the Timing icon ( ) to open the Timing
panel from the dock. Ensure that On Page Load is selected in the Event menu. The three
animations you worked with in the previous section are listed.

2. Click Animated Group in the list of animations. Because it was created first, it’s at the top
of the list and will play first.
3. Drag Animated Group to the bottom of the list so that it plays last.
4. Select Dog And Cat Group, and then Shift-click the animation named “Our mission …” to
select both objects.
5. Click the Play Together button ( ) at the bottom of the Timing panel.

6. Click Dog And Cat Group, and specify a delay of 1.5 seconds. This will delay the display
of this animation when the page opens. After the delay, the Dog And Cat Group will fly in,
and the red text frame will simultaneously fade in.
7. Click the Preview Spread button at the bottom of the Timing panel to open the EPUB
Interactivity Preview panel, and then click Play Preview to preview the page and check the
timing changes.
8. Choose File > Save to save your work.

Buttons
Buttons are one of the most versatile tools for adding multimedia features to a publication. A
button can trigger many actions. Next, you’ll configure buttons to play animations and add two
buttons using two different methods. The graphics that you will use to make buttons are on a
layer named Buttons above the layer with the rest of the content. This practice ensures that the
buttons will not disturb the other content, will always be above that content in the stacking order,
and is a good way to keep your file organized.

Using buttons to play animations

The animations you worked with in the previous section are configured to play automatically
when the page is displayed. You can also create animations that play when you perform other
actions, such as moving the pointer over an animated object or clicking an object or group that’s
been configured to work as a button.
In this section, you’ll first examine an object that’s already been animated and converted into a
button that plays an animation. Then you’ll create a new button that animates an alreadyanimated object.
1. Scroll down so that you can see the pasteboard at the bottom of the page. You’ll see two
vector hat illustrations. Zoom in as you wish to see the lower-left area of the page. Use the
Selection tool ( ) to position the first hat, matching the screen capture below, and then
choose View > Fit Page In Window.

Notice the two icons in the lower-right corner of the group’s bounding box. The icon on the
right indicates that the group is animated; the icon on the left indicates that the group is also
a button.
2. The hat illustration is made up of several paths created with the Pen tool, and the paths
have been grouped together (Object > Group). With the hat group selected, open the
Animation panel. This group is named is HatGroup1.
Notice that the Spin preset has been applied, and On Release is selected in the Event(s)
menu. This means that a button will trigger the animation. The Duration and Play values
show that the animation will take one second to play and will play two times.
3. Close the Animation panel and open the Buttons And Forms panel ( ), , which is located
in the dock on the right when you use the [Digital Publishing] workspace. Or choose
Window > Interactive > Buttons And Forms. Notice that the group has been configured to
work as a button that plays the HatGroup1 animation.

Note
Throughout this lesson, if you have trouble with the interactivity functioning in the
EPUB Interactivity Preview panel, click the Clear Preview button ( ) and then
click the Play button ( ) again.

4. Click the Preview Spread button ( ) at the bottom of the Buttons And Forms panel to
open the EPUB Interactivity Preview panel. After the opening animations are displayed,
click the hat group to play the animation and then close the panel.
Next, you’ll configure a button that animates a different object.
1. Select the hat illustration in the lower-right corner of the page.
The icon in the lower-right corner of the graphic indicates that this group is animated;
however, you may have noticed that when you preview the page, the group is not visible.
That’s because although the group is configured to fly in from above the page, there’s no
way to play the animation. To address this, you’ll convert the accompanying pet graphic
into a button.
2. Select the Rectangle Frame tool ( ) in the Tools panel and draw a frame over the photo of
the dog in the lower-right corner of the page. You should still be on the Buttons layer, but if
not, open the Layers panel and move the new frame up to the Buttons layer. Make sure the
frame is set to None for both Fill and Stroke. This makes an object you can use as a button
that appears to be one of the visual elements on the page but is actually a separate object on
the Buttons layer above, making sure you don’t disturb the artwork.
The size of the frame becomes the tappable or clickable area in the EPUB, so you can use a
frame with no fill and no stroke to make a button with a larger tappable area than a small
graphic would have. This technique makes using the EPUB easier for your audience.
3. In the Buttons And Forms panel, click the + sign ( ) next to Actions and choose
Animation from the menu. Then choose HatGroup5 from the Animation menu, which
shows the animations in the current file.

4. Name the button AddHat. Always name your buttons; otherwise, things will get very
confusing because InDesign will automatically name them Button 1, Button 2, and so on.
Make sure On Release Or Tap is selected in the Event menu.
You don’t need to choose a Type first because when you add an action the object is
automatically turned into a button. Notice the list of possible actions, but note that the
bottom group is only for PDFs. In the Buttons And Forms panel, click the triangle next to
PDF Options at the bottom of the panel to close that area. You won’t need those while
working on an EPUB.
5. Click the Preview Spread button at the bottom of the Buttons And Forms panel to open the
EPUB Interactivity Preview panel and click the play button. After the opening animations
are displayed, move the pointer over the photo of the dog at the lower right and click to
play the new animation. Notice that the pointer becomes a pointing finger when you hover
over something (such as this new button) that the reader can click to activate. Then close
the panel.
6. Choose File > Save to save your work.

Using a button to trigger custom motion paths for animations
Many of the motion presets in InDesign cause an object to move along a path. In addition to
using this type of preset to animate an object, you can use any InDesign object as the path for
animating another object by converting it to a motion path. Next you’ll configure a button to play
an animation that already has a custom path; then you’ll create a custom path of your own and
use it as a motion path.
1. Navigate to the pasteboard area at the top of the page above the fourth column. You’ll see a
hat illustration. Use the Selection tool ( ) to select the graphic.
As you’ve seen with the animations you worked on earlier, the green motion path indicates
how the hat will move when the animation is played. This custom path was created in
InDesign using the Pen tool.

Next, you’ll convert the graphics frame at the bottom of the column into a button that plays
the already-configured hat animation. Then, you’ll create your own custom path for a
different hat and configure a button to play it.

2. Choose View > Fit Page In Window. Select the Rectangle Frame tool ( ) and draw a
frame over the photo with the cat at the bottom of the fourth column, making sure that it
has no stroke and no fill and that it is on the Buttons layer.
3. In the Buttons And Forms panel, click the + sign ( ) next to Actions and choose
Animation from the menu. Then choose HatGroup4 from the Animation menu.
4. Name the button FloatingHat1. Make sure On Release Or Tap is selected in the Event
menu.
5. Click the Preview Spread button at the bottom of the Buttons And Forms panel to open the
EPUB Interactivity Preview panel and click the play button. After the opening animations
are displayed, move the mouse over the photo with the cat at the bottom of the fourth
column. Notice that the pointer changes to a pointing hand because it is sensing the button
you just created. Click to play the new animation, and then close the panel.
Now that you know how a custom motion path works, you’ll create your own custom animation
path and then configure a button to play it.
1. Navigate to the pasteboard area at the top of the page. You’ll see another hat illustration
above the third column. This hat is named HatGroup3.
2. Use the Pen tool ( ) to draw a zigzag path that begins near the middle of the hat and ends
slightly above the middle of the dog’s head in the third column. To create straight path
segments rather than curved segments, make sure you click and release the mouse button
each time you create a point. (If you’d like, you can use the Pen or Pencil tool to draw a
more complex path.)
3. Use the Selection tool to select both the hat above the third column and the line you just
created, and then click Convert To Motion Path ( ) at the bottom of the Animation panel.
On Page Load is selected in the Event(s) menu. Deselect it by choosing On Page Load
again to uncheck it, and set Duration to 2 seconds. The motion path has been connected to
HatGroup3 to create an animation.

4. Select the Rectangle Frame tool ( ) and draw a frame over the photo of the dog at the
bottom of the third column, making sure that it has no stroke and no fill and that it is on the
Buttons layer.
5. Click the + sign ( ) next to Actions in the Buttons And Forms panel and choose
Animation from the menu. Then choose HatGroup3 from the Animation menu. Name the
button FloatingHat2.
6. Click the Preview Spread button at the bottom of the Buttons And Forms panel to open the
EPUB Interactivity Preview panel. After the opening animations are displayed, click the
dog photo in the third column (which is the button you just configured to play the new
animation), verify that the animation is playing correctly, and then close the panel and click
the play button.
If you need to modify the position of the endpoint of the motion path so that the hat is
placed accurately at the end of the animation, use the Selection tool ( ) to select the hat
group and then click on the green motion path. Switch to the Direct Selection tool ( ) and
use it to move the endpoint of the path or, optionally, to modify other points or segments of
the path.
7. One pet remains without a hat. Navigate to the pasteboard area at the bottom of the page,
where there is one remaining hat. Use any of the animation techniques you’ve learned so
far or experiment with other techniques to position the hat on the cat above it. (Note: The
15_End file uses the Fly In From Bottom preset.)
8. Choose File > Save to save your work.

Creating a navigation button

The next button you’ll create will be a navigation button for the reader to move through the
pages. This is one of the most common uses for buttons.
1. Select the Rectangle Frame tool ( ) and draw a frame over the white triangle in the lowerright corner of the page, making sure that it has no stroke and no fill and that it is on the
Buttons layer. Make it larger than the triangle so that the reader does not have to click it
exactly.

Tip
Many apps for viewing EPUBs include navigation buttons, but each app will
perform navigation differently. Adding your own buttons ensures that the reader will
easily see the navigation buttons.

2. Open the Buttons And Forms panel ( ) and click the + sign(
Go To Next Page. Name this button Next Page.

) next to Actions. Choose

3. Open the EPUB Interactivity Preview panel, and this time choose the Preview Document
Mode button ( ) so that you can preview more than the current page. If you have trouble
with the interactivity functioning, click the Clear Preview button ( ), double-check that
you have chosen the Preview Document Mode button, and press Play ( ) again.

Tip
In a long document, create the navigation buttons on the master page. If there are
several master pages, use the parent master so that you can create the buttons once
and ensure that they are consistent on all pages.

4. After the opening animations are displayed, click the white navigation button you just
created, and the next page will display. You will see other animations on page 2 that you’ll
work with later in this lesson.

5. Click the white triangle in the lower left to navigate back to the first page.

Creating a pop-up caption
Pop-up captions are frequently used in EPUBs. There are many ways to create them. Using
InDesign’s ability to hide and show objects is one of the simplest methods. You’ll learn that
next.
1. Select the paw graphic on top of the large photo of the dog and cat. First you’ll add some
animation so that the reader is prompted to click it.
2. Open the Animation panel ( ). Name the animation Paw Caption Trigger. Choose the
Fade In preset, and set Duration to 2.5 seconds and Play to 4 times.
3. Open the Buttons And Forms panel ( ), click the + sign ( ) next to Actions, and choose
Show/Hide Buttons And Forms. Name the button Caption Trigger.
4. Select the caption above that says “I love making new friends.” This is a group of InDesign
text and path objects with effects applied. Click the + sign ( ) next to Actions, and again
choose Show/Hide Buttons And Forms in the Buttons And Forms panel ( ). Name this
button Caption.

Tip
The Visibility list available to the Show/Hide action lists all of the buttons on the
current page or spread. You can’t use this action to work with buttons elsewhere in a
document.

5. In the Visibility section, leave everything on Ignore ( ) except Caption and Caption
Trigger. Click the Ignore symbol ( ) next to Caption and click again to cycle through the
options until it is set to Hide ( ). Do the same with Caption Trigger until it is set to Show
( ). Also select Hidden Until Triggered below the Appearance area.
6. Select the paw object that you converted to a button in step 3. In the Buttons And Forms
panel ( ) (which will still be open), change the Visibility setting of Caption to Show ( )
and change Caption Trigger to Hide ( ).

As a result, the trigger object will be visible when the reader opens the page, and the caption
object will be hidden. When the trigger object is clicked or tapped, it will disappear, and the
caption object will appear. When the caption object is clicked or tapped, it will disappear
and the trigger object will reappear.
7. Click the Preview Spread button ( ) at the bottom of the panel to open the EPUB
Interactivity Preview panel and click the play button. Test this pop-up caption by clicking
the paw trigger object and then the caption.
8. Close the EPUB Interactivity Preview panel and choose File > Save.

Adding multimedia and interactive elements
The ability to add movies and sounds to an InDesign document that will be exported as a fixedlayout EPUB means that you can create media-rich, interactive publications that aren’t possible
with print publishing.
In many ways, imported movies and sounds are like other InDesign objects. For example, you
can copy, paste, move, and delete movies and sounds just like other objects—but they also have
unique properties that you can adjust within InDesign.

Adding a movie
Adding a movie to a fixed-layout EPUB InDesign document is similar to adding a photo or
illustration to a print document. Next, you’ll import a movie into the document, scale it, and use
the Media panel to choose a poster image that’s displayed when the movie isn’t playing.

1. Navigate to page 2. Choose File > Place. Select the RMPetSpa.mp4 video file in the Links
folder in the Lesson15 folder, and then click Open.

Tip
You can import video files in H.264-encoded MP4 format and audio files as MP3
format. You can use the Adobe Media Encoder application that is part of a Creative
Cloud membership to convert other video or audio formats to MP4 or MP3.

2. Click the loaded video icon ( ) where the horizontal ruler guide below the mountain peaks
intersects with the vertical ruler guide in the middle of the leftmost column. Clicking the
loaded video icon places the video at full size, which is too large for the layout, so you need
to make it smaller.

Tip
When you use a video in an EPUB, it is embedded in the final file. Be aware that
video files can be large and make the resulting EPUB file large; therefore, you need
to balance the quality level of the video with file size.

3. Make sure that the top left reference point ( ) is selected at the left end of the Control
panel. Enter 43 in the Scale X Percentage or Scale Y Percentage box in the Control panel
and press Enter (Windows) or Return (macOS). The movie now fits within the predrawn
guides.
4. Choose Window > Interactive > Media to open the Media panel, or click the Media icon (
) to open it from the dock. If you want, use the controls below the movie image to
preview the movie.

Note
A static poster image is displayed in a reader before the video plays.

Instead of displaying the first frame of the movie when the movie is not playing, you’ll

choose a poster image to display instead.
5. Drag the slider below the preview window almost all the way to the right. The final seconds
of the movie show a catchphrase. You’ll specify the selected frame as the default poster
image. From the Poster menu in the Media panel, choose From Current Frame. Click the
Click To Use Current Frame As Poster button ( ) to select the frame and display it in the
movie frame.

6. Click the Preview Spread button at the bottom of the Media panel to view the page. In the
EPUB Interactivity Preview panel, click the play button and then navigate to page 2 by
clicking the navigation button you created earlier in this lesson or by using the panel’s
navigation controls. On page 2, click the Play/Pause button in the movie controller to play
and pause the movie. There is a separate control to adjust the sound volume.

Note
Each reader app will have different video player controls. After you export your
EPUB, test the video player in different readers.

7. Close the EPUB Interactivity Preview panel and choose File > Save.

Adding a sound
Adding a sound to a page is the same as adding a movie, but the options for controlling how
sounds are displayed and played are a little different from those for modifying movies because
movies and sounds are different types of media.
Next, you’ll add a sound to the cover page, and then you’ll convert one of the objects on the page
into a button that plays the sound when clicked. You’ll also hide the sound object so that it’s not
visible on the page.

1. Navigate to page 1. Choose File > Place, select the BckgMusic.mp3 sound file in the Links
folder in the Lesson15 folder, and then click Open.
2. Click the pasteboard outside the upper-left corner of the page. Don’t worry about placing
the sound precisely because you’ll hide this object later.

3. Use the Selection tool to position the sound frame on top of the hat illustration.
4. Open the Media panel ( ), and notice the options available for a sound file. If you want,
use the Play and Pause buttons to preview the sound. Leave the default settings unchanged.

This is all you need to do to add a sound, but for this lesson, instead of displaying sound
controls in the reader, as would happen if you left the object where it is, you’ll make it
smaller, hide it, and then configure a button to play it.

Note
By default, a controller is displayed for a sound file. The Media panel doesn’t
include an option that enables you to turn off display of the controller for a sound
file.

5. In the Control panel, change the Width and Height of the sound frame to 30 (pixels).
6. Choose Object > Arrange > Send To Back.

7. Use the Selection tool to select the hat illustration that’s now in front of the sound frame.
8. Open the Buttons And Forms panel. Choose Button from the Type menu in the Buttons

And Forms panel, and enter Play Music in the Name field.
9. Make sure On Release Or Tap is selected in the Event menu. Click the + sign ( ) next to
Actions and choose Sound. Because the page has only one sound, it is automatically
selected in the Sound menu. Ensure that Play is selected in the Options menu.

10. Click the Preview Spread button. Click the Play Preview button in the EPUB Interactivity
Preview panel, and then click within the hat illustration to play the sound. The audio clip
(approximately 30 seconds in length) will play once and stop.
11. Close the EPUB Interactivity Preview panel and choose File > Save.

Creating a slideshow
A slideshow is a sequence of stacked images displayed one at a time as a viewer taps Previous
and Next buttons. The sample document for this lesson already includes the graphics you need to
create an interactive slideshow. You’ll arrange these graphics in a stack, convert them into a
multi-state object, and then configure buttons that enable a viewer to navigate through the slides.
1. Navigate to page 2 of the document.
2. Using the Selection tool ( ), select the top image of the dog, the frontmost of the five
overlapping graphics frames, to the right of the movie frame.
3. Press Shift, and then select each of the other four overlapping graphics frames in succession
from front to back. Release the Shift key after you’ve selected all five frames.
4. Choose Window > Object & Layout > Align. In the Align panel, choose Align To Selection
( ) from the Align To menu if it’s not already selected. Click the Align Left Edges button
( ), and then click the Align Bottom Edges button ( ). Close the Align panel.

5. With the graphics frames still selected, choose Window > Interactive > Object States to
display the Object States panel, or click the Object States icon ( ) to open it from the
dock, and then click the Convert Selection To Multi-State Object button ( ) at the bottom
of the panel. If necessary, lengthen the panel to display the names of all objects. (The panel

looks empty until you do the conversion.)

Tip
Each state in a multi-state object can be named. The stack is like a layer stack and the
order of the objects can be changed by dragging them up or down. 6 In the Object States
panel, enter Guest Quotes in the Object Name box, and then press Enter or Return.

Now that you’ve created a multi-state object, you’ll create a way to enable viewers to scroll
through the images.
1. Use the Selection tool to select the red arrow below the lower-left corner of the multi-state
object and open the Buttons And Forms panel ( ). This will be the button used to scroll
backward through the slides.
2. In the Buttons And Forms panel, click Convert To Button ( ) at the bottom of the panel,
and enter Previous in the Name box.

Tip
When there are several multi-state objects on a page, you may need to choose the
correct multi-state object from the Object menu in the Buttons And Forms panel. In
this file, InDesign automatically selects the Guest Quotes multi-state object because
it’s the only one on the page.

3. Click the + sign ( ) next to Actions and choose Go To Previous State from the menu.
(The “Guest Quotes” multi-state object is automatically added to the list of actions.)
4. Don’t select Stop At First State. When it’s not selected, when the user clicks to the last
slide and clicks the arrow again, the first slide will display. In other words, you can keep
clicking through the slides in a loop. When it is selected, nothing happens when the user
clicks the arrow again after the last slide is displayed.

5. Select the right-pointing red arrow and repeat steps 2–4 to configure a button named Next.
To make a button that scrolls forward through the slides, when you click Add New Action
For Selected Event, choose Go To Next State from the Actions menu, and then select Stop
At Last State (or not, as you choose).
6. Open the EPUB Interactivity Preview panel, click the Play Preview button, and then click
the Previous and Next buttons you created to view the slideshow.
7. Close the EPUB Interactivity Preview panel and choose File > Save.

Creating a hyperlink
Hyperlinks let viewers jump to other locations in a document, as well as to other documents or to
websites. A hyperlink includes a source element (text, a text frame, or a graphics frame) and a
destination, which is the URL, email address, page, or text anchor to which the hyperlink jumps.
Next, you’ll create a hyperlink to a website using a graphics frame.
1. Use the Selection tool to select the graphics frame in the lower-right corner of page 2 (the
Cat Spa photo). An animation icon is displayed in the lower-right corner because the
graphics frame—along with the other graphics frames along the bottom of the page—is
configured to fly in when the page loads.
2. Choose Window > Interactive > Hyperlinks to display the Hyperlinks panel, or click the
Hyperlinks icon ( ) to open it from the dock.
3. Choose New Hyperlink from the Hyperlinks panel flyout menu.

4. Select URL from the Link To menu, and type a URL in the URL box (the sample document
uses http://www.humanesociety.org). Deselect Shared Hyperlink Destination and click OK.
5. Open the EPUB Interactivity Preview panel, click the Play Preview button, and then click
the text frame to which you added the hyperlink. The Humane Society of the United States
home page is displayed in your browser.
6. Return to InDesign, and display the first page of the document.
7. Close the EPUB Interactivity Preview panel and choose File > Save.

Exporting an EPUB file
Much as the settings in the Print dialog box control the appearance of printed pages, the settings
you use when you export an InDesign document as an EPUB control the appearance of the
EPUB.
1. Choose File > Export.
2. In the Export dialog box, choose EPUB (Fixed Layout) from the Save As Type menu
(Windows) or the Format menu (macOS).
3. In the File Name box (Windows) or the Save As box (macOS), name the file
15_FixedLayout.epub and save the file in the Lesson15 folder, located inside the Lessons
folder within the InDesignCIB folder on your hard drive. Click Save.

Note
Rasterize First Page creates an image that will be used as an icon for the publication
in the ebook reader app and on an ebook storefront.

4. In the General section of the EPUB – Fixed Layout Export Options dialog box, notice that
EPUB 3.0 is automatically displayed for Version. This is the only EPUB version available
for fixed-layout EPUBs. Make sure the following options are selected:

Export Range: All Pages
Cover: Rasterize First Page
Navigation TOC: None
Spread Control: Disable Spreads

5. Click Metadata in the list on the left of the EPUB – Fixed Layout Export Options dialog
box. Enter Multimedia Brochure in the Title field and your name in the Creator field.

Tip
If your EPUB will be formally published, the information in the Metadata dialog
box is very important. Ebook sites require that this information be provided.
Download the metadata specifications from the publisher.

6. Click Conversion Settings in the list on the left of the EPUB – Fixed Layout Export
Options dialog box. Choose PNG from the Format menu to ensure that the graphics in
grouped objects are displayed correctly in the exported EPUB.
7. Click Viewing Apps in the list on the left of the EPUB – Fixed Layout Export Options
dialog box.
The System Default in the Viewing Apps section will vary depending on your operating
system. For this lesson, we’ll use Adobe Digital Editions as the viewing application (ebook
reader). If you’ve installed Adobe Digital Editions and it’s not listed as an application, click
Add Application and select it from the Program folder (Windows) or Applications folder
(macOS) on your computer, and then select it as the preferred viewing application.
Alternatively, select another program that reads EPUBs. When the EPUB is exported, it is
automatically opened in the selected program. The Adobe Digital Editions software is
available as a free download from www.adobe.com.

8. Click OK to export a fixed-layout EPUB. If an alert is displayed warning that certain
objects might not appear as expected after export, click OK to continue and view the
EPUB.
If Adobe Digital Editions is installed on your computer, the EPUB file will open
automatically, and you can navigate through it to view the content and work with the
multimedia and interactive elements you created. You can also open the EPUB file on any
device that supports the EPUB format.
Notice the differences in the interface between different ebook readers (frame, style and
location of controls, fit in window, etc.). Part of the process of creating a digital publication
such as a fixed-layout EPUB is to test the functionality on the various devices the target
audience might use.

9. Return to InDesign.
10. Choose File > Save.
Congratulations! You’ve created a fixed-layout EPUB with multimedia and inter-activity that
will have the same layout across all viewing devices.

Exploring on your own
For additional practice, try some of the following exercises. You can continue working on the
sample document and save your changes, or you can choose File > Save As and save a new
document with a new name to the Lesson15 folder.

Timing animations
In this lesson, you used the Timing panel to configure the timing of three animated objects on
page 1 that play automatically when the page opens. The controls in the Timing panel also let
you play the animations sequentially in any order you want, and you can even create
combinations of simultaneous and sequential timing.
1. With page 2 displayed in the document window, make sure nothing is selected, and then
open the Timing panel.
2. Choose On Page Load for Event. The five animations are listed in the order in which they
were created. Select the first animation, then Shift-click the last animation to select all
animations. Click the Play Together button ( ) at the bottom of the panel.

3. Click the Preview Spread button at the bottom of the panel to preview the page to see what
happens.
4. Select all of the animations again, and then click Play Separately ( ) at the bottom of the
Timing panel.
5. Continue to adjust the settings in the Timing panel. The Delay field lets you add pauses
between animations. Experiment with this field by selecting individual animations and
specifying a Delay value. Preview the page each time you make a change.
6. Continue to experiment by creating different combinations of sequential and simultaneous
animations. For example, configure two of the animations to play together first, and
configure the remaining animations to play together after a short delay.

InDesign CC Publish Online
The Publish Online feature in InDesign CC allows you to distribute digital versions of your
InDesign documents on the Internet. Documents you publish online can be viewed on any
desktop or mobile device and easily shared on Facebook and Twitter. You can easily
provide hyperlinks to these documents in emails or embed the hyperlinks in web pages.
The InDesign documents you publish online are visually identical to the original layouts,
and all interactive features are supported.

Tip
If you don’t intend to distribute your documents online, you can hide all Publish
Online commands and controls by selecting Disable Publish Online in the Publish
Online section of the Preferences dialog box.

1. To publish the currently displayed document online, click Publish Online in the
Application bar or choose File > Publish Online.
2. In the General section of the Publish Your Document Online dialog box, use the
default name or enter a new one in the Name field and, optionally, add a description.
3. The Advanced section of the Publish Your Document Online dialog box lets you
choose a cover page and specify image export settings. Make any changes you want in
this dialog box, and then click Publish.

A window displays as the document uploads and provides a preview of the first page,
the name of the document, the description (if any), a status bar showing the progress of
the upload, and the opportunity to cancel the upload.
4. When the upload is complete, click View Document to display the document in a web
browser and click Copy to copy the URL to the Clipboard. You can also click the
Facebook, Twitter, or email buttons to share the link on social networks. Test the
interactive features in your browser. Note that it may take a few minutes for both
pages to be loaded and working. Also notice that the interface looks different from the
ebook readers and will vary between browsers.

5. After viewing your file online, return to InDesign and click Close to close the Publish
Online window and return to your document.

After you publish documents online, you can easily access the five most recently published
documents from within InDesign by choosing File > Recently Published. (The Recently
Published menu does not appear until after you have published your first document.)
Choose a name from the list to open the document in your web browser.

The Publish Online Dashboard lets you view, share, and delete all published documents. If
you want to remove a document that you’ve published online, choose File > Publish Online
Dashboard. A web page opens in your default browser and displays in chronological order a
list of the documents you’ve uploaded with the most recent at the top. To delete a published
document, point at it in the list and then click the trash can icon on the right.

Adding sound control buttons
You also can add controls to a sound file in the Media panel. After you imported a sound file in
this lesson, you configured a button to play the sound. You also hid the sound object, which also
hides the sound controller in the exported file. See what happens if you choose to display the
sound.
1. Place the same BckgMusic.mp3 sound file in the Links folder in the Lesson15 folder onto
the pasteboard, and then drag it onto one of the pages.
2. Enter 300 in the Scale X Percentage or Scale Y Percentage box in the Control panel and
press Enter or Return. (Enlarging the object makes the sound controls in the exported
EPUB more visible and easier to operate.)

3. In the Media panel, choose Standard from the Poster menu. This displays a sound icon
within the frame on the InDesign page, as well as in an exported interactive PDF file.
4. Preview the page in the EPUB Interactivity Preview panel. Use the controls on the sound
controller to play and pause and to mute and unmute the sound. Optionally, export a fixedlayout EPUB and see how the sound controls are displayed and function in the selected
viewing app(s).

Viewing your EPUB on a tablet
It’s important to test the experience that readers of your EPUB will have when using an ebook
reader on devices such as a tablet. First, install one or more ebook readers on the device, such as
Adobe Digital Editions. The easiest way to view your EPUB on an iPad or Android tablet is to
email it to yourself as an attachment. On the tablet, open the email and tap the attachment to
download it and choose the ebook reader on your device to open it, such as Adobe Digital
Editions or iBooks. (The exact steps will vary with different email apps on different devices.)
Test the interactive features in the ebook reader.
Once you know the audience for your publication, it’s a best practice to test the publication in the
ebook readers they are most likely to use and make adjustments if necessary.

Creating a slide-in caption
In this exercise, you’ll learn how to create a slide-in caption using the techniques you’ve
explored throughout this book, especially Lesson 15. You’ll change the graphics used in the
existing mission statement and then to set them up to create this effect. You’ll use the Layers
panel to select groups and objects within groups. You’ll create mulit-state objects and buttons
and apply animation effects.
Although there are many steps and it seems complex, take your time and follow the steps
deliberately. You have learned all of the techniques needed.
1. To view the finished effect, open the file 15_FixedLayout-Alternate from the Lesson15
folder. The red box with the mission statement has been changed to a slide-in caption.
2. Open the EPUB Interactivity Preview panel (Window > Interactive) and click the red
triangle above the words “Our mission” on the far left of the photo of the dog and cat with a
white background. A text frame containing the mission statement slides in from the left,
over the picture.
3. Click the red triangle again; the mission statement slides off the photo and the button
returns to the start position. Close the EPUB Interactivity Preview panel.

If you want, leave the file 15_FixedLayout-Alternate open for reference as you work.
Setting up the graphics
First, you need to change the existing objects in the mission statement to create the new objects
that will work with the effect.
1. Choose File > Open, and then open the 15_FixedLayout_Partial file in the Lesson15 folder.
2. Choose File > Save As, name the file 15_FixedLayout_Slide-in.indd, and save it in the
Lesson15 folder.
3. Using the Selection tool ( ), select the red text frame that contains the mission statement.
Open the Layers panel and press Alt (Windows) or Option (macOS) while dragging the
blue square in the Layers panel up to the Buttons layer to create a copy of this object on the
Buttons layer. Click the visibility icon ( ) of the Buttons layer to hide the layer.
4. On Layer 1, select this red text frame again. With the Type tool ( ), select all the text and
delete it.
5. Press the Escape key to return to the Selection tool. Select Fill color ( ) at the bottom of
the Tools panel, in the Control panel, or in the Swatches panel, and choose [Paper]. Select
Stroke color and choose [None].
6. Choose Object > Content > Graphic. This converts the text frame to a graphics frame.
Choose File > Place, select Friends-Mission.jpg, and click Open.
7. Choose Object > Fitting > Content-Aware Fit.
8. Select the containing frame (not the image), and drag the left handle of the frame to the
edge of the page. Then choose Object > Fitting > Center Content.
9. Choose File > Save.
Now you’ll change the formatting of the mission statement text and text frame.
1. In the Layers panel, lock Layer 1 so that you don’t change anything accidentally. Click in
the far-left column next to the Button layer to restore layer visibility ( ).
2. Using the Selection tool ( ), select the red text frame that contains the mission statement.
Open the Swatches panel and click the Formatting Affects Text button ( ). Select Dark
Gray for the text fill color ( ). Click the Formatting Affects Container button ( ); select
[Paper] for the fill color and [None] for the stroke color.
3. With the text frame still selected, select the Type tool ( ) in the Tools panel. Using the
Character panel (Type > Character), change the font to Myriad Pro Bold and the size to 18
points. Close the Character Panel.
4. Choose Object > Text Frame Options. In the Inset Spacing section of the General tab, click
the Make All Settings The Same icon ( ) and click the down arrow twice in any one of

the settings so that they are all set to 10 px. Click OK.
5. Click the Selection tool again. Scale the text frame as follows: In the Control panel, set the
reference point to the center ( ) position and type 185 px in the Height box. Change the
reference point to upper left ( ) (or middle or lower left), and type 425 px in the Width
box.

6. Choose Window > Effects to open the Effects panel. Choose Clear Effects from the panel
menu to remove the drop shadow. Click the Fill level and change the opacity to 64%.
Now you will add the vertical text that says “Our mission,” which will become the button
that triggers the movement of the caption. To save a few steps, a vertical text frame is on the
pasteboard at left, ready for you to use.

7. Hold down the spacebar, and click and slide to the right to reveal the pasteboard to the left
of the page. Using the Selection tool, select the text frame containing “Our mission.” Hold
down the Shift key to constrain the movement to horizontal, and drag this text frame to the
right side of the mission statement text frame. This text frame also contains an anchored
vector object, the red triangle, which will signal the reader to click or tap there.
8. Choose File > Save.
Creating duplicate groups
The structure of this effect is based on using duplicated groups of the same objects moved to
different locations. Next, you’ll create those groups.
1. Using the Rectangle Frame tool ( ), create an empty graphics frame (no stroke and no fill)
over the vertical text frame with the red triangle. Make it a little larger so that it will be
easy for you to see the edge and distinguish between the text frame and the button. This
will become the clickable or tappable area for the reader.

2. Drag-select a small area that overlaps the mission statement text frame, the vertical text
frame, and the empty frame. Choose Object > Group.
3. Choose Edit > Copy. Then choose Edit > Paste In Place two times so three copies of the

group are placed on top of each other.
4. Open the Layers panel, and drag it off the dock so that it will stay open. You will use the
Layers panel to select the groups, and to select objects within a group, quite often to
complete this exercise, so it’s more efficient to leave it open.
5. Many objects now exist in the Buttons layer. To be sure you are working with the correct
groups, create another layer and name it Mission.

Tip
Another way to organize groups is to rename them. Triple-click the group name in
the Layers panel while the pointing hand is active. This enables you to click into the
name and type a new name.

6. Click the open triangle to the left of the Buttons layer to reveal the list of objects in that
layer. The top three groups are the groups you just pasted. You can confirm this by toggling
their visibility ( ) off and on. Click one to select it, and then hold down the Shift key and
select the other two duplicate groups. Drag them up to the Mission layer. Click the triangle
to close the Button layer. You will be working only on the Mission layer.

7. Select two of the groups by clicking the square next to one group, then holding down the
Shift key, and clicking the square to the right of another group in the Layers panel.
8. Drag the selected groups to the left to establish the starting position for this effect as shown.
The selected groups should be off the page except for the “Our mission” frame, which will
serve as the button that readers click to open the caption.

Creating a multi-state object
The next step is to turn the groups into object states.
1. In the Layers panel, select all three groups in the Mission layer by clicking the square to the
right of one of them and then Shift-clicking the other two groups.
2. Open the Object States panel and choose New State from the panel flyout menu. The new
multi-state object consists of three states that are identical, except for their position. Click

each state and notice its location. States 1 and 2 are in the same position (mostly off the
page), whereas State 3 is on the page.

3. Now you will name the states so that it is clear which is which as you continue creating the
effect. To change a name, triple-click it while the pointing hand is displayed. Name State 1
Begin, State 2 End, and State 3 Middle. Notice that the Begin and End states are exactly
the same at the moment. The effect needs these states to be identical because you will add a
different animation for each state.
4. Name the multi-state object itself Mission Caption.
5. At this point, it will be more convenient to leave the Object States panel open, so drag it off
the dock.
Creating buttons within the multi-state object
Now you will create the buttons the reader will use to open and close the caption.
1. Select the Begin state in the Object States panel. The objects within the state are
automatically selected. With the Selection tool ( ), double-click the frame with no stroke
and no fill on top of the “Our mission” text frame.

2. Open the Buttons And Forms panel (Window > Interactive). Click the plus sign to the right

3.
4.
5.
6.
7.
8.
9.

of Actions, and choose Go To State. Name the button Begin Button. From the State dropdown menu, choose Middle to specify that the button go to the Middle state when clicked
or tapped.
Press the Escape key three times to move the selection back to the parent object.
In the Object States panel, select the End state. Using the Selection tool, double-click the
frame with no stroke and no fill on top of the “Our mission” text frame in this state.
In the Buttons And Forms panel, choose Go To State for Action, and then Middle for State.
Name the button End Button.
Press the Escape key three times to move the selection back to the parent object.
On the Object States panel, select the Middle state. Using the Selection tool, double-click
the frame with no stroke and no fill on top of the “Our mission” text frame in this state.
In the Buttons And Forms panel, choose Go To State for Action and End for State. Name
the button Middle Button.
Press the Escape key three times to move the selection back to the parent object.
To summarize, the Begin button goes to the Middle state, the End button goes to the Middle
state, and the Middle button goes to the End state.

10. Open the EPUB Interactivity Preview panel, click the Play Preview button, and click the
“Our mission” button. The caption appears. Click it again and the caption closes. In the
next section, you will use animation to specify a smoother display for the caption. Close the
EPUB Interactivity Preview panel.
Adding animation to objects within the multi-state object
InDesign’s animation presets are used to create the smooth, sliding motion of opening and
closing the caption.
1. Make sure you still have the Middle state selected within the Object States panel.

2. In the Layers panel, click the triangle to open the Middle group, and click the square to
select one of the objects that make up this group. It’s important to select the objects and not

the state itself. If you select the state, you will produce a different effect. Select the Middle
Button object first.

3. Open the Animation panel and choose the Fly In From Left preset. For Event, make sure
that On State Load is selected (which it should be by default). Click the triangle next to
Properties to make more controls visible. For Animate, choose To Current Location. For
Opacity, choose None.

Note
After you change the Opacity setting to None, the Preset setting in the dialog box
changes to Custom (Fly In From Left) because you have changed a setting of the Fly
In From Left preset.

4. In the Layers panel, choose the next object in the Middle state and apply the same settings
in the Animation panel. Do the same with the third object.
5. Open the Timing panel. Make sure On State Load is selected from the Event menu. Shiftclick all the objects listed. Click the Play Together button ( ) at the bottom right.

6. Press the Escape key again until the parent object is selected. In the Object States panel,
choose the End state.
7. In the Layers panel, click the triangle to open the End group, and click the square to select
the objects that make up this group. Select the End Button object first.

8. In the Animation panel, choose Fly In From Right from the Preset menu. For Event, make
sure that On State Load is selected. Choose To Current Location from the Animate menu,
and choose None from the Opacity menu.
9. In the Layers panel, choose the next object in the End state and apply the same settings in
the Animation panel. Do the same with the third object.
10. Open the Timing panel. Make sure On State Load is selected from the Event menu, and
Shift-click all the objects listed. Click the Play Together button ( ) at the bottom right.
11. Open the EPUB Interactivity Preview panel, click the Play Preview button, and click the
“Our mission” button. Now the caption opens with a smooth, sliding motion. Click the
“Our mission” button again to close the caption. Now it also closes with the same smooth,
sliding motion.
12. Close the EPUB Interactivity Preview panel, and choose File > Save.
Congratulations! You have created a very useful and appealing slide-in caption. This effect can
be easily modified for objects that you want to slide in and out from other directions.

Review questions
1 What’s the primary difference between a reflowable EPUB and a fixed-layout EPUB?
2 InDesign provides two methods for animating objects. What are they, and how do they differ?
3 By default, animations play in the order in which they were created. How can you change the
order in which animations are played, and how can you play multiple animations
simultaneously?
4 How can you preview multimedia and interactive elements within InDesign?
5 How do you create a slideshow?

Review answers
1 The reflowable EPUB format allows the EPUB reader to optimize the content depending on the
display device. For example, the viewer of a reflowable EPUB can adjust the display size of
the text, which affects the amount of text on a given page and the flow of text from page to
page. In fixed-layout EPUBs, the dimensions of the original InDesign pages are maintained, as
is the fidelity to the original layout.
2 You can animate objects in groups by choosing a motion preset in the Animation panel, or you
can create a motion path. A motion path consists of two elements: the animated object or

group and a motion path along which the animated object moves.
3 The controls in the Timing panel let you control when animations are played. All animations
associated with the selected Event (such as On Page Load) are displayed. You can drag the
names within the list to change the order in which they’re played. To play them
simultaneously, you can select multiple animations and click the Play Together button ( ).
4 The EPUB Interactivity Preview panel lets you preview and test multimedia and interactive
elements. The Animation, Timing, Media, Object States, and Buttons And Forms panels all
include a Preview Spread button ( ), and you can also display the panel by choosing
Window > Interactive > EPUB Interactivity Preview.
5 To create a slideshow, first create a stack of objects, and then use the Object States panel to
create a multi-state object. Next, create and configure two buttons: one that displays the
previous state of the multi-state object, and one that displays the next state.
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Symbols
+ (addition), performing, 103
/ (division), performing, 103
* (multiplication), performing, 103
- (subtraction), performing, 103

A
Acrobat Reader, 377–378
addition (+), performing, 103
Adjust Layout feature, 74. See also layout aids
Adobe Acrobat Reader, 377–378
Adobe Bridge, importing graphics, 273–274
Adobe fonts, 173
Adobe Paragraph Composer, 186, 188

Adobe PDF proofs. See PDF proofs
alert icon
Find/Change dialog box, 159
graphics, 346
links, 265
Links panel, 267
missing font, 153
Align Center icon, 182, 302
Align Horizontal Centers button, 116
Align Right Edges button, 116
Align To Object Center, 95
Align To Object Edges, 95
aligning
objects, 115–116
text, 143–145
All Caps type style, 158
Alt key. See keyboard shortcuts
anchor point, selecting and unselecting, 93
anchored graphics frames. See also graphics frames
creating, 280–282
text wrap, 282–283
Angle and Altitude, transparency, 337
Animated Zoom, 25–26
Animation panel, 394
animations
motion presets, 384–386
playing with buttons, 388–391
Timing panel, 387–388
triggering motion paths, 391–393
Application bar, 9, 15–16, 37
Apply Style to Selection, 236
Arrange Documents button, 16
arrowheads, modifying, 120
assets, adding to CC Libraries, 287
attributes, changing, 158
audio
adding to EPUBs, 396–397
control buttons, 406
autocorrecting words, 163
Auto-Fit option, 102

Auto-Resize feature, 130

B
Background layer, moving items to, 90–91. See also dropped backgrounds
Based On style, 235
baseline grid, aligning text, 143–145
best practices, 52
Bevel and Emboss effect, 331
bitmap graphics. See also graphics
transparency, 326–327
vs. vector graphics, 263
Bleed and Slug option, 57–58
bleed guides, 77–79
Bleed mode, 37
blending modes
applying, 321–322, 324–325
removing, 339
transparency, 337
BMP format, 321
Body Copy style, 43
booklets. See Print Booklet feature
borders, adding to tables, 305–306
bounding box and path, 94
break characters, 181
breaking lines, 186–187
Bridge, importing graphics, 273–274
broken links, relinking, 275. See also linked files
bulleted lists, hanging indent, 192
buttons. See also EPUBs
motion paths for animations, 391–393
within multi-state objects, 411–412
navigation, 393
organizing, 388
PDFs with form fields, 376
playing animations, 388–391
sound control, 406
states, 376
Buttons And Forms panel, 389–390, 394, 399

C
capitalization. See Small Caps icon
Caption Setup dialog box, 104
captions
creating pop-ups, 394–395
slide-in type, 407–413
case. See Small Caps icon
Case Sensitive icon, 157–158
CC Libraries, 227, 287. See also object libraries
Cell Options, editing, 307
cell strokes, editing, 304–305
cell styles. See also styles
anchoring graphics, 309–310
applying, 313–314
creating, 248–250, 311–313
cells
adding graphics, 306–310
fill colors, 304
merging, 302
centering
paragraphs, 182
tables, 301
Change Format Settings dialog box, 158
Character Color box, 159
character formats, 40, 44
Character panel, 174–175
character styles. See also hidden characters; styles
applying, 239
creating, 237–239
creating and applying, 44–46
grouping, 20
nesting, 240–242
using, 42, 44
check boxes, PDFs with form fields, 373–374, 376
Choke, transparency, 337
circles, creating, 12
clear effects, Effects panel, 322, 339
Clear Overrides icon, 43
clipping paths, Photoshop, 276–279

cm (centimeter), 57
CMYK (cyan, magenta, yellow, black), 201, 208, 210–212, 348–350, 352–353, 362–364. See
also swatches
coated vs. uncoated, 349. See also Pantone Solid Coated library
collapsing panels, 19
color groups, adding colors, 223–224
color management, 201
color modes, converting for swatches, 207
color settings, displaying, 203
color swatches. See also swatch libraries
creating, 29–30
deleting, 223
color themes. See also Swatches panel
adding to CC Libraries, 227
adding to Swatches panel, 225–226
creating, 224
managing, 227
tool, 13, 210
viewing, 225
colorizing grayscale images, 319–321
colors. See also fill colors
applying, 320
applying to strokes, 215–216
applying to text, 216–217
assigning to layers, 88
changing for masthead, 345–347
creating, 207–212
managing, 351–353
proofing onscreen, 204
column widths, adjusting, 300–302
columns. See also tables
adjusting, 141–142, 181
beginning with headings, 96
creating, 132
inserting into tables, 299
rearranging in tables, 300
resizing, 301
specifying for text frames, 180
Columns section, 57
combo boxes, PDFs with form fields, 374, 376

Command key. See keyboard shortcuts
commands, Application bar, 37
compound shapes, 111
Consolidate All Windows, 17
Constrain Proportions For Scaling icon, 115
containers. See frames
content, choosing, 89
Content Collector tool, 105
Content Conveyor, adding objects, 105
Content Grabber icon, 48, 101, 270, 279
Content Placer tool, 106
context menus, 29
Control panel
moving, 22
reviewing, 14
scaling controls, 47
X and Y fields, 49
Convert Direction Point tool, 94
Convert Text To Table, 252
“copy” terminology, 43
copying effects between objects, 336–338
corners. See rounded corners
correcting misspelled words, 162–163
cropping graphics, 47–48, 99, 270–271
Ctrl key. See keyboard shortcuts

D
Delete, Effects panel, 322
deleting
color swatches, 223
document pages, 70–71
guides, 62
rows from tables, 300
dictionary, adding words, 161
Direct Selection tool. See also Selection tool
grayscale images, 320
grouped objects, 119
motion paths for animations, 393
reshaping text frames, 93–94

stroke and fill, 50
text wrap and anchored graphics frame, 283
Display Performance, 202, 269, 346
displaying. See also opening
Home page, 8
Learn page, 8
Start Screen, 8
Swatches panel, 29–30
Distance, transparency, 337
Distribute Horizontal Centers icon, 113
division (/), performing, 103
docking panels, 18, 22
document pages. See also pages
adding, 70
applying master pages, 69–70
rearranging and deleting, 70–71
document windows, 9, 15–18
documents. See also EPUBs; Fit Page In Window; pages
arranging, 16
changing magnification, 24–26
creating, 58–59
custom settings, 57–58
fixed-layout export, 383
viewing in Presentation mode, 51
dragging and dropping text, 163–164
dragging objects, 14
drawing
graphics frames, 98
lines, 120
drop caps, creating, 183–184
Drop Shadow effect, 331, 334
dropped backgrounds, 276–279. See also Background layer

E
Edit Original button, 275
editing text, 163–164
effects
adding to objects, 334–336
clearing, 339

copying between objects, 336–338
editing and removing, 338–339
panel, 322, 326
transparency, 331
either/or choices, PDFs with form fields, 372–373
Ellipse Frame tool, 12–13
em space, adding, 63
Emboss and Bevel effect, 331
EPUBs. See also buttons; documents
animations, 384–388
buttons, 388–393
duplicate groups, 409
exporting, 400–402
hyperlinks, 399–400
Interactivity Preview panel, 387
movies, 395–396
multi-state objects, 398–399, 410–413
navigation buttons, 393
pop-up captions, 394–395
reflowable versus fixed-layout, 383–384
slide-in captions, 407–413
slideshows, 398–399
sound, 396–397
sound control buttons, 406
viewing on tablets, 406
Essentials workspace, panels, 9
Expand Panels button, 19
Explorer, showing files in, 266, 272–273
exporting
EPUBs, 400–402
interactive PDF files, 377
eye icon
grayscale images, 319
Illustrator files with layers, 285
layers, 88
Photoshop files with layers, 280
previewing separations, 348
Eyedropper tool, 210

F
Facing Pages option, 57
Feather effects, 331–333
File Explorer, showing files in, 266, 272–273
files. See also images; linked files; Photoshop files
packaging, 362–364
preflighting, 345–347
relinking, 275
showing in Explorer, 266
showing in Finder, 266
selecting, 133
fill and stroke. See also strokes
applying to text, 178
changing, 50
Fill box
characters, 237
icon, 210
fill colors, applying to objects, 213–215, 320. See also colors
Fill Frame Proportionally, 271
fill patterns, adding to tables, 303
Find/Change dialog box, 158
Finder, showing files in, 266, 272–273
finding and changing
formatting, 158–159
text, 156–158
Fit Content Proportionally, 271
Fit Page In Window. See also documents; pages
aligning objects, 115
compound shapes, 111
document window and pasteboard, 16
fonts and leading, 174
preflighting, 39
Zoom tool, 26
Fit Spread In Window, 27, 64, 132, 135, 354. See also spreads
Fitting commands, 102
fixed-layout export, 383–384
flattening, 353–354, 360
floating panels, 18, 21
flowing text

automatically, 137–138
manually, 132–133
fonts. See also missing fonts
adding from Adobe fonts, 173
applying, 174–176
filtering options, 179
and leading, 174–176
ligatures, 176
OpenType, 174
selecting, 175
sizes, 174–176
styles, 174–176
Type menu, 177
footers, creating, 64. See also snippets
formatting. See also nesting styles
finding and changing, 158–159
tables, 303–306
text, 20, 233
text for character style, 44
using styles, 52
forms, workspace, 369. See also PDFs with form fields
fraction characters, inserting, 178–179
frame creation tools, using, 100
frame guides, hiding, 16
frames. See also shape of frames; threaded frames
adding rounded corners, 113
adjusting space between, 103
hiding, 79–80
parentheses, 75
Free Transform tool, 13
FX button, Effects panel, 322, 338

G
Gap tool, 103
gear icon, 14
Glow Color, setting, 336
glyphs, accessing, 176, 178–179
Go To Link button, 265, 269
Go To Page, 28

GPUs (graphics processing units), display performance, 269
gradient angles, constraining, 222
gradient blends, adjusting direction, 221–222
gradient feather, applying, 332–333
gradient swatches. See also swatches
applying, 221
creating, 220
graphic cells, placing images, 307–308
graphics. See also bitmap graphics; revised graphics; vector graphics
adding from programs, 263
adding to table cells, 306–310
alert, 346
anchoring in table cells, 309–310
cropping, 99, 270–271
dropping from desktop, 272–273
frame fitting options, 271
importing, 270–271, 273–274
placeholder frames, 66–67
placing in grid of frames, 100–101
placing in master pages, 75–77
placing into frames, 271–273
placing within frames, 99
placing without frames, 99–100
sizing, 270–271
vector versus bitmap, 263–264
working with, 46–48
wrapping text around, 109–110
graphics frames. See also anchored graphics frames
drawing, 98
metadata captions, 104–105
parent-child, 106–108
placing and linking, 105–108
Graphics layer, expanding, 89
grayscale images, importing and colorizing, 319–321. See also images
grouped objects, selecting and modifying, 118–119. See also objects
grouping panels, 20
grouping styles, 244
guides. See also Smart Guides
adding to master pages, 60
deleting, 62

dragging from rulers, 61–62
pasting, 62
stepping and repeating, 62
viewing, 37
gutter
explained, 60
setting, 57

H
Hand tool
effects between objects, 336
grayscale images, 320
and Line tool, 11–12
objects, 115
text frames on master pages, 63
transparent backgrounds, 278
using, 29
hanging indent
bulleted list, 192
numbered list, 192
hanging punctuation, 183. See also Punctuation filter
Head 2 style, keyboard shortcut, 236
headers, duplicating on master pages, 64–65. See also snippets
header rows, tables, 310–311. See also rows
headings, beginning columns with, 96
hidden characters, 37, 96, 189, 296. See also character styles
hiding frames and panels, 79
High Quality Display, 9, 31, 269, 284
Home page, opening, 8
horizontal rule, adding, 193–195
hyperlinks, EPUBs, 399–400
hyphenation settings, 186–187

I
IDML (InDesign Markup Language), 363
Illustrator files
importing, 284–285
transparency, 328–329

images. See also files; grayscale images; imported images; missing images
anchoring in tables, 306
displaying at full resolution, 202–203
placing in graphic cells, 307–308
resizing and moving in frames, 101–102
rotating within frames, 114–115
imported images, identifying, 264–265. See also images
importing
and flowing text, 40–42
graphics, 270–271, 273–274
grayscale images, 319–321
Illustrator files, 284–285
Illustrator files with transparency, 328–329
native Adobe graphic files, 280–285
tables, 297
text, 155–156
text into text frames, 129
video files, 395
in (inch marks), 57
indents, adjusting, 192
InDesign CC
best practices, 52
Publish Online feature, 404–405
InDesign library, creating, 288. See also CC Libraries
Info panel, opening and closing, 18
Ink Limit option, 348
Ink Manager, using, 351–353
ink swatches, 353
Inner Glow effect, 331
Inner Shadow effect, 331
Intent to Mobile, setting, 383
interactive elements and multimedia, 395–400
interactive PDF files, exporting, 377
Interactivity Preview panel, EPUBs, 387
interface preferences, modifying, 30–31
Isolate Blending, Effects panel, 322

J
JPEG format, 321

jump line page number, 146–147
Justification settings, 186

K
kerning and tracking, adjusting, 185
key object, specifying, 116. See also objects
keyboard shortcuts
formatting text, 233
Go To Page, 28
Head 2 style, 236
magnifying documents, 24
Quick Apply, 240
single letters, 11
Undo, 10, 14
using, 236, 239
Knockout Group, Effects panel, 322

L
layer lock icon, 319
layers
colors, 88
creating and reordering, 90
Illustrator files, 284–285
panel, 88
Photoshop files, 280
renaming, 90
showing and hiding, 329
using, 87
layout aids, 37. See also Adjust Layout feature
leading, applying for fonts, 174–176
leading grid, aligning text, 143–145
Learn page, displaying, 8
left stop marker, gradient swatches, 220
letter spacing, adjusting, 184–185
levels, Effects panel, 322
libraries. See CC Libraries; object libraries
ligatures, 176
line breaks

adjusting, 186–187
inserting manually, 187
line styles, nesting, 242
Line tool, 11–12
linear gradient, 219
lines, drawing, 120
link symbol, 346
linked files, 265–266. See also broken links; files
linking
and placing graphics frames, 105–108
tables, 297
text frames, 40
Links panel
alert icon, 265, 267
detaching, 265
status icons, 268
list boxes, PDFs with form fields, 376
list of choices, PDFs with form fields, 374
lists
bulleted, 192
numbered, 192
loaded graphics icon, 47, 100
loaded text icon, 129, 134–135, 137
loaded video icon, 395
lock icon, 96, 98, 323
lowercase. See Small Caps icon

M
magnification, changing, 24–26
mailto:, Submit button, 375
Make All Settings The Same icon, 97
margins
hanging punctuation, 183
setting, 57
mask, defined, 276
master items, overriding, 67–68
master pages
applying to document pages, 69–70
creating, 67

displaying icons, 67
duplicating headers, 64–65
explained, 59
guides, 60
overriding items, 75–77
parent, 68–69
parent-child, 67
placeholder frames for text, 65–66
renaming, 65
single-clicking, 73
spreads, 65
text and graphics, 75–77
text frames, 63–65
masthead, changing colors, 345–347
Measure tool, 71–72
measurements and units, 57
Media icon, 396
Media panel, 397
Menu bar, 9
menus. See context menus; panel menus
merging cells in tables, 302
metadata captions, graphics frames, 104–105
missing fonts, finding and changing, 153–154. See also fonts
missing icon, 275
missing images, selecting, 275. See also images
mm (millimeter), 57
Mobile and Web options, 383
More button, 234
motion paths, triggering for animations, 391–393
motion presets, animation, 384–386
movies, adding to EPUBs, 395–396
moving
Control panel, 22
images within frames, 101
objects, 14, 49
Tools panel, 22
multimedia and interactive elements, 395–400
multi-state objects, 398–399, 410–413. See also objects
multiplication (*), performing, 103

N
navigating pages, 27–28
navigation buttons, animations, 393
nesting styles, 240–244. See also formatting
New Character Style dialog box, 45
New Swatch icon, 211
Newsletter document, creating, 57
Next Page button, 27
Noise, transparency, 337
Normal icon, 37, 189
Notes panel, 166
Number Of Pages box, 57
numbered list, hanging indent, 192
numbering pages, 59

O
Object Arrange command, 89
object libraries, 286–289. See also CC Libraries
object styles. See also styles
applying, 247
described, 42
creating, 245–246
using, 51
objects. See also grouped objects; key object; multi-state objects
adding to Content Conveyor, 105
aligning, 115–116
anchoring in tables, 306
avoiding stacking, 52
copying effects, 336–338
dragging, 14
effects, 334–336
fill colors, 213–215
formatting for styles, 244–245
moving and resizing, 14
moving and rotating, 49
within multi-state objects, 412–413
rotating, 114
scaling, 117

selecting, 10
stroke and fill, 50
transforming, 117–118
opacity
bitmap graphics, 327
changing for solid-color objects, 323–324
Effects panel, 322
explained, 337
removing, 339
slider, 339
opening. See also displaying
and closing panels, 18
Info panel, 18
OpenType fonts, 174–175
Optical Margin Alignment, 183
Optimized Subsampling option, 360
Option key. See keyboard shortcuts
Ornaments filter, fonts, 179
Outer Glow effect, 331, 335
outlines, using, 244
output issues, preflighting, 38–39
oval graphics frame, dragging, 13
overset text frame, expanding, 39. See also text frames

P
p (pica), 57
packaging files, 362–364
page numbering, 59, 63, 72–74, 146–147
Page Size, specifying, 57
Page tool, 71
pages. See also document pages; Fit Page In Window
adding while flowing text, 139
navigating, 27–28
previewing, 354–355
resizing, 71–72
Pages panel
expanding, 19
opening, 58
using, 59

panel groups, minimizing, 21
panel menus, 29–30
panels
docking, 18
Essentials workspace, 9
expanding and collapsing, 19–20
floating, 18, 21
grouping, 20
hiding, 79
icon, 386
opening and closing, 18
rearranging and customizing, 20–21
styles, 233
undocking, 22
ungrouping, 21
using, 44
PANTONE color swatch, 208–209, 348–349, 352–353. See also swatches
Pantone Solid Coated library, 353. See also coated vs. uncoated
paragraph alignment, changing, 182–183
paragraph formats, 40, 181, 282
paragraph indents, adjusting, 192
paragraph return icon, 296
paragraph spacing, changing, 172
paragraph styles. See also styles
applying, 130, 236
applying to text, 140–141
creating, 234–236
grouping, 20
types, 42–43
paragraphs
density, 188
shading, 193
parent-child
graphics frames, 106–108
master pages, 67
parentheses, appearance with frames, 75
parent-master, modifying, 68–69
Paste Remembers Layers, 87
path and bounding box, 94
Pathfinder section, 111

PB (pasteboard), 15–16, 109
PDF files, exporting, 377
PDF proofs
creating, 355–357
press ready, 357–358
saving presets, 359
PDFs with form fields. See also forms
button states, 376
check boxes, 373–374, 376
combo boxes, 374, 376
either/or choices, 372–373
list boxes, 374, 376
radio buttons, 372–373, 376
signature, 376
Submit button, 375–376
tab order, 375
testing, 377–378
text, 370–371, 376
workspace, 370
yes/no choices, 373–374
Pen tool, 13, 319, 392
Pencil tool, 13
Photoshop
clipping paths, 276–279
transparent backgrounds, 278–279
Photoshop files, layers, 280. See also files
pictures. See files; graphics; images; placed pictures
Place command, 40–42, 271
placed pictures, editing, 275. See also graphics; pictures
placeholder frames
adding for graphics, 66–67
adding for text, 65–66
placeholder text, replacing, 77
pop-up captions, creating, 394–395
preferences, modifying, 30–31
preflight profiles
creating, 350
loading, 205–206
selecting, 206
preflighting, 38–39, 52, 345–347

Presentation mode, 37, 51. See also view commands and modes
press sheet, diagram, 78
Preview mode, 37
Preview Spread button, 385, 389. See also spreads
previewing
pages, 354–355
separations, 347–349
transparency effects, 353–354
Previous Page button, 27
Print Booklet feature, 361–362
print presets, saving, 359–362
printing
to edge of paper, 77–79
proofs, 359–362
requirements, 205–207
process colors, 212
proofing colors onscreen, 204
proofs, printing, 359–362
Properties panel, Transform area, 13
proxy preview, cell strokes, 304
PSD format, 321
pt (point), 57
Publish Online feature, 404–405
Punctuation filter, fonts, 179. See also hanging punctuation

Q
QR (quick response) codes, creating, 121
Quick Apply, character styles, 240

R
radial gradient, 219
radio buttons, PDFs with form fields, 372–373, 376
raster graphics icon, 270, 276, 320
Rasterize First Page, EPUBs, 400
rasterized areas, 353
Rectangle Frame tool
compound shapes, 111
and Ellipse Frame tool, 12–13

navigation buttons, 393
placeholder frames for graphics, 66
playing animations, 390–391
Smart Guides, 95
transparent backgrounds, 278
Rectangle tool, 13, 66, 112
Reference Point locator, 114, 285
reference point, viewing and changing, 49
reflowable vs. fixed-layout, 383–384
Relink button, 268
relinking files, 275
renaming
layers, 90
master pages, 65
resizing
columns, 301
graphics frames, 99
and moving images in frames, 101–102
objects, 14
pages, 71–72
pasteboard, 15
text frames, 91–94, 130–131
resolution
changing, 9
effectiveness, 266
of images, 202–203
restoring workspace, 23
Reveal In options, 266
reverse type, creating, 216. See also Type tool
revised graphics, updating, 267–268. See also graphics
RGB (red, green, blue) values, 201, 362–364
right stop marker, gradient swatches, 220
Right-Justified tab, 190
Rotate Pointer, 114, 278
rotating
images within frames, 114–115
objects, 49, 114
spreads, 80
rounded corners, adding to frames, 113
row heights, adjusting, 300–302, 308–309

rows. See also header rows; tables
adding to tables, 298–299
deleting from tables, 300
rearranging in tables, 300
ruler guides, dragging, 61
rules, adding to paragraphs, 194

S
Same icon, 58
Same Settings button, 63, 372
Sample Buttons And Forms icon, 372
Satin effect, 331
Saved documents, 58
Scale tool, 94
scaling
controls, 47
objects, 117
screen modes, 51, 354
search direction, toggling, 157
second hit, 348
sections, page numbering, 72–74
Select Next Object button, 119
Selection tool. See also Direct Selection tool
adjusting columns, 141
aligning objects, 116
anchored graphics frames, 281
bleed guides, 78
blending modes, 324
check boxes, 373–374
clipping paths in Photoshop, 277
colors for strokes, 215
columns for text frames, 180
compound shapes, 111
context menus, 29
Control panel, 14
copying effects between objects, 336
document window and pasteboard, 15
drop shadows, 334
editing placed pictures, 275

effects and objects, 334, 338–339
feather effects, 331
flowing text, 132, 137
gradient blends, 222
gradient feather, 332
gradient swatches, 221
graphics, 46–47, 270
graphics frames, 98
graphics in table cells, 309
grouped objects, 119
guides, 64
hanging punctuation, 183
Illustrator files, 284, 328
images in frames, 101
images in graphic cells, 307
imported images, 264
importing and flowing text, 41
importing graphics with Bridge, 274
InDesign libraries, 288
layers, 88, 90
metadata captions for graphics frames, 104
motion paths for animations, 391, 393
motion presets for animation, 385–386
multi-state objects, 411
object libraries, 286
object styles, 51, 245, 247
objects, 49
opacity, 323
panels, 18
PANTONE color swatch, 208
parent-child graphics frames, 107
placeholder frames for text, 66
playing animations, 389
radio buttons, 372
resizing graphics for cropping, 99
resizing text frames, 130
revised graphics, 268
rotating objects, 114
rounded corners for frames, 113
scaling objects, 117

sections for page numbering, 72
slide-in captions, 408
slideshows for EPUBs, 398
Submit button, 375
text fields, 370–371
text frames, 134
text inset and vertical alignment, 97
text wrap and anchored graphics frame, 282–283
threaded frames, 136–137
tint swatches, 218–219
transparency and text, 329–330
transparency of bitmap graphics, 327
transparency of vector graphics, 325–326
using, 10
separations, previewing, 347–349, 352
shading paragraphs, 193
shape of frames, transforming, 111–114. See also frames
shapes
converting, 112
repeating, 112–113
solid-colored objects, 323
Shift key. See keyboard shortcuts
Show Library Subset button, 286
Show/Hide Link Information button, 265
signature, PDFs with form fields, 376
Single-Line composer, 188
Size, transparency, 337
sizing graphics, 270–271
slide-in captions, EPUBs, 407–413
slideshows, EPUBs, 398–399
Slug mode, 37
Small Caps icon, 238
Smart Guides, 95, 107. See also guides
snippets, creating and using, 68, 289. See also footers; headers
sound
adding to EPUBs, 396–397
control buttons, 406
Space After icon, 234
Space Before icon, 234
space between frames, adjusting, 103

spacing
letters and words, 184–185
between paragraphs, 172
Span Columns controls, 181
special characters, adding, 176
Specify Attributes To Change icon, 158
spelling, checking, 160–163
spot colors, adding, 209, 212
spot icon, 352
Spread, transparency, 337
spreads. See also Fit Spread In Window; Preview Spread Button
rotating, 80
setting up for master pages, 65
viewing, 79–80
squares, creating, 12
stacking objects, avoiding, 52
Start Screen, displaying, 8
Story Editor, 164–165. See also text
straddle head, creating, 181
stroke and fill
applying to text, 178
changing, 50
strokes, colors, 215–216
style groups, 130
Style Name box, 45
styles. See also cell styles; character styles; object styles; paragraph styles; table styles
applying, 233
Based On, 235
basics, 233
benefits, 234
creating, 249
loading from documents, 255–257
modifying and redefining, 233
nesting, 240–244
overriding manual formatting, 233
panels, 233, 244
Quick Apply, 240
redefining, 255
sharing, 255
types, 42–46

updating globally, 253–255
using for formatting, 52
using with objects, 244–247
Submit button, PDFs with form fields, 375–376
subtraction (-), performing, 103
swatch libraries, choosing, 353. See also color swatches
swatches, 207. See also CMYK (cyan, magenta, yellow, black); gradient swatches; PANTONE
color swatch; tint swatches
Swatches panel, 29–30, 210, 323, 351. See also color themes

T
tab order, PDFs with form fields, 375
table borders, adding, 305–306
table cells. See cells
table styles. See also styles
applying, 252, 313–314
creating, 250–252, 311–313
table width, retaining, 301
tables. See also columns; rows
adding and deleting rows, 298–299
anchoring objects and images, 306
centering, 302
column widths, 300–302
converting text to, 295–296
creating, 295
fill patterns, 303
formatting, 303–306
header rows, 310–311
importing, 297
inserting columns, 299
linking, 297
merging cells, 302
rearranging rows and columns, 300
row heights, 300–302
text placement, 300–302
tabs
icon, 296
setting, 189–191
Technique, transparency, 337

templates. See master pages
text. See also Story Editor; Type tool
aligning, 143–145
applying paragraph styles, 140–141
colors, 216–217
converting to tables, 295–296
creating on master pages, 63–65
drop shadows, 334
editing, 163–164
entering, 155
finding and changing text, 156–158
flowing automatically, 137–138
flowing manually, 132–133
formatting, 20, 233
formatting for character style, 44
importing, 155–156
importing and flowing, 40–42
importing into text frames, 129
PDFs with form fields, 370–371, 376
placeholder frames, 65–66
placing in master pages, 75–77
stroke and fill, 178
transparency settings, 329–330
typing and styling, 39–40
wrapping around graphics, 109–110
text cells, converting to graphic cells, 307
text files, selecting, 156
text frames. See also overset text frame
creating and resizing, 91–93
creating while flowing text, 134–135
linking, 40
multicolumn, 96
options, 40, 97
reshaping, 93–94
resizing, 94, 130–131
sizing and positioning, 64
specifying columns, 180
threading, 52
text inset, adjusting, 97
Text layer, selecting, 88

text placement, tables, 300–302
text wrap, anchored graphics frame, 282–283. See also wrapping text around graphics
threaded frames, creating, 135–137. See also frames
threading, 40, 52, 132
TIFF (Tagged Image File Format), 319, 321
Timing panel, animations, 387–388
tint swatches. See also swatches
applying, 219
creating, 218
tints vs. transparency, 339
tools
Color Theme, 13, 210
Content Collector, 105
Content Placer, 106
Convert Direction Point, 94
Direct Selection, 50, 93–94, 119, 283, 320, 393
Ellipse Frame, 12–13
Eyedropper, 210
Free Transform, 13
Gap, 103
Hand, 11–12, 28, 63, 336
Line, 11–12
Measure, 71–72
Page, 71
Pen, 13, 392
Pencil, 13
Rectangle, 13, 66, 112
Rectangle Frame, 12–13, 66, 95, 111, 390–391, 393
Scale, 94
Selection, 10, 14–15, 18, 28, 41, 46–47, 49, 51, 64, 66, 72, 78, 88, 90, 92, 97–99, 101, 104,
107, 111, 113–114, 116–117, 119, 130, 132, 134, 136–137, 141, 180, 183, 208, 215,
218–219, 221–222, 245, 247, 264, 268, 270, 274–275, 277, 281–284, 286, 288, 307, 309,
323–332, 334, 336, 338–339, 370–375, 385–386, 389, 391, 393, 398, 408, 411
Type, 11, 14, 17, 39, 43–44, 63, 65–66, 91, 96–97, 130, 133, 135–136, 140, 144, 146, 155,
157, 160, 163, 165–166, 174–176, 181, 183, 185, 187, 189, 192–194, 216, 234, 236–237,
239, 241, 248, 252–253, 256, 281, 295, 297–301, 303–306, 308, 310–311
Zoom, 16, 25–26, 44, 88, 97, 99, 113, 117, 178, 248, 285
Tools panel
as horizontal row, 22
locating, 9

moving, 22
Top Offset option, 282
tracking and kerning, adjusting, 185
tracking changes, 165–166
Transform area, Properties panel, 13
Transform panel, controls, 61
transforming
and aligning objects, 114–118
objects, 117–118
transforming shape of frames, shape of frames, 111–114
transparency
applying, 354
applying to text, 329–330
best practices, 339
bitmap graphics, 326–327
effects, 331
flattening, 360
icon, 338
Illustrator files, 328–329
settings and options, 337
vs. tings, 339
vector graphics, 325–326
transparency effects, previewing, 353–354
transparency settings, applying, 321–325
transparent backgrounds, Photoshop, 278–279
TRUMATCH library, 351
Type menu, fonts, 177
Type tool. See also reverse type; text
adding rules to paragraphs, 194
adjusting columns, 181
aligning text, 144
anchored graphics frames, 281
baseline grid, 144
cell strokes, 304
cell styles, 248
character styles, 44, 237, 239
character styles for nesting, 241
checking spelling, 160
coloring text, 216
column widths, 301

correcting misspelled words, 163
document windows, 17
drop caps, 183
editing and formatting tables, 295
entering text, 155
fill patterns, 303
finding and changing text, 157
fonts and leading, 174–175
fraction characters, 178
graphic cells, 306
graphics in table cells, 310
header rows, 310
hyphenation settings, 187
images in graphic cells, 308
importing tables, 297
importing text, 155
jump line page number, 146
loading styles from documents, 256
loading with text files, 133
manual line breaks, 187
numbered list, 192
paragraph styles, 43, 140, 234, 236
placeholder frames for text, 66
row heights, 301
rows and columns, 300
selecting, 14
setting tabs, 189
shading paragraphs, 193
special characters, 176
Story Editor, 165
straddle head, 181
table and cell styles, 311, 313
table borders, 305
table rows, 298–299
table styles, 252
tables, 301
text frames, 91, 96, 130
text frames on master pages, 63, 65
text inset, 97
threaded frames, 135–136

tracking and kerning, 185
tracking changes, 166
typing and styling text, 39
updating styles globally, 253
using, 11

U
uncoated vs. coated, 349
undocking panels, 22
undoing actions, 10, 14
units and measurements, 57
updating revised graphics, 267–268
uppercase. See Small Caps icon
URLs, EPUBs, 400
Use Global Light, transparency, 337

V
vector graphics. See also graphics
vs. bitmap graphics, 263
and flattening, 353
icon, 328–329
transparency, 325–326
vertical alignment, adjusting, 97
vertical spacing, adjusting, 143, 171–172
video files, importing, 395
view commands and modes, 24, 37. See also Presentation mode
viewing guides, 37

W
Web and Mobile options, 383
Whole Word icon, 157
word spacing, adjusting, 184–185
words, adding to dictionary, 161
workspace
customizing, 23
interface, 9
restoring, 23

setting up for forms, 369
wrapping text around graphics, 109–110. See also text wrap

X
X and Y fields, 49
X Offset and Y Offset, transparency, 337

Y
yes/no choices, PDFs with form fields, 373–374

Z
Zoom tool
cell styles, 248
character styles, 44
document windows, 16
fraction characters, 178
Illustrator files with layers, 285
layers, 88
objects, 117
placing graphics, 99
rounded corners for frames, 113
text inset and vertical alignment, 97
using, 25–26

